Users not receiving activation emails. Would Gmail be better?

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
thetgc
Registered User
Posts: 86
Joined: Tue Apr 25, 2017 3:51 pm

Users not receiving activation emails. Would Gmail be better?

Post by thetgc »

I have had this issue for ages now but as I am using PhpBB 3.3 I thought this would be the correct place to ask the question?

For a long time now I have had issues with over half the people who sign up to my forum not receiving activation emails.

I CAN send an email directly from my email client using the same domain email account used in the forum and they go through fine. It is only when activation emails and sometimes notifications to existing users is sent directly from the forum that the problem seems to arise.

I am using SMTP and all the settings are correct. Test email from the forum works. But if I create a test account I do not receive the activation email. I have had 50 new members register today and none of them received the activation email.

My domain is not blacklisted anywhere by the way.

Also if I use the internal PHP mail function it is the same results.

I was wondering if it might be more reliable to use an external SMTP such as Gmail?
User avatar
Lumpy Burgertushie
Registered User
Posts: 68474
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Users not receiving activation emails. Would Gmail be better?

Post by Lumpy Burgertushie »

actually, that would probably increase the chances of the email not getting to the users.

most likely it is going into their spam folders for some reason.

free emails like gmail or hotmail etc. are prone to wind up in the spam pile at many hosts.

you say you are using smtp. what smtp server are you using? if you are using the smtp server of your host then make sure all your settings are correct etc.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
thetgc
Registered User
Posts: 86
Joined: Tue Apr 25, 2017 3:51 pm

Re: Users not receiving activation emails. Would Gmail be better?

Post by thetgc »

I am the hosting service for my site. I run a web hosting business.

The SMTP settings are fine. I am using my domain SMTP settings with the correct email, port, server name, password. Works fine sending a test from the admin control panel but activation emails are not going through. They are also not ending up in people's spam folders.

I can send an email using my mail client and the same email address used by the forum, to any other email account and it arrives in seconds. Yet the same thing does not work from the forum. However as mentioned, this only affects around 50% of signups. Some do receive the activation emails.

It is a complete mystery. And it also seems peculiar to PhpBB because I also run other forums and activation emails from them always go through.

It is incredibly frustrating and means I have to manually approve all registrations, which on a board like mine is a full-time job!
User avatar
janus_zonstraal
Registered User
Posts: 5038
Joined: Sat Aug 30, 2014 1:30 pm

Re: Users not receiving activation emails. Would Gmail be better?

Post by janus_zonstraal »

Did you check the dkim and spf settings from your emails?
Sorry! My English is bat ;) !!!
Post Reply

Return to “[3.3.x] Support Forum”