Known issues in 3.3.3

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
KaileyT
Community Team Member
Community Team Member
Posts: 2933
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Known issues in 3.3.3

Post by KaileyT »

This topic is dedicated for known issues in the 3.3.3 release.
  • After installing/upgrading, you may run into an issue accessing the ACP GENERAL page.
Kailey Truscott - Community Team
TomaGo
Registered User
Posts: 89
Joined: Sat Jan 21, 2017 10:42 am

Re: Known issues in 3.3.3

Post by TomaGo »

I was looking for a solution to this error after a clean upgrade to 3.3.3, thanks for the information, it's ok now.
Captain P-H-P-BB
Registered User
Posts: 20
Joined: Wed Mar 05, 2014 11:45 am

Re: Known issues in 3.3.3

Post by Captain P-H-P-BB »

Hi there,
Thanks a lot for providing this fix.
After upgrading from 3.3.2 to 3.3.3 I had the issue that I could not access the ACP general page. Everything else, including the rest of the ACP was working.
After adding this line of code to phpBB/includes/functions_admin.php as describd in Github I can access the ACP general page again.

But now I see the message " ERROR_DEFAULT_CHARSET ERROR_DEFAULT_CHARSET_EXPLAIN"
error_default.png
What does this mean, and how can that be fixed? Does anyone else have this?

Sorry, if this is the wrong place. I can also create a separate topic for this including the support template, if that is better for you.

Thanks a lot in advance for your support!
User avatar
Mick
Support Team Member
Support Team Member
Posts: 23057
Joined: Fri Aug 29, 2008 9:49 am

Re: Known issues in 3.3.3

Post by Mick »

Captain P-H-P-BB wrote:
Sat Jan 30, 2021 12:27 pm
I can also create a separate topic for this including the support template
Yes please👍🏼
"The more connected we get the more alone we become" - Kyle Broflovski©
User avatar
david63
Registered User
Posts: 19067
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Known issues in 3.3.3

Post by david63 »

This error message

Code: Select all

 [phpBB Debug] PHP Warning: in file [ROOT]/viewforum.php on line 1030: A non-numeric value encountered 
is generated by extensions due to this PR

The extensions that I am aware of are
Who Posted in this Topic
Topic Link
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
rxu
Extensions Development Team
Posts: 3474
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: Known issues in 3.3.3

Post by rxu »

This is most likely due to changing type of $topic_row['REPLIES'] in extensions which should remain integer. This can be fixed by typecasting the value either in in extension or in the core (like (int) $topic_row['REPLIES'] + 1). The latter way would be more a protection measure from what might be happening with the value in extensions.
User avatar
RMcGirr83
Former Team Member
Posts: 21913
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr

Re: Known issues in 3.3.3

Post by RMcGirr83 »

rxu wrote:
Sun Jan 31, 2021 4:16 pm
This is most likely due to changing type of $topic_row['REPLIES'] in extensions which should remain integer. This can be fixed by typecasting the value either in in extension or in the core (like (int) $topic_row['REPLIES'] + 1). The latter way would be more a protection measure from what might be happening with the value in extensions.
The REPLIES was overwritten by my extension to place a url link for an ajax call. typecasting wouldn't have fixed it, so I used a different event and altered the template block.
https://github.com/rmcgirr83/whoposted/ ... d6b04c3R69
Former Modifications/Extensions Team Member | My extensions | github | All requests for support via PM will be ignored
Appreciate the extensions/mods/support then buy me a beerImage
Outi
Registered User
Posts: 20
Joined: Sun Jan 01, 2006 8:14 am

Re: Known issues in 3.3.3

Post by Outi »

Captain P-H-P-BB wrote:
Sat Jan 30, 2021 12:27 pm
Hi there,
Thanks a lot for providing this fix.
After upgrading from 3.3.2 to 3.3.3 I had the issue that I could not access the ACP general page. Everything else, including the rest of the ACP was working.
....
Same issue to me if I switch to PHP 8.0.1.
Switched back to PHP 7.4.3 and everything is ok.
Best regards from Outi .... ;) :D
User avatar
ssl
Registered User
Posts: 585
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: Known issues in 3.3.3

Post by ssl »

Outi wrote:
Mon Feb 01, 2021 11:48 pm

Same issue to me if I switch to PHP 8.0.1.
Switched back to PHP 7.4.3 and everything is ok.
Please read this: viewtopic.php?f=661&t=2582531
Sorry for my English ... I do my best!

phpBB version: 3.3.3
php version: 8.0.2
User avatar
VeganFanatic
Registered User
Posts: 189
Joined: Mon Sep 08, 2008 8:27 pm
Location: Victoria, BC Canada
Contact:

Re: Known issues in 3.3.3

Post by VeganFanatic »

I was reading this and wanted to mention that PHP 8.x is buggy with WordPress as well as phpBB
User avatar
ssl
Registered User
Posts: 585
Joined: Sat Feb 08, 2020 2:15 pm
Location: France
Name: Fred
Contact:

Re: Known issues in 3.3.3

Post by ssl »

Hi
For Wordpress no I do not encounter any problem with php 8.0, on the other hand it is possible that some plu-ins are not compatible.
For phpBB no problem either.
Sorry for my English ... I do my best!

phpBB version: 3.3.3
php version: 8.0.2
User avatar
eeji
Jr. Style Validator
Posts: 1363
Joined: Fri Dec 12, 2008 9:08 pm
Location: Manchester, UK
Contact:

Re: Known issues in 3.3.3

Post by eeji »

Just confirming the bug in the first post affects databases with a dot in the name too, the solution posted fixes it.
My phpBB styles: phpbbstyles.oo.gd
My board: iansvivarium.com
User avatar
KaileyT
Community Team Member
Community Team Member
Posts: 2933
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Re: Known issues in 3.3.3

Post by KaileyT »

Thanks for confirming! I've updated the first post to reflect this information. ;)
Kailey Truscott - Community Team
User avatar
VeganFanatic
Registered User
Posts: 189
Joined: Mon Sep 08, 2008 8:27 pm
Location: Victoria, BC Canada
Contact:

Re: Known issues in 3.3.3

Post by VeganFanatic »

all of the databases on my server are text names only and MySQL 8 is what I am using with PHP 7.4.x


PHP 8 is probably going to be fixed soon to repair the problem as the dot, underscore and hyphen are common with some database servers
Post Reply

Return to “[3.3.x] Support Forum”