photos posted as attachments in messages are no longer loaded

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
Hensyr Wolf
Registered User
Posts: 9
Joined: Sat Aug 29, 2015 9:01 pm
Location: East-Flanders Belgium
Name: Hendrik Van Marcke
Contact:

photos posted as attachments in messages are no longer loaded

Post by Hensyr Wolf »

Hi there,
first of all, sorry for my bad English.
I have a Linux forum about computer operating systems.
With some friends from another computer forum we reinstall the forum software from a back-up.
The forum software is phpbb 3.3.4
Now all the pictures in the forum topics are gone, for example see this topic: How to become member on this forum
You will see that all the pictures are gone.

Now the way i post pictures in my topics:

I always used "add attachments" in my forum topics from the forum software phpbb 3.3.4
now they won't load anymore.
User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 4921
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: photos posted as attachments in messages are no longer loaded

Post by thecoalman »

It would appear they are corrupted. Did you recently transfer them using FileZillza? Newly posted images not affected?
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison
User avatar
Hensyr Wolf
Registered User
Posts: 9
Joined: Sat Aug 29, 2015 9:01 pm
Location: East-Flanders Belgium
Name: Hendrik Van Marcke
Contact:

Re: photos posted as attachments in messages are no longer loaded

Post by Hensyr Wolf »

Yes they did use FileZilla for refill the folder public.html
User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 4921
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: photos posted as attachments in messages are no longer loaded

Post by thecoalman »

phpBB attachments are stored without an extension and FileZilla defaults to ASCII mode when no extension is present, this corrupts the headers in binary files. Why they chose to do this many years ago and haven't changed it since I have no idea but the safe default would be binary mode as it will not corrupt ASCII files.

Hopefully you still have access to copy of the originals before using Filezilla, you need to change Filezillas default to binary and then you can transfer them. Or use a different FTP program like WinSCP.
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison
User avatar
Hensyr Wolf
Registered User
Posts: 9
Joined: Sat Aug 29, 2015 9:01 pm
Location: East-Flanders Belgium
Name: Hendrik Van Marcke
Contact:

Re: photos posted as attachments in messages are no longer loaded

Post by Hensyr Wolf »

Thank you very much for this answer.
So it's better to use another transfer program instead of FileZilla
Naturally i use Zorin OS 16 core as my computer operating system, i wonder if WinSCP will work
User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 4921
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: photos posted as attachments in messages are no longer loaded

Post by thecoalman »

Hensyr Wolf wrote:
Fri Aug 27, 2021 2:55 am
So it's better to use another transfer program instead of FileZilla
With the exception of this issue FileZilla is fine AFAIK, if you change the default the problem goes away.
Hensyr Wolf wrote:
Fri Aug 27, 2021 2:55 am
Naturally i use Zorin OS 16 core as my computer operating system
It's windows application so probably not unless you can run windows applications. It's a habit of suggesting it as it's what I use.
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison
User avatar
Hensyr Wolf
Registered User
Posts: 9
Joined: Sat Aug 29, 2015 9:01 pm
Location: East-Flanders Belgium
Name: Hendrik Van Marcke
Contact:

Re: photos posted as attachments in messages are no longer loaded

Post by Hensyr Wolf »

Do you know how i can change my FileZilla settins?
User avatar
Hensyr Wolf
Registered User
Posts: 9
Joined: Sat Aug 29, 2015 9:01 pm
Location: East-Flanders Belgium
Name: Hendrik Van Marcke
Contact:

Re: photos posted as attachments in messages are no longer loaded

Post by Hensyr Wolf »

OK sorry for the delay, i was after a coffee.
So i found it on FileZilla settings
the default transfer type is at this moment setting automatic, so i will now change that on binair
User avatar
Hensyr Wolf
Registered User
Posts: 9
Joined: Sat Aug 29, 2015 9:01 pm
Location: East-Flanders Belgium
Name: Hendrik Van Marcke
Contact:

Re: photos posted as attachments in messages are no longer loaded

Post by Hensyr Wolf »

I will upload this image to let you see that i found the settings
I have set it to binair
FileZilla 1.png
should I uncheck the two checkboxes?
treat files without extension as ASCII file
and
Treat point files as ASCII files
User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 4921
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: photos posted as attachments in messages are no longer loaded

Post by thecoalman »

Hensyr Wolf wrote:
Fri Aug 27, 2021 3:30 am
treat files without extension as ASCII file
and
Treat point files as ASCII files
Certainly the first one and I would uncheck the second one. There is no harm you can do by transferring everything in binary mode. In fact if you are using SFTP there is no option but binary.
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison
User avatar
Hensyr Wolf
Registered User
Posts: 9
Joined: Sat Aug 29, 2015 9:01 pm
Location: East-Flanders Belgium
Name: Hendrik Van Marcke
Contact:

Re: photos posted as attachments in messages are no longer loaded

Post by Hensyr Wolf »

Thank you very much for your info, I really appreciate it.
I'm now going to get started with FileZilla until the public.html folder is filled with my backup again
User avatar
Mick
Support Team Member
Support Team Member
Posts: 23534
Joined: Fri Aug 29, 2008 9:49 am

Re: photos posted as attachments in messages are no longer loaded

Post by Mick »

  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • There will be legions of cricket lovers of both genders through whose lips the abomination ‘BATTER’ will never pass so long as we live” - Simon Heffer - Telegraph
User avatar
Hensyr Wolf
Registered User
Posts: 9
Joined: Sat Aug 29, 2015 9:01 pm
Location: East-Flanders Belgium
Name: Hendrik Van Marcke
Contact:

Re: photos posted as attachments in messages are no longer loaded

Post by Hensyr Wolf »

Thanks a lot, you guys are wonderfull
Everything is ok here on the forum
Post Reply

Return to “[3.3.x] Support Forum”