Editing the Main Website Title

For support and discussion related to templates and themes in phpBB 3.3.
michaellanfield
Registered User
Posts: 132
Joined: Mon Feb 04, 2013 5:43 am
Name: Michael Lanfield
Contact:

Editing the Main Website Title

Post by michaellanfield »

How do I edit the entire website forum title where it says index page where the website tab is? Also, how do I change the small icon on the tab as well where my Bluehost logo is? Last question, is there a way to add SEO information to each page similar to Yoast WordPress plugin for example? Any extension for this? Thank you. https://peaceful-village.com/forum
https://www.weareinterconnected.com
Michael Lanfield - author and vegan advocate
User avatar
Elias
Registered User
Posts: 5136
Joined: Sat Feb 25, 2006 4:31 pm
Location: In the Water!
Name: Elias

Re: Editing the Main Website Title

Post by Elias »

michaellanfield wrote:
Thu Apr 23, 2020 11:05 pm
1.How do I edit the entire website forum title where it says index page where the website tab is?
2.Also, how do I change the small icon on the tab as well where my Bluehost logo is?
3.Last question, is there a way to add SEO information to each page similar to Yoast WordPress plugin for example? Any extension for this? Thank you. https://peaceful-village.com/forum
1. You can do that in your admin control panel
ACP > Board settings

2.
https://www.phpbb.com/support/docs/en/3 ... a-favicon/

3. No idea Yoast's wordpress plugin does, but maybe this?
https://www.phpbb.com/customise/db/exte ... _metadata/
"Mystery creates wonder, and wonder is the basis of man's desire to understand." - Neil Armstrong
|Installing Extensions|Writing Extensions|Extension Validation Policy|
Offering private web hosting. Contact me for details.
User avatar
EA117
Registered User
Posts: 1860
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Editing the Main Website Title

Post by EA117 »

Site is looking great.
michaellanfield wrote:
Thu Apr 23, 2020 11:05 pm
How do I edit the entire website forum title where it says index page where the website tab is?
Not an uncommon question, but unfortunately not a very straight-forward answer. That page title is being dynamically generated in the style's overall_header.html template, based on several different factors. Most people are fine with the title it dynamically generates except for the main index page, where seeing "index page" literally spelled out seems unnecessary.

To remove "just index page" without stopping the dynamic title generation for all other pages, see the discussion here about the changes that can be made to the conditional logic. The second suggestion in that thread is the one which intends to only remove "index page" without stopping the title generation for other pages.

michaellanfield wrote:
Thu Apr 23, 2020 11:05 pm
Also, how do I change the small icon on the tab as well where my Bluehost logo is?
In simplest terms, you just need to update the favicon.ico at the root of your site. Meaning the one that exists in https://peaceful-village.com/, not the one that may or may not exist in https://peaceful-village.com/forum/.

If you wanted to have an icon which only affects visitors of the https://peaceful-village.com/forum/ and not the main site, you can definitely achieve that, but it takes a bit more configuration. I won't explain that since I presume you'd be happy with having the icon be the same for both the main site and the phpBB forum for that site.

I've PM'd a quick favicon.ico to get you started (since you cannot attach .ico or .zip files right here), just based on the leaf in your logo. But you can do your own thing, and probably something even better. The site https://realfavicongenerator.net/ is one I happen to use for generating both the basic favicon.ico, but also a bunch of other browser & platform-specific additional icon and image data.

Trying to do everything that site can do might be a lot to try and bite off at once; but you can use that site to just generate a different favicon.ico file for you (and upload only the favicon.ico from what they generate) if you end up wanting to create an icon based off a different image.
User avatar
3Di
Former Team Member
Posts: 16053
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano 🇮🇹 - Frankfurt 🇩🇪
Name: Marco
Contact:

Re: Editing the Main Website Title

Post by 3Di »

Emojis can also be used as favicons: https://css-tricks.com/emojis-as-favicons/
To request support for our extensions you can also contact me here: phpBB Studio

Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user º Extensions, Scripts, MOD porting, Update/Upgrades
🚀 Looking for a specific feature or alternative option? We will rock you! 🚀
michaellanfield
Registered User
Posts: 132
Joined: Mon Feb 04, 2013 5:43 am
Name: Michael Lanfield
Contact:

Re: Editing the Main Website Title

Post by michaellanfield »

michaellanfield wrote:
Thu Apr 23, 2020 11:05 pm
Also, how do I change the small icon on the tab as well where my Bluehost logo is?
In simplest terms, you just need to update the favicon.ico at the root of your site. Meaning the one that exists in https://peaceful-village.com/, not the one that may or may not exist in https://peaceful-village.com/forum/.

If you wanted to have an icon which only affects visitors of the https://peaceful-village.com/forum/ and not the main site, you can definitely achieve that, but it takes a bit more configuration. I won't explain that since I presume you'd be happy with having the icon be the same for both the main site and the phpBB forum for that site.

hi and thank you brother for the help. I uploaded my own favicon and with no luck. I did it just as it was specified or at least I think I did. hehe. Is there a way to check if I did it correctly? the other issues i will look into.
https://www.weareinterconnected.com
Michael Lanfield - author and vegan advocate
michaellanfield
Registered User
Posts: 132
Joined: Mon Feb 04, 2013 5:43 am
Name: Michael Lanfield
Contact:

Re: Editing the Main Website Title

Post by michaellanfield »

EA117 wrote:
Fri Apr 24, 2020 1:13 am
Not an uncommon question, but unfortunately not a very straight-forward answer. That page title is being dynamically generated in the style's overall_header.html template, based on several different factors. Most people are fine with the title it dynamically generates except for the main index page, where seeing "index page" literally spelled out seems unnecessary.

To remove "just index page" without stopping the dynamic title generation for all other pages, see the discussion here about the changes that can be made to the conditional logic. The second suggestion in that thread is the one which intends to only remove "index page" without stopping the title generation for other pages.
I tried this and gave me a blank page in Firefox and an error message in Chrome.

This page isn’t working
peaceful-village.com is currently unable to handle this request.
HTTP ERROR 500

I am not sure what i am doing with everything...
https://www.weareinterconnected.com
Michael Lanfield - author and vegan advocate
User avatar
tbackoff
Former Team Member
Posts: 7064
Joined: Thu Jun 04, 2009 1:41 am
Location: cheerleading practice
Name: Tabitha Backoff

Re: Editing the Main Website Title

Post by tbackoff »

Have you checked the servers error log for a clue? What are the last few lines of that file?
Flying is the second best thrill to cheerleaders; being caught is the first.
User avatar
EA117
Registered User
Posts: 1860
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Editing the Main Website Title

Post by EA117 »

michaellanfield wrote:
Fri Apr 24, 2020 10:45 pm
This page isn’t working
peaceful-village.com is currently unable to handle this request.
HTTP ERROR 500
Clearly it's not as impossible as I would have assumed it should be, but that kind of error seems like it should have been difficult to cause if just editing the overall_header.html template. The HTTP 500 status is typically due to a PHP execution failure.

Regardless, the first thing to do would be to put back your original overall_header.html template file (the original from prosilver if that's the one you had to edit; or the one originally downloaded with your style, if it contained its own overall_header.html template that you edited) so that you get back to the working original file.

Once the overall_header.html file has been put back to it's original state, then you should also purge the phpBB cache by deleting the "production" subfolder that exists under the /cache directory. e.g. Delete this /cache/production/ folder using your FTP client, or using a file manager your hosting provider may have in their control panel. If you were able to login to the phpBB ACP you would use the "Purge cache" button there to do the same thing; but I'm assuming you cannot get into phpBB's ACP at the moment.

If restoring the original_header.html file and purging the cache doesn't bring your site back, then it seems like perhaps something else had changed besides the overall_header.html template. And like tbackoff recommended, looking at your web server's PHP error log (which is usually different from the web server logs) may be necessary in order to understand what kind of PHP execution error is happening now.



edit: The HTTP 500 status you are seeing is unrelated to the change that was attempted for the page title. The issue causing your current HTTP 500 status is the YouTube video which was added to the overall_header.html template, and that fact that the conditional <!-- IF not S_USER_LOGGED_IN and not S_IS_BOT --> block its inside of was never closed with an <!-- ENDIF -->. It should work correctly when the inserted lines look like:

Code: Select all

<!-- IF not S_USER_LOGGED_IN and not S_IS_BOT -->
<div style="text-align: center"><iframe width="560" height="315" src="https://www.youtube.com/embed/crQuh1NzvmI" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<!-- ENDIF -->
Otherwise, the changes you did for the <title> actually look correct, and like the title change will be successful once the HTTP 500 status is fixed.


michaellanfield wrote:
Fri Apr 24, 2020 10:03 pm
hi and thank you brother for the help. I uploaded my own favicon and with no luck. I did it just as it was specified or at least I think I did. hehe. Is there a way to check if I did it correctly? the other issues i will look into.
It does appear to be there correctly. I see you made "a pineapple icon" from the main site logo, which is now set as the favicon.ico file at the root of the we site. Once your phpBB board is back online, I expect that same favicon.ico to be displayed for the phpBB site, too. So that should be all good now.

edit: Now that I've seen your overall_header.html template changes, a couple corrections. I see now that the favicon.ico at the root of the site is actually the "leaf" icon. The "pineapple" icon is actually being set by metadata unique to the main site, unrelated to the presence of the favicon.ico file there.

The <link rel="shortcut icon" href="favicon.ico" /> line that was added the overall_header.html template is a good kind of change to make, because it gives you explicit control of where to load the favicon.ico from. However, the current line you have added is trying to load favicon.ico "from the current folder", which for the purposes of the template will be the style directory, which is not where your favicon.ico file lives.

You could load the file from where it currently exists by adding a slash to the beginning of the path:
<link rel="shortcut icon" href="/favicon.ico" />

Or you could move this icon specific to your phpBB site to the /forum folder, and then use:
<link rel="shortcut icon" href="/forum/favicon.ico" />

Or, since you're putting this in a style-specific template anyway, you could put the favicon.ico file into the style's "images" folder, and then load this icon as a style-specific resource using:
<link rel="shortcut icon" href="{T_THEME_PATH}/images/favicon.ico">

Any of these are valid options. Mainly depends on where you would prefer to maintain existence of the favicon.ico file. As a style-specific resource would be my "vote", so that you could even potentially have a different favicon.ico depending on which style was being displayed. And keeps the file close to where you have to maintain reference to it in overall_header.html anyway.
Last edited by EA117 on Sat Apr 25, 2020 2:27 am, edited 1 time in total.
michaellanfield
Registered User
Posts: 132
Joined: Mon Feb 04, 2013 5:43 am
Name: Michael Lanfield
Contact:

Re: Editing the Main Website Title

Post by michaellanfield »

EA117 wrote:
Sat Apr 25, 2020 1:39 am
michaellanfield wrote:
Fri Apr 24, 2020 10:03 pm
hi and thank you brother for the help. I uploaded my own favicon and with no luck. I did it just as it was specified or at least I think I did. hehe. Is there a way to check if I did it correctly? the other issues i will look into.
It does appear to be there correctly. I see you made "a pineapple icon" from the main site logo, which is now set as the favicon.ico file at the root of the we site. Once your phpBB board is back online, I expect that same favicon.ico to be displayed for the phpBB site, too. So that should be all good now.

michaellanfield wrote:
Fri Apr 24, 2020 10:45 pm
This page isn’t working
peaceful-village.com is currently unable to handle this request.
HTTP ERROR 500
Clearly it's not as impossible as I would have assumed it should be, but that kind of error seems like it should have been difficult to cause if just editing the overall_header.html template. The HTTP 500 status is typically due to a PHP execution failure.

Regardless, the first thing to do would be to put back your original overall_header.html template file (the original from prosilver if that's the one you had to edit; or the one originally downloaded with your style, if it contained its own overall_header.html template that you edited) so that you get back to the working original file.

Once the overall_header.html file has been put back to it's original state, then you should also purge the phpBB cache by deleting the "production" subfolder that exists under the /cache directory. e.g. Delete this /cache/production/ folder using your FTP client, or using a file manager your hosting provider may have in their control panel. If you were able to login to the phpBB ACP you would use the "Purge cache" button there to do the same thing; but I'm assuming you cannot get into phpBB's ACP at the moment.

If restoring the original_header.html file and purging the cache doesn't bring your site back, then it seems like perhaps something else had changed besides the overall_header.html template. And like tbackoff recommended, looking at your web server's PHP error log (which is usually different from the web server logs) may be necessary in order to understand what kind of PHP execution error is happening now.
The pineapple was the original on peaceful-village.com, but I uploaded a new one leaf for both the main site and the forum. I will try the other recommendations with the error. :) Gracias.

Update: Funny thing is, I just uploaded the original overall_header.html file and everything seems to be back up and running. So something must be wrong with that code. Here is the entire file code.

Code: Select all

<!DOCTYPE html>
<html dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1" />
{META}
<title><!-- IF UNREAD_NOTIFICATIONS_COUNT -->({UNREAD_NOTIFICATIONS_COUNT}) <!-- ENDIF --><!-- IF not S_VIEWTOPIC and not S_VIEWFORUM -->{SITENAME}<!-- ENDIF --><!-- IF S_IN_MCP --> - {L_MCP} - {PAGE_TITLE}<!-- ELSEIF S_IN_UCP --> - {L_UCP} - {PAGE_TITLE}<!-- ENDIF --><!-- IF S_VIEWTOPIC or S_VIEWFORUM -->{PAGE_TITLE} - {SITENAME}<!-- ENDIF --></title>

<link rel="shortcut icon" href="favicon.ico" />

<!-- IF S_ENABLE_FEEDS -->
	<!-- IF S_ENABLE_FEEDS_OVERALL --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {SITENAME}" href="{{ path('phpbb_feed_index') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_NEWS --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FEED_NEWS}" href="{{ path('phpbb_feed_news') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_FORUMS --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_ALL_FORUMS}" href="{{ path('phpbb_feed_forums') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_TOPICS --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FEED_TOPICS_NEW}" href="{{ path('phpbb_feed_topics') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_TOPICS_ACTIVE --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FEED_TOPICS_ACTIVE}" href="{{ path('phpbb_feed_topics_active') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_FORUM and S_FORUM_ID --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FORUM} - {FORUM_NAME}" href="{{ path('phpbb_feed_forum', { forum_id : S_FORUM_ID } ) }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_TOPIC and S_TOPIC_ID --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_TOPIC} - {TOPIC_TITLE}" href="{{ path('phpbb_feed_topic', { topic_id : S_TOPIC_ID } ) }}"><!-- ENDIF -->
	<!-- EVENT overall_header_feeds -->
<!-- ENDIF -->

<!-- IF U_CANONICAL -->
	<link rel="canonical" href="{U_CANONICAL}">
<!-- ENDIF -->

<!--
	phpBB style name: Flat Style
	Based on style:   prosilver (this is the default phpBB3 style)
	Original author:  Tom Beddard ( http://www.subBlue.com/ )
	Modified by:      Ian Bradley ( http://phpbbstyles.oo.gd/ )
-->

<!-- IF S_ALLOW_CDN -->
<script>
	WebFontConfig = {
		google: {
			families: ['Open+Sans:300,300i,400,400i,600,600i,700,700i,800,800i&subset=cyrillic,cyrillic-ext,greek,greek-ext,latin-ext,vietnamese']
		}
	};

	(function(d) {
		var wf = d.createElement('script'), s = d.scripts[0];
		wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.18/webfont.js';
		wf.async = true;
		s.parentNode.insertBefore(wf, s);
	})(document);
</script>
<!-- ENDIF -->
<link href="{T_FONT_AWESOME_LINK}" rel="stylesheet">
<link href="{T_STYLESHEET_LINK}" rel="stylesheet">
<link href="{T_STYLESHEET_LANG_LINK}" rel="stylesheet">

<!-- IF S_CONTENT_DIRECTION eq 'rtl' -->
	<link href="{T_THEME_PATH}/bidi.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<!-- ENDIF -->

<!-- IF S_PLUPLOAD -->
	<link href="{T_THEME_PATH}/plupload.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<!-- ENDIF -->

<!-- IF S_COOKIE_NOTICE -->
	<link href="{T_ASSETS_PATH}/cookieconsent/cookieconsent.min.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<!-- ENDIF -->

<!--[if lte IE 9]>
	<link href="{T_THEME_PATH}/tweaks.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<![endif]-->

<!-- EVENT overall_header_head_append -->

{$STYLESHEETS}

<!-- EVENT overall_header_stylesheets_after -->

</head>
<body id="phpbb" class="nojs notouch section-{SCRIPT_NAME} {S_CONTENT_DIRECTION} {BODY_CLASS}">

<!-- EVENT overall_header_body_before -->

<div id="wrap" class="wrap">
	<a id="top" class="top-anchor" accesskey="t"></a>
	<div id="page-header">
		<div class="headerbar" role="banner">
		<!-- EVENT overall_header_headerbar_before -->
			<div class="inner">

			<div id="site-description">
				<a id="logo" class="logo" href="<!-- IF U_SITE_HOME -->{U_SITE_HOME}<!-- ELSE -->{U_INDEX}<!-- ENDIF -->" title="<!-- IF U_SITE_HOME -->{L_SITE_HOME}<!-- ELSE -->{L_INDEX}<!-- ENDIF -->"><span class="site_logo"></span></a>
				<div  class="site-description">
					<h1>{SITENAME}</h1>
					<p>{SITE_DESCRIPTION}</p>
					<p class="skiplink"><a href="#start_here">{L_SKIP}</a></p>
				</div>
			</div>

			</div>
			<!-- EVENT overall_header_headerbar_after -->
		</div>
		<!-- EVENT overall_header_navbar_before -->
		<!-- INCLUDE navbar_header.html -->
	</div>

	<!-- EVENT overall_header_page_body_before -->

	<a id="start_here" class="anchor"></a>
	<div id="page-body" class="page-body" role="main">
		<!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN and (U_MCP or U_ACP) -->
		<div id="information" class="rules">
			<div class="inner">
				<strong>{L_INFORMATION}{L_COLON}</strong> {L_BOARD_DISABLED}
			</div>
		</div>

<!-- IF not S_USER_LOGGED_IN and not S_IS_BOT -->
<div style="text-align: center"><iframe width="560" height="315" src="https://www.youtube.com/embed/crQuh1NzvmI" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>

		<!-- ENDIF -->

		<!-- EVENT overall_header_content_before -->
Last edited by michaellanfield on Sat Apr 25, 2020 2:32 am, edited 1 time in total.
https://www.weareinterconnected.com
Michael Lanfield - author and vegan advocate
User avatar
EA117
Registered User
Posts: 1860
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Editing the Main Website Title

Post by EA117 »

michaellanfield wrote:
Sat Apr 25, 2020 2:25 am
The pineapple was the original on peaceful-village.com, but I uploaded a new one leaf for both the main site and the forum. I will try the other recommendations with the error. :) Gracias.
D'oh, I just missed your post with my edits. 😜 Go back to that message and check the two places where you see "edit:".
michaellanfield
Registered User
Posts: 132
Joined: Mon Feb 04, 2013 5:43 am
Name: Michael Lanfield
Contact:

Re: Editing the Main Website Title

Post by michaellanfield »

I changed the code as you mentioned, and the video is still not up as for guests to see, but I didn't do yet the favicon and now it is working great on the forum site, which is funny thing. The main peaceful-village.com site has the pineapple still there. Which is initially what I wanted. So it is a myster to me. As long as I get the video up now, everything else seems to be functioning properly. You are a genious or maybe I am in heaven, or both! ;) hehehehe

Update: The index page still showing up on the tab description and the video code not working. I had to again revert to orgibal overall_header.html file as it gave me again error 500 code. But at least the favicon is working. ;)
https://www.weareinterconnected.com
Michael Lanfield - author and vegan advocate
User avatar
EA117
Registered User
Posts: 1860
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Editing the Main Website Title

Post by EA117 »

michaellanfield wrote:
Sat Apr 25, 2020 2:54 am
The index page still showing up on the tab description and the video code not working. I had to again revert to orgibal overall_header.html file as it gave me again error 500 code. But at least the favicon is working. ;)
That's disappointing. I had taken both the <title> change you made and also a fixed version of the YouTube block from your overall_header.html and put it into a test board here, and it worked for both. Well, I mean there was no HTTP 500 error and the page title no longer had "index page" when at the main forum page. I didn't actually check the display or playing of the YouTube video itself.

Maybe just attach your latest proposed overall_header.html file (or put it's contents in a [code] block), without actually putting the changes live on your site again yet. And we'll see whether there are any remaining differences that can be spotted.

Yes, once you removed the <link rel="shortcut icon" href="favicon.ico" /> line from the overall_header.html template, then in absence of the more explicit direction of were to load from, the web browsers themselves would have fallen back to the legacy behavior of "let me try and see if there is a favicon.ico file in the root of the site." Which there is on your site, now, and it's the leaf icon.

You may already realize, but you can put all the same icon and OpenGraph and other site description image metadata that you have on the main site into the overall_header.html template to be used for the forum too, if you wanted the forum to have that same kind of identity. Somehow I thought I was still seeing just the BlueHost logo even on your main site, and just wanted to "start slow" by introducing only the favicon.ico. And didn't realize all the site image work ("pineapple" icon) you had there until you pointed it out.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68304
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Editing the Main Website Title

Post by Lumpy Burgertushie »

have you purged the cache and refreshed your browser a couple of times.?


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
michaellanfield
Registered User
Posts: 132
Joined: Mon Feb 04, 2013 5:43 am
Name: Michael Lanfield
Contact:

Re: Editing the Main Website Title

Post by michaellanfield »

here is the code for my overall_header.html file with the changes.

Code: Select all

<!DOCTYPE html>
<html dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1" />
{META}
<title><!-- IF UNREAD_NOTIFICATIONS_COUNT -->({UNREAD_NOTIFICATIONS_COUNT}) <!-- ENDIF --><!-- IF not S_VIEWTOPIC and not S_VIEWFORUM -->{SITENAME}<!-- ENDIF --><!-- IF S_IN_MCP --> - {L_MCP} - {PAGE_TITLE}<!-- ELSEIF S_IN_UCP --> - {L_UCP} - {PAGE_TITLE}<!-- ENDIF --><!-- IF S_VIEWTOPIC or S_VIEWFORUM -->{PAGE_TITLE} - {SITENAME}<!-- ENDIF --></title>

<link rel="shortcut icon" href="favicon.ico" />

<!-- IF S_ENABLE_FEEDS -->
	<!-- IF S_ENABLE_FEEDS_OVERALL --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {SITENAME}" href="{{ path('phpbb_feed_index') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_NEWS --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FEED_NEWS}" href="{{ path('phpbb_feed_news') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_FORUMS --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_ALL_FORUMS}" href="{{ path('phpbb_feed_forums') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_TOPICS --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FEED_TOPICS_NEW}" href="{{ path('phpbb_feed_topics') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_TOPICS_ACTIVE --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FEED_TOPICS_ACTIVE}" href="{{ path('phpbb_feed_topics_active') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_FORUM and S_FORUM_ID --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FORUM} - {FORUM_NAME}" href="{{ path('phpbb_feed_forum', { forum_id : S_FORUM_ID } ) }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_TOPIC and S_TOPIC_ID --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_TOPIC} - {TOPIC_TITLE}" href="{{ path('phpbb_feed_topic', { topic_id : S_TOPIC_ID } ) }}"><!-- ENDIF -->
	<!-- EVENT overall_header_feeds -->
<!-- ENDIF -->

<!-- IF U_CANONICAL -->
	<link rel="canonical" href="{U_CANONICAL}">
<!-- ENDIF -->

<!--
	phpBB style name: Flat Style
	Based on style:   prosilver (this is the default phpBB3 style)
	Original author:  Tom Beddard ( http://www.subBlue.com/ )
	Modified by:      Ian Bradley ( http://phpbbstyles.oo.gd/ )
-->

<!-- IF S_ALLOW_CDN -->
<script>
	WebFontConfig = {
		google: {
			families: ['Open+Sans:300,300i,400,400i,600,600i,700,700i,800,800i&subset=cyrillic,cyrillic-ext,greek,greek-ext,latin-ext,vietnamese']
		}
	};

	(function(d) {
		var wf = d.createElement('script'), s = d.scripts[0];
		wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.18/webfont.js';
		wf.async = true;
		s.parentNode.insertBefore(wf, s);
	})(document);
</script>
<!-- ENDIF -->
<link href="{T_FONT_AWESOME_LINK}" rel="stylesheet">
<link href="{T_STYLESHEET_LINK}" rel="stylesheet">
<link href="{T_STYLESHEET_LANG_LINK}" rel="stylesheet">

<!-- IF S_CONTENT_DIRECTION eq 'rtl' -->
	<link href="{T_THEME_PATH}/bidi.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<!-- ENDIF -->

<!-- IF S_PLUPLOAD -->
	<link href="{T_THEME_PATH}/plupload.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<!-- ENDIF -->

<!-- IF S_COOKIE_NOTICE -->
	<link href="{T_ASSETS_PATH}/cookieconsent/cookieconsent.min.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<!-- ENDIF -->

<!--[if lte IE 9]>
	<link href="{T_THEME_PATH}/tweaks.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<![endif]-->

<!-- EVENT overall_header_head_append -->

{$STYLESHEETS}

<!-- EVENT overall_header_stylesheets_after -->

</head>
<body id="phpbb" class="nojs notouch section-{SCRIPT_NAME} {S_CONTENT_DIRECTION} {BODY_CLASS}">

<!-- EVENT overall_header_body_before -->

<div id="wrap" class="wrap">
	<a id="top" class="top-anchor" accesskey="t"></a>
	<div id="page-header">
		<div class="headerbar" role="banner">
		<!-- EVENT overall_header_headerbar_before -->
			<div class="inner">

			<div id="site-description">
				<a id="logo" class="logo" href="<!-- IF U_SITE_HOME -->{U_SITE_HOME}<!-- ELSE -->{U_INDEX}<!-- ENDIF -->" title="<!-- IF U_SITE_HOME -->{L_SITE_HOME}<!-- ELSE -->{L_INDEX}<!-- ENDIF -->"><span class="site_logo"></span></a>
				<div  class="site-description">
					<h1>{SITENAME}</h1>
					<p>{SITE_DESCRIPTION}</p>
					<p class="skiplink"><a href="#start_here">{L_SKIP}</a></p>
				</div>
			</div>

			</div>
			<!-- EVENT overall_header_headerbar_after -->
		</div>
		<!-- EVENT overall_header_navbar_before -->
		<!-- INCLUDE navbar_header.html -->
	</div>

	<!-- EVENT overall_header_page_body_before -->

	<a id="start_here" class="anchor"></a>
	<div id="page-body" class="page-body" role="main">
		<!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN and (U_MCP or U_ACP) -->
		<div id="information" class="rules">
			<div class="inner">
				<strong>{L_INFORMATION}{L_COLON}</strong> {L_BOARD_DISABLED}
			</div>
		</div>
<!-- IF not S_USER_LOGGED_IN and not S_IS_BOT -->
<div style="text-align: center"><iframe width="560" height="315" src="https://www.youtube.com/embed/crQuh1NzvmI" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
		<!-- ENDIF -->

		<!-- EVENT overall_header_content_before -->
https://www.weareinterconnected.com
Michael Lanfield - author and vegan advocate
User avatar
EA117
Registered User
Posts: 1860
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Editing the Main Website Title

Post by EA117 »

That copy is still showing the problem of the missing ENDIF that was pointed out earlier. That is why this file would still cause an HTTP 500 status.

Let me quote a smaller section of lines to try and make the issue and change easier to see. Taking just this section from the full file you just posted:

Code: Select all

		<!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN and (U_MCP or U_ACP) -->
		<div id="information" class="rules">
			<div class="inner">
				<strong>{L_INFORMATION}{L_COLON}</strong> {L_BOARD_DISABLED}
			</div>
		</div>

<!-- IF not S_USER_LOGGED_IN and not S_IS_BOT -->
<div style="text-align: center"><iframe width="560" height="315" src="https://www.youtube.com/embed/crQuh1NzvmI" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>

		<!-- ENDIF -->
You added your conditional YouTube link, and "there is an ENDIF after it." The problem is, that particular ENDIF was already there before your changes. When adding your addiitonal conditional block, there now need to be two ENDIFs; one for the condition that was already there, and now one for your new additional block, too.

So you want that block to actually look like this:

Code: Select all

		<!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN and (U_MCP or U_ACP) -->
		<div id="information" class="rules">
			<div class="inner">
				<strong>{L_INFORMATION}{L_COLON}</strong> {L_BOARD_DISABLED}
			</div>
		</div>

<!-- IF not S_USER_LOGGED_IN and not S_IS_BOT -->
<div style="text-align: center"><iframe width="560" height="315" src="https://www.youtube.com/embed/crQuh1NzvmI" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<!-- ENDIF -->

		<!-- ENDIF -->
Post Reply

Return to “[3.3.x] Styles Support & Discussion”