Editing the Main Website Title

For support and discussion related to templates and themes in phpBB 3.3.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68470
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Editing the Main Website Title

Post by Lumpy Burgertushie »

actually the code is in the wrong place to begin with.
I said to put it at the very bottom of the file. you mistakenly put it above the ENDIF that was at the bottom of the file instead of after it.
by putting it inside the previous IF statement it will only show up if the board is disabled and you are logged in etc.

it should be the last thing in the file after this line: <!-- EVENT overall_header_content_before -->

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
EA117
Registered User
Posts: 1970
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Editing the Main Website Title

Post by EA117 »

Good point. So my final example of "what the block should look like" actually needs to be like what Robert described.

The example is long enough now that you'll probably need to use the scroll bars in order to see it all:

Code: Select all

		<!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN and (U_MCP or U_ACP) -->
		<div id="information" class="rules">
			<div class="inner">
				<strong>{L_INFORMATION}{L_COLON}</strong> {L_BOARD_DISABLED}
			</div>
		</div>

		<!-- ENDIF -->
		
		<!-- EVENT overall_header_content_before -->		
		
<!-- IF not S_USER_LOGGED_IN and not S_IS_BOT -->
<div style="text-align: center"><iframe width="560" height="315" src="https://www.youtube.com/embed/crQuh1NzvmI" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<!-- ENDIF -->
michaellanfield
Registered User
Posts: 132
Joined: Mon Feb 04, 2013 5:43 am
Name: Michael Lanfield
Contact:

Re: Editing the Main Website Title

Post by michaellanfield »

I don't know any longer. I aprreciate you guys trying to assist me, but maybe i think I am too tired...Maybe it's Coronavirus. hahahaha! :lol:

here is the full code again.

Code: Select all

<!DOCTYPE html>
<html dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1" />
{META}
<title><!-- IF UNREAD_NOTIFICATIONS_COUNT -->({UNREAD_NOTIFICATIONS_COUNT}) <!-- ENDIF --><!-- IF not S_VIEWTOPIC and not S_VIEWFORUM -->{SITENAME}<!-- ENDIF --><!-- IF S_IN_MCP --> - {L_MCP} - {PAGE_TITLE}<!-- ELSEIF S_IN_UCP --> - {L_UCP} - {PAGE_TITLE}<!-- ENDIF --><!-- IF S_VIEWTOPIC or S_VIEWFORUM -->{PAGE_TITLE} - {SITENAME}<!-- ENDIF --></title>

<link rel="shortcut icon" href="favicon.ico" />

<!-- IF S_ENABLE_FEEDS -->
	<!-- IF S_ENABLE_FEEDS_OVERALL --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {SITENAME}" href="{{ path('phpbb_feed_index') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_NEWS --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FEED_NEWS}" href="{{ path('phpbb_feed_news') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_FORUMS --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_ALL_FORUMS}" href="{{ path('phpbb_feed_forums') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_TOPICS --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FEED_TOPICS_NEW}" href="{{ path('phpbb_feed_topics') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_TOPICS_ACTIVE --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FEED_TOPICS_ACTIVE}" href="{{ path('phpbb_feed_topics_active') }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_FORUM and S_FORUM_ID --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FORUM} - {FORUM_NAME}" href="{{ path('phpbb_feed_forum', { forum_id : S_FORUM_ID } ) }}"><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_TOPIC and S_TOPIC_ID --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_TOPIC} - {TOPIC_TITLE}" href="{{ path('phpbb_feed_topic', { topic_id : S_TOPIC_ID } ) }}"><!-- ENDIF -->
	<!-- EVENT overall_header_feeds -->
<!-- ENDIF -->

<!-- IF U_CANONICAL -->
	<link rel="canonical" href="{U_CANONICAL}">
<!-- ENDIF -->

<!--
	phpBB style name: Flat Style
	Based on style:   prosilver (this is the default phpBB3 style)
	Original author:  Tom Beddard ( http://www.subBlue.com/ )
	Modified by:      Ian Bradley ( http://phpbbstyles.oo.gd/ )
-->

<!-- IF S_ALLOW_CDN -->
<script>
	WebFontConfig = {
		google: {
			families: ['Open+Sans:300,300i,400,400i,600,600i,700,700i,800,800i&subset=cyrillic,cyrillic-ext,greek,greek-ext,latin-ext,vietnamese']
		}
	};

	(function(d) {
		var wf = d.createElement('script'), s = d.scripts[0];
		wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.18/webfont.js';
		wf.async = true;
		s.parentNode.insertBefore(wf, s);
	})(document);
</script>
<!-- ENDIF -->
<link href="{T_FONT_AWESOME_LINK}" rel="stylesheet">
<link href="{T_STYLESHEET_LINK}" rel="stylesheet">
<link href="{T_STYLESHEET_LANG_LINK}" rel="stylesheet">

<!-- IF S_CONTENT_DIRECTION eq 'rtl' -->
	<link href="{T_THEME_PATH}/bidi.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<!-- ENDIF -->

<!-- IF S_PLUPLOAD -->
	<link href="{T_THEME_PATH}/plupload.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<!-- ENDIF -->

<!-- IF S_COOKIE_NOTICE -->
	<link href="{T_ASSETS_PATH}/cookieconsent/cookieconsent.min.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<!-- ENDIF -->

<!--[if lte IE 9]>
	<link href="{T_THEME_PATH}/tweaks.css?assets_version={T_ASSETS_VERSION}" rel="stylesheet">
<![endif]-->

<!-- EVENT overall_header_head_append -->

{$STYLESHEETS}

<!-- EVENT overall_header_stylesheets_after -->

</head>
<body id="phpbb" class="nojs notouch section-{SCRIPT_NAME} {S_CONTENT_DIRECTION} {BODY_CLASS}">

<!-- EVENT overall_header_body_before -->

<div id="wrap" class="wrap">
	<a id="top" class="top-anchor" accesskey="t"></a>
	<div id="page-header">
		<div class="headerbar" role="banner">
		<!-- EVENT overall_header_headerbar_before -->
			<div class="inner">

			<div id="site-description">
				<a id="logo" class="logo" href="<!-- IF U_SITE_HOME -->{U_SITE_HOME}<!-- ELSE -->{U_INDEX}<!-- ENDIF -->" title="<!-- IF U_SITE_HOME -->{L_SITE_HOME}<!-- ELSE -->{L_INDEX}<!-- ENDIF -->"><span class="site_logo"></span></a>
				<div  class="site-description">
					<h1>{SITENAME}</h1>
					<p>{SITE_DESCRIPTION}</p>
					<p class="skiplink"><a href="#start_here">{L_SKIP}</a></p>
				</div>
			</div>

			</div>
			<!-- EVENT overall_header_headerbar_after -->
		</div>
		<!-- EVENT overall_header_navbar_before -->
		<!-- INCLUDE navbar_header.html -->
	</div>

	<!-- EVENT overall_header_page_body_before -->

	<a id="start_here" class="anchor"></a>
	<div id="page-body" class="page-body" role="main">
				<!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN and (U_MCP or U_ACP) -->
		<div id="information" class="rules">
			<div class="inner">
				<strong>{L_INFORMATION}{L_COLON}</strong> {L_BOARD_DISABLED}
			</div>
		</div>

		<!-- ENDIF -->
		
		<!-- EVENT overall_header_content_before -->		
		
<!-- IF not S_USER_LOGGED_IN and not S_IS_BOT -->
<div style="text-align: center"><iframe width="560" height="315" src="https://www.youtube.com/embed/crQuh1NzvmI" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<!-- ENDIF -->
https://www.weareinterconnected.com
Michael Lanfield - author and vegan advocate
User avatar
Lumpy Burgertushie
Registered User
Posts: 68470
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Editing the Main Website Title

Post by Lumpy Burgertushie »

you put the correct code in the correct place in the overall_header.html file.
assuming the embed code is correct it should show up. have you purged the cache?

let me try your exact code and see what happens on my test site.


robret

ok, your code works just fine on my test site here:
https://phpbbace.com/phpbb3.3/phpBB3/

so, either you are not purging your cache or there is some other problem.

do you have some other caching like cloudfare etc.? if so, turn it off or reset it so you can work on your board etc.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
EA117
Registered User
Posts: 1970
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Editing the Main Website Title

Post by EA117 »

michaellanfield wrote:
Sun Apr 26, 2020 3:11 am
Maybe it's Coronavirus. hahahaha! :lol:
I thought they were saying the symptom was "losing your sense of SMELL." But maybe they've been saying "your sense of HTML" and I just misunderstood... 😁

Agree that the template currently on the site looks like it should be working, and suspect that a phpBB ACP "Purge cache" could be what's needed.
michaellanfield
Registered User
Posts: 132
Joined: Mon Feb 04, 2013 5:43 am
Name: Michael Lanfield
Contact:

Re: Editing the Main Website Title

Post by michaellanfield »

The video shows now. It also seems like the title is fixed too. Thank you all for assistance and the back and forth.
https://www.weareinterconnected.com
Michael Lanfield - author and vegan advocate
Post Reply

Return to “[3.3.x] Styles Support & Discussion”