Advertisement Management

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
User avatar
buyloewen
Registered User
Posts: 43
Joined: Thu Aug 14, 2008 7:12 am
Contact:

Re: Advertisement Management

Post by buyloewen »

just curious if I make a backup using acp will this save everything including my posts or is something else I have to do. Also to insatll this mod how do I navigate to this file Open: includes/constants.php I can't figure it out. thx for the help.

endeffects
Registered User
Posts: 27
Joined: Thu Sep 18, 2008 2:40 pm

Re: Advertisement Management

Post by endeffects »

hallo,

i have a small problem with adsense text advertisements on the footer
of my counter strike forum, the forum seems to modify the styles.

it works correctly for the header, please have a look:
http://www.shoot-em.com/forum/counterst ... e-t61.html

the text ads on the top uses the custom colors, the text ads at the bottom
uses borders and other colors.

any ideas how to fix this?

durtyrok
Registered User
Posts: 31
Joined: Tue Aug 19, 2008 2:42 am
Location: South Carolina USA!
Contact:

Re: Advertisement Management

Post by durtyrok »

I am 99.999% sure I followed the directions but I am coming up with this. I did the subsilver2 install and I put the proper code in constants and funtions then added to code in the 3 subsilver2 html's. What did I do wrong?
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3452: page_header(./ads/functions.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3452: page_header(./ads/functions.php): failed to open stream: No such file or directory

Fatal error: page_header(): Failed opening required './ads/functions.php' (include_path='.:/usr/local/lib/php') in /home/content/d/u/r/durtyrok2001/html/messageboard/includes/functions.php on line 3452
This is what I added to funtions.php

Code: Select all

	// Which timezone?
	$tz = ($user->data['user_id'] != ANONYMOUS) ? strval(doubleval($user->data['user_timezone'])) : strval(doubleval($config['board_timezone']));

	// Advertisement Management
	require($phpbb_root_path . 'ads/functions.' . $phpEx);
	setup_ads();

	// Send a proper content-language to the output
	$user_lang = $user->lang['USER_LANG'];
	if (strpos($user_lang, '-x-') !== false)
	{
		$user_lang = substr($user_lang, 0, strpos($user_lang, '-x-'));
	}

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Advertisement Management

Post by RMcGirr83 »

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3452: page_header(./ads/functions.php): failed to open stream: No such file or directory
Looks to me you didn't upload the files into their proper locations for the mod.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

stouphan
Registered User
Posts: 5
Joined: Sun Nov 26, 2006 1:30 pm
Contact:

Re: Advertisement Management

Post by stouphan »

Sorry guys,

I double checked all file editings, uploaded all files (also the template files) and had no errors. The AM is showing up in the ACP and I created an ad which should show up in all available positions. Groups ads are disabled. As raw html code I just wrote 'This is a test'. But nothing shows up. What did I wrong? Any ideas? I search now for hours and can't find the bug...
My forum is located at www.zorbas.de/scripts/phpBB3

Some help please! - And greetings from Greece!

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Advertisement Management

Post by RMcGirr83 »

Did you purge the cache in the ACP?
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

dodgyr
Registered User
Posts: 2
Joined: Sun Sep 28, 2008 1:22 pm

Re: Advertisement Management

Post by dodgyr »

Hi guys,
I am needing a bit of help.
I am using the non-standard theme called Black Pearl.

What do I do when the installation instructions tell me to add code after a certain existing code, but that exisiting code that is supposed to be there is not in the file?
For example, for the instruction below, there is no "page-header" div id. Where would I include it if this div-id does not exist?

Find
Tip: This may be a partial find and not the whole line.

Code:Select All
<div id="page-header">

Add after
Tip: Add these lines on a new blank line after the preceding line(s) to find.

Code:Select All
{ADS_1}


I am also having problems with this one (but I am assuming that this will be pretty similar to <a name="top"> -

Find
Tip: This may be a partial find and not the whole line.

Code:Select All
<a name="start_here"></a>
Add before
Tip: Add these lines on a new blank line before the preceding line(s) to find.

Code:Select All
<!-- IF ADS_2 -->
<br />
<div class="forabg">
<div class="inner"><span class="corners-top"><span></span></span>
<ul class="topiclist">
<li class="header">
<dl class="icon">
<dt>{L_ADVERTISEMENT}</dt>
</dl>
</li>
</ul>
<div style="padding: 5px 5px 2px 5px; font-size: 1.1em; background-color: #ECF1F3; margin: 0px auto; text-align: center;">
{ADS_2}
</div>
<span class="corners-bottom"><span></span></span></div>
</div>
<!-- ENDIF -->


Is there a standard rule or something that tells me where to add code when the code I am supposed to find does not exist (or nothing in the existing code comes close to being in the right location or to serve that purpose?)

stouphan
Registered User
Posts: 5
Joined: Sun Nov 26, 2006 1:30 pm
Contact:

Re: Advertisement Management

Post by stouphan »

RMcGirr83 wrote:Did you purge the cache in the ACP?
Here we go! That was it! So easy! Should have asked earlier....
Thanks a lot!!

durtyrok
Registered User
Posts: 31
Joined: Tue Aug 19, 2008 2:42 am
Location: South Carolina USA!
Contact:

Re: Advertisement Management

Post by durtyrok »

RMcGirr83 wrote:
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3452: page_header(./ads/functions.php): failed to open stream: No such file or directory
Looks to me you didn't upload the files into their proper locations for the mod.
I did upload them just like the instructions say.

DaannO
Registered User
Posts: 86
Joined: Mon Sep 17, 2007 11:24 am

Re: Advertisement Management

Post by DaannO »

Is it also possible to give an ad per topic? So i want one banner at a specific topic?

AdMac
Registered User
Posts: 11
Joined: Sat May 24, 2008 11:59 pm

Re: Advertisement Management

Post by AdMac »

Thank you very much :)
I'm gonna try it right away ;)

durtyrok
Registered User
Posts: 31
Joined: Tue Aug 19, 2008 2:42 am
Location: South Carolina USA!
Contact:

Re: Advertisement Management

Post by durtyrok »

RMcGirr83 wrote:
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3452: page_header(./ads/functions.php): failed to open stream: No such file or directory
Looks to me you didn't upload the files into their proper locations for the mod.
Could somebody walk me through the process for uploading the root folder? I seem to be having trouble with it. I copied it into the root folder on my server. Should I have done it another way? :mrgreen:

Keep in mind that I am using subsilver2. Thanks!
Last edited by durtyrok on Sat Oct 04, 2008 4:15 pm, edited 1 time in total.

HISHAMOO
Registered User
Posts: 51
Joined: Thu Mar 03, 2005 11:06 am
Location: BaHrAiN

Re: Advertisement Management

Post by HISHAMOO »

Hi

thanks for the great mod

but I can't find this step

============================

Find
Tip: This may be a partial find and not the whole line.

Code:Select All
<div id="wrapheader">
Add after
Tip: Add these lines on a new blank line after the preceding line(s) to find.

Code:Select All
<!-- IF ADS_1 -->{ADS_1}<br /><!-- ENDIF -->

mladen88
Registered User
Posts: 158
Joined: Wed May 30, 2007 9:06 pm

Re: Advertisement Management

Post by mladen88 »

Is this some joke? this guy don't give support for free users, just if you pay?????????????

Clicks don't working, and guy tells that i must pay to him if i want support OMFG :evil: :evil:

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29253
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Re: Advertisement Management

Post by Marshalrusty »

MOD authors are not obligated to support their code. As you can see, however, people in this topic are getting support. You certainly were not told that you have to pay anywhere on this site.

If the MOD or the support of the MOD is not meeting your expectations, then the best course of action would be to uninstall it.

Pardon the preemptive concern, but I would ask that you do not turn this topic into a discussion of the MOD author's policies.
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

Locked

Return to “[3.0.x] MOD Database Releases”