NV usertopics

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
vonhazey
Registered User
Posts: 89
Joined: Wed Dec 02, 2009 2:43 pm

Re: NV usertopics

Post by vonhazey »

Hi nickvergessen, I installed the mod onto a brand new phpBB 3.0.6 board and everything is fine but on my check for mod updates it says I only have 1.0.2 installed but it was the 1.0.3 package i downloaded and installed, I re-downloaded the 1.0.3 package and uploaded the mod version check but it is still saying it's out of date, anyway to fix this please?.
Image
Blueprins
Registered User
Posts: 557
Joined: Thu Feb 13, 2003 2:16 pm
Contact:

Re: NV usertopics

Post by Blueprins »

Hello nickvergessen , that is realy great Mod. But there are one deficiency. I've installed a mod, but the users topic counter is not count the older topics, for example in the past, I have posted 500 Topic and I have installed this mod and I see on my Profil Page 0 topics. However after this mod, if I open my 501th , 502th. topic the Topic counter begin to show 1 , 2. I mean that how can I add to the Topic counter my older Topic number? :roll:
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: NV usertopics

Post by nickvergessen »

On the first page in the ACP there is an option to recalculate the topic-count.
No Support via PM
Blueprins
Registered User
Posts: 557
Joined: Thu Feb 13, 2003 2:16 pm
Contact:

Re: NV usertopics

Post by Blueprins »

nickvergessen wrote:On the first page in the ACP there is an option to recalculate the topic-count.
Yes I've already done but I've got the same results :roll:
Khamosh-Saya
Registered User
Posts: 871
Joined: Fri Nov 23, 2007 6:46 am
Location: UAE
Name: Jamshed Ansari
Contact:

Re: NV usertopics

Post by Khamosh-Saya »

When i try to Execute the sql qurree
its give me error

Code: Select all

General Error
SQL ERROR [ mysql4 ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '"' at line 1 [1064]

SQL

ALTER TABLE phpbb_users ADD user_topics mediumint(8) unsigned DEFAULT &quot

BACKTRACE


FILE: includes/db/mysql.php
LINE: 174
CALL: dbal_mysql->sql_error()

FILE: sql.php
LINE: 45
CALL: dbal_mysql->sql_query()
User avatar
eunaumtenhoid
Registered User
Posts: 998
Joined: Wed Jun 03, 2009 12:46 am
Location: ????

Re: NV usertopics

Post by eunaumtenhoid »

how set to show topics only for id forum?
My translations of the extensions for Brazilian Portuguese
https://github.com/phpBBTraducoes
ChezUK
Registered User
Posts: 74
Joined: Wed May 20, 2009 8:45 pm

Re: NV usertopics

Post by ChezUK »

vonhazey wrote:
ChezUK wrote:
parkstee wrote:If anyone wants to change their memberlist so that the users topics display in a seperate column than you need to remove all edits from the memberlist_body.html and do the following edits:

find

Code: Select all

<th class="posts"><a href="{U_SORT_POSTS}#memberlist">{L_POSTS}</a></th>
after add

Code: Select all

<th class="posts"><a href="{U_SORT_TOPICS}#memberlist">{L_TOPICS}</a></th>
find

Code: Select all

<td colspan="<!-- IF U_SORT_ACTIVE -->5<!-- ELSE -->4<!-- ENDIF -->">&nbsp;</td>
replace with

Code: Select all

<td colspan="<!-- IF U_SORT_ACTIVE -->6<!-- ELSE -->5<!-- ENDIF -->">&nbsp;</td>
find

Code: Select all

<td class="posts"><!-- IF memberrow.POSTS --><a href="{memberrow.U_SEARCH_USER}" title="{L_SEARCH_USER_POSTS}">{memberrow.POSTS}</a><!-- ELSE -->{memberrow.POSTS}<!-- ENDIF --></td>
after add

Code: Select all

               <td class="posts"><!-- IF memberrow.TOPICS --><a href="{memberrow.U_SEARCH_USER_TOPICS}" title="{L_SEARCH_USER_TOPICS}">{memberrow.TOPICS}</a><!-- ELSE -->{memberrow.TOPICS}<!-- ENDIF --></td>
don't forget to refresh your template
I did this and it works great on the memberslist, however when viewing a group, there is no header for the topics row and the table looks badly aligned -

http://www.ohlookaforum.com/supporters-g8.html
hi you need to do this bit twice once for the main list and one for the groups

Code: Select all

<th class="posts"><a href="{U_SORT_POSTS}#memberlist">{L_POSTS}</a></th>
after add

Code: Select all

<th class="posts"><a href="{U_SORT_TOPICS}#memberlist">{L_TOPICS}</a></th>
that seem to work for me, as fi you look in the install instructions there are two of this to edit

Code: Select all

<th class="posts"><a href="{U_SORT_POSTS}#memberlist">{L_POSTS}</a></th>

That did the job! Thank you vonhazey :mrgreen:
vonhazey
Registered User
Posts: 89
Joined: Wed Dec 02, 2009 2:43 pm

Re: NV usertopics

Post by vonhazey »

No probs glad I could help.
Image
ricjonhay
Registered User
Posts: 247
Joined: Tue Feb 16, 2010 6:08 pm

Re: NV usertopics

Post by ricjonhay »

Installed version 1.0.3 and working fine, great mod.
User avatar
Sr X
Registered User
Posts: 202
Joined: Wed Feb 07, 2007 9:25 am

Re: NV usertopics

Post by Sr X »

In forum/memberlist.php when I put the mouse over the topic link appears this language error: {SEARCH_USER_TOPICS}
how fix? thanks.
User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Re: NV usertopics

Post by IPB_Refugee »

Hi,

probably you didn't do the changes in language files (do them for ALL of your installed languages).

Or you didn't purge the cache (main page in ACP) and/or you didn't refresh your styles (somewhere on ACP/styles page).

Regards
Wolfgang
User avatar
Sr X
Registered User
Posts: 202
Joined: Wed Feb 07, 2007 9:25 am

Re: NV usertopics

Post by Sr X »

IPB_Refugee wrote:Hi,

probably you didn't do the changes in language files (do them for ALL of your installed languages).

Or you didn't purge the cache (main page in ACP) and/or you didn't refresh your styles (somewhere on ACP/styles page).

Regards
Wolfgang
i have done all that, you can seen this error in any site: Image
isNumB
Registered User
Posts: 86
Joined: Thu Aug 06, 2009 7:59 am

Re: NV usertopics

Post by isNumB »

can't find this line

Code: Select all

'SEARCH_USER_POSTS'		=> 'Search user’s posts',
in language/en/memberlist.php :(

EDIT: Fixed that, but....

Resynchronise topic counts
Only existing topics will be taken into consideration. Pruned topics will not be counted.

Code: Select all

SQL ERROR [ mysql4 ]

Unknown column 'user_topics' in 'field list' [1054]

SQL

UPDATE phpbb_users SET user_topics = 0 WHERE user_id = 1

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: includes/acp/acp_main.php
LINE: 263
CALL: dbal_mysql->sql_query()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_main->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()
EDIT: Ok, forgot one step... :D
MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: NV usertopics

Post by MydnyteSyn »

Hi nickvergessen, I installed the mod onto a brand new phpBB 3.0.6 board and everything is fine but on my check for mod updates it says I only have 1.0.2 installed but it was the 1.0.3 package i downloaded and installed, I re-downloaded the 1.0.3 package and uploaded the mod version check but it is still saying it's out of date, anyway to fix this please?.
I have the same issue. Everything's been purged, all cache's cleared, all edits made appropriately, and it still says I have 1.0.2 installed when I have 1.0.3 installed.
User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: NV usertopics

Post by nickvergessen »

adm/mods/nv_usertopics_version.php
find:

Code: Select all

1.0.2
replace with:

Code: Select all

1.0.3
No Support via PM
Locked

Return to “[3.0.x] MOD Database Releases”