NV usertopics

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
mickaldinho
Registered User
Posts: 36
Joined: Sun Feb 24, 2008 9:01 pm

Re: NV usertopics

Post by mickaldinho » Mon Sep 08, 2008 4:07 pm

Yeah did everthing it said :( lol

MGLorencin
Registered User
Posts: 17
Joined: Wed Aug 20, 2008 9:40 am

Re: NV usertopics

Post by MGLorencin » Thu Sep 18, 2008 10:39 am

mickaldinho wrote:Hey man do you know why i get this error?

Code: Select all

    General Error
    SQL ERROR [ mysql4 ]

    Unknown column 'user_topics' in 'field list' [1054]

    SQL

    UPDATE phpbb_users SET user_topics = 0 WHERE user_id = 1

    BACKTRACE

    FILE: includes/db/mysql.php
    LINE: 158
    CALL: dbal->sql_error()

    FILE: includes/acp/acp_main.php
    LINE: 221
    CALL: dbal_mysql->sql_query()

    FILE: includes/functions_module.php
    LINE: 471
    CALL: acp_main->main()

    FILE: adm/index.php
    LINE: 74
    CALL: p_master->load_active()
I get the same error, I am using prosilever_se template but edited all files as instructed, I am sure I didn't miss anything.

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: NV usertopics

Post by nickvergessen » Thu Sep 18, 2008 10:59 am

you missed to run the SQL
No Support via PM

MGLorencin
Registered User
Posts: 17
Joined: Wed Aug 20, 2008 9:40 am

Re: NV usertopics

Post by MGLorencin » Thu Sep 18, 2008 11:07 am

No I didnt ...that was acctually the frist thing I did when starting to apply this mod.

Code: Select all

ALTER TABLE phpbb_users ADD user_topics mediumint(8) unsigned DEFAULT "0" NOT NULL;
Is there anything else to run ?

MGLorencin
Registered User
Posts: 17
Joined: Wed Aug 20, 2008 9:40 am

Re: NV usertopics

Post by MGLorencin » Thu Sep 18, 2008 11:08 am

Could this have anything to do with size of my dB ? ...it's at 120 MB and has lots of topics.

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: NV usertopics

Post by nickvergessen » Thu Sep 18, 2008 12:42 pm

No the message says you didn't run the sql yet.
No Support via PM

MGLorencin
Registered User
Posts: 17
Joined: Wed Aug 20, 2008 9:40 am

Re: NV usertopics

Post by MGLorencin » Thu Sep 18, 2008 3:36 pm

I understand, but thats the wird thing ...as I did and if try to run it again I get this error.

Code: Select all

Error
SQL query:

ALTER TABLE phpbb_users ADD user_topics MEDIUMINT( 8 ) UNSIGNED DEFAULT "0" NOT NULL ;


MySQL said: 

#1060 - Duplicate column name 'user_topics'

User avatar
JimA
Community Team Leader
Community Team Leader
Posts: 7608
Joined: Thu Jul 31, 2008 5:54 am
Location: The Netherlands
Name: Jim Mossing Holsteyn
Contact:

Re: NV usertopics

Post by JimA » Thu Sep 18, 2008 3:47 pm

This means you've already runned the SQL before. You don't have to run it twice. ;)
Image Jim Mossing Holsteyn - Community Team Leader
Knowledge Base | Documentation | Board rules

If you're having any questions about the rules/customs of this website, feel free to drop me a PM.

MGLorencin
Registered User
Posts: 17
Joined: Wed Aug 20, 2008 9:40 am

Re: NV usertopics

Post by MGLorencin » Thu Sep 18, 2008 3:57 pm

Thats what I have been saying ...because mod avtor said I didn't run the query.

I really would like to point out that I think this mod is great so I hope that I can make it work somehow :P

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: NV usertopics

Post by nickvergessen » Thu Sep 18, 2008 9:25 pm

are you sure you were in the right DB? could you show a link to your board with a user or permissions to see profiles?
No Support via PM

MGLorencin
Registered User
Posts: 17
Joined: Wed Aug 20, 2008 9:40 am

Re: NV usertopics

Post by MGLorencin » Thu Sep 18, 2008 9:36 pm

Will check again just to make sure :) ...and get back to you.

---- EDIT ----

Well SQL query was did run in correct dB, here is a test user I created for you to take check.

check here
username: Test
password: test_user

In profiles you can see topic count is 0, I have set board lang for you in english because native lang of board isnt english.

If you need additional permissions please let me know.

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: NV usertopics

Post by nickvergessen » Thu Sep 18, 2008 11:37 pm

Hm, the Column seems to exist, as there are no problems on posting a new topic. the topic-counter also increases by 1 :roll:
No Support via PM

JeRicHoOL
Registered User
Posts: 449
Joined: Sun Jun 01, 2008 4:02 pm

Re: NV usertopics

Post by JeRicHoOL » Sat Oct 18, 2008 4:15 pm

Thanks for this mod. Installation took a bit time because of all the file edits but it worked without any trouble for me. :)

User avatar
Sr X
Registered User
Posts: 202
Joined: Wed Feb 07, 2007 9:25 am

Re: NV usertopics

Post by Sr X » Tue Oct 21, 2008 12:02 pm

userful mod.
i don´t know why this mod is not in core version. thanks for your work :)

JasonWade
Registered User
Posts: 287
Joined: Mon Jun 05, 2006 9:22 am

Re: NV usertopics

Post by JasonWade » Wed Oct 22, 2008 5:38 pm

woops, forgot to resynchronise, nm. ;)

Locked

Return to “[3.0.x] MOD Database Releases”