Board3 Portal

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
kaw
Registered User
Posts: 4
Joined: Tue Dec 30, 2008 11:37 am

Re: Board3 Portal

Post by kaw »

Thank you for a great mod, it is working awesome!

I like it so much I would like to stay in the portal even when browsing around the forum, is this possible?
I guess I would need to somehow merge portal.php & index.php, but not sure where to even begin.

Any hints would be greatly appreciated. :)

Cheers,
Kaw
jswear1
Registered User
Posts: 28
Joined: Sun Jun 07, 2009 6:01 pm

Re: Board3 Portal

Post by jswear1 »

kaw wrote:Thank you for a great mod, it is working awesome!

I like it so much I would like to stay in the portal even when browsing around the forum, is this possible?
I guess I would need to somehow merge portal.php & index.php, but not sure where to even begin.

Any hints would be greatly appreciated. :)

Cheers,
Kaw
If you're using phpbb3, you would need to add the PortalView mod, which is available from the Board3.de site. This allows your forum to load while still showing the left block column. It would probably also show the right column with some tweaking, but I didn't take it that far.
kaw
Registered User
Posts: 4
Joined: Tue Dec 30, 2008 11:37 am

Re: Board3 Portal

Post by kaw »

jswear1 wrote:
kaw wrote:Thank you for a great mod, it is working awesome!

I like it so much I would like to stay in the portal even when browsing around the forum, is this possible?
I guess I would need to somehow merge portal.php & index.php, but not sure where to even begin.

Any hints would be greatly appreciated. :)

Cheers,
Kaw
If you're using phpbb3, you would need to add the PortalView mod, which is available from the Board3.de site. This allows your forum to load while still showing the left block column. It would probably also show the right column with some tweaking, but I didn't take it that far.
Thank you for your reply jswear1, I will go check it out. :)
asiapain
Registered User
Posts: 5
Joined: Thu Aug 27, 2009 2:38 pm

Re: Board3 Portal

Post by asiapain »

Sirrah wrote:Thanks for the advice, but you will realise now my stupidity:

How do I run the installer?


Edit: Do not worry, I have done it. For some reason the url didnt work at first, thought I was done for. yay!
able to share how you install?
jswear1
Registered User
Posts: 28
Joined: Sun Jun 07, 2009 6:01 pm

Re: Board3 Portal

Post by jswear1 »

asiapain wrote:
Sirrah wrote:Thanks for the advice, but you will realise now my stupidity:

How do I run the installer?


Edit: Do not worry, I have done it. For some reason the url didnt work at first, thought I was done for. yay!
able to share how you install?
Once you've uploaded the files to the directory you want, point your browser to the install page and just follow the directions. :)
Mircea007
Registered User
Posts: 74
Joined: Mon Jun 15, 2009 9:24 pm

Re: Board3 Portal

Post by Mircea007 »

when someone posts something new it doesn't apear on the portal recent posts ... why ?
Flash Games like you never seen before
jim_nagh
Registered User
Posts: 2
Joined: Thu Apr 09, 2009 9:25 pm

Re: Board3 Portal

Post by jim_nagh »

I am having a wee bit of an issue i get this after i installed the portal.

SQL ERROR [ mysqli ]

Table 'clmbeihj_dip1.PORTAL_CONFIG_TABLE' doesn't exist [1146]


where am i to get a Portal Config Table to place in my sql?

Especially if it does not exist?

Much help is appreciated and if i am posting in wrong are please dirct me to the correct place.

Thanks
Jim
User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5470
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: Board3 Portal

Post by Marc »

You didn't do the edits to constants.php.
You might also want to check if you did the other changes.
madphoenix33
Registered User
Posts: 26
Joined: Mon Aug 31, 2009 4:54 pm

Re: Board3 Portal

Post by madphoenix33 »

i edited all..install and then i go to ACP ..in mods i have portal mode..but when i try to clik on i got this error:


General Error
SQL ERROR [ mysqli ]

Table 'betonska_phpbb3.PORTAL_CONFIG_TABLE' doesn't exist [1146]

SQL

SELECT config_name, config_value FROM PORTAL_CONFIG_TABLE

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: portal/includes/functions.php
LINE: 32
CALL: dbal_mysqli->sql_query()

FILE: includes/acp/acp_portal.php
LINE: 25
CALL: obtain_portal_config()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_portal->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()


any solutions? suggests


thx in advance
robgib
Registered User
Posts: 84
Joined: Sat Aug 28, 2004 11:48 am
Location: UK
Contact:

Re: Board3 Portal install problem....

Post by robgib »

installing on a local host using automod

mod version checker is installed........

got some manual edits......

have edited all the files but get this error



Parse error: syntax error, unexpected '{' in C:\xampp\htdocs\forum\includes\functions.php on line 3762


when viewing the instruction files

Code: Select all

 includes/functions.php
Find

// The following assigns all _common_ variables that may be used at any point in a template.

Add Before

	$user->add_lang('mods/lang_portal');
	include_once($phpbb_root_path . 'portal/includes/functions.'.$phpEx);
	$portal_config = obtain_portal_config();

Success
Find

'U_PRIVATEMSGS'			=> append_sid("{$phpbb_root_path}ucp.$phpEx", 'i=pm&folder=inbox'),

Add Before

		'U_PORTAL'				=> ($portal_config['portal_enable']) ? append_sid("{$phpbb_root_path}portal.$phpEx") : '',

Success
i cant see the whole line??
milplus
Registered User
Posts: 105
Joined: Thu Jun 14, 2007 11:03 am

Re: Board3 Portal

Post by milplus »

HI I've installed this MOD it's a very great tool easy to install,
However I'm getting errore message below

Fatal error: Not able to open ./cache/data_global.php in D:\inetpub\webs\mil-depotscom\public\shanahaneng.it\public\phpbb3\includes\acm\acm_file.php on line 112

The only problem I 'm getting now it that I do not see at all the header portal with tabs menu.

I'm just getting the standard prosilver one belong to my old forum.
-----------

Another issue I have is to avoid to show up info to any simple guest instead a register user.

When I simply jump into the dbase all the infos are freely posted.

I guess it has been submitted in some thread but I cannot find it anymore.

thanks

viktor
milplus
Registered User
Posts: 105
Joined: Thu Jun 14, 2007 11:03 am

Re: Board3 Portal home index re-link an Tabs

Post by milplus »

All
it's probably a stupid question but I have to link th eportal index with the Board index on my previous forum home. same for the logo . It hasto be linked to the portal home page.
I tried to follow some thread suggestion replacing u_Index with the new path but no luck.
---------------------------

then I have to understand whether it's normal to do not see Portal Overallheader page upper side with tabs. I'm just getting my forum header for now .

----------------------------

hope someone can give me an hand.

thanks

viktor
Sirrah
Registered User
Posts: 10
Joined: Mon Aug 31, 2009 4:36 pm

Re: Board3 Portal

Post by Sirrah »

Hey,

Just another quick query for you guys. Thanks in advance for all the help.

Q: In which CSS file can I find the code needed to change the background colour of the side blocks on the portal?

I believe that as it is installed in prosilver, the portal inherits from that style. I am using Prosilver_SE which in turn inherits stuff from Prosilver. Would it be best to copy some of the portal files from prosilver theme into Prosilver_SE or just edit the Prosilver css? That is assuming that I have read the problem correctly - chances are I havn't. Any help would be great.

Really like this mod guys.

Sirrah
milplus
Registered User
Posts: 105
Joined: Thu Jun 14, 2007 11:03 am

Re: Board3 Portal

Post by milplus »

PHP Version: 3.0.4
MySQL Version: 5


I've installed the Board3 portal on my forum and I have following problems now:

1.the Board Main header I was expecting to be shown on top page with all the customizable Tabs is not shown on overallheader.html. Is there a way to get it shown same of the portal.php.
2. regardless if you are a registered user or simply a guest before log in private infos like Board members, top posters etc etc are shown on portal. Di dnot find the way to avoid this disabling something in the MOD panel ACP. please advise if you can if this is possible in some way with some different set-up.
3. I'm getting since the installation of the MOd error below reported:

Fatal error: Not able to open ./cache/data_global.php in ..\inetpub\webs\mywebpage.com\public\.......\phpbb3\includes\acm\acm_file.php on line 112

I've checked and I cannot sort out the issue. all the files I've been modified properly and accordingly to the installation instruction posted on the MOD.

4. I'm missing on the top left MENU the thumbs arrows, just getting some bullet instead.
5. I went to the ACP, System--MOD-PORTAL, tried to enable some module and disable some other with no chances and no effects, cache has been purged, styles refreshed wit no any change on the portal. it seems there is no connection.
6. I need to then link on my board forum page LOGO (once all the point 1-5 will be sorted) the Portal unless I cannot maintain the Portal Main Header ever on the Top also on my Board, this should be Great!
7. once I'll sort out the above I need also to be able to change colors and make up to the Portal page but I'll go through the styles forum to learn more with additional styles.

I've installed only skype mod and ACP user MOD so far. I did some other minor customization at my Board is not affecting really files involved in the MOD of the portal.

hope someone will give me an hand to fix this bugs I have.
thanks milplus
osmorphyus
Registered User
Posts: 36
Joined: Thu Nov 13, 2008 11:42 pm

Re: Board3 Portal

Post by osmorphyus »

this is retarded. why there is only *one* forum thread to ask questions for help in is beyond me, but i'll play the game...


ive been working on this POS for over 4 hours now. i manually alterered each and every file by hand as directed in the "xml" file, why its not just a readme is also beyond me, but OK. i was looking for the installation directions forever before i finally realized it was an xml, but whatever...

so, i altered the files, i moved the files into my phpbb and then uploaded the whole package to my server. i setup the forums first. that went well.

then i browse to ../portal/install_portal/install.php

the script ran and claimed it completed itself.


i browse to .../portal.php and its F'in BROKEN!
General Error
SQL ERROR [ mysqli ]

Table 'b5_4156490_ssupport.PORTAL_CONFIG_TABLE' doesn't exist [1146]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
so i asssssume that the install script DI NOTin fact properly execute?

seriously, is there just a premodded package out there i can download, upload to my server, and execute the install scripts? because this is for the birds!
Locked

Return to “[3.0.x] MOD Database Releases”