Board3 Portal

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5479
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: Board3 Portal

Post by Marc »

frec wrote:conflict updating from 1.0.4

in the update xml file, it says
Find:
if (!empty($_GET['style']))
and replace with:
if (!empty($_GET['style']) && !defined('ADMIN_START'))

but 3.0.6 file is already
if (!empty($_GET['style']) && $auth->acl_get('a_styles') && !defined('ADMIN_START'))
The conflicting line is caused by your phpBB update to 3.0.6. For the edit, take a look at the normal install.xml.
User avatar
Kilzin
Registered User
Posts: 22
Joined: Wed Jan 13, 2010 4:53 am
Location: Örebro, Sweden

Re: Board3 Portal

Post by Kilzin »

I have changed all board3 files with UTF-8 but it doesnt still works. Must to reinstall and change them with UTF-8 before installing process or need update phpBB 3.0.6?
Sorry for bad english. Im swedish and have little problem with english :P
User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5479
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: Board3 Portal

Post by Marc »

I can see the portal page, but are you sure that your portal.php is up to date?
chrisball904
Registered User
Posts: 12
Joined: Fri Jan 29, 2010 4:41 pm

Re: Board3 Portal

Post by chrisball904 »

Thanks im gonna use this, i think.
User avatar
Kilzin
Registered User
Posts: 22
Joined: Wed Jan 13, 2010 4:53 am
Location: Örebro, Sweden

Re: Board3 Portal

Post by Kilzin »

marc1706 wrote:I can see the portal page, but are you sure that your portal.php is up to date?
Yes, its up to date. U can see the portal page but not when login get always blank page. U can try to register and check it.
Sorry for bad english. Im swedish and have little problem with english :P
User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5479
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: Board3 Portal

Post by Marc »

Please turn debug on and send me a copy of all the files you edit for Board3 Portal.
User avatar
Kilzin
Registered User
Posts: 22
Joined: Wed Jan 13, 2010 4:53 am
Location: Örebro, Sweden

Re: Board3 Portal

Post by Kilzin »

Where can I turn on debug mode and how I find error log?

EDIT: Im using cPANEL X and need submit a support to my the hosting to turn on debug mode
Sorry for bad english. Im swedish and have little problem with english :P
User avatar
Kilzin
Registered User
Posts: 22
Joined: Wed Jan 13, 2010 4:53 am
Location: Örebro, Sweden

Re: Board3 Portal

Post by Kilzin »

Okay, I got turn on debug mode.

This see we error log:

Code: Select all

Fatal error: Call to undefined function get_unread_topics() in /home/quantumg/public_html/forum/portal/block/user_menu.php on line 62
Sorry for bad english. Im swedish and have little problem with english :P
User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5479
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: Board3 Portal

Post by Marc »

Update to phpBB 3.0.6.
User avatar
Kilzin
Registered User
Posts: 22
Joined: Wed Jan 13, 2010 4:53 am
Location: Örebro, Sweden

Re: Board3 Portal

Post by Kilzin »

marc1706 wrote:Update to phpBB 3.0.6.
Thanks you! It works now :)
Sorry for bad english. Im swedish and have little problem with english :P
phpbb.it
Registered User
Posts: 110
Joined: Tue Mar 15, 2005 2:40 pm
Location: Italy
Contact:

Re: Board3 Portal

Post by phpbb.it »

I correct

Code: Select all

{ MINI_CALENDAR }
This translation is it perfect

ITALIAN PACK
Attachments

[The extension rar has been deactivated and can no longer be displayed.]

phpbb italian support phpbb.it
italian models passionelotto.com
User avatar
casper™
Registered User
Posts: 119
Joined: Sat Nov 15, 2008 5:01 am
Location: Porto/Portugal

Re: Board3 Portal

Post by casper™ »

Hello there.

I've a problem with the update from 1.0.4 to 1.0.5 with the follow file edit:

Find:

Code: Select all

	$user->add_lang(array('mods/lang_portal', 'mods/additional_blocks'));
	if (!function_exists('obtain_portal_config'))
	{
		include($phpbb_root_path . 'portal/includes/functions.' . $phpEx);
	}
	$portal_config = obtain_portal_config();
Replace with:

Code: Select all

$user->add_lang(array('mods/lang_portal', 'mods/additional_blocks'));
	if (!function_exists('obtain_portal_config'))
	{
		include($phpbb_root_path . 'portal/includes/functions.' . $phpEx);
	}
	if(sql_table_exists(PORTAL_CONFIG_TABLE) == true)
	{
		$portal_config = obtain_portal_config();
	}

After this I've got this error:

Code: Select all

Fatal error: Call to undefined function sql_table_exists() in /home/******/public_html/forum/includes/functions.php on line 4109
Any idea how can I fix this? If I dont do this change the forum turn it online again.

P.S. At localhost I havent this issue, cant understand why it's only happen in online forum! :roll:

Edit: includes/functions.php, line 4109:

Code: Select all

if(sql_table_exists(PORTAL_CONFIG_TABLE) == true)
User avatar
wang5555
Translator
Posts: 605
Joined: Wed Oct 27, 2004 2:57 pm
Location: Taiwan

Re: Board3 Portal

Post by wang5555 »

Any idea how can I fix this? If I dont do this change the forum turn it online again.

P.S. At localhost I havent this issue, cant understand why it's only happen in online forum!
The function sql_table_exists() is new.
Check this file following:
  • portal/includes/functions.php

Code: Select all

* @version $Id: functions.php 604 2010-01-03 10:07:08Z marc1706 $
It is more blessed to give than to reveive, welcome to letter, thanks & good-bye!
Good luck ^_^
Welcome to my forum!!
http://wang5555.hopto.org/phpBB3/
p.s. Shut down computer before 11 clock night!!!
User avatar
casper™
Registered User
Posts: 119
Joined: Sat Nov 15, 2008 5:01 am
Location: Porto/Portugal

Re: Board3 Portal

Post by casper™ »

wang5555 wrote:
Any idea how can I fix this? If I dont do this change the forum turn it online again.

P.S. At localhost I havent this issue, cant understand why it's only happen in online forum!
The function sql_table_exists() is new.
Check this file following:
  • portal/includes/functions.php

Code: Select all

* @version $Id: functions.php 604 2010-01-03 10:07:08Z marc1706 $
Ooops, thats it friend. I'm failed to upload this file to the forum. :oops:

Solved.

Thank You so much. :)
vonhazey
Registered User
Posts: 89
Joined: Wed Dec 02, 2009 2:43 pm

Re: Board3 Portal

Post by vonhazey »

marc1706: A can't seem to find a working download for the gallery portal add-on, could provide one please.

Edit: someone gave me a copy :D
Image
Locked

Return to “[3.0.x] MOD Database Releases”