User Notes/Warnings in Viewtopic

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
misfit69
Registered User
Posts: 65
Joined: Fri Sep 11, 2009 4:25 am
Contact:

Re: User Notes/Warnings in Viewtopic

Post by misfit69 » Mon Sep 28, 2009 6:07 pm

RMcGirr83 wrote:You do the edits in order. So once you do one edit then the very next find that matches the next edit is where the code goes. Keep in mind that a FIND may not be the entire line, but the code goes on a new blank line after you do the FIND.

Great, an answer and a why I was screwing it up. Thank you very much. Now lets see if I can wrap this up. I missed that "next Find" part.

Again, thank you very much.
Brian

dexto
Registered User
Posts: 16
Joined: Wed Nov 05, 2008 10:50 pm

Re: User Notes/Warnings in Viewtopic

Post by dexto » Mon Sep 28, 2009 6:37 pm

Hi,

I'm having a little error problem (probably nooby)

When i want to go to user notes page i get this error:

Code: Select all

Parse error: syntax error, unexpected ';' in ../includes/mcp/mcp_notes.php on line 179
and i find on line 179:

Code: Select all

include($phpbb_root_path . 'includes/notes_in_viewtopic.' . $phpEx);
Taken from:

Code: Select all

// begin user notes in viewtopic mod
				include($phpbb_root_path . 'includes/notes_in_viewtopic.' . $phpEx);
			 	notes_in_viewtopic($action, $user_id);
				// end user notes in viewtopic mod
Hoping for a solution, ty.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: User Notes/Warnings in Viewtopic

Post by RMcGirr83 » Mon Sep 28, 2009 6:46 pm

Please post the 10 lines before and after that line
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

dexto
Registered User
Posts: 16
Joined: Wed Nov 05, 2008 10:50 pm

Re: User Notes/Warnings in Viewtopic

Post by dexto » Mon Sep 28, 2009 7:03 pm

RMcGirr83 wrote:Please post the 10 lines before and after that line
Ok:

Code: Select all

if ($usernote && $action == 'add_feedback')
		{
			if (check_form_key('mcp_notes'))
			{
				add_log('admin', 'LOG_USER_FEEDBACK', $userrow['username']);
				add_log('mod', 0, 0, 'LOG_USER_FEEDBACK', $userrow['username']);

				add_log('user', $user_id, 
						// begin user notes in viewtopic mod
				include($phpbb_root_path . 'includes/notes_in_viewtopic.' . $phpEx);
			 	notes_in_viewtopic($action, $user_id);
				// end user notes in viewtopic mod
				'LOG_USER_GENERAL', $usernote);
				$msg = $user->lang['USER_FEEDBACK_ADDED'];
			}
			else
			{
				$msg = $user->lang['FORM_INVALID'];
			}
			$redirect = $this->u_action;
			meta_refresh(3, $redirect);

			trigger_error($msg .  '<br /><br />' . sprintf($user->lang['RETURN_PAGE'], '<a href="' . $redirect . '">', '</a>'));
		}

misfit69
Registered User
Posts: 65
Joined: Fri Sep 11, 2009 4:25 am
Contact:

Re: User Notes/Warnings in Viewtopic

Post by misfit69 » Mon Sep 28, 2009 7:05 pm

I got it installed and it works, shows me exactly what I wanted.

However, the site seems a bit slower now. Any thoughts???

I just started the site, have only 20 members, do what I call a lot of mods but this seems to dog it down a bit. It could be just weird timing, I don't know. I'm going to call a few other members and see if they are feeling anything.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: User Notes/Warnings in Viewtopic

Post by RMcGirr83 » Mon Sep 28, 2009 7:12 pm

dexto wrote:
RMcGirr83 wrote:Please post the 10 lines before and after that line
Ok:
should be

Code: Select all

		if ($usernote && $action == 'add_feedback')
		{
			if (check_form_key('mcp_notes'))
			{
				add_log('admin', 'LOG_USER_FEEDBACK', $userrow['username']);
				add_log('mod', 0, 0, 'LOG_USER_FEEDBACK', $userrow['username']);

				add_log('user', $user_id, 'LOG_USER_GENERAL', $usernote);
				// begin user notes in viewtopic mod
				include($phpbb_root_path . 'includes/notes_in_viewtopic.' . $phpEx);
			 	notes_in_viewtopic($action, $user_id);
				// end user notes in viewtopic mod				
				$msg = $user->lang['USER_FEEDBACK_ADDED'];
			}
			else
			{
				$msg = $user->lang['FORM_INVALID'];
			}
			$redirect = $this->u_action;
			meta_refresh(3, $redirect);

			trigger_error($msg .  '<br /><br />' . sprintf($user->lang['RETURN_PAGE'], '<a href="' . $redirect . '">', '</a>'));
		}
misfit69, for when viewing a topic? Shouldn't "bog down" as there are no queries added when viewing a topic. Only when adding/deleting a users notes.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

misfit69
Registered User
Posts: 65
Joined: Fri Sep 11, 2009 4:25 am
Contact:

Re: User Notes/Warnings in Viewtopic

Post by misfit69 » Mon Sep 28, 2009 7:18 pm

I have a buddy testing it also to see if he is feeling anything.

What I'm feeling is this, I post a reply, hit enter and it takes a few seconds to respond and post my reply.

I installed the "Instant Post Redirect" - http://www.phpbb.com/community/viewtopi ... 9&t=584852
a few days ago and that made it pretty much instant. Now it's not. I'm not saying it's your mod, just a place I am starting with. I could be all my side until I hear back from somebody.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: User Notes/Warnings in Viewtopic

Post by RMcGirr83 » Mon Sep 28, 2009 7:27 pm

misfit69 wrote:What I'm feeling is this, I post a reply, hit enter and it takes a few seconds to respond and post my reply.
As this mod makes no edits to either posting.php nor includes/functions_posting.php I have to think it doesn't have anything to do with this mod.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

misfit69
Registered User
Posts: 65
Joined: Fri Sep 11, 2009 4:25 am
Contact:

Re: User Notes/Warnings in Viewtopic

Post by misfit69 » Mon Sep 28, 2009 7:36 pm

RMcGirr83 wrote:
misfit69 wrote:What I'm feeling is this, I post a reply, hit enter and it takes a few seconds to respond and post my reply.
As this mod makes no edits to either posting.php nor includes/functions_posting.php I have to think it doesn't have anything to do with this mod.
Sounds good, it could be my firewall, it's been a bit stupid as of late. I will go that direction.

Thanks for the mod and the input.
Brian.

dexto
Registered User
Posts: 16
Joined: Wed Nov 05, 2008 10:50 pm

Re: User Notes/Warnings in Viewtopic

Post by dexto » Mon Sep 28, 2009 7:39 pm

RMcGirr83 wrote:ff
Yep! that fixed it!
Ty so much :)

misfit69
Registered User
Posts: 65
Joined: Fri Sep 11, 2009 4:25 am
Contact:

Re: User Notes/Warnings in Viewtopic

Post by misfit69 » Mon Sep 28, 2009 8:07 pm

I'm going to test removing the mod and seeing that makes a difference. My buddy says it's much slower also. No clue why, what or how but it's the last thing I did, so I will start with it.

misfit69
Registered User
Posts: 65
Joined: Fri Sep 11, 2009 4:25 am
Contact:

Re: User Notes/Warnings in Viewtopic

Post by misfit69 » Mon Sep 28, 2009 8:26 pm

I'm not sure what it was but it does seem to be better now, I had to restore my database but it seems better now. I'm guessing I just screwed something up in the mod. Now I need to see if the other guys notices the difference.

misfit69
Registered User
Posts: 65
Joined: Fri Sep 11, 2009 4:25 am
Contact:

Re: User Notes/Warnings in Viewtopic

Post by misfit69 » Tue Sep 29, 2009 5:42 pm

Just a follow up. I was still have a lot of problems with our site. It turns out we were getting a ****load of hits on our site. Good thing, right??? Wrong. It as all coming from one IP - 68.68.100.106. We are a site that just started with maybe 15 users right now, and we noticed today that all of our threads were getting about 1500 views a day for the last 2 days :shock:

So, we have now block the IP and we are running like lightning again. :D

I'm going to give a few days then try out this mod again.

thanks again for the input.

Richazey
Registered User
Posts: 823
Joined: Mon Oct 27, 2008 9:03 pm

Re: User Notes/Warnings in Viewtopic

Post by Richazey » Thu Oct 08, 2009 1:44 pm

Post Removed by Author

User avatar
davaguco
Registered User
Posts: 179
Joined: Thu Jul 28, 2005 5:57 pm
Location: España
Name: DAVID AGULLO
Contact:

Re: User Notes/Warnings in Viewtopic

Post by davaguco » Wed Nov 25, 2009 10:14 am

Will this MOD work with a 3.0.6 board?

Thanks.
David.
English-Spanish Mod Translator. Send me a PM if you need anything translated (usually free unless you need a fixed finishing date).

Locked

Return to “[3.0.x] MOD Database Releases”