simple RSS mod for phpBB3

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
only1_PO
Registered User
Posts: 35
Joined: Wed Oct 24, 2007 3:12 am
Location: Serbia
Contact:

Re: simple RSS mod for phpBB3

Post by only1_PO »

I have SEO mod installed on my forum and url's are like this

Code: Select all

http://www.url.com/feedback-recommendations-f5.html
and my robots.txt is like this:

Code: Select all

User-agent: *
Disallow: /viewtopic.php
Disallow: /viewforum.php
Disallow: /index.php?
Disallow: /posting.php
Disallow: /search.php?
Disallow: /ucp.php
Disallow: /mcp.php
Disallow: /post
Disallow: /member
Disallow: /memberlist.php
Disallow: /faq.php
So is it possible to change address from

Code: Select all

http://www.url.com/viewtopic.php?f=28&t=7986
to

Code: Select all

http://www.url.com/feedback-recommendations-f5.html
and make topics/posts from rss.php accessible to google crawler?
Last edited by only1_PO on Mon Jun 08, 2009 3:57 pm, edited 1 time in total.
Xemployee
Registered User
Posts: 2
Joined: Fri May 22, 2009 3:37 pm

Re: simple RSS mod for phpBB3

Post by Xemployee »

The feed is working but the date for today's posts are showing up as yesterday. Any suggestions for how to fix this?
xXRoxasXx
Registered User
Posts: 1
Joined: Wed Jun 17, 2009 8:07 pm

Re: simple RSS mod for phpBB3

Post by xXRoxasXx »

I actually have two questions...

1. When you post a new thread will the new RSS item appear instantly or will it take some time to propagate and go up?

2. Is there a way to specify which forum's posts you don't want shown on the feed?

Thanks for the info guys. ^.^ Hope my questions weren't too vague.
User avatar
nguyencongminh
Registered User
Posts: 107
Joined: Thu Jul 10, 2008 1:38 pm
Contact:

Re: simple RSS mod for phpBB3

Post by nguyencongminh »

xXRoxasXx wrote: 2. Is there a way to specify which forum's posts you don't want shown on the feed?
I am using some private forums on my site, this is my problem, too. Anyone know a solution?
Creating Communities
User avatar
wilsonmorgado
Registered User
Posts: 2
Joined: Sun Jul 27, 2008 10:54 am
Location: Portugal
Contact:

Re: simple RSS mod for phpBB3

Post by wilsonmorgado »

Antheii wrote:Hi,

Most likely you forgot to add something like

Code: Select all

<link href="http://www.mysite.com/forum/rss.php" rel="alternate" type="application/rss+xml" title="My MessageBoard">
to your header (in your overall_header.html)

Regards,

Hans
the right code:

Code: Select all

    <link rel="alternate" type="application/rss+xml" title="{L_RSS_EXPLAIN}" href="{U_RSS}" />
crazzzydave
Registered User
Posts: 120
Joined: Sat Feb 14, 2009 12:10 pm

Re: simple RSS mod for phpBB3

Post by crazzzydave »

Hi all. I've tried installing this on my test forum, and when its installed and i try to go to site, the screen filles with loads of scripts,and eventually i get this error
"The requested URL /testforum/. str_replace( was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request
."

If remove the modified functions.php, the forum works again though still no rss feed. :roll:
Any ideas?

Oh, its installed on 3.5 although my real forum is running 3.4. I want to install this on two of my real sites. Both have modified versions of prosilver (modified with navigation buttons along top, and one has a flash header.)
This is the ones that it will be eventually going into http://hondaclub-uk.com/forum/index.php ... b33e66f97b and http://civic5.com/forum/index.php?sid=b ... 152b8d4148

this is the test forum http://hondaclub-uk.com/testforum/index ... bba1c34540

I really want this mod, so any help much appreciated in advance! :D
User avatar
cedarrapidsboy
Registered User
Posts: 35
Joined: Thu Sep 29, 2005 9:45 pm

Re: simple RSS mod for phpBB3

Post by cedarrapidsboy »

crazzzydave wrote:"The requested URL /testforum/. str_replace( was not found on this server.
Not sure, but that seems to indicate you have some quoting issues somewhere. Seems like '/testforum/' is not being properly concatenated with the results of the str_replace function call.

I'd start by searching functions.php and rss.php for occurrences of str_replace. Then, see if any aren't quoted properly.

For instance, in functions.php:

Code: Select all

function build_url($strip_vars = false)
{
   ...
   return $phpbb_root_path . str_replace('&', '&', $redirect);
}
This may result in your problem if it somehow all got put in double-quotes...
crazzzydave
Registered User
Posts: 120
Joined: Sat Feb 14, 2009 12:10 pm

Re: simple RSS mod for phpBB3

Post by crazzzydave »

Thanks mate, you were spot on about the double quotes. Ive sorted that, and the forum is working again, and the rss logo is there. Im now getting this when i click on the rss feed

The requested URL /testforum/{$phpbb_root_path}rss.$phpEx was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request


ive noticed that the url that appears in the address bar once you click the rss feed is this:
http://hondaclub-uk.com/testforum/%7B$p ... rss.$phpEx
I gather there must be spaces in there that shouldnt be, hence the "%" ?
Any ideas guys? I till relatively new to this! :D

UPDATE: ok, just been in the ACP/system/module management/system/general tasks there is no RSS in the drop down bar?
User avatar
3Di
Former Team Member
Posts: 16038
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: simple RSS mod for phpBB3

Post by 3Di »

the problem seems to be the $phpEx extension being not global.

Code: Select all

global $phpEx;
should be somewhere.. on the fly.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
Looking for a specific feature or alternative option? We will rock you! 🚀
crazzzydave
Registered User
Posts: 120
Joined: Sat Feb 14, 2009 12:10 pm

Re: simple RSS mod for phpBB3

Post by crazzzydave »

Now im lost! lol I take it that code is somewhere in the functions.php?
User avatar
cedarrapidsboy
Registered User
Posts: 35
Joined: Thu Sep 29, 2005 9:45 pm

Re: simple RSS mod for phpBB3

Post by cedarrapidsboy »

crazzzydave wrote:Now im lost! lol I take it that code is somewhere in the functions.php?
You may want to check functions.php again... It may have to do with this line (#3761 for me):

Code: Select all

	'U_RSS'	=>append_sid("{$phpbb_root_path}rss.$phpEx") . (($f === 0 || !(empty($f))) ? '?f=' . $f : ''),
If it is quoted wrong, the variables will not resolve. For instance, mine wouldn't work if they were single quotes.

If it is a quoting issue... how did they all get messed up when you merged-in the mod? Some strange UTF8 to ??? conversion?
crazzzydave
Registered User
Posts: 120
Joined: Sat Feb 14, 2009 12:10 pm

Re: simple RSS mod for phpBB3

Post by crazzzydave »

Many thanks! It was the program i was using to edit the file that was causing the error! Just when you asked about the utf conversion I realised it was the program! Using DW now and the mods working!!! Only problem i have is the Feed is named "untitled", but someone else posted about that so I'll go and read up how to resolve that.
Thatnks again to the mod author for making this mod, and to all members who helped me get it working ;)

Much appreciated 8-)
crazzzydave
Registered User
Posts: 120
Joined: Sat Feb 14, 2009 12:10 pm

Re: simple RSS mod for phpBB3

Post by crazzzydave »

soulpatch wrote:
soulpatch wrote:I installed this mod with 3.0.4 and when I get to the last part where you add it in the ACP, i don't see it in the drop down menu. When I go to the home page of my forums, I get this:
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3763: Undefined index: rss_enable
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3764: Undefined index: rss_overall_forums
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3765: Undefined index: rss_overall_threads
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3766: Undefined index: rss_overall_posts
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3767: Undefined index: rss_egosearch
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3768: Undefined index: rss_forum
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3769: Undefined index: rss_thread
Is anyone else getting this? Please help.
Minor update here, I purged the cache and the above PHP Notices disappeared but I am still having trouble with this part:
A.1) Navigate to "System" tab.
A.2) Under "Module management" click on "Administration Control Panel".
A.3) Click on "System".
A.4) Clik on "General tasks".
A.5) in "add module" select "RSS" and click on "add module", them click on "yes".
A.6) Afert refresh screen click RSS "enable".
A.7) Afert refresh screen click again in "System" tab.
A.8) Now you will able to see "RSS" down the "General tasks" in left menu.
A.9) Click on "RSS" and set to your liking.
Once I get to Step A.4, I don't see RSS under "Add Module". Please help.
Forgot! I have this problem too, but didnt actually see these instructions anywhere in the download? So is this actually part of the mod?
crazzzydave
Registered User
Posts: 120
Joined: Sat Feb 14, 2009 12:10 pm

Re: simple RSS mod for phpBB3

Post by crazzzydave »

ok, sorted the "untitled " problem, still got the above acp problem and also the feed wont validate? My feeds button on explorer stays grey, as if there isnt a feed on the page. :cry:
Edit:feed is now validated, but it says there are problems with this pub date thing. is there a fix for it, as its causing the feed not to register on the browser feed button, even though the feed actually works fine and updates perfectly :roll:
Locked

Return to “[3.0.x] MOD Database Releases”