RSS Feed 2.0

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
pashmak
Registered User
Posts: 55
Joined: Sun Apr 10, 2005 12:07 am

Re: RSS Feed 2.0

Post by pashmak » Fri Oct 03, 2008 4:40 pm

Great mod!

thanks!

ryan11
Registered User
Posts: 25
Joined: Tue Sep 30, 2008 10:34 am

Re: RSS Feed 2.0

Post by ryan11 » Fri Oct 03, 2008 5:14 pm

thx, fixed, i am so careless :cry:

ryan11
Registered User
Posts: 25
Joined: Tue Sep 30, 2008 10:34 am

Re: RSS Feed 2.0

Post by ryan11 » Sat Oct 04, 2008 12:33 am

when i'm using ie 7or 8 too subscribe rss.php
it's said there are some error
also, the rss.php cant pass under rss validator. (but "rss.php?mode=forums /topics.." can pass)

i open rss.php under ff3, the page can be opened, but some word cant be shown correctly and shown like that -> "��"
(there is no problem under ie or ff viewing the forum but rss.php)

my forum in utf-8 encoding and the word is chinese
how can i fix this, thx~

here is my link of rss.php:
http://www.needagoal.com/phpbb3/rss.php

ryan11
Registered User
Posts: 25
Joined: Tue Sep 30, 2008 10:34 am

Re: RSS Feed 2.0

Post by ryan11 » Sat Oct 04, 2008 12:44 am

leviatan21 wrote:
dattad wrote:If we use "Max length of post text to display", we get "�..." at the end of the post's text and it causes code errors and the feed can't be dispayed. Any idea how to fix that?
In every post or only one ? I think is only 1, because when the text is cute I only add "..." so the wrong character ( � ) is in the post, may be the post have it.
I test it in 4 different languages ( that are in my board actually ), English, Spanish, Portuguese, Turkish and the last 3 have special characters and everything is fine.
i hv the exactly same problrm which dattad said

> In every post or only one ?
in some posts, not every or only one

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: RSS Feed 2.0

Post by leviatan21 » Sat Oct 04, 2008 4:38 am

ryan11 wrote:when i'm using ie 7or 8 too subscribe rss.php
it's said there are some error
also, the rss.php cant pass under rss validator. (but "rss.php?mode=forums /topics.." can pass)

i open rss.php under ff3, the page can be opened, but some word cant be shown correctly and shown like that -> "��"
(there is no problem under ie or ff viewing the forum but rss.php)

my forum in utf-8 encoding and the word is chinese
how can i fix this, thx~

here is my link of rss.php:
http://www.needagoal.com/phpbb3/rss.php
HI ryan11 : and thanks for the example ;) , so now I can work on it with real post text in non standard languages :D
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

User avatar
Fridge
Registered User
Posts: 307
Joined: Sat Nov 11, 2006 1:41 am
Location: Rotterdam, The Netherlands
Name: Martin
Contact:

Re: RSS Feed 2.0

Post by Fridge » Sat Oct 04, 2008 11:34 pm

Installed your mod and works great, thnx for a long awaited and good working RSS mod :)

One question......how can i remove the Board statistics on top of the feed page ?

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: RSS Feed 2.0

Post by leviatan21 » Sun Oct 05, 2008 3:30 am

Fridge wrote:Installed your mod and works great, thnx for a long awaited and good working RSS mod :)

One question......how can i remove the Board statistics on top of the feed page ?
Open your root/styles/rss_template.xml, search and delete this, then refresh the cache

Code: Select all

	<!-- IF (PAGINATION and ON_PAGE == 1) -->
		<item>
			<title><![CDATA[{L_FORUM_STATS}]]></title>
			<description><![CDATA[
			<table cellspacing="0" cellpadding="5" border="1" id="SiteStats">
				<tbody>
					<tr>
						<td><b>{L_BOARD_STARTED}:</b></td>
						<td>{STAT_BOARD_STARTED}</td>
						<td><b>{L_BOARD_DAYS}:</b></td>
						<td>{STAT_BOARD_DAYS}</td>
					</tr>
					<tr>
						<td><b>{L_BOARD_VERSION}:</b></td>
						<td>phpbb {STAT_BOARD_VERSION}</td>
						<td><b>{L_STAT_TIMEZONE}:</b></td>
						<td>{STAT_TIMEZONE}</td>
					</tr>
					<tr>
						<td><b>{L_NUMBER_POSTS}:</b></td>
						<td>{STAT_TOTAL_POSTS}</td>
						<td><b>{L_POSTS_PER_DAY}:</b></td>
						<td>{STAT_POSTS_PER_DAY}</td>
					</tr>
					<tr>
						<td><b>{L_NUMBER_TOPICS}:</b></td>
						<td>{STAT_TOTAL_TOPICS}</td>
						<td><b>{L_TOPICS_PER_DAY}:</b></td>
						<td>{STAT_TOPICS_PER_DAY}</td>
					</tr>
					<tr>
						<td><b>{L_NUMBER_USERS}:</b></td>
						<td>{STAT_TOTAL_USERS}</td>
						<td><b>{L_USERS_PER_DAY}:</b></td>
						<td>{STAT_USERS_PER_DAY}</td>
					</tr>
					<tr>
						<td><b>{L_NEWEST_USER}:</b></td>
						<td colspan="3">{STAT_NEWEST_USER}</td>
					</tr>
					<tr>
						<td colspan="4">{STAT_ONLINE_USERS}</td>
					</tr>
				</tbody>
			</table>
			<hr />]]></description>
			<content:encoded><![CDATA[<p>{STAT_BOARD_STARTED}<br />{STAT_TOTAL_POSTS} &bull; {STAT_TOTAL_TOPICS} &bull; {STAT_TOTAL_USERS} &bull; {STAT_NEWEST_USER}</p><hr />]]></content:encoded>
			<guid isPermaLink="true">{FEED_INDEX}</guid>
		</item>
	<!-- ENDIF -->
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

Tom2008
Registered User
Posts: 9
Joined: Sun Feb 03, 2008 1:03 am

Re: RSS Feed 2.0

Post by Tom2008 » Sun Oct 05, 2008 4:59 am

Hi,

I've installed this mod, but it didn't work... When i go to /rss.php, it appears a message:

Code: Select all

Referência à entidade 'aacute' não definida.
 Linha: 677 Caractere: 35

   <title>Clique para ir para a p&aacute;gina…</title>
My board is in brazilian portuguese and i think the problem is the entities that i use...

What can I do to make it works?

Thanks!

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: RSS Feed 2.0

Post by leviatan21 » Sun Oct 05, 2008 5:16 am

Tom2008 wrote:Hi,

I've installed this mod, but it didn't work... When i go to /rss.php, it appears a message:

Code: Select all

Referência à entidade 'aacute' não definida.
 Linha: 677 Caractere: 35

   <title>Clique para ir para a p&aacute;gina…</title>
My board is in brazilian portuguese and i think the problem is the entities that i use...

What can I do to make it works?

Thanks!
Can I see it ? please, post a link, Thanks
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

User avatar
Fridge
Registered User
Posts: 307
Joined: Sat Nov 11, 2006 1:41 am
Location: Rotterdam, The Netherlands
Name: Martin
Contact:

Re: RSS Feed 2.0

Post by Fridge » Sun Oct 05, 2008 8:01 am

leviatan21 wrote:Open your root/styles/rss_template.xml, search and delete this, then refresh the cache
Thnx this works for the rss page, it stil produces a link to the statistics as you embed the rss in for example wordpress.....

Edit: forget the last remark......statistics link took some time to disappear ;)

User avatar
jaunty_mellifluous
Registered User
Posts: 438
Joined: Mon May 21, 2007 1:59 am
Name: Asad Kay
Contact:

Re: RSS Feed 2.0

Post by jaunty_mellifluous » Sun Oct 05, 2008 8:39 am

General Error
SQL ERROR [ mysql4 ]

Duplicate entry 'rss_enable' for key 1 [1062]

SQL

INSERT INTO phpbbb_config (config_name, config_value, is_dynamic) VALUES ('rss_enable', 1, 0)

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: includes/functions.php
LINE: 156
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_rss.php
LINE: 104
CALL: set_config()

FILE: includes/functions_module.php
LINE: 471
CALL: acp_rss->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()
I get this error while trying to enable RSS Feed. Any help?
Stay Cool!

ryan11
Registered User
Posts: 25
Joined: Tue Sep 30, 2008 10:34 am

Re: RSS Feed 2.0

Post by ryan11 » Sun Oct 05, 2008 9:16 am

Fridge wrote:
leviatan21 wrote:Open your root/styles/rss_template.xml, search and delete this, then refresh the cache
Thnx this works for the rss page, it stil produces a link to the statistics as you embed the rss in for example wordpress.....

Edit: forget the last remark......statistics link took some time to disappear ;)
remove some code in a file (i forget which)
just like this: http://www.needagoal.com/phpbb3/rss.php (stat info is gone)

User avatar
jaunty_mellifluous
Registered User
Posts: 438
Joined: Mon May 21, 2007 1:59 am
Name: Asad Kay
Contact:

Re: RSS Feed 2.0

Post by jaunty_mellifluous » Sun Oct 05, 2008 1:42 pm

jaunty_mellifluous wrote:
General Error
SQL ERROR [ mysql4 ]

Duplicate entry 'rss_enable' for key 1 [1062]

SQL

INSERT INTO phpbbb_config (config_name, config_value, is_dynamic) VALUES ('rss_enable', 1, 0)

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: includes/functions.php
LINE: 156
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_rss.php
LINE: 104
CALL: set_config()

FILE: includes/functions_module.php
LINE: 471
CALL: acp_rss->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()
I get this error while trying to enable RSS Feed. Any help?
Alright, the Installation Instructions need to be changed. Author should clearly state in there that SQL entries are "not" to be made by us, the users. They will be made by the MOD automatically when it's enabled.

Otherwise, it will just create the following error that I just quoted.
Stay Cool!

User avatar
jaunty_mellifluous
Registered User
Posts: 438
Joined: Mon May 21, 2007 1:59 am
Name: Asad Kay
Contact:

Another Question!

Post by jaunty_mellifluous » Sun Oct 05, 2008 1:59 pm

Is there a way to show the Feed Urls automatically on the forum somewhere instead of only on the url bar?
Stay Cool!

User avatar
Fridge
Registered User
Posts: 307
Joined: Sat Nov 11, 2006 1:41 am
Location: Rotterdam, The Netherlands
Name: Martin
Contact:

Re: RSS Feed 2.0

Post by Fridge » Sun Oct 05, 2008 2:05 pm

jaunty_mellifluous wrote:Alright, the Installation Instructions need to be changed. Author should clearly state in there that SQL entries are "not" to be made by us, the users. They will be made by the MOD automatically when it's enabled.

Otherwise, it will just create the following error that I just quoted.
I added the SQL manually and worked just fine......

Locked

Return to “[3.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 27 guests