Posts per day

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
User avatar
MartectX
Translator
Posts: 1324
Joined: Wed Dec 19, 2007 8:05 pm
Location: Marienplatz

Re: Posts per day

Post by MartectX » Thu Oct 30, 2008 12:18 am

stokerpiller wrote:Then I will be hearing from You soon ;)
Maybe a new stats mod?
Nah... this was even close to not being made a mod because it's really a very small modification.

Richazey
Registered User
Posts: 823
Joined: Mon Oct 27, 2008 9:03 pm

Re: Posts per day

Post by Richazey » Wed Nov 05, 2008 8:56 pm

Good little mod just installed it no problem :D

Richazey
Registered User
Posts: 823
Joined: Mon Oct 27, 2008 9:03 pm

Re: Posts per day

Post by Richazey » Thu Nov 06, 2008 11:27 pm

edited wrong topic :oops:

alphared
Registered User
Posts: 30
Joined: Tue Mar 27, 2007 10:39 pm

Re: Posts per day

Post by alphared » Thu Dec 11, 2008 8:44 am

FeuerSturm wrote:hey guys!

first of all, thanks for this Mod!

I have a big problem though:
I can install that mod without a problem, it shows the posts per day correctly,
BUT after installing the mod the captcha image on "Register" is broken in my forum.
It just shows a white square with a red cross in it and noone can successfully register
anymore.

After undoing the changes in the files (uninstalling the mod), the captcha image worked
again like it never stopped working.

Does anyone have the same problem and maybe a solution?

I'm pretty sure that I installed the mod correctly!

Thanks in advance!
Well, I have say that I think this is my problem too. I modded my board about two weel\ks ago and since then noone can register because the captcha image neither shows in the registration form nor in the acp. I have looked through all my mods threads and this is the only one that has a report of this problem....none of the mods should have this problem as none of them go near the captcha.

I know the person who found the problem found the solution, I would appreciate some guidance, I edit in notepad normally, as I did with this mod.

User avatar
MartectX
Translator
Posts: 1324
Joined: Wed Dec 19, 2007 8:05 pm
Location: Marienplatz

Re: Posts per day

Post by MartectX » Thu Dec 11, 2008 11:49 am

alphared wrote:Well, I have say that I think this is my problem too. I modded my board about two weel\ks ago and since then noone can register because the captcha image neither shows in the registration form nor in the acp. I have looked through all my mods threads and this is the only one that has a report of this problem....none of the mods should have this problem as none of them go near the captcha.

I know the person who found the problem found the solution, I would appreciate some guidance, I edit in notepad normally, as I did with this mod.
1.) This is not related to this MOD

2.) You should've at least read two posts further:
FeuerSturm wrote:damn, I have been really stupid!

I made the changes with standard windows notepad!

alphared
Registered User
Posts: 30
Joined: Tue Mar 27, 2007 10:39 pm

Re: Posts per day

Post by alphared » Thu Dec 11, 2008 2:20 pm

MartectX wrote:
alphared wrote:Well, I have say that I think this is my problem too. I modded my board about two weel\ks ago and since then noone can register because the captcha image neither shows in the registration form nor in the acp. I have looked through all my mods threads and this is the only one that has a report of this problem....none of the mods should have this problem as none of them go near the captcha.

I know the person who found the problem found the solution, I would appreciate some guidance, I edit in notepad normally, as I did with this mod.
1.) This is not related to this MOD

2.) You should've at least read two posts further:
FeuerSturm wrote:damn, I have been really stupid!

I made the changes with standard windows notepad!
1) If two people have the same issue with the same mod, it 'may' very well have to do with the mod. Since I have been using notepad for every webpage I have ever built, and I have never had a problem before.

2) I DID read two posts later, notice my second paragraph where I illude to the solution. I have designed hundreds of pages with notepad, so I would like to know what they used instead, and if they changed anything in the new editor.

3) Since this problem seems to be connected in some (even indirect) way to your mod it may benefit your mod users to know that a problem (even an indirect one) exists and that a solution is possible.

stokerpiller
Registered User
Posts: 1934
Joined: Wed Feb 28, 2007 8:06 pm

Re: Posts per day

Post by stokerpiller » Thu Dec 11, 2008 2:26 pm

alphared -> This mod is easy to install/uninstall
Try uninstall and see what happens
I am done with phpBB

User avatar
MartectX
Translator
Posts: 1324
Joined: Wed Dec 19, 2007 8:05 pm
Location: Marienplatz

Re: Posts per day

Post by MartectX » Thu Dec 11, 2008 2:31 pm

alphared wrote:I have designed hundreds of pages with notepad, so I would like to know what they used instead, and if they changed anything in the new editor.
Try Notepad++, especially when tempering with language files.

stokerpiller
Registered User
Posts: 1934
Joined: Wed Feb 28, 2007 8:06 pm

Re: Posts per day

Post by stokerpiller » Fri Feb 13, 2009 11:58 pm

Hope to get some help on formatting the numbers with a comma so it would look like this_
3,14
instead of
3.14
any idea how to do that?
I am done with phpBB

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20430
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Posts per day

Post by RMcGirr83 » Sat Feb 14, 2009 2:02 am

You can try this, open index.php, find

Code: Select all

$posts_per_day = $total_posts / $boarddays;
after add

Code: Select all

$posts_per_day = number_format($posts_per_day, 2, ',', ' ');
You could probably get more clever and have it display based off the users language.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

stokerpiller
Registered User
Posts: 1934
Joined: Wed Feb 28, 2007 8:06 pm

Re: Posts per day

Post by stokerpiller » Sat Feb 14, 2009 8:50 am

No, that does not work. No comma and it removed the decimals.
I am done with phpBB

User avatar
MartectX
Translator
Posts: 1324
Joined: Wed Dec 19, 2007 8:05 pm
Location: Marienplatz

Re: Posts per day

Post by MartectX » Sat Feb 14, 2009 10:02 am

stokerpiller wrote:Hope to get some help on formatting the numbers with a comma so it would look like this: 3,14
OPEN

index.php

FIND

Code: Select all

	'POSTS_PER_DAY'	=> sprintf($user->lang[$l_posts_per_day_s], $posts_per_day),
REPLACE WITH

Code: Select all

	'POSTS_PER_DAY'	=> str_replace('.', ',', sprintf($user->lang[$l_posts_per_day_s], $posts_per_day)),

stokerpiller
Registered User
Posts: 1934
Joined: Wed Feb 28, 2007 8:06 pm

Re: Posts per day

Post by stokerpiller » Sat Feb 14, 2009 11:11 am

Thanks, worked perfect :)
I am done with phpBB

Richazey
Registered User
Posts: 823
Joined: Mon Oct 27, 2008 9:03 pm

Re: Posts per day

Post by Richazey » Wed May 06, 2009 1:58 pm

For anyone wanting to do the same for topics all you have to do is duplicate every edit and replace every POSTS with TOPICS and every posts with topics and the mod works fine, not worked out how to do the same for users yet though :D

Boewie
Registered User
Posts: 5
Joined: Wed Apr 14, 2010 2:32 pm

Re: Posts per day

Post by Boewie » Wed Apr 14, 2010 5:43 pm

I have installed the mod, but nothing happend. I have uninstalled it and installed it again, but nothing happend.
I read everything in this forum, tryed the solutions, but nothing seems to work.
Please help me.

Locked

Return to “[3.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 9 guests