TinyPic Plugin

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
wraaa
Registered User
Posts: 22
Joined: Fri Sep 05, 2008 10:06 pm

Re: TinyPic Plugin

Post by wraaa »

King-Nothing wrote:Because it sets [img] tags around the file. But since I use a bbcode to show pictures I need to remove the [img]-tag and replace it with the bbcode.

If not, you have to remove the [img]-tag and then use the bbcode. More work..

Isn't the img tag the bbcode? I'm not sure what you're trying to do. Can you give me an example of what you are trying to do?

King-Nothing
Registered User
Posts: 458
Joined: Sat Oct 06, 2007 6:14 pm

Re: TinyPic Plugin

Post by King-Nothing »

Ok, I`ll try to explain what I want to do:

I have a mod for showing pictures. In order to make this mod work, all pictures has to be within a certain bbcode. The code is [hspicture]"link to image"[/hspicture]. But when I upload pictures with tinypic and add them to the forum, it is automaticlly set to [img]"link%20to%20image[/img].

Thats why I need to change the default [img]-setting to be [hspicture] instead.

Got it now? ;)

Calman
Registered User
Posts: 339
Joined: Sat Jul 12, 2008 1:01 am
Location: Okanagan Valley, Canada
Contact:

Re: TinyPic Plugin

Post by Calman »

HELP!!

I've installed this plugin and it looks great. Only problem is, the "tinypic" tab only shows up when we are logged in as admin??? ... privilege setting?

Cal :(
Visiting, Researching or Relocating to the Okanagan Valley in BC?
http://www.okanaganforum.com

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17182
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

TinyPic Plugin

Post by DavidIQ »

MOD Updated to version 1.0.6
See first post for Download Link
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

Calman
Registered User
Posts: 339
Joined: Sat Jul 12, 2008 1:01 am
Location: Okanagan Valley, Canada
Contact:

Re: TinyPic Plugin

Post by Calman »

Many thanks for the update! :D

The question is, is it a matter of re-uploading the new files, or do I have to carry out file edits again?

All the best,
Cal :)
Visiting, Researching or Relocating to the Okanagan Valley in BC?
http://www.okanaganforum.com

Calman
Registered User
Posts: 339
Joined: Sat Jul 12, 2008 1:01 am
Location: Okanagan Valley, Canada
Contact:

Re: TinyPic Plugin

Post by Calman »

Fairly sure I've followed the file changes correctly, as V1.06 seems to only be an adaption for subsilver (myself running prosilver) ... but I can still only see the "tinypic" tab in new/edit posts, when I'm logged in as admin??


STUCK! :(
Visiting, Researching or Relocating to the Okanagan Valley in BC?
http://www.okanaganforum.com

wraaa
Registered User
Posts: 22
Joined: Fri Sep 05, 2008 10:06 pm

Re: TinyPic Plugin

Post by wraaa »

Calman wrote:Many thanks for the update! :D

The question is, is it a matter of re-uploading the new files, or do I have to carry out file edits again?

All the best,
Cal :)
You should only need to do the edits for subsilver2 if you have already installed the plugin. There was a change to how it was setting the option to show the upload, but if you already have it working you shouldn't need to redo it.

wraaa
Registered User
Posts: 22
Joined: Fri Sep 05, 2008 10:06 pm

Re: TinyPic Plugin

Post by wraaa »

Calman wrote:Fairly sure I've followed the file changes correctly, as V1.06 seems to only be an adaption for subsilver (myself running prosilver) ... but I can still only see the "tinypic" tab in new/edit posts, when I'm logged in as admin??


STUCK! :(

You should only see the tinypic option if you are logged in to post... it should not matter if you are logged in as an admin or not...

wraaa
Registered User
Posts: 22
Joined: Fri Sep 05, 2008 10:06 pm

Re: TinyPic Plugin

Post by wraaa »

King-Nothing wrote:Ok, I`ll try to explain what I want to do:

I have a mod for showing pictures. In order to make this mod work, all pictures has to be within a certain bbcode. The code is [hspicture]"link to image"[/hspicture]. But when I upload pictures with tinypic and add them to the forum, it is automaticlly set to [img]"link%20to%20image[/img].

Thats why I need to change the default [img]-setting to be [hspicture] instead.

Got it now? ;)

Oh so you have a custom tag. So you can use the direct link and modify the callback function to put the [hspicture][/hspicture] you're self.

So you'll want to change tinypic_links to 'url' in the posting_upload_body.html.


Then edit the callback.html:

change:

Code: Select all

parent.parent.insert_text(getParameter(document.location.href, "code"), true);
to something like:

Code: Select all

 parent.parent.insert_text("[hspicture]"+getParameter(document.location.href, "code")+"[/hspicture]", true);

I think that'll do what you want.

Calman
Registered User
Posts: 339
Joined: Sat Jul 12, 2008 1:01 am
Location: Okanagan Valley, Canada
Contact:

Re: TinyPic Plugin

Post by Calman »

You should only see the tinypic option if you are logged in to post... it should not matter if you are logged in as an admin or not...
Yeah, I would expect that ... but when I log in as a normal member, I don't see the tinypic tab in a new post or editing an existing one. I can only see the new plugin when I am logged in as admin, this is why I asked earlier if it may have something to do with user permissions on our board or something along those lines?

All the best,
Cal
Visiting, Researching or Relocating to the Okanagan Valley in BC?
http://www.okanaganforum.com

King-Nothing
Registered User
Posts: 458
Joined: Sat Oct 06, 2007 6:14 pm

Re: TinyPic Plugin

Post by King-Nothing »

wraaa wrote:
King-Nothing wrote:Ok, I`ll try to explain what I want to do:

I have a mod for showing pictures. In order to make this mod work, all pictures has to be within a certain bbcode. The code is [hspicture]"link to image"[/hspicture]. But when I upload pictures with tinypic and add them to the forum, it is automaticlly set to [img]"link%20to%20image[/img].

Thats why I need to change the default [img]-setting to be [hspicture] instead.

Got it now? ;)

Oh so you have a custom tag. So you can use the direct link and modify the callback function to put the [hspicture][/hspicture] you're self.

So you'll want to change tinypic_links to 'url' in the posting_upload_body.html.


Then edit the callback.html:

change:

Code: Select all

parent.parent.insert_text(getParameter(document.location.href, "code"), true);
to something like:

Code: Select all

 parent.parent.insert_text("[hspicture]"+getParameter(document.location.href, "code")+"[/hspicture]", true);

I think that'll do what you want.
That worked great! Thanks alot. :)

Only one more question:

Is there a way to make this box appear also when you edit a post? Now it only appears when you write a new one.

Calman
Registered User
Posts: 339
Joined: Sat Jul 12, 2008 1:01 am
Location: Okanagan Valley, Canada
Contact:

Re: TinyPic Plugin

Post by Calman »

... not sure if this info will help with my problem, but I refreshed the templates in ACP and have "attachments" set to yes?

So....

Normal Member Login (even editing their own previous posts): [Options] - [Upload Attachment]
Mod/Admin Login: [Options] - [Poll] - [Upload Attachment] - [tinypic plugin]

???
Visiting, Researching or Relocating to the Okanagan Valley in BC?
http://www.okanaganforum.com

Calman
Registered User
Posts: 339
Joined: Sat Jul 12, 2008 1:01 am
Location: Okanagan Valley, Canada
Contact:

Re: TinyPic Plugin

Post by Calman »

Oh well, I guess nobody can help with this?

I will remove it tomorrow, as it doesn't look promising on my setup for some reason (coding issue or otherwise)

Thanks for trying! :(
Visiting, Researching or Relocating to the Okanagan Valley in BC?
http://www.okanaganforum.com

wraaa
Registered User
Posts: 22
Joined: Fri Sep 05, 2008 10:06 pm

Re: TinyPic Plugin

Post by wraaa »

Calman wrote:
You should only see the tinypic option if you are logged in to post... it should not matter if you are logged in as an admin or not...
Yeah, I would expect that ... but when I log in as a normal member, I don't see the tinypic tab in a new post or editing an existing one. I can only see the new plugin when I am logged in as admin, this is why I asked earlier if it may have something to do with user permissions on our board or something along those lines?

All the best,
Cal

Odd, i'll look at it today and see if i can reproduce the issue.

wraaa
Registered User
Posts: 22
Joined: Fri Sep 05, 2008 10:06 pm

Re: TinyPic Plugin

Post by wraaa »

King-Nothing wrote:
That worked great! Thanks alot. :)

Only one more question:

Is there a way to make this box appear also when you edit a post? Now it only appears when you write a new one.

I'm submitting a new version with this fixed. If you want to do it yourself,

in phpBB3/posting.php find:

Code: Select all

$message_parser->bbcode_uid = $post_data['bbcode_uid'];
Add after find:

Code: Select all

    //Tinypic Plugin MOD by tinypic.com - start
    $template->assign_var('S_SHOW_UPLOAD_BOX', true);
    //Tinypic Plugin MOD by tinypic.com - end
Last edited by wraaa on Tue Jun 09, 2009 3:57 pm, edited 2 times in total.

Locked

Return to “[3.0.x] MOD Database Releases”