User Blog Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
isNumB
Registered User
Posts: 86
Joined: Thu Aug 06, 2009 7:59 am

Re: User Blog Mod

Post by isNumB » Sun Mar 14, 2010 9:12 am

isNumB wrote:does this mode ads a new RECENT BLOG ENTRIES section in the right/left side of the forum index page right near the forums. Like Vbulletin 4.0 style. Sorry for this :D, phpBB still the best. ;)
Or it's only a separate blog page that you have to access it?

Thanks. ;)
anyone???

Angry_Sun
Registered User
Posts: 430
Joined: Fri Aug 01, 2008 2:17 am
Location: Dry Dry Desert
Contact:

Re: User Blog Mod

Post by Angry_Sun » Sun Mar 14, 2010 2:34 pm

novanilla wrote:@Angry_Sun: That's odd... Check your Blog Settings in the ACP and make sure the field, "Output profile Blog links in Custom Profile Fields:" is set to YES.
Alright I enabled it, but I still don't see anything. That's weird. Could someone just give the the code it puts into the memberlist_view.html page?

User avatar
novanilla
Registered User
Posts: 332
Joined: Wed Jul 02, 2008 1:08 pm
Location: Colorado
Contact:

Re: User Blog Mod

Post by novanilla » Sun Mar 14, 2010 2:46 pm

@Angry_Sun: I looked at my own instructions, and it seems that's not the file to edit after all. Did you do the acp_users_profile.html edit?

Open: adm/style/acp_users_profile.html
Find

Code: Select all

</fieldset>
Add after
Tip: Add these lines on a new blank line after the preceding line(s) to find.

Code: Select all

<!-- INCLUDE acp_blog_users.html -->
I actually don't think this is the file edit you need, but I can't figure out what else the problem may be. There's a LONG list of blog permissions added to the permissions page of the ACP. Make sure you go through those carefully and see if maybe you're missing something there.

Angry_Sun
Registered User
Posts: 430
Joined: Fri Aug 01, 2008 2:17 am
Location: Dry Dry Desert
Contact:

Re: User Blog Mod

Post by Angry_Sun » Sun Mar 14, 2010 3:07 pm

Output profile Blog links in Custom Profile Fields:
If this is set to No the View Blogs link in each profile will not be outputted using the custom profile fields. You will need to manually add the links in the template if you wish to display them if this is set to No.
I think this is the problem, I've edited and moved the custom profile links in the memberlist_view.html. So If I could just get the correct code, I could easily add it in.

User avatar
jsebean
Registered User
Posts: 378
Joined: Sat Dec 12, 2009 3:20 pm
Location: Atlantic Canada
Name: Jonah
Contact:

Re: User Blog Mod

Post by jsebean » Sun Mar 14, 2010 8:55 pm

YAY, I got the mod installed successfully, but...


Should the database.php script be deleted after the mod is setup successfully?
-Jonah
:lol:

User avatar
jsebean
Registered User
Posts: 378
Joined: Sat Dec 12, 2009 3:20 pm
Location: Atlantic Canada
Name: Jonah
Contact:

Re: User Blog Mod

Post by jsebean » Mon Mar 15, 2010 5:55 pm

jsbean wrote: Should the database.php script be deleted after the mod is setup successfully?
Anybody???

Also, is there a way that I can make it so that my blog can be viewed by people who are not logged in (in other words, so guests can see them, unless the users choose not to allow guests to see their blog)
-Jonah
:lol:

Samanthavv
Registered User
Posts: 36
Joined: Tue Mar 31, 2009 2:07 am
Location: Alaska
Contact:

Re: User Blog Mod

Post by Samanthavv » Tue Mar 16, 2010 5:53 am

Does this work on 3.0.7-PL?
I am a BIRTH DOULA.
I use CLOTH DIAPERS.
My son is exclusively BREASTFED.
I have donated my MILK to 8 other babies in need.
I keep a BLOG at http://www.anotherteenmom.com

ricjonhay
Registered User
Posts: 247
Joined: Tue Feb 16, 2010 6:08 pm

Re: User Blog Mod

Post by ricjonhay » Tue Mar 16, 2010 11:27 am

Samanthavv wrote:Does this work on 3.0.7-PL?
YES! :D

User avatar
novanilla
Registered User
Posts: 332
Joined: Wed Jul 02, 2008 1:08 pm
Location: Colorado
Contact:

Re: User Blog Mod

Post by novanilla » Tue Mar 16, 2010 12:14 pm

jsbean wrote:
jsbean wrote: Should the database.php script be deleted after the mod is setup successfully?
Anybody???

Also, is there a way that I can make it so that my blog can be viewed by people who are not logged in (in other words, so guests can see them, unless the users choose not to allow guests to see their blog)
@jsbean, I didn't even think of that when I installed it - my database.php is still there, but nothing says you can't remove it and see what happens.

As for the viewing permissions, there's a whole new permissions section for the blog in the ACP. You can give guests permission to view (and even post) blogs if you want. I hesitate to do that, because it seems users can't change the default and will have to remember to go into their settings to block guests from viewing their blogs every time.

Nesa
Registered User
Posts: 33
Joined: Fri Feb 15, 2008 5:34 pm

Re: User Blog Mod

Post by Nesa » Tue Mar 16, 2010 10:11 pm

I have a problem with this mod, when I set

Output profile Blog links in Custom Profile Fields: Yes
Always show blog link in profile: Yes

I Get this Profile field text, broken in several lines

Image

Is there any help here, I love this mod ;)

PHP Version 5.2.6
board link: http://www.topola-online.com

Below Avatar member fields are

Posts
Age
Join Date
Loacation
Thanked
Thank's got - These 2 lines are from Thanks 4 posts mod..

Please help I really love this Blogmania :D

Samanthavv
Registered User
Posts: 36
Joined: Tue Mar 31, 2009 2:07 am
Location: Alaska
Contact:

Re: User Blog Mod

Post by Samanthavv » Wed Mar 17, 2010 11:20 am

Worked great for me! :D Giving it a rating now!
I am a BIRTH DOULA.
I use CLOTH DIAPERS.
My son is exclusively BREASTFED.
I have donated my MILK to 8 other babies in need.
I keep a BLOG at http://www.anotherteenmom.com

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: User Blog Mod

Post by keith10456 » Wed Mar 17, 2010 1:31 pm

Nesa wrote:I have a problem with this mod, when I set

Output profile Blog links in Custom Profile Fields: Yes
Always show blog link in profile: Yes

I Get this Profile field text, broken in several lines

Image

Is there any help here, I love this mod ;)

PHP Version 5.2.6
board link: http://www.topola-online.com

Below Avatar member fields are

Posts
Age
Join Date
Loacation
Thanked
Thank's got - These 2 lines are from Thanks 4 posts mod..

Please help I really love this Blogmania :D

Did you double-check your style edits?

Nesa
Registered User
Posts: 33
Joined: Fri Feb 15, 2008 5:34 pm

Re: User Blog Mod

Post by Nesa » Wed Mar 17, 2010 3:34 pm

I've checked my edits and this line has 3 possible solutions..
: adm/style/acp_users_profile.html
Find
Tip: This may be a partial find and not the whole line.

Code:Select all
</fieldset>
Add after
Tip: Add these lines on a new blank line after the preceding line(s) to find.

Code:Select all
<!-- INCLUDE acp_blog_users.html -->
This </fieldset> shows 3 times in this file acp_users_profile.html

Code: Select all

	<form id="user_profile" method="post" action="{U_ACTION}">

	<fieldset>
		<legend>{L_USER_PROFILE}</legend>
	<dl>
		<dt><label for="icq">{L_UCP_ICQ}:</label></dt>
		<dd><input type="text" id="icq" name="icq" value="{ICQ}" /></dd>
	</dl>
	<dl>
		<dt><label for="aim">{L_UCP_AIM}:</label></dt>
		<dd><input type="text" id="aim" name="aim" value="{AIM}" /></dd>
	</dl>
	<dl>
		<dt><label for="msn">{L_UCP_MSNM}:</label></dt>
		<dd><input type="text" id="msn" name="msn" value="{MSN}" /></dd>
	</dl>
	<dl>
		<dt><label for="yim">{L_UCP_YIM}:</label></dt>
		<dd><input type="text" id="yim" name="yim" value="{YIM}" /></dd>
	</dl>
	<dl>
		<dt><label for="jabber">{L_UCP_JABBER}:</label></dt>
		<dd><input type="text" id="jabber" name="jabber" value="{JABBER}" /></dd>
	</dl>
	<dl>
		<dt><label for="website">{L_WEBSITE}:</label></dt>
		<dd><input type="text" id="website" name="website" value="{WEBSITE}" /></dd>
	</dl>
	<dl>
		<dt><label for="location">{L_LOCATION}:</label></dt>
		<dd><input type="text" id="location" name="location" value="{LOCATION}" /></dd>
	</dl>
	<dl>
		<dt><label for="occupation">{L_OCCUPATION}:</label></dt>
		<dd><textarea id="occupation" name="occupation" rows="3" cols="30">{OCCUPATION}</textarea></dd>
	</dl>
	<dl>
		<dt><label for="interests">{L_INTERESTS}:</label></dt>
		<dd><textarea id="interests" name="interests" rows="3" cols="30">{INTERESTS}</textarea></dd>
	</dl>
	<dl> 
		<dt><label for="birthday">{L_BIRTHDAY}:</label><br /><span>{L_BIRTHDAY_EXPLAIN}</span></dt>
		<dd>{L_DAY}: <select id="birthday" name="bday_day">{S_BIRTHDAY_DAY_OPTIONS}</select> {L_MONTH}: <select name="bday_month">{S_BIRTHDAY_MONTH_OPTIONS}</select> {L_YEAR}: <select name="bday_year">{S_BIRTHDAY_YEAR_OPTIONS}</select></dd>
	</dl>
	</fieldset>

	<!-- IF .profile_fields -->
		<fieldset>
			<legend>{L_USER_CUSTOM_PROFILE_FIELDS}</legend>
		<!-- BEGIN profile_fields -->
		<dl> 
			<dt><label<!-- IF profile_fields.FIELD_ID --> for="{profile_fields.FIELD_ID}"<!-- ENDIF -->>{profile_fields.LANG_NAME}:</label><!-- IF profile_fields.LANG_EXPLAIN --><br /><span>{profile_fields.LANG_EXPLAIN}</span><!-- ENDIF --></dt>
			<dd>{profile_fields.FIELD}</dd>
			<!-- IF profile_fields.ERROR -->
				<dd><span class="small" style="color: red;">{profile_fields.ERROR}</span></dd>
			<!-- ENDIF -->
		</dl>
		<!-- END profile_fields -->
		</fieldset>
	<!-- ENDIF -->

	<fieldset class="quick">
		<input class="button1" type="submit" name="update" value="{L_SUBMIT}" />
		{S_FORM_TOKEN}
	</fieldset>
	</form>

Where to put

Code: Select all

 <!-- INCLUDE acp_blog_users.html -->
?

Nesa
Registered User
Posts: 33
Joined: Fri Feb 15, 2008 5:34 pm

Re: User Blog Mod

Post by Nesa » Wed Mar 17, 2010 3:50 pm

Found my Error
in viewtopic.php

Find
// Dump vars into template
$template->assign_block_vars('postrow', $postrow);
Add after

Code: Select all

	// Start Add User Blog Mod ------------------
	if (isset($config['user_blog_enable']) && $config['user_blog_enable'])
	{
		add_blog_links($poster_id, 'postrow.custom_fields', $user_cache[$poster_id]);
	}
	// End Add User Blog Mod --------------------
I have added new code after first line // Dump vars into template

Note to myself - don't do forum mods after hard day at work :mrgreen:

kiore
Registered User
Posts: 91
Joined: Wed Aug 26, 2009 1:11 am

Re: User Blog Mod

Post by kiore » Wed Mar 17, 2010 7:31 pm

I have WP-United installed and they both have blog.php in the root folder and since i don't want to overwrite the WP-United Blog.php how do i chnage the user blog.php so that i can name it somthing else and it work

Locked

Return to “[3.0.x] MOD Database Releases”