User Blog Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17377
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: User Blog Mod

Post by DavidIQ »

wolf2009 wrote:no way to get this working on php 4.4.8 ?
You can try it...but it's your funeral if it doesn't work and you definitely won't be getting support for doing that. I'm sure there's good reasons why Ex stated it's only for php 5 and up...
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: User Blog Mod

Post by EXreaction »

It's not possible, unless you want to rewrite everything.
alienbabeltech
Registered User
Posts: 415
Joined: Mon Sep 17, 2007 12:54 pm

Re: User Blog Mod

Post by alienbabeltech »

DavidIQ wrote:
wolf2009 wrote:no way to get this working on php 4.4.8 ?
You can try it...but it's your funeral if it doesn't work and you definitely won't be getting support for doing that. I'm sure there's good reasons why Ex stated it's only for php 5 and up...
so do I ask my Hoster to update to php 5 ?

will the update affect my forum in any way ?
This is the best and most helpful community I have been on. You are some of the best people I have met. GOD Bless You ALL !
My Forum - http://alienbabeltech.com/abt/index.php
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: User Blog Mod

Post by EXreaction »

Updating PHP should not be any issue, but usually, when hosts update PHP they update MySQL as well, which might give some issues depending on what version you currently have and what version they update to.
alienbabeltech
Registered User
Posts: 415
Joined: Mon Sep 17, 2007 12:54 pm

Re: User Blog Mod

Post by alienbabeltech »

EXreaction wrote:Updating PHP should not be any issue, but usually, when hosts update PHP they update MySQL as well, which might give some issues depending on what version you currently have and what version they update to.
what kind of issues ?

I think this is the MySQL version

MySQL 4.1.22-standard
This is the best and most helpful community I have been on. You are some of the best people I have met. GOD Bless You ALL !
My Forum - http://alienbabeltech.com/abt/index.php
User avatar
M0PIES
Registered User
Posts: 103
Joined: Sun Sep 14, 2008 6:37 pm

Re: User Blog Mod

Post by M0PIES »

I went to blog/install.php and got this error:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Field 'poll_title' doesn't have a default value [1364]

SQL

INSERT INTO phpbb_blogs (user_id, user_ip, blog_time, blog_subject, blog_text, blog_checksum, blog_approved, enable_bbcode, enable_smilies, enable_magic_url, bbcode_bitfield, bbcode_uid, blog_edit_reason) VALUES ('2', '71.238.201.170', 1227652140, 'Welcome to the User Blog Mod!', 'Welcome to the User Blog Mod!\n\nRelease Topic:\n<!-- m --><a class=\"postlink\" href=\"http://lithiumstudios.org/forum/viewtopic.php?f=41&t=433\">http://lithiumstudios.org/forum/viewtop ... f=41&t=433</a><!-- m -->\n\nSupport will only be given at lithiumstudios.org. If you have any comments or need support ask in this forum:\n<!-- m --><a class=\"postlink\" href=\"http://lithiumstudios.org/forum/viewforum.php?f=41\">http://lithiumstudios.org/forum/viewforum.php?f=41</a><!-- m -->', '2c01862dbe8ccd69da8113703f825792', 1, 1, 1, 1, '', '2rx2ti39', '')

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: blog/install/data.php
LINE: 93
CALL: dbal_mysql->sql_query()

FILE: blog/install.php
LINE: 71
CALL: include('blog/install/data.php')
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: User Blog Mod

Post by EXreaction »

I believe there were issues with upgrading MySQL 4.x to MySQL 5.x. I never had the problem myself and never looked into it myself though.
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: User Blog Mod

Post by EXreaction »

M0PIES wrote:I went to blog/install.php and got this error:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Field 'poll_title' doesn't have a default value [1364]

SQL

INSERT INTO phpbb_blogs (user_id, user_ip, blog_time, blog_subject, blog_text, blog_checksum, blog_approved, enable_bbcode, enable_smilies, enable_magic_url, bbcode_bitfield, bbcode_uid, blog_edit_reason) VALUES ('2', '71.238.201.170', 1227652140, 'Welcome to the User Blog Mod!', 'Welcome to the User Blog Mod!\n\nRelease Topic:\n<!-- m --><a class=\"postlink\" href=\"http://lithiumstudios.org/forum/viewtopic.php?f=41&t=433\">http://lithiumstudios.org/forum/viewtop ... f=41&t=433</a><!-- m -->\n\nSupport will only be given at lithiumstudios.org. If you have any comments or need support ask in this forum:\n<!-- m --><a class=\"postlink\" href=\"http://lithiumstudios.org/forum/viewforum.php?f=41\">http://lithiumstudios.org/forum/viewforum.php?f=41</a><!-- m -->', '2c01862dbe8ccd69da8113703f825792', 1, 1, 1, 1, '', '2rx2ti39', '')

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: blog/install/data.php
LINE: 93
CALL: dbal_mysql->sql_query()

FILE: blog/install.php
LINE: 71
CALL: include('blog/install/data.php')
Hmm, not sure why you would get that.

Everything else should have been installed correctly except the version. Run this query manually first:

Code: Select all

INSERT INTO phpbb_config (config_name, config_value) VALUES ('user_blog_version', '1.0.8');
Then purge the cache by deleting everything in the cache/ folder except index.htm and .htaccess
User avatar
M0PIES
Registered User
Posts: 103
Joined: Sun Sep 14, 2008 6:37 pm

Re: User Blog Mod

Post by M0PIES »

Alright now I have this error:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Table 'phpbb_blogs' already exists [1050]

SQL

CREATE TABLE phpbb_blogs ( blog_id mediumint(8) UNSIGNED NOT NULL auto_increment, user_id mediumint(8) UNSIGNED DEFAULT '0' NOT NULL, user_ip varbinary(40) DEFAULT '' NOT NULL, blog_subject blob NOT NULL, blog_text mediumblob NOT NULL, blog_checksum varbinary(32) DEFAULT '' NOT NULL, blog_time int(11) UNSIGNED DEFAULT '0' NOT NULL, blog_approved tinyint(1) UNSIGNED DEFAULT '1' NOT NULL, blog_reported tinyint(1) UNSIGNED DEFAULT '0' NOT NULL, enable_bbcode tinyint(1) UNSIGNED DEFAULT '1' NOT NULL, enable_smilies tinyint(1) UNSIGNED DEFAULT '1' NOT NULL, enable_magic_url tinyint(1) UNSIGNED DEFAULT '1' NOT NULL, bbcode_bitfield varbinary(255) DEFAULT '' NOT NULL, bbcode_uid varbinary(8) DEFAULT '' NOT NULL, blog_edit_time int(11) UNSIGNED DEFAULT '0' NOT NULL, blog_edit_reason blob NOT NULL, blog_edit_user mediumint(8) UNSIGNED DEFAULT '0' NOT NULL, blog_edit_count smallint(4) UNSIGNED DEFAULT '0' NOT NULL, blog_edit_locked tinyint(1) UNSIGNED DEFAULT '0' NOT NULL, blog_deleted mediumint(8) UNSIGNED DEFAULT '0' NOT NULL, blog_deleted_time int(11) UNSIGNED DEFAULT '0' NOT NULL, blog_read_count mediumint(8) UNSIGNED DEFAULT '1' NOT NULL, blog_reply_count mediumint(8) UNSIGNED DEFAULT '0' NOT NULL, blog_real_reply_count mediumint(8) UNSIGNED DEFAULT '0' NOT NULL, blog_attachment tinyint(1) UNSIGNED DEFAULT '0' NOT NULL, perm_guest tinyint(1) DEFAULT '1' NOT NULL, perm_registered tinyint(1) DEFAULT '2' NOT NULL, perm_foe tinyint(1) DEFAULT '0' NOT NULL, perm_friend tinyint(1) DEFAULT '2' NOT NULL, rating decimal(6,2) DEFAULT '0' NOT NULL, num_ratings mediumint(8) UNSIGNED DEFAULT '0' NOT NULL, poll_title blob NOT NULL, poll_start int(11) UNSIGNED DEFAULT '0' NOT NULL, poll_length int(11) UNSIGNED DEFAULT '0' NOT NULL, poll_max_options tinyint(4) DEFAULT '1' NOT NULL, poll_last_vote int(11) UNSIGNED DEFAULT '0' NOT NULL, poll_vote_change tinyint(1) UNSIGNED DEFAULT '0' NOT NULL, PRIMARY KEY (blog_id), KEY user_id (user_id), KEY user_ip (user_ip), KEY blog_approved (blog_approved), KEY blog_deleted (blog_deleted), KEY perm_guest (perm_guest), KEY perm_registered (perm_registered), KEY perm_foe (perm_foe), KEY perm_friend (perm_friend), KEY rating (rating) )

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: blog/install/tables.php
LINE: 53
CALL: dbal_mysql->sql_query()

FILE: blog/install.php
LINE: 67
CALL: include('blog/install/tables.php')
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: User Blog Mod

Post by EXreaction »

Yes, do just as I said, do not run the installer again.
User avatar
M0PIES
Registered User
Posts: 103
Joined: Sun Sep 14, 2008 6:37 pm

Re: User Blog Mod

Post by M0PIES »

Alright, everything is working fine now, Thanks. :)
eugene187
Registered User
Posts: 108
Joined: Sun Aug 15, 2004 4:05 am

Re: User Blog Mod

Post by eugene187 »

another fantastic mod thanks for all your hard work and the support was well worth the small donation

-e
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: User Blog Mod

Post by EXreaction »

M0PIES wrote:Alright, everything is working fine now, Thanks. :)
No problem. I've already fixed the cause of it in SVN and it'll be permanently fixed with the next version (whenever that gets released).
Artack
Registered User
Posts: 312
Joined: Thu Feb 07, 2008 11:26 pm

Re: User Blog Mod

Post by Artack »

Update to 1.0.8 without any problems
Thanks)
Kharon
Registered User
Posts: 235
Joined: Thu Oct 26, 2006 5:27 pm

Re: User Blog Mod

Post by Kharon »

install error

mod verison 1.0.8
phpBB version 3.0.3

Code: Select all

[phpBB Debug] PHP Notice: in file /blog/install/tables.php on line 21: Undefined property: dbal_mysql::$mysql_version
tables.php on line 21:

Code: Select all

if ($dbms == 'mysqli' || version_compare($db->mysql_version, '4.1.3', '>='))

thanks
Last edited by Kharon on Sat Nov 29, 2008 9:39 pm, edited 1 time in total.
Locked

Return to “[3.0.x] MOD Database Releases”