Page 10 of 10

Re: user warnings / ban info in viewtopic

Posted: Wed Feb 17, 2010 3:00 pm
by TTInternetHelp
RMcGirr83 wrote:Did you install this mod? The code above will not work until this mod is installed.

Yes I have this mod working, I see

BANNED_USERS
SUSPENDED_USERS

at the groups, so the mod is working! But if I do wat you says nothing will happend and the banned username stil not strikethrough!!

My style is subsilver2 based, so do I need to do something else????

Thank you for your quick reply

Re: user warnings / ban info in viewtopic

Posted: Wed Feb 17, 2010 3:15 pm
by RMcGirr83
This mod has nothing to do with groups.

Re: user warnings / ban info in viewtopic

Posted: Wed Feb 17, 2010 5:58 pm
by TTInternetHelp
hmmmm.... strange because after doing this mod I have that????????

Wat do I wrong, because if I reinstall this mod I reseave a error on the userpage

This user don't exist!

But the user exist and is banned?????


So can you help me pleace with this

Re: user warnings / ban info in viewtopic

Posted: Sat Apr 03, 2010 9:49 pm
by kocureq
The "memberlist" modifications don't work when I try to install them with automod, automod cannot find the "sear for" sections.

Is it just my board, or is it that the mod development has been stopped and it's incompatible with the latest phpBB version?

Re: user warnings / ban info in viewtopic

Posted: Mon Apr 05, 2010 12:33 am
by bibendum92
Hi Everybody

I'm trying to install this mod but i don't understand this tip :

You said find this in member list :

Code: Select all

trigger_error('NO_USER');
         }
But in this file, i can find this code 5 times !!!!

Thanks for your help.

Re: user warnings / ban info in viewtopic

Posted: Mon Apr 05, 2010 12:56 am
by bonelifer
bibendum92 that's true, but all FINDS are in ORDER. Therefore if you install from top to bottom then you don't have to worry about that.

Re: user warnings / ban info in viewtopic

Posted: Mon Apr 05, 2010 11:37 am
by bibendum92
Thanks a lot

That's work perfectly.

Re: user warnings / ban info in viewtopic

Posted: Mon Apr 05, 2010 2:10 pm
by Phil7789
Hi,
i have a little problem with this mod ^^

I am using a subsilver2 based style ( AeroBlue ) and while viewing the profile there is no "banned" status shown, just the warnings and the two options for making notes or warnings. I already doublechecked the memberlist.php and everything seems to be correct there

I hope anybody can help me

Phil

Re: user warnings / ban info in viewtopic

Posted: Mon Apr 05, 2010 7:20 pm
by kocureq
kocureq wrote:The "memberlist" modifications don't work when I try to install them with automod, automod cannot find the "sear for" sections.
OK, in my case install.xml was looking for

Code: Select all

			<!-- IF U_NOTES or U_WARN -->
			<dt>{L_WARNINGS}: </dt>
			<dd><strong>{WARNINGS}</strong> [ <a href="{U_NOTES}">{L_VIEW_NOTES}</a> <!-- IF U_WARN --> | <a href="{U_WARN}">{L_WARN_USER}</a> <!-- ENDIF -->]</dd>
			<!-- ENDIF -->
but I had this code instead

Code: Select all

			<!-- IF S_WARNINGS -->
			<dt>{L_WARNINGS}: </dt>
			<dd><strong>{WARNINGS}</strong><!-- IF U_NOTES or U_WARN --> [ <!-- IF U_NOTES --><a href="{U_NOTES}">{L_VIEW_NOTES}</a><!-- ENDIF --> <!-- IF U_WARN --><!-- IF U_NOTES --> | <!-- ENDIF --><a href="{U_WARN}">{L_WARN_USER}</a><!-- ENDIF --> ]<!-- ENDIF --></dd>
			<!-- ENDIF -->
So I had replaced the "search for" sections in actual install.xml.



For subsilver skin, in install.xml there was

Code: Select all

         <!-- IF U_NOTES or U_WARN -->
            <tr>
               <td class="gen" align="{S_CONTENT_FLOW_END}" valign="top" nowrap="nowrap">{L_WARNINGS}: </td>
               <td width="100%"><b class="gen">{WARNINGS}</b><br /><span class="genmed">[ <a href="{U_NOTES}">{L_VIEW_NOTES}</a> <!-- IF U_WARN --> | <a href="{U_WARN}">{L_WARN_USER}</a> <!-- ENDIF -->]</span></td>
            </tr>
         <!-- ENDIF -->
but I had on my board

Code: Select all

			<!-- IF S_WARNINGS -->
				<tr>
					<td class="gen" align="{S_CONTENT_FLOW_END}" valign="top" nowrap="nowrap">{L_WARNINGS}: </td>
					<td width="100%"><b class="gen">{WARNINGS}</b><!-- IF U_NOTES or U_WARN --><br /><span class="genmed"> [ <!-- IF U_NOTES --><a href="{U_NOTES}">{L_VIEW_NOTES}</a><!-- ENDIF --> <!-- IF U_WARN --><!-- IF U_NOTES --> | <!-- ENDIF --><a href="{U_WARN}">{L_WARN_USER}</a><!-- ENDIF --> ]</span><!-- ENDIF --></td>
				</tr>
			<!-- ENDIF -->

And the mod installed fine.



@author: please check if the same problems exist on vanilla phpBB 3.0.6, and if yes, update the install.xml with my fixes so that you have a complete package.