Forum Background for phpBB3

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
User avatar
wang5555
Translator
Posts: 602
Joined: Wed Oct 27, 2004 2:57 pm
Location: Taiwan

Re: Forum Background for phpBB3

Post by wang5555 »

PowWowPalace wrote:This mod is great! But I have one problem. Please look at http://www.powwowpalace.com and under the first category Automotive. The left side is displaying a thin space that the image is not filling in. I don't know why, the image is longer then the space so that is not the problem. It's happening on all categories below too. It's like this is a separate table cell, please help. Thanks.
Thanks for your problem.

Try it followiing:
--OPEN--
styles/YOUR_STYLE/template/forumlist_body.html

--FIND--

Code: Select all

<dl class="icon" style="background-image: url({forumrow.FORUM_BG}); background-repeat: repeat;">
--REPLACE WITH--

Code: Select all

<dl class="icon" style="background-image: url({forumrow.FORUM_BG}); background-repeat: repeat; background-position: 0 50%;">
--SAVE & CLOSE--

P.S.
Purge the cache.
It is more blessed to give than to reveive, welcome to letter, thanks & good-bye!
Good luck ^_^
Welcome to my forum!!
http://wang5555.hopto.org/phpBB3/
p.s. Shut down computer before 11 clock night!!!
User avatar
PowWowPalace
Registered User
Posts: 58
Joined: Thu Jul 09, 2009 3:28 pm
Contact:

Re: Forum Background for phpBB3

Post by PowWowPalace »

wang5555 wrote:
PowWowPalace wrote:This mod is great! But I have one problem. Please look at http://www.powwowpalace.com and under the first category Automotive. The left side is displaying a thin space that the image is not filling in. I don't know why, the image is longer then the space so that is not the problem. It's happening on all categories below too. It's like this is a separate table cell, please help. Thanks.
Thanks for your problem.

Try it followiing:
--OPEN--
styles/YOUR_STYLE/template/forumlist_body.html

--FIND--

Code: Select all

<dl class="icon" style="background-image: url({forumrow.FORUM_BG}); background-repeat: repeat;">
--REPLACE WITH--

Code: Select all

<dl class="icon" style="background-image: url({forumrow.FORUM_BG}); background-repeat: repeat; background-position: 0 50%;">
--SAVE & CLOSE--

P.S.
Purge the cache.

Worked perfectly! Thanks a lot :D Great mod
User avatar
PowWowPalace
Registered User
Posts: 58
Joined: Thu Jul 09, 2009 3:28 pm
Contact:

Re: Forum Background for phpBB3

Post by PowWowPalace »

wang5555 wrote:
JamieG wrote:Just noticed another problem with forum icons man!

Any help ?
Try to add some words as "Forum Desc",
or amend following:

OPEN:
includes/functions_display.php

FIND:

Code: Select all

			'FORUM_NAME'			=> $row['forum_name'],
			'FORUM_DESC'			=> generate_text_for_display($row['forum_desc'], $row['forum_desc_uid'], $row['forum_desc_bitfield'], $row['forum_desc_options']),
			'TOPICS'				=> $row['forum_topics'],
IN LINE FIND:

Code: Select all

			'FORUM_DESC'			=> generate_text_for_display($row['forum_desc'], $row['forum_desc_uid'], $row['forum_desc_bitfield'], $row['forum_desc_options']),
IN LINE REPLACE WITH:

Code: Select all

			'FORUM_DESC'			=> $row['forum_desc']) ? generate_text_for_display($row['forum_desc'], $row['forum_desc_uid'], $row['forum_desc_bitfield'], $row['forum_desc_options']) : '&nbsp;',
SAVE & CLOSE

P.S.
Thanks ScarerSulley! ;)
http://www.phpbb.com/community/viewtopi ... 5#p8878635

This worked fine for the main forums but the sub forums are still having the issue. Can you please check. Thanks
User avatar
wang5555
Translator
Posts: 602
Joined: Wed Oct 27, 2004 2:57 pm
Location: Taiwan

Re: Forum Background for phpBB3

Post by wang5555 »

PowWowPalace wrote:This worked fine for the main forums but the sub forums are still having the issue.
Thanks for your issue.

I already changed the codes in lastest 1.0.7 version below.

Code: Select all

'FORUM_DESC'			=> !empty($row['forum_desc']) ? generate_text_for_display($row['forum_desc'], $row['forum_desc_uid'], $row['forum_desc_bitfield'], $row['forum_desc_options']) : '',
P.S.
About 442 lines.

But it did not work normally. :oops:
Must fix it following:

Code: Select all

'FORUM_DESC'			=> !empty($row['forum_desc']) ? generate_text_for_display($row['forum_desc'], $row['forum_desc_uid'], $row['forum_desc_bitfield'], $row['forum_desc_options']) : '&nbsp;',
So, the main forums and the sub forums will work normally.
It is more blessed to give than to reveive, welcome to letter, thanks & good-bye!
Good luck ^_^
Welcome to my forum!!
http://wang5555.hopto.org/phpBB3/
p.s. Shut down computer before 11 clock night!!!
User avatar
PowWowPalace
Registered User
Posts: 58
Joined: Thu Jul 09, 2009 3:28 pm
Contact:

Re: Forum Background for phpBB3

Post by PowWowPalace »

wang5555 wrote:
PowWowPalace wrote:This worked fine for the main forums but the sub forums are still having the issue.
Thanks for your issue.

I already changed the codes in lastest 1.0.7 version below.

Code: Select all

'FORUM_DESC'			=> !empty($row['forum_desc']) ? generate_text_for_display($row['forum_desc'], $row['forum_desc_uid'], $row['forum_desc_bitfield'], $row['forum_desc_options']) : '',
P.S.
About 442 lines.

But it did not work normally. :oops:
Must fix it following:

Code: Select all

'FORUM_DESC'			=> !empty($row['forum_desc']) ? generate_text_for_display($row['forum_desc'], $row['forum_desc_uid'], $row['forum_desc_bitfield'], $row['forum_desc_options']) : '&nbsp;',
So, the main forums and the sub forums will work normally.
Worked fine, thanks again.
sTimulated
Registered User
Posts: 91
Joined: Fri Mar 27, 2009 4:16 pm
Contact:

Re: Forum Background for phpBB3

Post by sTimulated »

Installed mod,working fine :) thanks

What is the size of the image one should use?
User avatar
wang5555
Translator
Posts: 602
Joined: Wed Oct 27, 2004 2:57 pm
Location: Taiwan

Re: Forum Background for phpBB3

Post by wang5555 »

sTimulated wrote:What is the size of the image one should use?
Has no certain rule, as long as you like.
It is more blessed to give than to reveive, welcome to letter, thanks & good-bye!
Good luck ^_^
Welcome to my forum!!
http://wang5555.hopto.org/phpBB3/
p.s. Shut down computer before 11 clock night!!!
User avatar
PowWowPalace
Registered User
Posts: 58
Joined: Thu Jul 09, 2009 3:28 pm
Contact:

Re: Forum Background for phpBB3

Post by PowWowPalace »

I had this mod working fine and now it's messed up. I've installed a few mods since this one and have no idea which one messed it up. I have attached screen shots of the admin forum and the forum itself. Notice that the image is not acting as a background anymore. The image is acting as a regular image and the text is not overlaying onto it. Any ideas what might have caused this or where I should check code? Thanks

Image


Image
User avatar
wang5555
Translator
Posts: 602
Joined: Wed Oct 27, 2004 2:57 pm
Location: Taiwan

Re: Forum Background for phpBB3

Post by wang5555 »

PowWowPalace wrote:I had this mod working fine and now it's messed up. I've installed a few mods since this one and have no idea which one messed it up. I have attached screen shots of the admin forum and the forum itself. Notice that the image is not acting as a background anymore. The image is acting as a regular image and the text is not overlaying onto it. Any ideas what might have caused this or where I should check code? Thanks
Suggest you:
Check your file following.
adm/style/acp_forums.html
It is more blessed to give than to reveive, welcome to letter, thanks & good-bye!
Good luck ^_^
Welcome to my forum!!
http://wang5555.hopto.org/phpBB3/
p.s. Shut down computer before 11 clock night!!!
User avatar
PowWowPalace
Registered User
Posts: 58
Joined: Thu Jul 09, 2009 3:28 pm
Contact:

Re: Forum Background for phpBB3

Post by PowWowPalace »

wang5555 wrote:
PowWowPalace wrote:I had this mod working fine and now it's messed up. I've installed a few mods since this one and have no idea which one messed it up. I have attached screen shots of the admin forum and the forum itself. Notice that the image is not acting as a background anymore. The image is acting as a regular image and the text is not overlaying onto it. Any ideas what might have caused this or where I should check code? Thanks
Suggest you:
Check your file following.
adm/style/acp_forums.html

I restored my backup files that I edited after installing this mod and it did not work either. Do you know of any other file that could be causing this? Thanks
User avatar
wang5555
Translator
Posts: 602
Joined: Wed Oct 27, 2004 2:57 pm
Location: Taiwan

Re: Forum Background for phpBB3

Post by wang5555 »

PowWowPalace wrote:
wang5555 wrote:
PowWowPalace wrote:I had this mod working fine and now it's messed up. I've installed a few mods since this one and have no idea which one messed it up. I have attached screen shots of the admin forum and the forum itself. Notice that the image is not acting as a background anymore. The image is acting as a regular image and the text is not overlaying onto it. Any ideas what might have caused this or where I should check code? Thanks
Suggest you:
Check your file following.
adm/style/acp_forums.html

I restored my backup files that I edited after installing this mod and it did not work either. Do you know of any other file that could be causing this? Thanks
Please compress your file then paste download link.
adm/style/acp_forums.html
It is more blessed to give than to reveive, welcome to letter, thanks & good-bye!
Good luck ^_^
Welcome to my forum!!
http://wang5555.hopto.org/phpBB3/
p.s. Shut down computer before 11 clock night!!!
User avatar
PowWowPalace
Registered User
Posts: 58
Joined: Thu Jul 09, 2009 3:28 pm
Contact:

Re: Forum Background for phpBB3

Post by PowWowPalace »

http://www.powwowpalace.com/acp_forums.zip

Did you also see that it is happening on the forum pages too in the image I attached?

I appreciate your help, thanks.
User avatar
wang5555
Translator
Posts: 602
Joined: Wed Oct 27, 2004 2:57 pm
Location: Taiwan

Re: Forum Background for phpBB3

Post by wang5555 »

PowWowPalace wrote:http://www.powwowpalace.com/acp_forums.zip

Did you also see that it is happening on the forum pages too in the image I attached?

I appreciate your help, thanks.
This file is right for the mod.
Because you already install many mods,
So you maybe check every other file about the mod.
  • includes/functions_content.php
  • includes/functions_display.php
  • includes/acp/acp_forums.php
It is more blessed to give than to reveive, welcome to letter, thanks & good-bye!
Good luck ^_^
Welcome to my forum!!
http://wang5555.hopto.org/phpBB3/
p.s. Shut down computer before 11 clock night!!!
User avatar
PowWowPalace
Registered User
Posts: 58
Joined: Thu Jul 09, 2009 3:28 pm
Contact:

Re: Forum Background for phpBB3

Post by PowWowPalace »

I actually restored all those files to the day I installed the mod and it didn't work. So some other file I modified recently cause the mod not to work. Have any idea whiich file it could be? Maybe the functions.php file or contents.php, any ideas would be great. Thanks
User avatar
wang5555
Translator
Posts: 602
Joined: Wed Oct 27, 2004 2:57 pm
Location: Taiwan

Re: Forum Background for phpBB3

Post by wang5555 »

PowWowPalace wrote:I actually restored all those files to the day I installed the mod and it didn't work. So some other file I modified recently cause the mod not to work. Have any idea whiich file it could be? Maybe the functions.php file or contents.php, any ideas would be great. Thanks
Please compress your files then paste download link.
  • includes/functions_content.php
  • includes/functions_display.php
  • includes/acp/acp_forums.php
It is more blessed to give than to reveive, welcome to letter, thanks & good-bye!
Good luck ^_^
Welcome to my forum!!
http://wang5555.hopto.org/phpBB3/
p.s. Shut down computer before 11 clock night!!!
Locked

Return to “[3.0.x] MOD Database Releases”