easyPortal

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
wideglide1340
Registered User
Posts: 21
Joined: Sat Oct 10, 2009 2:51 pm

Removing EasyPortal,not so easy.

Post by wideglide1340 »

Wolfman.
I used these backups,
located in:/forum/store/mods/easyPortal_100/_backups.

I looked in them with an editor ,because you told me I still didn't restore the backup files.
But I did.

viewonline.php and ucp.online both had the word "portal" in them.

So,the backup file is contaminated by EasyPortal.
I took both files from a "fresh" phpbb 3.05 download,
and replaced them.

Now,as far as I can see,everything is working like it did before EasyPortal installation.
Noxwizard&Wolfman,thank you both for your help.
ZonaKaoz
Registered User
Posts: 5
Joined: Wed Jan 28, 2009 7:14 pm

Re: easyPortal

Post by ZonaKaoz »

ZonaKaoz wrote:Nice mod dud, only a question, how i change the title of the portal page? Now only show "Home" and i want the title been my forums name, my code in overall_header is

Code: Select all

<title>{PAGE_TITLE}<!-- IF S_IN_MCP --> &bull; {L_MCP}<!-- ELSEIF S_IN_UCP --> &bull; {L_UCP}<!-- ENDIF --></title>
i use phpbb seo advanced.

Thanks dud, sorry my english
---
You can the language entry specified in portal.php:

Code: Select all

page_header($user->lang['HOME']);
Thanks for the reply, i doit, i change the code for this..

Code: Select all

page_header($user->lang['ZonaKaoz']);
But in portal.php appear this error:

Code: Select all

[phpBB Debug] PHP Notice: in file /portal.php on line 232: Undefined index: ZonaKaoz
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3922: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3294)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3923: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3294)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3924: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3294)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3925: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3294)
User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10406
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: easyPortal

Post by Noxwizard »

Unless that language string is defined, what you added isn't going to work. It would need to be:

Code: Select all

page_header('My new page title');
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.
wideglide1340
Registered User
Posts: 21
Joined: Sat Oct 10, 2009 2:51 pm

Remove easyPortal

Post by wideglide1340 »

Hello,back again.
I was happy to soon.
Still got this message,after uploading (from a fresh phpBB download) all files mentioned in the EasyPortal backup files.
error.gif
error.gif (5.71 KiB) Viewed 1281 times
Who can help?
Thanks.
wolfman24
Registered User
Posts: 387
Joined: Tue Mar 07, 2006 12:07 pm

Re: Remove easyPortal

Post by wolfman24 »

wideglide1340 wrote:Hello,back again.
I was happy to soon.
Still got this message,after uploading (from a fresh phpBB download) all files mentioned in the EasyPortal backup files.
error.gif
Who can help?
Thanks.
As I have written 2 days ago:
wolfman24 wrote:You also need to remove the new files. At least portal.php is still on your server. Also have a look into the .htaccess file. It still redirects to portal.php instead of index.php. Just change that.
It would be the best you start reading the help other people give you and following their advice. It is all said, so please remove all of the (new) portal files from your webspace and edit the .htaccess thing. Or delete your browser cache. The help you need is all written down in the last 2 pages.
wideglide1340
Registered User
Posts: 21
Joined: Sat Oct 10, 2009 2:51 pm

Remove easyPortal

Post by wideglide1340 »

Wolfman,I'm sorry.
I've been reading all the advises very carefully.
I've deleted all files with"portal" in it.
Replaced all the files named in EasyPortal backup files,with fresh,new downloaded files.
I've replaced the .htaccess file.
When I delete "portal.php", I get an PHP error message,file not found.

I notice you are getting annoyed,
I'm doing my utmost,I'm just here to get help,so I can solve my "problem".
wolfman24
Registered User
Posts: 387
Joined: Tue Mar 07, 2006 12:07 pm

Re: Remove easyPortal

Post by wolfman24 »

wideglide1340 wrote:Wolfman,I'm sorry.
I've been reading all the advises very carefully.
I've deleted all files with"portal" in it.
Replaced all the files named in EasyPortal backup files,with fresh,new downloaded files.
I've replaced the .htaccess file.
When I delete "portal.php", I get an PHP error message,file not found.

I notice you are getting annoyed,
I'm doing my utmost,I'm just here to get help,so I can solve my "problem".
You shall not delete all files with portal in it, you must delete all files you uploaded that came with the portal installation. I'm not sure if they are all named portal so read the installation instructions and delete all the new files.

You still have the portal.php in your root directory so please delete it now. If I am using http://www.harley-heaven.com/forum/ I am on the index of your board as supposed to be, so the .htaccess seems to be right now. If you are still redirected to the portal.php page which gives this 404 error after you deleted the portal.php (I assume that is what you are talking about when you are talking about a php error) please clear the cache of your browser (what I have written in my last post).

If it is still not working for you, you are still not doing what I have written down, otherwise please post the correct error you get.
wideglide1340
Registered User
Posts: 21
Joined: Sat Oct 10, 2009 2:51 pm

Removing easyPortal

Post by wideglide1340 »

Wolfman,
I still get this message,it can be seen when members have logged in:
error.gif
error.gif (5.71 KiB) Viewed 1272 times
When I delete portal.php from the root,I get a 404 error message.

When I delete from forum/includes functions_portal.php,
I get this error message:
forum_includes.gif
forum_includes.gif (38.79 KiB) Viewed 1272 times
wolfman24
Registered User
Posts: 387
Joined: Tue Mar 07, 2006 12:07 pm

Re: easyPortal

Post by wolfman24 »

Looks like after logon you are redirected to portal.php => You still have not removed all the edits you made during installation of the portal. Either way, upload all the original, backed up files to their positions or just remove all the edits you made. There is nothing more that I can say since you are still not doing what you are advised to do. The error in your second screen is also caused by still not removing the portal edits. Your includes/functions.php still has reference(s) to functions_portal.php.

Best is to reupload all the files from your backup, but I assume you don't have any backup. Next time you try to install a mod, please backup your files and database before installation.

If you have no other mods installed on your forum, you can upload all the files from the original phpbb package except the install folder and the config.php.
wideglide1340
Registered User
Posts: 21
Joined: Sat Oct 10, 2009 2:51 pm

Re: easyPortal

Post by wideglide1340 »

Thank you Wolfman.
Automod has made the changes for me.

If it did more than just replace files,
I'm not capable to undo these changes.

The backups in the store/mod file,were polluted,and as I told,
I replaced the files mentioned in store/mod ,by fresh downloaded ones.

Thank you for yor advises,
the forum members they learn to live with it...
wolfman24
Registered User
Posts: 387
Joined: Tue Mar 07, 2006 12:07 pm

Re: easyPortal

Post by wolfman24 »

No you did not, otherwise the reference to includes/functions_portal.php would not be in includes/functions.php. Why don't you try to open includes/functions.php and search for the reference to functions_portal? IF you do what I and others told you severall times, you will fix the errors, but I don't know what you copied from where to where I can't help anymore. Maybe you copied to the wrong places? Double check everything.
User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10406
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: easyPortal

Post by Noxwizard »

I don't know how you managed to get edits copied into your backup folder unless you somehow got AutoMOD to run it twice and it backed up the edited files. If you don't have any other MODs installed, then you can just replace the modified files with fresh ones from the phpBB Full Package on our Downloads page. The files that were modified are as follows:
  • includes/functions.php,
    styles/prosilver/template/overall_header.html,
    ucp.php,
    viewonline.php,
    .htaccess
Alternatively, you could do what the error message says and finish the installation by following the DIY.
easyPortal DIY wrote:Go to the System tab. In the Module Management section, click Administration Control Panel link. In the drop down menu next to the "Add Module" button, choose "easyPortal" and click "Add Module". Then click "Enable" for that module.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.
wideglide1340
Registered User
Posts: 21
Joined: Sat Oct 10, 2009 2:51 pm

Remove easyPortal

Post by wideglide1340 »

Wolfman,
this is what It shows when the file is searched on"Portal"
Can you tell me what to do?
portal.gif
portal.gif (14.03 KiB) Viewed 1266 times
Guminukas
Registered User
Posts: 23
Joined: Tue Sep 22, 2009 6:00 pm

Re: easyPortal

Post by Guminukas »

Open: .htaccess

Find

Code: Select all

<Files "config.php">
Add before

Code: Select all

DirectoryIndex index.html index.htm portal.php index.php
But then I get this error:

Sorry, bet server unable to process your request. It might happen of incorrect .htaccess fail or php programm.
Blupa
Registered User
Posts: 17
Joined: Fri Jul 31, 2009 1:56 pm

Re: easyPortal

Post by Blupa »

Edit fixed problem ><
Locked

Return to “[3.0.x] MOD Database Releases”