phpBB Mood Swings

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Xanta Media
Registered User
Posts: 213
Joined: Sat Dec 27, 2008 4:33 pm

Re: phpBB Mood Swings

Post by Xanta Media »

Primy wrote:Hey Xanta, congrats for this release :)

Just a thing: in templates/subsilver2.xml

Open: styles/subsilver2/template/memberlist_view.html

Code: Select all

         <!-- IF MOOD -->
			<tr>
				<td class="gen" align="{S_CONTENT_FLOW_END}" nowrap="nowrap">{L_MOOD}: </td>
				<td><b class="genmed">{USER_MOOD}</b></td>
			</tr>
			<!-- ENDIF -->
It should be:

Code: Select all

			<!-- IF USER_MOOD -->
			<tr>
				<td class="gen" align="{S_CONTENT_FLOW_END}" nowrap="nowrap">{L_MOOD}: </td>
				<td><b class="genmed">{USER_MOOD}</b></td>
			</tr>
			<!-- ENDIF -->
;)
Well spotted Primy :D Added to the FAQ for other members to find this will be fixed in next update.
User avatar
barryoneoff
Registered User
Posts: 248
Joined: Sat Mar 24, 2007 10:14 pm
Location: East London, England
Contact:

Re: phpBB Mood Swings

Post by barryoneoff »

I've only just noticed that I have this code appearing at the top of the ACP:

Code: Select all

[phpBB Debug] PHP Notice: in file /adm/index.php on line 348: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'acp_board::mood_type_select' was given
[phpBB Debug] PHP Notice: in file /adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3184)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 155: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3184)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 156: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3184)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 157: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3184)
EDIT:
Edit: Also check the edits for includes/acp/acp_board.php mainly the second edit because that is where it gets the items for the drop down.
You were right. I inserted the edit before a bracket instead of after. Working OK now except I get the red X instead of images. Will have a look round.

EDIT 2: All fixed :) Hadn't uploaded image folder! :oops:
Last edited by barryoneoff on Thu Apr 23, 2009 5:58 am, edited 1 time in total.
Image
Click above to support St. Josephs Hospice.
Barryoneoff's London. ... City of London walks.
Xanta Media
Registered User
Posts: 213
Joined: Sat Dec 27, 2008 4:33 pm

Re: phpBB Mood Swings

Post by Xanta Media »

barryoneoff wrote:I've only just noticed that I have this code appearing at the top of the ACP:

Code: Select all

[phpBB Debug] PHP Notice: in file /adm/index.php on line 348: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'acp_board::mood_type_select' was given
[phpBB Debug] PHP Notice: in file /adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3184)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 155: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3184)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 156: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3184)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 157: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3184)
Double check the edits you made in includes/acp/acp_board.php

Also make sure there is no space after the php closing tag at the end of the file it looks like this: ?>

If you like you can send me a copy of it in a pm and i'll take a look, I just finished a night shift at work so i'll be up for the next 20 mins or so.

Edit: I just noticed your Edit! Glad you got it working. I just went to your forum and I can see the images fine in Firefox.
primetime33
Registered User
Posts: 66
Joined: Sat Nov 15, 2008 6:15 am

Re: phpBB Mood Swings

Post by primetime33 »

I have installed this MOD in 3 themes, but in one of them, submerged, I get this showing up in the profile view..

');" onmouseout="return nd();" href="./memberlist.php?mode=viewprofile&u=56">

Can anyone figure this out?

Thank you,
Prime
Xanta Media
Registered User
Posts: 213
Joined: Sat Dec 27, 2008 4:33 pm

Re: phpBB Mood Swings

Post by Xanta Media »

primetime33 wrote:I have installed this MOD in 3 themes, but in one of them, submerged, I get this showing up in the profile view..

');" onmouseout="return nd();" href="./memberlist.php?mode=viewprofile&u=56">

Can anyone figure this out?

Thank you,
Prime
For submerged the change for memberlist_view.html is:

Find:

Code: Select all

<tr>
												<td class="gensmall" align="right" nowrap="nowrap"><b>{L_INTERESTS}: </b></td>
												<td class="gensmall">{INTERESTS}</td>
											</tr>
After, Add:

Code: Select all

											<!-- IF USER_MOOD -->
											<tr>
												<td class="gensmall" align="right" nowrap="nowrap"><b>{L_MOOD}: </b></td>
												<td class="gensmall">{USER_MOOD}</td>
											</tr>
											<!-- ENDIF -->
User avatar
barryoneoff
Registered User
Posts: 248
Joined: Sat Mar 24, 2007 10:14 pm
Location: East London, England
Contact:

Re: phpBB Mood Swings

Post by barryoneoff »

The mod is working perfectly now, but for anyone else who has the same trouble I did, check this out:
I use PHP Designer (the free version) to edit the files and the search facility was the thing that caused my problems.
When you select the code to search for, and enter it into the search box in PHP Designer it only highlights one line of text. So if you have copied a piece of code with a bracket on another line, it ignores the bracket and you paste the 'add after' code inside the brackets rather than outside.
Sounds complicated, but it's not really! :roll:
Last edited by barryoneoff on Sun Apr 26, 2009 7:18 am, edited 1 time in total.
Image
Click above to support St. Josephs Hospice.
Barryoneoff's London. ... City of London walks.
Matthew1992
Registered User
Posts: 43
Joined: Tue Jan 13, 2009 12:14 am

Re: phpBB Mood Swings

Post by Matthew1992 »

I've added this MOD successfully. Thanks for the MOD :)
User avatar
whoisit
Registered User
Posts: 283
Joined: Sat Feb 02, 2008 10:12 am

Re: phpBB Mood Swings

Post by whoisit »

Hi

Excellent and well detailed Mod. ;)

Anyone having trouble then try Notepad ++ for all your editing, it's free.

Graham
User avatar
whoisit
Registered User
Posts: 283
Joined: Sat Feb 02, 2008 10:12 am

Re: phpBB Mood Swings

Post by whoisit »

Hi
Ok sorted it! forgot to purge cache and refresh templates! :lol:

Thanks
Graham
Mr. XaaN
Registered User
Posts: 1
Joined: Fri Apr 24, 2009 4:46 pm

Re: phpBB Mood Swings

Post by Mr. XaaN »

Greetings! :)
I installed this mod on localhost and it's works perfectly.
But yesterday, I installed another mod (XFire Mod) to localhost and I received this error:

Code: Select all

SQL ERROR [ mysqli ]

Unknown column 'user_xfire' in 'field list' [1054]

SQL

UPDATE phpbb_users SET user_icq = '', user_aim = '', user_msnm = '', user_xfire = '', user_xfire_style = NULL, user_yim = '', user_jabber = '', user_website = '', user_from = '', user_occ = '', user_interests = '', user_notify_type = 2, user_mood = '1', user_birthday = ' 0- 0- 0' WHERE user_id = 2

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/ucp/ucp_profile.php
LINE: 419
CALL: dbal_mysqli->sql_query()

FILE: includes/functions_module.php
LINE: 507
CALL: ucp_profile->main()

FILE: ucp.php
LINE: 321
CALL: p_master->load_active()
Can anybody help me about this error:?:
Xanta Media
Registered User
Posts: 213
Joined: Sat Dec 27, 2008 4:33 pm

Re: phpBB Mood Swings

Post by Xanta Media »

Mr. XaaN wrote:Greetings! :)
I installed this mod on localhost and it's works perfectly.
But yesterday, I installed another mod (XFire Mod) to localhost and I received this error:

Code: Select all

SQL ERROR [ mysqli ]

Unknown column 'user_xfire' in 'field list' [1054]

SQL

UPDATE phpbb_users SET user_icq = '', user_aim = '', user_msnm = '', user_xfire = '', user_xfire_style = NULL, user_yim = '', user_jabber = '', user_website = '', user_from = '', user_occ = '', user_interests = '', user_notify_type = 2, user_mood = '1', user_birthday = ' 0- 0- 0' WHERE user_id = 2

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/ucp/ucp_profile.php
LINE: 419
CALL: dbal_mysqli->sql_query()

FILE: includes/functions_module.php
LINE: 507
CALL: ucp_profile->main()

FILE: ucp.php
LINE: 321
CALL: p_master->load_active()
Can anybody help me about this error:?:
The unknown column is to do with the xfire mod. you need to ask in the release topic for that mod.
Greylock3491
Registered User
Posts: 34
Joined: Wed Jan 09, 2008 1:11 am

Re: phpBB Mood Swings

Post by Greylock3491 »

Mr. XaaN wrote:Greetings! :) Can anybody help me about this error:?:
Mr Xaan - I had same issue and replied in other mod's topic here
Channy
Registered User
Posts: 20
Joined: Fri May 30, 2008 7:21 pm

Re: phpBB Mood Swings

Post by Channy »

Hi there!
I've installed this mod and had the same "bracket" issue as the gentleman above...good call on that, it was the issue I was looking for! However, I still can't see the moods! I'm not getting error messages, I can see the moods option in the UCP, and the ACP, but not on people's profiles! Any idea what I might need to look for, to correct this? I went back over the codes twice and I'm stumped...I was thinking maybe I had forgotten to upload one of the files but I don't think so after rechecking. Any help would be much appreciated! (PS--I did clear all cache and temp files, several times, in hopes that it would be the culprit!)
Xanta Media
Registered User
Posts: 213
Joined: Sat Dec 27, 2008 4:33 pm

Re: phpBB Mood Swings

Post by Xanta Media »

Channy wrote:Hi there!
I've installed this mod and had the same "bracket" issue as the gentleman above...good call on that, it was the issue I was looking for! However, I still can't see the moods! I'm not getting error messages, I can see the moods option in the UCP, and the ACP, but not on people's profiles! Any idea what I might need to look for, to correct this? I went back over the codes twice and I'm stumped...I was thinking maybe I had forgotten to upload one of the files but I don't think so after rechecking. Any help would be much appreciated! (PS--I did clear all cache and temp files, several times, in hopes that it would be the culprit!)
Are you using a subsilver based style? is so read this topic: http://www.phpbb.com/community/viewtopi ... 5#p9353115
Channy
Registered User
Posts: 20
Joined: Fri May 30, 2008 7:21 pm

Re: phpBB Mood Swings

Post by Channy »

Xanta Media wrote:
Channy wrote:Hi there!
I've installed this mod and had the same "bracket" issue as the gentleman above...good call on that, it was the issue I was looking for! However, I still can't see the moods! I'm not getting error messages, I can see the moods option in the UCP, and the ACP, but not on people's profiles! Any idea what I might need to look for, to correct this? I went back over the codes twice and I'm stumped...I was thinking maybe I had forgotten to upload one of the files but I don't think so after rechecking. Any help would be much appreciated! (PS--I did clear all cache and temp files, several times, in hopes that it would be the culprit!)
Are you using a subsilver based style? is so read this topic: http://www.phpbb.com/community/viewtopi ... 5#p9353115
No, I am using proglass red, the bit of code containing that stuff in my viewtopic_body looks like this:

Code: Select all

<!-- IF postrow.POSTER_POSTS != '' --><dd><strong>{L_POSTS}:</strong> {postrow.POSTER_POSTS}</dd><!-- ENDIF -->
		<!-- IF postrow.POSTER_MOOD --><dd><strong>{L_MOOD}:</strong> {postrow.POSTER_MOOD}</dd><!-- ENDIF -->
		<!-- IF postrow.POSTER_JOINED --><dd><strong>{L_JOINED}:</strong> {postrow.POSTER_JOINED}</dd><!-- ENDIF -->
		<!-- IF postrow.POSTER_FROM --><dd><strong>{L_LOCATION}:</strong> {postrow.POSTER_FROM}</dd><!-- ENDIF -->
I keep going over to check for mistakes but I'm not finding anything!
Locked

Return to “[3.0.x] MOD Database Releases”