phpBB Mood Swings

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
Xanta Media
Registered User
Posts: 213
Joined: Sat Dec 27, 2008 4:33 pm

Re: phpBB Mood Swings

Post by Xanta Media » Thu May 07, 2009 11:04 pm

Stretcher25 wrote:hing is there for it to work but the image is displaying an red X. When I look at the url for the image it is http://www.mywebsite/happy.gif when it should be http://www.mywebsite/images/moods/happy.gif for some reason the images/moods is not getting appended to the url. Any suggestions?

Thanks,

My website is http://www.powwowpalace.com for you to please take a look.
Ok try 2 things:

open styles/prosilver/template/ucp_profile_profile_info.html

Find:

Code: Select all

<script type="text/javascript">
	function update_image(newimage)
	{
		document.getElementById('image').src = (newimage) ? "{MOOD_PATH}/" + encodeURI(newimage) : "./images/spacer.gif";
	}
</script>
Replace, with:

Code: Select all

<script type="text/javascript">
// <![CDATA[
	function update_image(newimage)
	{
		document.getElementById('image').src = (newimage) ? "{MOOD_PATH}/" + encodeURI(newimage) : "./images/spacer.gif";
	}
// ]]>
</script>
If that doesn't work then hardcode the image path by replacing

Code: Select all

"{MOOD_PATH}/"
with

Code: Select all

"./images/moods/"

Stretcher25
Registered User
Posts: 21
Joined: Thu Apr 30, 2009 11:55 am

Re: phpBB Mood Swings

Post by Stretcher25 » Fri May 08, 2009 11:00 am

I got it to work, I had another JavaScript on that page that was causing conflict. Thank you for your help. Excellent add-on!

Xanta Media
Registered User
Posts: 213
Joined: Sat Dec 27, 2008 4:33 pm

Re: phpBB Mood Swings

Post by Xanta Media » Fri May 08, 2009 1:00 pm

Stretcher25 wrote:I got it to work, I had another JavaScript on that page that was causing conflict. Thank you for your help. Excellent add-on!
Glad you got it working. Also you have another error on that page, when I was testing and submitted the page it gave an error because I hadn't entered a twitter password.

Stretcher25
Registered User
Posts: 21
Joined: Thu Apr 30, 2009 11:55 am

Re: phpBB Mood Swings

Post by Stretcher25 » Fri May 08, 2009 6:05 pm

I found another problem, the mood is not displaying in the view topic after adding the add-on. When I put back the original file functions_mood.php it shows up fine. Please check into this, thanks.

cbourne
Registered User
Posts: 109
Joined: Sun May 25, 2008 6:49 am

Installed but can't see it.

Post by cbourne » Fri May 08, 2009 6:21 pm

Ok installed MOD successfully with AutoMOD but where is it in my ACP panel. I have purged the cache and refreshed the template?

Any help gratefully received.

cbourne
Registered User
Posts: 109
Joined: Sun May 25, 2008 6:49 am

Re: phpBB Mood Swings

Post by cbourne » Fri May 08, 2009 6:59 pm

Have enabled the MOD in ACP but can't seem to find - Admin Panel add, edit and delete Moods - shown in the second screenshot. Can someone point this out. Must be having a bad day.

Xanta Media
Registered User
Posts: 213
Joined: Sat Dec 27, 2008 4:33 pm

Re: phpBB Mood Swings

Post by Xanta Media » Fri May 08, 2009 7:01 pm

Stretcher25 wrote:I found another problem, the mood is not displaying in the view topic after adding the add-on. When I put back the original file functions_mood.php it shows up fine. Please check into this, thanks.
What version of the mod are you using? The addon will only work if you have updated to v1.0.1
cbourne wrote:Ok installed MOD successfully with AutoMOD but where is it in my ACP panel. I have purged the cache and refreshed the template?

Any help gratefully received.
Did you run the installer? If not you need to run it.

You will find the settings on the front page of the ACP. Click Board Settings on the left and scroll to the bottom.
For Mood Management click the "Users and Groups" Tab and you will see the link on the left.

cbourne
Registered User
Posts: 109
Joined: Sun May 25, 2008 6:49 am

Re: phpBB Mood Swings

Post by cbourne » Fri May 08, 2009 7:16 pm

What version of the mod are you using? The addon will only work if you have updated to v1.0.1

v1.0.1
Did you run the installer? If not you need to run it.

I installed it through AutoMOD where do the 'installer'

You will find the settings on the front page of the ACP. Click Board Settings on the left and scroll to the bottom.

Got that thanks

For Mood Management click the "Users and Groups" Tab and you will see the link on the left.

Nothing there called Mood Management

Thanks for the help i'm nearly there I think.

cbourne
Registered User
Posts: 109
Joined: Sun May 25, 2008 6:49 am

Re: phpBB Mood Swings

Post by cbourne » Fri May 08, 2009 7:29 pm

Not sure if you meant this when you said have you run the installer but I looked at your notes and pointed the url at /install.php and got this message;

phpBB Mood Swings
Here you can install, update or uninstall phpBB Mood Swings.

Mod Version: 1.0.1
Currently Installed: 1.0.1

The only selection I could access was uninstall.

What am I doing wrong.

-----------------------------------------------------------------------------------------------------------------
I've uninstalled with AutoMOD. May revisit again in the future. Nice MOD though.
Last edited by cbourne on Fri May 08, 2009 7:49 pm, edited 1 time in total.

Stretcher25
Registered User
Posts: 21
Joined: Thu Apr 30, 2009 11:55 am

Re: phpBB Mood Swings

Post by Stretcher25 » Fri May 08, 2009 7:31 pm

I'm using version v1.0.1, everything works find except that it does not display in the view topic screen. If I put the original functions_mood.php file back it then displays. That is why it has to be something in that file. Thanks

JasonWade
Registered User
Posts: 287
Joined: Mon Jun 05, 2006 9:22 am

Re: phpBB Mood Swings

Post by JasonWade » Fri May 08, 2009 8:35 pm

I have anothe rmood mod installed, but I don't really like that one, so I wanted this one, but now when I try to install it I get:

Adding a new column named user_mood to table phpbb_users

ERROR: The column user_mood already exists on table phpbb_users.

ANything I can do about that?

*edit: deleted teh table, seems succesfull now I'll check if they actually work

JasonWade
Registered User
Posts: 287
Joined: Mon Jun 05, 2006 9:22 am

Re: phpBB Mood Swings

Post by JasonWade » Fri May 08, 2009 8:47 pm

hmm when I go to my profile I now get:

*fixed*?

**Edit: guess more went wrong, when going to a random user's profile I get:

Code: Select all

Fatal error: Cannot redeclare get_user_mood() (previously declared in /home/.tiara/backstreetforums/backstreetforums.com/includes/functions_mood.php:25) in /home/.tiara/backstreetforums/backstreetforums.com/includes/functions_mood.php on line 54
line 54 is:

Code: Select all

}

right after:
		$mood = '<img src="' . $phpbb_root_path . 'images/moods/' . $row['mood_image'] . '" alt="' . $row['mood_name'] . '" />' . $row['mood_name'] . '';
	}

	return $mood;
**edit: and when viewing the memberlist I get:

Code: Select all

Fatal error: Cannot redeclare get_user_mood() (previously declared in /home/.tiara/backstreetforums/backstreetforums.com/includes/functions_mood.php:25) in /home/.tiara/backstreetforums/backstreetforums.com/includes/functions_mood.php on line 54
aswell

**(last?) edit:
I also saw that in the admin panel I only see the images, but not the option to turn it on or off or whatever

**edit (again yep ;)): I managed to add a mood to my own profile and when going to a topic it does show fine there, so that's the one part that does seem to have done ok

Xanta Media
Registered User
Posts: 213
Joined: Sat Dec 27, 2008 4:33 pm

Re: phpBB Mood Swings

Post by Xanta Media » Sat May 09, 2009 4:44 am

Stretcher25 wrote:I'm using version v1.0.1, everything works find except that it does not display in the view topic screen. If I put the original functions_mood.php file back it then displays. That is why it has to be something in that file. Thanks
But how can it be an error in that file when it works fine on the demo and when I install it on a new board?

The only thing I can suggest is that you have a conflict with another mod that you have installed.

Can you send me a PM a list of every Mod that you have installed and I will look for conflicts.

Xanta Media
Registered User
Posts: 213
Joined: Sat Dec 27, 2008 4:33 pm

Re: phpBB Mood Swings

Post by Xanta Media » Sat May 09, 2009 4:46 am

JasonWade wrote:hmm when I go to my profile I now get:

*fixed*?

**Edit: guess more went wrong, when going to a random user's profile I get:

Code: Select all

Fatal error: Cannot redeclare get_user_mood() (previously declared in /home/.tiara/backstreetforums/backstreetforums.com/includes/functions_mood.php:25) in /home/.tiara/backstreetforums/backstreetforums.com/includes/functions_mood.php on line 54
line 54 is:

Code: Select all

}

right after:
		$mood = '<img src="' . $phpbb_root_path . 'images/moods/' . $row['mood_image'] . '" alt="' . $row['mood_name'] . '" />' . $row['mood_name'] . '';
	}

	return $mood;
**edit: and when viewing the memberlist I get:

Code: Select all

Fatal error: Cannot redeclare get_user_mood() (previously declared in /home/.tiara/backstreetforums/backstreetforums.com/includes/functions_mood.php:25) in /home/.tiara/backstreetforums/backstreetforums.com/includes/functions_mood.php on line 54
aswell

**(last?) edit:
I also saw that in the admin panel I only see the images, but not the option to turn it on or off or whatever

**edit (again yep ;)): I managed to add a mood to my own profile and when going to a topic it does show fine there, so that's the one part that does seem to have done ok
Did you complerely remove the old Mod before installing this one?

User avatar
Aurora Primavera
Registered User
Posts: 7
Joined: Sat May 09, 2009 4:45 am

Re: phpBB Mood Swings

Post by Aurora Primavera » Sat May 09, 2009 5:03 am

Hi there! First off - Really awesome mod! But seeing as it's been forever since I've done anything like this, I'm very rusty. :p

I did okay with everything up until it was time to install. I went through the whole process and then go this message:

Code: Select all

phpBB Mood Swings
PHP Version: 5.2.6
DBMS: MySQL 5.0.67-userstats-log
phpBB3 Version: 3.0.4

Test images inserted.
SQL ERROR Table 'focsforums.MOODS_DATA_TABLE' doesn't exist
What could I have missed?

Locked

Return to “[3.0.x] MOD Database Releases”