Profile friend list

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
User avatar
phreakwars
Registered User
Posts: 237
Joined: Thu Feb 22, 2007 4:57 am
Location: The Suckage
Contact:

Re: Profile friend list

Post by phreakwars » Sun Oct 25, 2009 11:49 pm

I don't know if this could be the reason it works on my site or not, but I use memberlist_avatar.css for the actual "SHOW MEMBER AVATARS ON MEMBERLIST" mod. So I'm thinking my memberlist_avatar.css file might differ a bit.

For reference, my memberlist_avatar.css reads.

Code: Select all

/**
 * @package styles
 * @version $Id: memberlist_avatar.css 45 2007-09-10 04:49:51Z Highway of Life $
 * @copyright (c) 2007 David Lewis (Highway of Life) - http://startrekguide.com
 * @license http://opensource.org/licenses/gpl-license.php GNU Public License
 ---------------------------------------- */
.thumbnail {
	z-index: 0;
	position:relative;
}

a.thumbnail:hover {
	background-color: transparent;
	z-index: 50;
}

.thumbnail span {
	position: absolute;
	background: #e0e5e9 url("./images/cellpic1.gif") repeat-x;
	padding: 4px;
	border: 1px solid #a9b8c2;
	left: 0px;
	display: none;
	color: #FFF;
	text-decoration: none;
}

.thumbnail span img {
	border-width: 0;
	padding: 2px;
}

a.thumbnail:hover span {
	position:absolute;
	display:block;
	top: 20px;
	left: 7px;
}
I don't remember right off hand if this MOD uses the same thing, but it would be worth looking into. I guess I've never ran across an issue like "WHY DOES IT WORK ON MY FORUM, BUT NOT FOR OTHERS", because I usually modify MODS that I have installed to suit my needs and forget which ones I modded.

.
.
Image
MODS by me: Default Topic Icon

thesecret
Registered User
Posts: 270
Joined: Mon Sep 29, 2008 12:13 pm

Re: Profile friend list

Post by thesecret » Mon Oct 26, 2009 2:34 am

thesecret wrote:
platinum_2007 wrote:I have yet to figure out why that is happening as i cannot replicate it but removing

Code: Select all

|| $auth->acl_get('u_viewonline')
from that line will fix it.
I'm facing this error as well,,
after removing this line it worked

but is this the exact right solution??
did you know what is the cause?
help please

platinum_2007
Registered User
Posts: 1101
Joined: Tue Jul 22, 2008 2:47 am
Location: Nova Scotia, Canada

Re: Profile friend list

Post by platinum_2007 » Mon Oct 26, 2009 12:13 pm

thesecret wrote:
thesecret wrote:
platinum_2007 wrote:I have yet to figure out why that is happening as i cannot replicate it but removing

Code: Select all

|| $auth->acl_get('u_viewonline')
from that line will fix it.
I'm facing this error as well,,
after removing this line it worked

but is this the exact right solution??
did you know what is the cause?
help please
That solution is fine.

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: Profile friend list

Post by keith10456 » Wed Oct 28, 2009 3:39 am

platinum_2007 wrote:
thesecret wrote:
thesecret wrote:
platinum_2007 wrote:I have yet to figure out why that is happening as i cannot replicate it but removing

Code: Select all

|| $auth->acl_get('u_viewonline')
from that line will fix it.
I'm facing this error as well,,
after removing this line it worked

but is this the exact right solution??
did you know what is the cause?
help please
That solution is fine.
Which file do we remove that code from (I'm getting this error as well... every now and then)?

thesecret
Registered User
Posts: 270
Joined: Mon Sep 29, 2008 12:13 pm

Re: Profile friend list

Post by thesecret » Wed Oct 28, 2009 3:47 am

I'm facing a new bug with the Soft delete mod
I think the cause of this bug is removing

Code: Select all

|| $auth->acl_get('u_viewonline')
so are you sure this is the best solution :)

User avatar
phreakwars
Registered User
Posts: 237
Joined: Thu Feb 22, 2007 4:57 am
Location: The Suckage
Contact:

Re: Profile friend list

Post by phreakwars » Wed Oct 28, 2009 4:51 am

thesecret wrote:I'm facing a new bug with the Soft delete mod
I think the cause of this bug is removing

Code: Select all

|| $auth->acl_get('u_viewonline')
so are you sure this is the best solution :)
Actually, no that WASN'T the best solution. You had to remove a little more then that. I remember because I had that issue at one point as well. I don't recall what the exact line removal was, I'd have to look at the original and compare.
.
.
Image
MODS by me: Default Topic Icon

User avatar
phreakwars
Registered User
Posts: 237
Joined: Thu Feb 22, 2007 4:57 am
Location: The Suckage
Contact:

Re: Profile friend list

Post by phreakwars » Wed Oct 28, 2009 4:57 am

phreakwars wrote:
thesecret wrote:I'm facing a new bug with the Soft delete mod
I think the cause of this bug is removing

Code: Select all

|| $auth->acl_get('u_viewonline')
so are you sure this is the best solution :)
Actually, no that WASN'T the best solution. You had to remove a little more then that. I remember because I had that issue at one point as well. I don't recall what the exact line removal was, I'd have to look at the original and compare.
.
.
OK, I looked, you need to remove

Code: Select all

$online = (time() - $update_time < $member['session_time'] && ((isset($member['session_viewonline']) && $member['session_viewonline']) || $auth->acl_get('u_viewonline'))) ? true : false;
Image
MODS by me: Default Topic Icon

platinum_2007
Registered User
Posts: 1101
Joined: Tue Jul 22, 2008 2:47 am
Location: Nova Scotia, Canada

Re: Profile friend list

Post by platinum_2007 » Wed Oct 28, 2009 11:17 am

The online feature still works after removing that?

if you remove that whats going to happen with

Code: Select all

        return $online;
??


so that will break the MOD.

User avatar
phreakwars
Registered User
Posts: 237
Joined: Thu Feb 22, 2007 4:57 am
Location: The Suckage
Contact:

Re: Profile friend list

Post by phreakwars » Thu Oct 29, 2009 3:11 am

Odd but it's still working on my site. I just checked again, what I have is:

Code: Select all

// function to check if the friend is online or not.
function is_user_online($id)
{
		global $db, $config;
		
        $session_sql = 'SELECT MAX(session_time) AS session_time, MIN(session_viewonline) AS session_viewonline
            FROM ' . SESSIONS_TABLE . '
            WHERE session_user_id = '.intval($id);
        $session_result = $db->sql_query($session_sql);
        $session_row = $db->sql_fetchrow($session_result);

        $member['session_time'] = (isset($session_row['session_time'])) ? $session_row['session_time'] : 0;
        $member['session_viewonline'] = (isset($session_row['session_viewonline'])) ? $session_row['session_viewonline'] :    0;

        $update_time = $config['load_online_time'] * 60;
        $db->sql_freeresult($session_sql);

        return $online;

}
Odd, but it didn't give me an error.

Wow, that's like so wierd... WHY DOES THIS MOD WORK PERFECT FOR ME???? :shock: :shock: :shock: :shock:

http://www.newsucks500.com/memberlist.p ... rofile&u=8

But on a serious note:
platinum_2007 wrote:The online feature still works after removing that?

if you remove that whats going to happen with

Code: Select all

        return $online;
??


so that will break the MOD.
Perhaps that's the key to the problem we are all having, the way it is interpreting who is online.

My board doesn't display when the friend is online, not really a function I need anyway, but still an issue that needs addressed. I'm not the only one who experienced that problem, so I say if that bit of code is screwing it up, take it out or fix it.

I'm no REAL coder, I just like to play with the code and see what comes up for me on localhost. If it's handy, I'll share it. So tons of respect for the MOD's you have done Ian. I think this can be documented as a certified glitch with respects for your talent. I can work around it with some slop work, so I won't say I know what is or isn't right for a solution to the prob.
.
.
Image
MODS by me: Default Topic Icon

Br33zer
Registered User
Posts: 76
Joined: Fri Sep 19, 2008 7:07 pm
Contact:

Re: Profile friend list

Post by Br33zer » Mon Nov 09, 2009 4:39 pm

I have installed this and working fine but for one problem. When a member including the Admin clicks on the friend's profile or link, only blank page shows.

PhpBB 3.0.5 and Prosilver Style

URL: http://desiforum.byethost5.com/forum/index.php

Please help.
Visit: http://www.gossipall.com/ For the latest news, images and other stuff of entertainment.
Visit: http://www.easyrecipesmenu.com/ For Easy Recipes.

c1nco
Registered User
Posts: 11
Joined: Tue Nov 25, 2008 2:45 am

Re: Profile friend list

Post by c1nco » Fri Nov 13, 2009 3:51 pm

Br33zer wrote:I have installed this and working fine but for one problem. When a member including the Admin clicks on the friend's profile or link, only blank page shows.

PhpBB 3.0.5 and Prosilver Style

URL: http://desiforum.byethost5.com/forum/index.php

Please help.
I am having a similar issue w/ 3.0.5 -- Only some users profiles lead the blank page, the rest seem to work great.

Any Ideas?

code daddy
Registered User
Posts: 35
Joined: Sun Jul 26, 2009 10:11 pm

Re: Profile friend list

Post by code daddy » Sat Nov 14, 2009 1:39 am

Just installed this mod, but the avatars on the friendlist are just appeearing

Going vertically down- Not horizontal, causing a lot of scrolling needed.

It is listing al the friends (ith 2 avatars, the thumbnail and the avatar) verticcally down the page.

Please help

Artack
Registered User
Posts: 312
Joined: Thu Feb 07, 2008 11:26 pm

Re: Profile friend list

Post by Artack » Mon Nov 30, 2009 3:30 pm

Check it
open includes/function.php
find

Code: Select all

// function to check if the friend is online or not.
function is_user_online($id)
{
		global $db, $config;
		
        $session_sql = 'SELECT MAX(session_time) AS session_time, MIN(session_viewonline) AS session_viewonline
            FROM ' . SESSIONS_TABLE . '
            WHERE session_user_id = '.intval($id);
        $session_result = $db->sql_query($session_sql);
        $session_row = $db->sql_fetchrow($session_result);

        $member['session_time'] = (isset($session_row['session_time'])) ? $session_row['session_time'] : 0;
        $member['session_viewonline'] = (isset($session_row['session_viewonline'])) ? $session_row['session_viewonline'] :    0;

        $update_time = $config['load_online_time'] * 60;
        $online = (time() - $update_time < $member['session_time'] && ((isset($member['session_viewonline']) && $member['session_viewonline']) || $auth->acl_get('u_viewonline'))) ? true : false;
        $db->sql_freeresult($session_sql);

        return $online;

}
find

Code: Select all

global $db, $config;
replace

Code: Select all

global $db, $config, $auth;

marcotics
Registered User
Posts: 58
Joined: Fri Sep 02, 2005 1:33 pm

Re: Profile friend list

Post by marcotics » Tue Dec 29, 2009 11:32 pm

vwrmic wrote:Just an issue I found.

When changing options in ACP for the mod. This shows as the logged action:

Code: Select all

{LOG CONFIG PROFILEFRIENDS}
Nothing major, just thought I would let you know. :)
I had the same. For the people with the same problem, a small fix.

Open:
/language/en/acp/

Find:

Code: Select all

'LOG_CONFIG_VISUAL'			=> '<strong>Altered antibot settings</strong>',
AFTER ADD:

Code: Select all

'LOG_CONFIG_PROFILEFRIENDS'	=> '<strong>Altered Profile Friends mod settings</strong>',
Did the trick for me

momofone
Registered User
Posts: 47
Joined: Tue Jun 23, 2009 10:27 pm

Re: Profile friend list

Post by momofone » Thu Jan 07, 2010 12:31 am

^^^ Thank you. :)

Locked

Return to “[3.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 15 guests