Page 5 of 5

Re: PM Search

Posted: Fri Feb 05, 2010 10:10 am
by lovelysummer
Hi,

The downloaded folder 1.0.3 does not have update instruction for 1.0.2 to 1.0.3 in contrib folder. What should do to update from 1.0.2 ?

Tks. ;)

Re: PM Search

Posted: Fri Feb 05, 2010 11:16 am
by tumba25
Just replace the included files. If you use a Subsilver2 based style you don't have to do anything. This is just a update to fix a IE-bug. If you use a Prosilver based style you just replace the files in /styles/your_style/template/.

Re: PM Search

Posted: Fri Feb 05, 2010 7:39 pm
by dhvmoon
I had to make the following changes for it to not disable the export and mark buttons (only in prosilver):

1. /styles/your_style/template/ucp_pm_message_header.html

Remove the first occurance of the line:

Code: Select all

<form id="viewfolder" method="post" action="{S_PM_ACTION}">
Then before:

Code: Select all

<!-- IF TOTAL_MESSAGES or S_VIEW_MESSAGE -->
Add the following:

Code: Select all

	<!-- IF S_DISPLAY_SEARCHBOX -->
		<!-- INCLUDE ucp_pm_search.html -->
	<!-- ENDIF -->
<form id="viewfolder" method="post" action="{S_PM_ACTION}">
2. To fix the IE8 issue, I followed the instructions here and they worked great:
http://www.phpbb.com/community/viewtopi ... #p10438475

(adds a meta tag to force "IE7 Compatibility mode")

Re: PM Search

Posted: Sat Feb 06, 2010 1:39 pm
by asinshesq
I am running three boards and they each have identical files that include pm search 1.0.3. I separately ran this mod's install script for each of them and that properly created pm search permissions for each. (BTW, I love the part in the install file that reads "// Setup $auth_admin class so we can add tabulated survey permission options" :mrgreen: )

Anyway, pm search works fine on the first board but the pm search option does not show up on the other two boards. I have already cleared cache and template cache (and browser cache while I was at it) multiple times, and I have pm search permissions set to on for everyone.

I did a permissions mask test for my individual account (I'm an admin and founder) as well as for a regular account and I confirmed that pm search permissions really are on for everyone.

The problem goes away when I change:

Code: Select all

	<!-- IF S_DISPLAY_SEARCHBOX -->
		<!-- INCLUDE ucp_pm_search.html -->
	<!-- ENDIF -->
to

Code: Select all

	<!-- INCLUDE ucp_pm_search.html -->
so that makes it appear like it's a permissions problem or a problem with pm_search.php not being included when it should be (and as I said the first board with identical files is working fine so it sounds like it must be a permissions problem), but given that running individual user permission masks showed the permissions are on I'm stumped.

I'm sure I can trace this with a bit of time, but I figured I'd ask here in case you have an idea off the top of you head that would save me the trouble.

Re: PM Search

Posted: Sat Feb 06, 2010 1:52 pm
by tumba25
Go to ACP > System > User Control Panel > Private messages and make sure PM Search is installed and enabled.
And then in ACP > General > Search settings make sure "Enable search facilities" is set to yes.

Re: PM Search

Posted: Sat Feb 06, 2010 2:03 pm
by asinshesq
Are you trying to say I should actually look at the DIY :roll: :oops:

Thanks. I set up the first board a while ago and when I cloned the files for the second and third board I forgot it adds a ucp module. Would have traced it eventually but you just saved me a bunch of time that my own carelessness would have cost me. Thanks.

Maybe next version will use umil to deal with stupid people like me?

Re: PM Search

Posted: Thu Feb 25, 2010 10:21 am
by alterastro
Installed this and seems to work fine, except... I cannot 'Mark all' or do anything with the results, such as move or delete. If I manually select them and then select delete from the drop down box, nothing happens when I click go.

Running 3.0.6

Thanks

Nick

Re: PM Search

Posted: Thu Feb 25, 2010 10:48 am
by tumba25
Just tested at my test site, works fine. Better not tell my GF that I deleted her PM's. :)

Recheck your edits.

Re: PM Search

Posted: Mon Mar 01, 2010 6:40 pm
by tumba25
Tested and works with phpBB 3.0.7.