Contact Board Admin

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
User avatar
jeffm2008
Registered User
Posts: 84
Joined: Tue Sep 29, 2009 12:31 pm

Re: Contact Board Admin

Post by jeffm2008 »

RMcGirr83 wrote:Purge the cache in the ACP.

I've done all that...cleared cache in ACP - theme, template, imageset. Even cleared the cache folder.

I'm going to install it manually and see if I get different results. Thanks.

User avatar
jeffm2008
Registered User
Posts: 84
Joined: Tue Sep 29, 2009 12:31 pm

Re: Contact Board Admin

Post by jeffm2008 »

I've tried to install it manually, with the same exact errors. It tells me "You are not authorised to access this area." when I try to run contact.php, even though I sign in as Admim before I run it.

Hmm wierd. oh well, was worth a shot. Thanks anyway.

User avatar
Hippie459MN
Registered User
Posts: 945
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: Contact Board Admin

Post by Hippie459MN »

You need to be logged in under the founder account for it to install if I remember right. I believe it was RMcGirr83 that posted it but there was an edit you can make in the install file to not check if you are using a founder account or not. I think I seen it somewhere.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Contact Board Admin

Post by RMcGirr83 »

Hippie459MN wrote:You need to be logged in under the founder account for it to install if I remember right.
Correct
I believe it was RMcGirr83 that posted it but there was an edit you can make in the install file to not check if you are using a founder account or not. I think I seen it somewhere.
correct x 2

http://www.phpbb.com/community/viewtopi ... #p10494765
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
jeffm2008
Registered User
Posts: 84
Joined: Tue Sep 29, 2009 12:31 pm

Re: Contact Board Admin

Post by jeffm2008 »

RMcGirr83 wrote:
Hippie459MN wrote:You need to be logged in under the founder account for it to install if I remember right.
Correct
I believe it was RMcGirr83 that posted it but there was an edit you can make in the install file to not check if you are using a founder account or not. I think I seen it somewhere.
correct x 2

http://www.phpbb.com/community/viewtopi ... #p10494765
WORKED! you guys rule...thank you.

denlowforum
Registered User
Posts: 2
Joined: Tue Oct 27, 2009 7:25 pm

Re: Contact Board Admin

Post by denlowforum »

I'm new to the phpBB and have just installed it. I followed the instructions to add the "Contact Board Admin" mod.

At the end of the instructions, I see the following DIY instructions:

"Login to your forum as admin and browse to the contact.php file located in the root of your forum. This will update the database for you.
Now go to the ACP Module management, select the general category, then select "Board configuration" as a subcategory, scroll down and look at the dropdown box
and select the "Contact board administration" module. Add it and enable it.
Click on the general tab at the top and look if it's there. Then refresh both the styles template as well as imageset and theme.
Enjoy the mod!!"

First, how do I "browse to the contact.php"?
Second, I don't see "Module management" under the "general" tab in the ACP. It does have a "Board Configuration" area under the "general", but no drop down box inside it.

Please help! I'm using phpBB 3.0.5.

Thanks,
Henry

User avatar
jeffm2008
Registered User
Posts: 84
Joined: Tue Sep 29, 2009 12:31 pm

Re: Contact Board Admin

Post by jeffm2008 »

Guess I'm trying to use this mod for something that it's not really intended to do. Is there an easy way to have users post a reply in a topic using this mod...e.g. a user would enter a forum topic and when they went to reply, it would be a form to fill out and then that is the info that was posted?

Was hoping to use this as more of a posting form I guess, since there really aren't many if any posting forms...

any ideas? thanks for your help.

User avatar
Hippie459MN
Registered User
Posts: 945
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: Contact Board Admin

Post by Hippie459MN »

jeffm2008 wrote:Guess I'm trying to use this mod for something that it's not really intended to do. Is there an easy way to have users post a reply in a topic using this mod...e.g. a user would enter a forum topic and when they went to reply, it would be a form to fill out and then that is the info that was posted?

Was hoping to use this as more of a posting form I guess, since there really aren't many if any posting forms...

any ideas? thanks for your help.
Is this what your looking for?
http://www.phpbb.com/community/viewtopi ... 9&t=712785

User avatar
jeffm2008
Registered User
Posts: 84
Joined: Tue Sep 29, 2009 12:31 pm

Re: Contact Board Admin

Post by jeffm2008 »

Hippie459MN wrote: Is this what your looking for?
http://www.phpbb.com/community/viewtopi ... 9&t=712785

I've tried that and my board is nothing but mods being used for reasons unintended. lol. that would be a perfect mod...but I use the "clone post" mod on my board and the posting template overwrites the "cloned" info that is supposed to be in the message body in the new post, if that makes any sense. lol.

if I knew enough about this stuff to make sure that the "cloned" info and the template info could be there together in the new post, it would be perfect.

I really do appreciate the help though. thanks

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Contact Board Admin

Post by Oyabun1 »

denlowforum wrote: First, how do I "browse to the contact.php"?
Second, I don't see "Module management" under the "general" tab in the ACP. It does have a "Board Configuration" area under the "general", but no drop down box inside it.
Whilst logged into your forum as founder (if you are not a Board Founder see viewtopic.php?p=10494765#p10494765
for the change you will need to make), say your forum address is http://www.xyz.com/phpbb3/index.php, then use your web browser to navigate to http://www.xyz.com/phpbb3/contact.php and follow any instructions it gives you.

After having done this go back and check the ACP.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

denlowforum
Registered User
Posts: 2
Joined: Tue Oct 27, 2009 7:25 pm

Re: Contact Board Admin

Post by denlowforum »

Oyabun1 wrote:
denlowforum wrote: First, how do I "browse to the contact.php"?
Second, I don't see "Module management" under the "general" tab in the ACP. It does have a "Board Configuration" area under the "general", but no drop down box inside it.
Whilst logged into your forum as founder (if you are not a Board Founder see viewtopic.php?p=10494765#p10494765
for the change you will need to make), say your forum address is http://www.xyz.com/phpbb3/index.php, then use your web browser to navigate to http://www.xyz.com/phpbb3/contact.php and follow any instructions it gives you.

After having done this go back and check the ACP.
Thanks! Got it working!

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Contact Board Admin

Post by RMcGirr83 »

Getting there for the release of 3.0.6!! :D

A tease for all. :P
Noname.jpg
Noname.jpg (77.47 KiB) Viewed 406 times
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
Rotsblok
Registered User
Posts: 648
Joined: Fri Nov 11, 2005 12:47 pm
Location: Upper north of Holland
Name: Rikkert Westa
Contact:

Re: Contact Board Admin

Post by Rotsblok »

RMcGirr83 wrote:Getting there for the release of 3.0.6!! :D

A tease for all. :P
You are evil ;) cant wait for it :P
Nederlandse Support site
Several dutch translations for 3.1 extensions if you need one or there is an update of an extension feel free to notify me.

User avatar
nGAGE™
Registered User
Posts: 14
Joined: Sun Dec 16, 2007 4:29 pm
Location: Probably at a Computer
Contact:

Re: Contact Board Admin

Post by nGAGE™ »

I'm also getting this error:

Code: Select all

[phpBB Debug] PHP Notice: in file /adm/index.php on line 356: call_user_func_array() expects parameter 1 to be a valid callback, class 'acp_board' does not have a method 'contact_method_select'
[phpBB Debug] PHP Notice: in file /adm/index.php on line 356: call_user_func_array() expects parameter 1 to be a valid callback, class 'acp_board' does not have a method 'contact_bot_user_select'
[phpBB Debug] PHP Notice: in file /adm/index.php on line 356: call_user_func_array() expects parameter 1 to be a valid callback, class 'acp_board' does not have a method 'contact_post_select'
[phpBB Debug] PHP Notice: in file /adm/index.php on line 356: call_user_func_array() expects parameter 1 to be a valid callback, class 'acp_board' does not have a method 'contact_bot_forum_select'
[phpBB Debug] PHP Notice: in file /adm/index.php on line 155: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 157: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 158: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 159: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3493)
I've temporarily solved this by commenting out these options, resulting to this:

Code: Select all

//-- mod : Contact board administration ------------------------------------------------------------
//-- add
			case 'contact_admin':
				include($phpbb_root_path . 'includes/constants_contact.' . $phpEx);
				$user->add_lang('mods/contact');
				$display_vars = array(
					'title'	=> 'ACP_CONTACT_ADMIN_SETTINGS',
					'vars'	=> array(
						'legend1'					=> 'CONTACT_GENERAL_SETTINGS',
						'contact_enable'			=> array('lang' => 'CONTACT_ENABLE',			'validate' => 'bool',			'type' => 'radio:yes_no', 'explain' => true),
						'contact_confirm'			=> array('lang' => 'CONTACT_ACP_CONFIRM',		'validate' => 'bool',			'type' => 'radio:yes_no', 'explain' => true),
						'contact_confirm_guests'	=> array('lang' => 'CONTACT_CONFIRM_GUESTS',	'validate' => 'bool',			'type' => 'radio:yes_no', 'explain' => true),
						'contact_bbcodes_allowed'	=> array('lang' => 'CONTACT_BBCODES',			'validate' => 'bool',			'type' => 'radio:yes_no', 'explain' => true),
						'contact_smilies_allowed'	=> array('lang' => 'CONTACT_SMILIES',			'validate' => 'bool',			'type' => 'radio:yes_no', 'explain' => true),						
						'contact_max_attempts'		=> array('lang' => 'CONTACT_MAX_ATTEMPTS',		'validate' => 'int',			'type' => 'text:3:3', 'explain' => true),
						/*
						'contact_method'			=> array('lang' => 'CONTACT_METHOD',			'validate' => 'int',			'type' => 'custom', 'method' => 'contact_method_select', 'explain' => true),
						*/
						'contact_reasons'			=> array('lang' => 'CONTACT_REASONS',			'validate' => 'string',			'type' => 'textarea:5:40', 'explain' => true),
						'contact_founder_only'		=> array('lang' => 'CONTACT_FOUNDER',			'validate' => 'bool',			'type' => 'radio:yes_no', 'explain' => true),

						'legend2'					=> 'CONTACT_BOT_SETTINGS',
						/*
						'contact_bot_user'			=> array('lang' => 'CONTACT_BOT_USER',			'validate' => 'int',			'type' => 'custom', 'method' => 'contact_bot_user_select', 'explain' => true),
						'contact_bot_poster'		=> array('lang' => 'CONTACT_BOT_POSTER',		'validate' => 'int',			'type' => 'custom', 'method' => 'contact_post_select', 'explain' => true),
						'contact_bot_forum'			=> array('lang' => 'CONTACT_BOT_FORUM',			'validate' => 'int',			'type' => 'custom', 'method' => 'contact_bot_forum_select', 'explain' => true),
						*/
					),
				);
			break;
//-- fin mod : Contact board administration --------------------------------------------------------
This is found with the edits for: includes/acp/acp_board.php

I've then set 'Founder-Only' to 'yes', for now.

EDIT: Thought things were showing up, but it's not working correctly.
Image verification doesn't show and even if I disable it, I get: "The submitted form was invalid. Try submitting again."


Hope somebody can look into this.
I'm running 3.0.6RC2

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Contact Board Admin

Post by RMcGirr83 »

Image verification will not show up. This mod, as found in download from first topic, is for a 3.0.5 forum...not a 3.0.6 one.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

Locked

Return to “[3.0.x] MOD Database Releases”