Page 16 of 25

Re: Contact Board Admin

Posted: Tue Nov 24, 2009 8:46 pm
by John3
RMcGirr83 wrote:Sorry I just don't have the time to write something up for that. Maybe some kind soul will do it.
I understand. Thanks for the fast reply.

Re: Contact Board Admin

Posted: Wed Nov 25, 2009 1:28 am
by neonshares
Check the application form mod, JAMES. There is a tutorial on adding new fields to the application form. As application and contact forms are near to each other you can find that tutorial helpfull and if you have the coding knowledge you can figure it out yourself.

Re: Contact Board Admin

Posted: Wed Nov 25, 2009 8:34 pm
by RMcGirr83
To those that have downloaded the zip from google code. A few issues were found and fixed. Please redownload the zip, extract it and overwrite contact.php and includes/functions_contact.php on your forum.

Re: Contact Board Admin

Posted: Mon Nov 30, 2009 10:13 pm
by maarten-jan
Hi,
This looks like a great MOD. I've tried to install the mod but didn't have succes when doing the DIY instructions. I followed all the intsructions, made sure that I edited the acp_board files correctly but sadly I don't see the Contact Admin Board in the Board configuration.

I have read all the posts here and can't find anything wrong. Installingen of the contact.php was succesfull.

Can you please inform me wether I have made a mistake elswhere? I run my board on a edited prosilver style and have edited the right files in it.
When I cannot get it working, do I need to replace the backup or can I just reverse the changes in the files?

Thanks for your help!

Re: Contact Board Admin

Posted: Mon Nov 30, 2009 10:31 pm
by maarten-jan
I didn't stop searching and found out that the Module can be added on the SYSTEM tab and when I looked there I found out I could ad the CBA!

The settings for the CBA appeared as a tab and not within the general tab (like the picture in one of the earlier posts)

Now I can test and work with the MOD!

Re: Contact Board Admin

Posted: Tue Dec 01, 2009 7:14 am
by Rotsblok
RMcGirr83 found a small error :P

Don't think this is suppose to be in the lang file for the acp

Code: Select all

// equally where a string contains only two placeholders which are used to wrap text
// in a url you again do not need to specify an order e.g., 'Click %sHERE%s' is fine

// Adding new category
$lang['permission_cat']['mchat'] = 'mChat';

// Adding the permissions
;) somehting with mchat :S

BTW why are you still using \' when you have somewhere above this line?
// Some characters for use
// ’ » “ ” …

which makes the use of \' somewhat ridiculus imo

Re: Contact Board Admin

Posted: Tue Dec 01, 2009 8:22 am
by ChriZathens
Yeah, and the fact that you have to copy this character every time because you have no easy way of typing it is not ridiculous... :roll:

Re: Contact Board Admin

Posted: Tue Dec 01, 2009 9:32 am
by Artack
Hello RMcGirr83
Thanks for update mod
Small issure.
My board default langauge is russian
In 1.0.6 contact metod is email, I give notifications without message, something like
Hello Founder,

An individual by the name of "Username" with an email address of
"Here email of sender" and an IP address of "Here IP" sent the
following message on "Tuesday 01-Dec-09 08:47:00 GMT" with a reason of
"Reason":

Empty space


using the Contact form at "Sitename".

--
Signature

Re: Contact Board Admin

Posted: Tue Dec 01, 2009 11:08 am
by RMcGirr83
Rotsblok wrote:RMcGirr83 found a small error :P

Don't think this is suppose to be in the lang file for the acp

Code: Select all

// equally where a string contains only two placeholders which are used to wrap text
// in a url you again do not need to specify an order e.g., 'Click %sHERE%s' is fine

// Adding new category
$lang['permission_cat']['mchat'] = 'mChat';

// Adding the permissions
Thanks and fixed and concerning the ’ as opposed to /' 6 of one, 1/2 a dozen of another.

Artack,

It would appear my regex is a little to, uhmmm, stringent. I'll fix that as well shortly thanks.

Re: Contact Board Admin

Posted: Tue Dec 01, 2009 3:35 pm
by RMcGirr83
I have just committed quite a few changes to SVN for the 3.0.6 version, which means I need some guinea pigs, uhmmm, testers :)

To update overwrite the following files from the zip download

http://code.google.com/p/phpbb3contactb ... loads/list

root/contact.php
root/includes/functions_contact.php
root/language/en/*.*
root/styles/prosilver/template/*.*
root/styles/subsilver2/template/*.*

*.* means all the files in the directory.

This fixes the mchat lang issue ( :lol: that's what I get for working on more than one mod at a time) as well as the missing message in the email and other minutia stuff...like error messaging etc.

At least I hope it does. Thanks for the bug reports and please keep them coming if there are any.

Re: Contact Board Admin

Posted: Tue Dec 01, 2009 5:44 pm
by Artack
message is appear :)

Re: Contact Board Admin

Posted: Tue Dec 01, 2009 6:25 pm
by maarten-jan
Can you resolve this button?

Re: Contact Board Admin

Posted: Tue Dec 01, 2009 6:37 pm
by RMcGirr83
What version of phpBB are you running?

Re: Contact Board Admin

Posted: Tue Dec 01, 2009 7:43 pm
by maarten-jan
I'm running 3.0.5. Because of the MOD's I have installed which are only compatible with 3.0.5 I have postponed the upgrade to 3.0.6 untill I have everything running smoothly.

Check the button at http://www.forum.lanciathema.nl/

Re: Contact Board Admin

Posted: Tue Dec 01, 2009 8:17 pm
by RMcGirr83
Those are language errors and the VC_REFRESH was part of 3.0.5. You should see the same sort of thing when you go to register on your forum.

3.0.6 mods will not work, if they have CAPTCHA stuffs, on a 3.0.5 forum.