Thanks for posts

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
lovelysummer
Registered User
Posts: 437
Joined: Fri Mar 20, 2009 1:49 pm

Re: Thanks for posts

Post by lovelysummer »

JC4912 wrote:Where is the list of thanks? i've turned it on but I cannot see it.
There should be a link besides members and named as 'Gratitudes', check your edit in overall_header.html. ;)
User avatar
w00t!
Registered User
Posts: 179
Joined: Thu Feb 12, 2009 12:33 am
Location: Santiago, Chile

Re: Thanks for posts

Post by w00t! »

Groundy wrote:Thi sMOD should b withdrawn, support for it is too hit and miss.

Fails to work with the REDS theme, despite it being Prosilver based.

Have now disabled it completely.

Using User Rep point MOD ( BEta) instead)
No, it shouldn't. If it doesn't work is because you've done something wrong. Double check all the steps and don't forget to enable the module at the Admin CP to control how it works. I have this in both a Prosilver and subsilver2 based themes and works flawlessly.

Also, using beta/dev MODs on live boards is highly unrecommended...
digitalperson
Registered User
Posts: 38
Joined: Tue Jan 15, 2008 4:41 pm

Re: Thanks for posts

Post by digitalperson »

there is a problem

when any user writes this like this code in his topic

Code: Select all

[img]http://mydomain/forum/viewtopic.php?p=46546&thanks=8543&to_id=324[/img]  
the [img] tag executes the thanking function automaticly :(
digitalperson
Registered User
Posts: 38
Joined: Tue Jan 15, 2008 4:41 pm

Re: Thanks for posts

Post by digitalperson »

there is a problem

when any user writes this like this code in his topic

Code: Select all

[img]http://mydomain/forum/viewtopic.php?p=46546&thanks=8543&to_id=324[/img]  
the [img] tag executes the thanking function automaticly :(
alebrescia
Registered User
Posts: 22
Joined: Sat Mar 20, 2010 11:32 am
Name: Alessandro Sosta

Re: Thanks for posts

Post by alebrescia »

hi, and thanks for this good mod...

i have only one little problem...
in the list of users thanks i can't sort by thanks give and thanks received....

sorry for my bad eng... i hope this is comprensible.... ^_^

Thanks for help...
shoeib
Registered User
Posts: 13
Joined: Sat Feb 27, 2010 12:46 pm

Re: Thanks for posts

Post by shoeib »

Палыч wrote:
shoeib wrote: way so that I can place the icon in the right side of text.
try the following:
shoeib wrote:"has received gratitude ", and" has received thanks - %d". What's the difference?
One thank you and more than one thank you (from different users)
shoeib wrote:I want to write this text: " -(the number of ppl who have thanked)- users have thanked -the author- for this post."How can I do this?
Thanks a lot m8. It totally worked. ;)
Milllion wrote: Agha shoeib irani chetory? :D
Salam,
Are aziz iraniam ;)

Chakeram.
User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Re: Thanks for posts

Post by IPB_Refugee »

digitalperson wrote:there is a problem

when any user writes this like this code in his topic

Code: Select all

[img]http://mydomain/forum/viewtopic.php?p=46546&thanks=8543&to_id=324[/img]  
the [img] tag executes the thanking function automaticly :(
Thank you for the bug report! (It's similar to Cross Site Request Forgery.)

@Палыч:

Propably we should add hashes to the links: functions generate_link_hash and check_link_hash.

Regards
Wolfgang
User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Re: Thanks for posts

Post by IPB_Refugee »

Here is the fix:

OPEN /includes/functions_thanks.php

FIND

Code: Select all

function insert_thanks($post_id, $user_id)
{
	global $db, $user, $phpbb_root_path, $phpEx, $forum_id, $config;
	$to_id = request_var('to_id', 0);
ADD AFTER:

Code: Select all

	$token = request_var('thanks_hash', '');
	if (!check_link_hash($token, $user->data['username_clean']))
	{
		return;
	}
FIND

Code: Select all

function delete_thanks($post_id, $user_id)
{
	global $db, $user, $phpbb_root_path, $phpEx, $forum_id, $config;
	$to_id = request_var('to_id', 0);
ADD AFTER:

Code: Select all

	$token = request_var('thanks_hash', '');
	if (!check_link_hash($token, $user->data['username_clean']))
	{
		return;
	}
FIND:

Code: Select all

			'THANKS_LINK'			=> append_sid("{$phpbb_root_path}viewtopic.$phpEx", "p={$row['post_id']}" . (($topic_data['topic_type'] == POST_GLOBAL) ? "&f=$forum_id" : '') . "&" . get_thanks_link($row['post_id']) . "={$row['post_id']}&to_id=$poster_id"),
REPLACE WITH:

Code: Select all

			'THANKS_LINK'			=> append_sid("{$phpbb_root_path}viewtopic.$phpEx", "p={$row['post_id']}" . (($topic_data['topic_type'] == POST_GLOBAL) ? "&f=$forum_id" : '') . "&" . get_thanks_link($row['post_id']) . "={$row['post_id']}&to_id=$poster_id&thanks_hash=" . generate_link_hash($user->data['username_clean'])),
Thanks again for reporting this issue, digitalperson!

Regards
Wolfgang
digitalperson
Registered User
Posts: 38
Joined: Tue Jan 15, 2008 4:41 pm

Re: Thanks for posts

Post by digitalperson »

IPB_Refugee wrote:Here is the fix:

OPEN /includes/functions_thanks.php

FIND

Code: Select all

function insert_thanks($post_id, $user_id)
{
	global $db, $user, $phpbb_root_path, $phpEx, $forum_id, $config;
	$to_id = request_var('to_id', 0);
ADD AFTER:

Code: Select all

	$token = request_var('thanks_hash', '');
	if (!check_link_hash($token, $user->data['username_clean']))
	{
		return;
	}
FIND

Code: Select all

function delete_thanks($post_id, $user_id)
{
	global $db, $user, $phpbb_root_path, $phpEx, $forum_id, $config;
	$to_id = request_var('to_id', 0);
ADD AFTER:

Code: Select all

	$token = request_var('thanks_hash', '');
	if (!check_link_hash($token, $user->data['username_clean']))
	{
		return;
	}
FIND:

Code: Select all

			'THANKS_LINK'			=> append_sid("{$phpbb_root_path}viewtopic.$phpEx", "p={$row['post_id']}" . (($topic_data['topic_type'] == POST_GLOBAL) ? "&f=$forum_id" : '') . "&" . get_thanks_link($row['post_id']) . "={$row['post_id']}&to_id=$poster_id"),
REPLACE WITH:

Code: Select all

			'THANKS_LINK'			=> append_sid("{$phpbb_root_path}viewtopic.$phpEx", "p={$row['post_id']}" . (($topic_data['topic_type'] == POST_GLOBAL) ? "&f=$forum_id" : '') . "&" . get_thanks_link($row['post_id']) . "={$row['post_id']}&to_id=$poster_id&thanks_hash=" . generate_link_hash($user->data['username_clean'])),
Thanks again for reporting this issue, digitalperson!

Regards
Wolfgang
thank u very very much
i will try the solution :P
digitalperson
Registered User
Posts: 38
Joined: Tue Jan 15, 2008 4:41 pm

Re: Thanks for posts

Post by digitalperson »

than u very much
i have trued the solution and every thing is ok right now :P
Balero
Registered User
Posts: 145
Joined: Tue Dec 18, 2007 10:57 am

Re: Thanks for posts

Post by Balero »

This mod install with AutoMod?

Thanks! ;)
User avatar
Палыч
Translator
Posts: 1543
Joined: Sun Jul 01, 2007 7:59 pm
Location: St. Petersburg
Name: Сергей
Contact:

Re: Thanks for posts

Post by Палыч »

@digitalperson
Thank you for your bug report!

@IPB_Refugee
Very grateful for your timely help! :)
Balero wrote:This mod install with AutoMod?
Yes, of course.
Sorry for my bad english
alebrescia
Registered User
Posts: 22
Joined: Sat Mar 20, 2010 11:32 am
Name: Alessandro Sosta

Re: Thanks for posts

Post by alebrescia »

alebrescia wrote:hi, and thanks for this good mod...

i have only one little problem...
in the list of users thanks i can't sort by thanks give and thanks received....

sorry for my bad eng... i hope this is comprensible.... ^_^

Thanks for help...
no help for me?.... :cry:
User avatar
w00t!
Registered User
Posts: 179
Joined: Thu Feb 12, 2009 12:33 am
Location: Santiago, Chile

Re: Thanks for posts

Post by w00t! »

alebrescia wrote:
alebrescia wrote:hi, and thanks for this good mod...

i have only one little problem...
in the list of users thanks i can't sort by thanks give and thanks received....

sorry for my bad eng... i hope this is comprensible.... ^_^

Thanks for help...
no help for me?.... :cry:
Палыч said it's not possible yet, I asked about this some pages ago. Hopefully there's a way to do so soon.
LuMiDeN
Registered User
Posts: 12
Joined: Thu Jan 10, 2008 5:14 am

Re: Thanks for posts

Post by LuMiDeN »

I installed the mod with automod. It installed correctly. Did the DiY. Gave all the permissions.

But it doesn't work. I don't see the thank buttons.

http://cabletruch.com.ar
Locked

Return to “[3.0.x] MOD Database Releases”