Post number in viewtopic

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
desiii
Registered User
Posts: 17
Joined: Mon Nov 09, 2009 2:35 am

Re: Post number in viewtopic

Post by desiii » Tue Feb 09, 2010 3:21 pm

Oh my goodness, how embarassing! lol. I forgot to enable it in the ACP. It's working great now. :oops:
Thanks!

vera
Registered User
Posts: 17
Joined: Wed Feb 10, 2010 3:01 am

Re: Post number in viewtopic

Post by vera » Wed Feb 10, 2010 3:10 am

Hello,

I have installed the software and the Post Number MOD. But I cannot seem to make it show, and I understand it is because I am using a different template (Getaway Green). I have once time succeeded to make the number show - but then the icon for "quote" disappeared. I do not know how to program in php, a newbie really. Please help.

The following code in the template/viewtopic_body.php, as I understand, is for (1) the line where the number should appear (in front of the "Edit" and "Quote" buttons), aligned to right; and (1) the post subject in the same row, aligned to the left:
<!-- IF not S_IS_BOT --><div style="float: {S_CONTENT_FLOW_END};"><!-- IF postrow.U_EDIT --><a href="{postrow.U_EDIT}">{EDIT_IMG}</a> <!-- ENDIF --> <!-- IF postrow.U_QUOTE --><a href="{postrow.U_QUOTE}">{QUOTE_IMG}</a><!-- ENDIF --></div><!-- ENDIF -->

<div class="postsubject"><!-- IF S_IS_BOT -->{postrow.MINI_POST_IMG}<!-- ELSE --><a href="{postrow.U_MINI_POST}"><!-- IF postrow.POST_ICON_IMG --><img src="{T_ICONS_PATH}{postrow.POST_ICON_IMG}" width="{postrow.POST_ICON_IMG_WIDTH}" height="{postrow.POST_ICON_IMG_HEIGHT}" alt="" /><!-- ELSE -->{postrow.MINI_POST_IMG}<!-- ENDIF --></a><!-- ENDIF -->&nbsp;{postrow.POST_SUBJECT}</div>
Thank you in advance. :)

User avatar
ChriZathens
Registered User
Posts: 1477
Joined: Tue Apr 18, 2006 9:11 pm
Location: Athens, Greece
Name: Chris

Re: Post number in viewtopic

Post by ChriZathens » Wed Feb 10, 2010 10:22 am

Getaway Green is based on subsilver2
The whole relevant line must become

Code: Select all

                <div class="postsubject"><!-- IF S_IS_BOT -->{postrow.MINI_POST_IMG}<!-- ELSE --><!-- IF S_ENABLE_POST_NUM -->{L_POST_NUM}<a href="{postrow.U_MINI_POST}"<!-- IF S_ENABLE_POST_NUM_JS --> onclick="prompt('{L_POST_DIRECT_LINK}',this.href); return false;"<!-- ENDIF -->><strong>{L_POST_NUM_SYMBOL}{postrow.POST_NUM}</strong></a>&nbsp;&nbsp;{postrow.MINI_POST_IMG}<!-- ELSE --><a href="{postrow.U_MINI_POST}"><!-- IF postrow.POST_ICON_IMG --><img src="{T_ICONS_PATH}{postrow.POST_ICON_IMG}" width="{postrow.POST_ICON_IMG_WIDTH}" height="{postrow.POST_ICON_IMG_HEIGHT}" alt="" /><!-- ELSE -->{postrow.MINI_POST_IMG}<!-- ENDIF --><!-- ENDIF --></a><!-- ENDIF -->&nbsp;{postrow.POST_SUBJECT}</div>
Of course you must also enable the mod via the ACP (Board configuration -->post settings), since it is disabled by default.
Let me know if it is OK... :)
My mods in MODDB:
Add Homepage link in header - Change user activity post limit - Post number in viewtopic
If you need support click on the support tab there and post your question.
Do not PM me - chances of viewing my PMs are way thinner than viewing the support question in the customization DB...

vera
Registered User
Posts: 17
Joined: Wed Feb 10, 2010 3:01 am

Re: Post number in viewtopic

Post by vera » Wed Feb 10, 2010 12:32 pm

ChriZathens wrote:Getaway Green is based on subsilver2
The whole relevant line must become

Code: Select all

                <div class="postsubject"><!-- IF S_IS_BOT -->{postrow.MINI_POST_IMG}<!-- ELSE --><!-- IF S_ENABLE_POST_NUM -->{L_POST_NUM}<a href="{postrow.U_MINI_POST}"<!-- IF S_ENABLE_POST_NUM_JS --> onclick="prompt('{L_POST_DIRECT_LINK}',this.href); return false;"<!-- ENDIF -->><strong>{L_POST_NUM_SYMBOL}{postrow.POST_NUM}</strong></a>&nbsp;&nbsp;{postrow.MINI_POST_IMG}<!-- ELSE --><a href="{postrow.U_MINI_POST}"><!-- IF postrow.POST_ICON_IMG --><img src="{T_ICONS_PATH}{postrow.POST_ICON_IMG}" width="{postrow.POST_ICON_IMG_WIDTH}" height="{postrow.POST_ICON_IMG_HEIGHT}" alt="" /><!-- ELSE -->{postrow.MINI_POST_IMG}<!-- ENDIF --><!-- ENDIF --></a><!-- ENDIF -->&nbsp;{postrow.POST_SUBJECT}</div>
Of course you must also enable the mod via the ACP (Board configuration -->post settings), since it is disabled by default.
Let me know if it is OK... :)
Thank you for the answer. I have enabled the acp, that was fine.

Well, no, this is not exactly the answer. What happens now is the number in fact appears - but before the Topic Title, on the left. I understand you have changed the SECOND line of the two I posted. The FIRST deals with the buttons on the right, if I read them correctly. The Post number should go there somehow. Does that sound right?

Here is the URL of the a topic in the Forum, so you could look at it:
http://www.russianavantgard.com/phpBB3/ ... hp?f=6&t=5

Thank you so much. I really appreciate your help. :)

User avatar
ChriZathens
Registered User
Posts: 1477
Joined: Tue Apr 18, 2006 9:11 pm
Location: Athens, Greece
Name: Chris

Re: Post number in viewtopic

Post by ChriZathens » Wed Feb 10, 2010 12:47 pm

Oh, I see now...
Your question was that you actually want the post number to be on the right side and not on the left along with the post subject... Is this correct?
If yes then I must check and get back to you...

EDIT:
OK, try this:
Find:

Code: Select all

<!-- IF not S_IS_BOT --><div style="float: {S_CONTENT_FLOW_END};">
Inline after add

Code: Select all

<!-- IF S_ENABLE_POST_NUM -->{L_POST_NUM}<a href="{postrow.U_MINI_POST}"<!-- IF S_ENABLE_POST_NUM_JS --> onclick="prompt('{L_POST_DIRECT_LINK}',this.href); return false;"<!-- ENDIF -->><strong>{L_POST_NUM_SYMBOL}{postrow.POST_NUM}&nbsp;&nbsp;</strong></a><!-- ENDIF -->
P.S.: Don't forget to purge cache afterwards. ;)
My mods in MODDB:
Add Homepage link in header - Change user activity post limit - Post number in viewtopic
If you need support click on the support tab there and post your question.
Do not PM me - chances of viewing my PMs are way thinner than viewing the support question in the customization DB...

vera
Registered User
Posts: 17
Joined: Wed Feb 10, 2010 3:01 am

Re: Post number in viewtopic

Post by vera » Wed Feb 10, 2010 8:56 pm

ChriZathens wrote:Oh, I see now...
Your question was that you actually want the post number to be on the right side and not on the left along with the post subject... Is this correct?
If yes then I must check and get back to you...

EDIT:
OK, try this:
Find:

Code: Select all

<!-- IF not S_IS_BOT --><div style="float: {S_CONTENT_FLOW_END};">
Inline after add

Code: Select all

<!-- IF S_ENABLE_POST_NUM -->{L_POST_NUM}<a href="{postrow.U_MINI_POST}"<!-- IF S_ENABLE_POST_NUM_JS --> onclick="prompt('{L_POST_DIRECT_LINK}',this.href); return false;"<!-- ENDIF -->><strong>{L_POST_NUM_SYMBOL}{postrow.POST_NUM}&nbsp;&nbsp;</strong></a><!-- ENDIF -->
P.S.: Don't forget to purge cache afterwards. ;)
Bingo! You are amazing, thank you! This is nothing short of magic, really, for someone like me. :lol:

Is it possible you may perhaps know why the Topic icons don't show when posting? I see smileys - but not Topic icons. I looked through many support forum postings, but found no clue. Thank you in any case.

User avatar
spaceace
Registered User
Posts: 1857
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: Post number in viewtopic

Post by spaceace » Wed Feb 10, 2010 10:45 pm

vera wrote:Is it possible you may perhaps know why the Topic icons don't show when posting? I see smileys - but not Topic icons. I looked through many support forum postings, but found no clue. Thank you in any case.
by default, phpbb has topic icons disabled. you can enable them in the ACP by editing each forum. the setting is in the "General forum settings" - "Enable topic icons:"

vera
Registered User
Posts: 17
Joined: Wed Feb 10, 2010 3:01 am

Re: Post number in viewtopic

Post by vera » Wed Feb 10, 2010 11:42 pm

spaceace wrote:
vera wrote:Is it possible you may perhaps know why the Topic icons don't show when posting? I see smileys - but not Topic icons. I looked through many support forum postings, but found no clue. Thank you in any case.
by default, phpbb has topic icons disabled. you can enable them in the ACP by editing each forum. the setting is in the "General forum settings" - "Enable topic icons:"
Oh, that simple. Found it. Thank you so much.

alanahermsen
Registered User
Posts: 10
Joined: Thu Feb 11, 2010 1:20 am
Contact:

Re: Post number in viewtopic

Post by alanahermsen » Thu Feb 11, 2010 1:33 am

What would this be used for?

User avatar
spaceace
Registered User
Posts: 1857
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: Post number in viewtopic

Post by spaceace » Thu Feb 11, 2010 1:57 am

alanahermsen wrote:What would this be used for?
in my opinion, it makes identifying an individual post easier as each post will have an actual number. so you can say, go to post 35 in topic blabla instead of having to post the link.

MsIrey
Registered User
Posts: 144
Joined: Tue Sep 02, 2008 1:50 am
Location: Florida

Re: Post number in viewtopic

Post by MsIrey » Thu Feb 11, 2010 7:25 am

I am considering adding this to our board but before I start trying to wrap my head around the instructions I have to ask if this is working in 3.0.6? I saw a post saying it was working but the main MOD post only says 3.0.5.

alanahermsen
Registered User
Posts: 10
Joined: Thu Feb 11, 2010 1:20 am
Contact:

Re: Post number in viewtopic

Post by alanahermsen » Thu Feb 11, 2010 8:28 am

lol oh... sorry.. newb!

User avatar
ChriZathens
Registered User
Posts: 1477
Joined: Tue Apr 18, 2006 9:11 pm
Location: Athens, Greece
Name: Chris

Re: Post number in viewtopic

Post by ChriZathens » Thu Feb 11, 2010 10:43 am

MsIrey wrote:I am considering adding this to our board but before I start trying to wrap my head around the instructions I have to ask if this is working in 3.0.6? I saw a post saying it was working but the main MOD post only says 3.0.5.
When it was released, the current release was 3.0.5, thus the description. But it works just fine in 3.0.6 as well. In fact it should work in any version from 3.0.0 to 3.0.7-dev
My mods in MODDB:
Add Homepage link in header - Change user activity post limit - Post number in viewtopic
If you need support click on the support tab there and post your question.
Do not PM me - chances of viewing my PMs are way thinner than viewing the support question in the customization DB...

User avatar
hinix
Registered User
Posts: 18
Joined: Tue Feb 16, 2010 1:54 pm
Location: Szczecin (Poland)
Contact:

Re: Post number in viewtopic

Post by hinix » Tue Feb 23, 2010 9:13 am

It's possible to edit this mod to display post number in forum (not topic - actually first post of every topic has number one)?
I mean the number of post who is use in direct link to post, example:
domain.com/viewtopic.php?p=9321#p9321

edit:
I do it in my way using $post_id, somebody can delete this post.
(\__/)
(O.o)
(> <) <-- This is Bunny. Copy Bunny into your signature to help him on his way to world domination!

Redy
Registered User
Posts: 102
Joined: Sun Feb 07, 2010 5:37 pm

Re: Post number in viewtopic

Post by Redy » Fri Feb 26, 2010 9:18 pm

Great! THX :)

Locked

Return to “[3.0.x] MOD Database Releases”