phpBB Smartfeed

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
zuber
Registered User
Posts: 17
Joined: Tue Aug 11, 2009 11:18 am

Re: phpBB Smartfeed

Post by zuber » Tue Aug 11, 2009 11:23 am

Hell-o!

- I have installed Smartfeed 2.2.12 for my forum running on phpBB 3.0.5
- forum is running on intranet

And I have such problem:
- I have proper feed updates when I'm loggeg in as administrator
- but when I'm not logged, or logged as ordinary user I do NOT have proper feed update, and Firefox says that 'Live Bookmark feed failed to load."

Regards

Michal

User avatar
MarkDHamill
Registered User
Posts: 3876
Joined: Fri Aug 02, 2002 12:36 am
Location: Florence, MA USA
Contact:

Re: phpBB Smartfeed

Post by MarkDHamill » Tue Aug 11, 2009 1:42 pm

If you are on an Intranet then by definition it is not publicly accessible. Are you trying to access it from the outside your network?
Get the latest versions of my Digests and Smartfeed extensions.
Need phpBB services or a phpBB consultant? I offer most phpBB services.

zuber
Registered User
Posts: 17
Joined: Tue Aug 11, 2009 11:18 am

Re: phpBB Smartfeed

Post by zuber » Tue Aug 11, 2009 2:02 pm

No, I'm accessing it only locally on the intranet. It is not available on the internet.

So I don't know If I need to set some permissions, update SQL database in some way?

Previously I was using Smartfeed 2.2.3 and it was working fine. Then I upgraded to 2.2.12 and problem showed up.

So maybe update caused some problems?

Regards

Michal

User avatar
MarkDHamill
Registered User
Posts: 3876
Joined: Fri Aug 02, 2002 12:36 am
Location: Florence, MA USA
Contact:

Re: phpBB Smartfeed

Post by MarkDHamill » Wed Aug 12, 2009 12:50 am

I don't know if you went through each upgrade from 2.2.3 to 2.2.12 individually or not. The safest thing would be to do a fresh install.
Get the latest versions of my Digests and Smartfeed extensions.
Need phpBB services or a phpBB consultant? I offer most phpBB services.

Bogey
Registered User
Posts: 419
Joined: Wed Sep 19, 2007 2:31 am

Re: phpBB Smartfeed

Post by Bogey » Wed Aug 12, 2009 5:17 am

MarkDHamill wrote:You can try out the mod here:

http://phpbbservices.com/phpBB3

Look for the Smartfeed link in the header.

However, to see how it works differently when you are registered, you will have to register.
All of the Feeds are empty :(

zuber
Registered User
Posts: 17
Joined: Tue Aug 11, 2009 11:18 am

Re: phpBB Smartfeed

Post by zuber » Wed Aug 12, 2009 8:04 am

I did 2.2.12 installation over 2.2.3.

I checked manually all the update steps from 2.2.3 to 2.2.12 and I'm sure that all changes required for version 2.2.12 are in.

Regards

Michal

User avatar
MarkDHamill
Registered User
Posts: 3876
Joined: Fri Aug 02, 2002 12:36 am
Location: Florence, MA USA
Contact:

Re: phpBB Smartfeed

Post by MarkDHamill » Wed Aug 12, 2009 2:18 pm

Sorry about the rework. There must have been an error in one or more of the upgrade instructions.
Get the latest versions of my Digests and Smartfeed extensions.
Need phpBB services or a phpBB consultant? I offer most phpBB services.

zuber
Registered User
Posts: 17
Joined: Tue Aug 11, 2009 11:18 am

Re: phpBB Smartfeed

Post by zuber » Wed Aug 12, 2009 2:29 pm

I just made a test and used, those files:
- smartfeed.php
- smartfeed_url.php
- smartfeed_url_new_key.php

from version 2.2.11

and it turned out that now everything works fine!

So there is for sure some problem with 2.2.12 version.

sponkey
Registered User
Posts: 8
Joined: Wed Aug 12, 2009 7:10 pm

Re: phpBB Smartfeed

Post by sponkey » Wed Aug 12, 2009 7:12 pm

Justin_False wrote:<b>Fatal error</b>: Cannot redeclare login_db() (previously declared in /opt/phpbb3/includes/auth/auth_db.php:27) in <b>/opt/phpbb3/includes/auth/auth_db.php</b> on line <b>235</b><br />
I'm getting this same line of code appended to my feeds, regardless of feed type or other settings. What could be causing this?

User avatar
MarkDHamill
Registered User
Posts: 3876
Joined: Fri Aug 02, 2002 12:36 am
Location: Florence, MA USA
Contact:

Re: phpBB Smartfeed

Post by MarkDHamill » Wed Aug 12, 2009 11:15 pm

Yeah, that's pretty mysterious because this mod does not make any changes to auth_db.php.

You can try commenting out line 37 in smartfeed.php to see if it goes away:

Code: Select all

$user->session_begin();
Odd, no one had noticed this during more than a year of beta testing.
Get the latest versions of my Digests and Smartfeed extensions.
Need phpBB services or a phpBB consultant? I offer most phpBB services.

sponkey
Registered User
Posts: 8
Joined: Wed Aug 12, 2009 7:10 pm

Re: phpBB Smartfeed

Post by sponkey » Thu Aug 13, 2009 12:28 pm

Thanks for the suggestion - now I'm getting a general SQL error, so it looks like that line is necessary. I have another mod installed (AntiSpam ACP) - think that could be causing interference?

User avatar
MarkDHamill
Registered User
Posts: 3876
Joined: Fri Aug 02, 2002 12:36 am
Location: Florence, MA USA
Contact:

Re: phpBB Smartfeed

Post by MarkDHamill » Thu Aug 13, 2009 2:22 pm

Yeah, there is probably a mod conflict somewhere. If your antispam mod has a list of approved programs, you might have to add smartfeed.php to the list.

If you get a definitive answer please post it so I can ponder if there is something I could do with subsequent versions to mitigate future issues.
Get the latest versions of my Digests and Smartfeed extensions.
Need phpBB services or a phpBB consultant? I offer most phpBB services.

WastedJoker
Registered User
Posts: 74
Joined: Mon Nov 17, 2008 10:20 pm

Re: phpBB Smartfeed

Post by WastedJoker » Thu Aug 13, 2009 5:26 pm

I'm also getting "Failed to load" error when not logged in but everything works fine when I am logged in.

I installed using latest version 2.2.12 from scratch.

WastedJoker
Registered User
Posts: 74
Joined: Mon Nov 17, 2008 10:20 pm

Re: phpBB Smartfeed

Post by WastedJoker » Thu Aug 13, 2009 5:37 pm

Also, the setting:
Feed image path:
The image you want to appear in the feed to brand your board. The default is site_logo.gif, which is the phpBB icon (or the image you substituted for it). The default style will be used, so set it to the relative path from your board's default style directory.
I've not amended this but when I view the feed in Sage for Firefox there's no image showing?

I've amended my theme to not show site logo BUT the file is still existing in the directory/path...

User avatar
MarkDHamill
Registered User
Posts: 3876
Joined: Fri Aug 02, 2002 12:36 am
Location: Florence, MA USA
Contact:

Re: phpBB Smartfeed

Post by MarkDHamill » Thu Aug 13, 2009 7:04 pm

Can you be more specific on the error message you are getting?

Whether the image shows up depends on the feed type and whether your newsreader thinks it should be shown. RSS 2.0 is the default and allows for a feed image. I don't believe there is an equivalent for RSS 1.0 or Atom 1.0. If you try it in the browser with the defaults you should see the feed image.
Get the latest versions of my Digests and Smartfeed extensions.
Need phpBB services or a phpBB consultant? I offer most phpBB services.

Locked

Return to “[3.0.x] MOD Database Releases”