Page 5 of 12

Re: Forum SEO

Posted: Sun Nov 15, 2009 8:47 pm
by bloodmage
hello ,

i have test your reply but i dont know if its correct or no ,

when i go to mysite.com/mysql_upgrade.php i have this .

http://img5.imageshack.us/img5/9594/testpxm.jpg ( and more )

i dont know if i go to this site i will have a this as the picture visual .

when i am on this link what i need to doe ? ( its all time same : modify , modify , ... ... )

thanks in advance bloodmage .

( soms people have asking me i juste need delete forum seo tab but i see anithing about forum seo key , what are the tab name the mod forum seo install ? )

Re: Forum SEO

Posted: Sun Nov 15, 2009 9:19 pm
by stokerpiller
They are stored in the forums table.
You can delete them in phpmyadmin: http://easycaptures.com/0581755286
Uninstalling the mod will not fix your database.

About the tool, follow the instructions from the link.
If you have further questions, ask them in the support forum.

Your problems is not related to this mod.
Its an error in the database schema.

Re: Forum SEO

Posted: Sun Nov 15, 2009 9:40 pm
by bloodmage
ohhh okay ,

i think my mysql updater bug , check by you self .

http://robpleasure.com/forum/mysql_updater.php

if its correct what i need to doe ? cause i can go to my forum but the problem still here ...

thanks in advance bloodmage .

Re: Forum SEO

Posted: Sun Nov 15, 2009 10:42 pm
by stokerpiller
stokerpiller wrote:They are stored in the forums table.
You can delete them in phpmyadmin: http://easycaptures.com/0581755286
This was the explanation how to uninstall Forum SEO in the database.
However you still have a problem with the database schema that might appear again later.

stokerpiller wrote:About the tool, follow the instructions from the link.
If you have further questions, ask them in the support forum.
This was the answer about the tool.
I cant support a tool that I dont fully understand. Thats why I asked you to go to the support forum and ask about the specific tool.

Re: Forum SEO

Posted: Mon Nov 16, 2009 8:57 am
by Br33zer
Just wanted to ask, why does the keywords and/or SEO description has to be visible on forum? Shouldn't it be visible only to spiders?

Re: Forum SEO

Posted: Mon Nov 16, 2009 9:08 am
by stokerpiller
No, that would be cloaking.

Re: Forum SEO

Posted: Mon Nov 16, 2009 10:10 am
by DoYouSpeakWak
Br33zer wrote:Just wanted to ask, why does the keywords and/or SEO description has to be visible on forum? Shouldn't it be visible only to spiders?
Read this post and the one before it. http://www.phpbb.com/community/viewtopi ... #p11194015

Re: Forum SEO

Posted: Mon Nov 16, 2009 5:28 pm
by bloodmage
its not the mysql problem see this :

Code: Select all

[quote="Paul"]That error is caused by your seo MOD. You will need to ask for support for that at the topic for the MOD.[/quote]
but the problem its again not resolverd :

quote of the problem .
bloodmage wrote:

Code: Select all

General Error
SQL ERROR [ mysqli ]

Field 'forum_seo_key' doesn't have a default value [1364]

SQL

INSERT INTO phpbb_forums (parent_id, forum_type, forum_status, forum_parents, forum_name, forum_link, forum_desc, forum_desc_uid, forum_desc_options, forum_desc_bitfield, forum_rules, forum_rules_uid, forum_rules_options, forum_rules_bitfield, forum_rules_link, forum_image, forum_style, display_subforum_list, display_on_index, forum_topics_per_page, enable_indexing, enable_icons, enable_prune, prune_days, prune_viewed, prune_freq, forum_password, forum_name_colour, forum_flags, left_id, right_id) VALUES (1, 1, 0, '', 'test', '', 'test', '', 7, '', '', '', 7, '', '', '', 0, 1, 1, 0, 1, 1, 1, 7, 7, 1, '$H$9cveJjFzdR6ltBjOU0fZMjgWhIoj3v.', 'FF0000', 48, '12', 13)

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/acp/acp_forums.php
LINE: 1049
CALL: dbal_mysqli->sql_query()

FILE: includes/acp/acp_forums.php
LINE: 183
CALL: acp_forums->update_forum_data()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_forums->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()
one member have ask to me if i doe that this will remove the bug ...
in my phpmyadmin i havent the 3 forum seo tables and i have unstall it whit automod .

thanks in advance bloodmage .

Re: Forum SEO

Posted: Mon Nov 16, 2009 5:55 pm
by stokerpiller
Your error tells that you still have something in the database.

They are stored in the forums table.
Please backup before doing anything.

Re: Forum SEO

Posted: Mon Nov 16, 2009 6:01 pm
by stokerpiller
And the correct screenshot showing you what to remove is this one: http://easycaptures.com/0581755286

Re: Forum SEO

Posted: Mon Nov 16, 2009 6:02 pm
by bloodmage
stokerpiller wrote:Your error tells that you still have something in the database.

They are stored in the forums table.
Please backup before doing anything.
i have this , ... :

http://img264.imageshack.us/img264/4167/capture1z.png

i have go to phpmyadmin and i have push on the table on left .

if i need to delete that i need delete much other table .

its possible im wrong way ...

thanks in advance .

Re: Forum SEO

Posted: Mon Nov 16, 2009 6:07 pm
by bloodmage
problem resolved

Re: Forum SEO

Posted: Mon Nov 16, 2009 6:36 pm
by stokerpiller
I am glad to hear :)
How did you solve it?

Re: Forum SEO

Posted: Tue Nov 17, 2009 4:43 pm
by Br33zer
Hey,

For Envision style [subsilver2], I have edited like this which you had mentioned it here:

in viewforum_body.html

Find:

Code: Select all

	<td align="{S_CONTENT_FLOW_END}"><!-- INCLUDE jumpbox.html --></td>
Add before:

Code: Select all

    <!-- IF FORUM_SEO_DESC --><span style="font-weight:bold;">{FORUM_SEO_KEY}</span><br /><span>{FORUM_SEO_DESC}<br /></span><!-- ENDIF -->
    <!-- IF FORUM_SEO_BOTTOM --><br /><div><span>{FORUM_SEO_BOTTOM}</span></div><!-- ENDIF -->
Will this work for subsilver2?. I do see the keywords and description at bottom.

Re: Forum SEO

Posted: Tue Nov 17, 2009 5:10 pm
by stokerpiller