phpBB Gallery

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
Dan1898
Registered User
Posts: 5
Joined: Sat Dec 26, 2009 5:27 pm

Re: phpBB Gallery

Post by Dan1898 » Sat Dec 26, 2009 9:03 pm

Ok intresting now.

Made a fresh install of PHPBB3 and patched to version 3.0.6
Installed AutoMod.

Uploaded gallery - however auto mod doesnt seem to like the installation and cant find tect to edit. i have checked myself in directory and cant find it. I thought all mods here worked with automod?
viewonline.php
Find

$sql = 'SELECT u.user_id, u.username, u.username_clean, u.user_type, u.user_colour, s.session_id, s.session_time, s.session_page, s.session_ip, s.session_browser, s.session_viewonline, s.session_forum_id

In-Line Find

, s.session_forum_id

In-Line After, Add

, s.session_album_id

Success
Find

preg_match('#^([a-z/_]+)#i', $row['session_page'], $on_page);
if (!sizeof($on_page))
{
$on_page[1] = '';
}

Add After

// phpBB Gallery integration
if ((utf8_substr($on_page[1], 0, utf8_strlen(GALLERY_ROOT_PATH))) == GALLERY_ROOT_PATH)
{
$gallery_on_page[1] = $on_page[1];
$on_page[1] = utf8_substr($on_page[1], 0, utf8_strlen(GALLERY_ROOT_PATH));
}

The Find specified by the MOD could not be found
styles/prosilver/template/memberlist_view.html
Find

<!-- IF S_GROUP_OPTIONS --><dt>{L_USERGROUPS}:</dt> <dd><select name="g">{S_GROUP_OPTIONS}</select> <input type="submit" name="submit" value="{L_GO}" class="button2" /></dd><!-- ENDIF -->

Add After

<!-- IF U_GALLERY --><dt>{L_GALLERY}:</dt> <dd><a href="{U_GALLERY}">{SHOW_PERSONAL_ALBUM_OF}</a></dd><!-- ENDIF -->

Success
Find

<dt>{L_TOTAL_POSTS}:</dt>
<dd>{POSTS} | <strong><a href="{U_SEARCH_USER}">{L_SEARCH_USER_POSTS}</a></strong>
<!-- IF POSTS_PCT --><br />({POSTS_PCT} / {POSTS_DAY})<!-- ENDIF -->
<!-- IF POSTS_IN_QUEUE and U_MCP_QUEUE --><br />(<a href="{U_MCP_QUEUE}">{L_POSTS_IN_QUEUE}</a>)<!-- ELSEIF POSTS_IN_QUEUE --><br />({L_POSTS_IN_QUEUE})<!-- ENDIF -->
</dd>

Add After

<!-- IF TOTAL_IMAGES -->
<dt>{L_TOTAL_IMAGES}:</dt>
<dd>{IMAGES} | <strong><a href="{U_SEARCH_GALLERY}">{L_SEARCH_USER_IMAGES}</a></strong>
<!-- IF IMAGES_PCT --><br />({IMAGES_PCT} / {IMAGES_DAY})<!-- ENDIF -->
</dd>
<!-- ENDIF -->

The Find specified by the MOD could not be found
styles/subsilver2/template/memberlist_view.html
Find

<tr>
<td class="gen" align="{S_CONTENT_FLOW_END}" valign="top" nowrap="nowrap">{L_TOTAL_POSTS}: </td>
<td><b class="gen">{POSTS}</b><span class="genmed"><!-- IF POSTS_PCT --><br />[{POSTS_PCT} / {POSTS_DAY}]<!-- ENDIF -->
<!-- IF POSTS_IN_QUEUE and U_MCP_QUEUE --><br />[<a href="{U_MCP_QUEUE}">{L_POSTS_IN_QUEUE}</a>]<!-- ELSEIF POSTS_IN_QUEUE --><br />[{L_POSTS_IN_QUEUE}]<!-- ENDIF -->
<br /><a href="{U_SEARCH_USER}">{L_SEARCH_USER_POSTS}</a></span></td>
</tr>

Add After

<!-- IF TOTAL_IMAGES -->
<tr>
<td class="gen" align="{S_CONTENT_FLOW_END}" valign="top" nowrap="nowrap">{L_TOTAL_IMAGES}: </td>
<td><b class="gen">{IMAGES}</b><span class="genmed"><!-- IF IMAGES_PCT --><br />[{IMAGES_PCT} / {IMAGES_DAY}]<!-- ENDIF --><br /><a href="{U_SEARCH_GALLERY}">{L_SEARCH_USER_IMAGES}</a></span></td>
</tr>
<!-- ENDIF -->

The Find specified by the MOD could not be found
tyles/subsilver2/template/viewtopic_body.html
Find

<td><div class="gensmall" style="float: {S_CONTENT_FLOW_BEGIN};">&nbsp;<!-- IF postrow.U_PROFILE --><a href="{postrow.U_PROFILE}">{PROFILE_IMG}</a> <!-- ENDIF --> <!-- IF postrow.U_PM --><a href="{postrow.U_PM}">{PM_IMG}</a> <!-- ENDIF --> <!-- IF postrow.U_EMAIL --><a href="{postrow.U_EMAIL}">{EMAIL_IMG}</a> <!-- ENDIF -->&nbsp;</div> <div class="gensmall" style="float: {S_CONTENT_FLOW_END};"><!-- IF not S_IS_BOT --><!-- IF postrow.U_EDIT --><a href="{postrow.U_EDIT}">{EDIT_IMG}</a> <!-- ENDIF --> <!-- IF postrow.U_QUOTE --><a href="{postrow.U_QUOTE}">{QUOTE_IMG}</a> <!-- ENDIF --> <!-- ENDIF -->&nbsp;</div></td>

In-Line Find

This MOD has an invalid instruction, or an in-line find operation failed.

The Find specified by the MOD could not be found
They appear to be the only 4 errors

Dan1898
Registered User
Posts: 5
Joined: Sat Dec 26, 2009 5:27 pm

Re: phpBB Gallery

Post by Dan1898 » Sat Dec 26, 2009 9:12 pm

now I find Mod only works with PHPbb3 Ver 3.0.5 not 3.0.6.

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: phpBB Gallery

Post by nickvergessen » Sun Dec 27, 2009 5:08 pm

you would have just needed to edit the includes/cache.php not to install the hole mod again.

For your new problem you would need to use the package from:
http://www.phpbb.com/community/viewtopi ... 0&t=682765
No Support via PM

Dan1898
Registered User
Posts: 5
Joined: Sat Dec 26, 2009 5:27 pm

Re: phpBB Gallery

Post by Dan1898 » Wed Dec 30, 2009 1:53 am

Hi - I tried a fresh install on 3.0.6 of Gallery 1.0.4 and now when I click gallery on the board index I get the following errors, am I doing somthing really wrong?

I'm really new at this stuff and some simply laymens terms answers would be greatly appreciated.
SQL ERROR [ mysql4 ]

Table 'memphisd_phpb1.phpbb_gallery_users' doesn't exist [1146]

SQL

SELECT * FROM phpbb_gallery_users WHERE user_id = 2

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: gallery/includes/functions.php
LINE: 44
CALL: dbal_mysql->sql_query()

FILE: gallery/includes/common.php
LINE: 24
CALL: include('gallery/includes/functions.php')

FILE: gallery/index.php
LINE: 29
CALL: include('gallery/includes/common.php')

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: phpBB Gallery

Post by nickvergessen » Wed Dec 30, 2009 10:32 am

Did you run the install/update?
No Support via PM

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17052
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

phpBB Gallery

Post by DavidIQ » Thu Dec 31, 2009 1:10 pm

MOD Updated to version 1.0.4
See first post for Download Link
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: phpBB Gallery

Post by nickvergessen » Thu Dec 31, 2009 1:39 pm

Thanks to the MOD-Team for validation and have fun on updating everyone!
No Support via PM

asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

Re: phpBB Gallery

Post by asinshesq » Thu Dec 31, 2009 3:01 pm

Congratulations. And have a happy and safe new year, Nick.

CMA
Registered User
Posts: 330
Joined: Mon Jun 02, 2003 4:15 pm
Location: Vancouver BC Canada
Contact:

Re: phpBB Gallery

Post by CMA » Thu Dec 31, 2009 3:37 pm

nickvergessen wrote:Thanks to the MOD-Team for validation and have fun on updating everyone!
is it exactly same as you have on your site that i download?

if not then i will re-install everything...

TheTattooist
Registered User
Posts: 5
Joined: Tue Dec 29, 2009 8:53 am

Re: phpBB Gallery

Post by TheTattooist » Sat Jan 02, 2010 9:59 am

Sorted!
Delete Please
Last edited by TheTattooist on Sun Jan 03, 2010 10:37 am, edited 1 time in total.

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: phpBB Gallery

Post by nickvergessen » Sat Jan 02, 2010 10:11 am

CMA wrote:Is it exactly same as you have on your site that i download?
if not then i will re-install everything...
If it wasn't the same, it would have a different version number.
No Support via PM

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: phpBB Gallery

Post by nickvergessen » Sat Jan 02, 2010 10:23 am

This is a problem of your bridge, please ask the Bridge-Support.
No Support via PM

silberfuchs
Registered User
Posts: 36
Joined: Mon Oct 27, 2008 6:17 pm

Re: phpBB Gallery

Post by silberfuchs » Sun Jan 03, 2010 10:05 am

I have only a little issue on my page but I can't find the mistake...... I am missing the "icon gallery gif" in the header between "FAQ" and "Members".

I copied it on the server in the right directory, did a refresh for the style ......could you please give me a hint?

My page is "http://www.motorsportfreunde-ludwigshafen.de"

it seems to be working now... :-)

asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

moving acp module to its own tab

Post by asinshesq » Sun Jan 03, 2010 10:54 am

I'm trying to get the acp config links for this mod to appear under a gallery tab rather than under the default .mods tab. This should be easy but for some reason I can't get it to work no matter what combination of specs I use in adding the modules. Each time I try, I end up with a gallery tab but no side links underneath allowing me to set permissions, configure, etc (even though I set up the gallery config modules with parent set to gallery module and enabled it).

Any hints?

Thanks.

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: phpBB Gallery

Post by nickvergessen » Sun Jan 03, 2010 2:11 pm

Just create a new category in ACP > System > Administration-Control-Panel >
Than just go furhter deep to > MODs > and move the gallery module to your own new tab
No Support via PM

Locked

Return to “[3.0.x] MOD Database Releases”