phpBB Gallery

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
Boyobejamin
Registered User
Posts: 71
Joined: Sat Jun 27, 2009 11:18 pm

Re: phpBB Gallery

Post by Boyobejamin » Mon Apr 05, 2010 5:28 pm

4ndr01d wrote:Hi everyone.

I have installed this mod before, but now i've got a little incovenience.

I have installed it corretly ( i think ), and my ACP is not showing the configurations like before anymore.
It's only in blank. Although its look well on the forum, by clicking create a new album ( Its not possible because you havent the "x" permission ), i think thats working correctly. Its just not showing the configuratios on ACP.

Screen:

http://img101.imageshack.us/img101/2711/screensk.png

http://boxdownload.gofreeserve.com/forum/index.php

I've sent the STYLE things twice.
I've purged the cache.

Thank's. ;)
When you click phpBB Gallery in the Module management, is everything enabled or disabled? If its all disabled all you have to do is enable it and maybe purge the cache
sleevedbiker wrote:using phpbb 3.0.7-PL1
sonsofanarchyforever.com/forum
twilightbb - subsilver2

How do i remove the multiple Phpbb gallery mods that are showing up in my acp... picture below.....


also getting multiple phpbb albums in the control panel along with some randome code looking link that doesnt link to anything(the first option in pic)

also have 3 different albums showing up in the users profile

any help to clean this up would be much appreciated
This is really simple ;)

Just go to the ACP (Administration Control Panel) > System > Module Management
from their you will see the links to the ACP, MCP, and UCP. Just click on the appropriete links until you get to the duplicate entries for phpBB gallery and delete the duplicates deleting everything inside of the phpBB duplicate modules.

4ndr01d
Registered User
Posts: 22
Joined: Thu Jun 05, 2008 11:25 pm

Re: phpBB Gallery

Post by 4ndr01d » Mon Apr 05, 2010 5:42 pm

Everything already enable.
The problem remains.

Thanks.

User avatar
sleevedbiker
Registered User
Posts: 789
Joined: Mon Oct 12, 2009 4:33 pm

Re: phpBB Gallery

Post by sleevedbiker » Mon Apr 05, 2010 6:33 pm

Boyobejamin wrote:
4ndr01d wrote:Hi everyone.

I have installed this mod before, but now i've got a little incovenience.

I have installed it corretly ( i think ), and my ACP is not showing the configurations like before anymore.
It's only in blank. Although its look well on the forum, by clicking create a new album ( Its not possible because you havent the "x" permission ), i think thats working correctly. Its just not showing the configuratios on ACP.

Screen:

http://img101.imageshack.us/img101/2711/screensk.png

http://boxdownload.gofreeserve.com/forum/index.php

I've sent the STYLE things twice.
I've purged the cache.

Thank's. ;)
When you click phpBB Gallery in the Module management, is everything enabled or disabled? If its all disabled all you have to do is enable it and maybe purge the cache
sleevedbiker wrote:using phpbb 3.0.7-PL1
sonsofanarchyforever.com/forum
twilightbb - subsilver2

How do i remove the multiple Phpbb gallery mods that are showing up in my acp... picture below.....


also getting multiple phpbb albums in the control panel along with some randome code looking link that doesnt link to anything(the first option in pic)

also have 3 different albums showing up in the users profile

any help to clean this up would be much appreciated
This is really simple ;)

Just go to the ACP (Administration Control Panel) > System > Module Management
from their you will see the links to the ACP, MCP, and UCP. Just click on the appropriete links until you get to the duplicate entries for phpBB gallery and delete the duplicates deleting everything inside of the phpBB duplicate modules.
that cleaned up the Control Panel...But...

When i try to delete the two extra gallerys under System, modules, user control panel
it tells me Warning
Unable to remove module, it has assigned children. Please remove or move all children before performing this action.

also, the multiple copies of the gallery preferences are still showing in the profiles.
You ride with an outlaw, You die with an outlaw

Boyobejamin
Registered User
Posts: 71
Joined: Sat Jun 27, 2009 11:18 pm

Re: phpBB Gallery

Post by Boyobejamin » Mon Apr 05, 2010 7:13 pm

Yeah, you have to click on phpBB Gallery and delete everything inside of it.

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: phpBB Gallery

Post by nickvergessen » Mon Apr 05, 2010 10:20 pm

Fantom3D wrote:Hi again. :)
Fantom3D wrote:After successful installation of gallery mod I have troubles with registration of new users. After filling all fields they see such error:

Code: Select all

SQL ERROR [ mysql4 ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'OR user_id IN (1110, 276, 2)' at line 2 [1064]

SQL

SELECT user_id, username, user_email, user_lang, user_jabber, user_notify_type FROM phpbb_users OR user_id IN (1110, 276, 2)

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal_mysql->sql_error()

FILE: includes/functions_dap.php
LINE: 505
CALL: dbal_mysql->sql_query()

FILE: includes/ucp/ucp_register.php
LINE: 437
CALL: dap->notify_admin_dupe_ips()

FILE: includes/functions_module.php
LINE: 507
CALL: ucp_register->main()

FILE: includes/functions_module.php
LINE: 802
CALL: p_master->load_active()

FILE: ucp.php
LINE: 71
CALL: p_master->load()

Gallery is working fine.
forum version: 3.0.6
mysql verison: 5.0.89
You can see this trouble on my forum - http://abonentik.ru/ucp.php?mode=register :?
has nothing to do with this mod.
panhead wrote:I'd like to change the name of the owner/uploader of an image. Can I just update the image_username and image_username_clean fields?
also image_user_colour, image_user_id and on phpbb_gallery_users the user_images
No Support via PM

panhead
Registered User
Posts: 682
Joined: Sat Dec 20, 2003 8:17 pm

Re: phpBB Gallery

Post by panhead » Tue Apr 06, 2010 7:15 am

also image_user_colour, image_user_id and on phpbb_gallery_users the user_images
Thank you Nick. Will this become a standard feature in a next release?

User avatar
sleevedbiker
Registered User
Posts: 789
Joined: Mon Oct 12, 2009 4:33 pm

Re: phpBB Gallery

Post by sleevedbiker » Tue Apr 06, 2010 8:33 am

thanks. the only thing left is the multiple galleries in the profile
You ride with an outlaw, You die with an outlaw

Blazeflack
Registered User
Posts: 50
Joined: Sat May 16, 2009 2:00 pm

Re: phpBB Gallery

Post by Blazeflack » Tue Apr 06, 2010 9:21 am

asinshesq wrote:I'm trying to get the acp config links for this mod to appear under a gallery tab rather than under the default .mods tab. This should be easy but for some reason I can't get it to work no matter what combination of specs I use in adding the modules. Each time I try, I end up with a gallery tab but no side links underneath allowing me to set permissions, configure, etc (even though I set up the gallery config modules with parent set to gallery module and enabled it).

Any hints?

Thanks.
nickvergessen wrote:Just create a new category in ACP > System > Administration-Control-Panel >
Than just go furhter deep to > MODs > and move the gallery module to your own new tab
It's important to note that even though you are presented with the option to choose a parent during install, you HAVE TO let it use the default .MODs parent during install else you will get the issue described above. You can then move the module to its own tab later on in the ACP.

User avatar
ameisez
Registered User
Posts: 1166
Joined: Sun Nov 04, 2007 7:04 am

Re: phpBB Gallery

Post by ameisez » Tue Apr 06, 2010 10:27 am

When I change my the code responsible for displaying the upload button in album_body.html to this

STATIC URL TO UPLOAD BUTTON

Code: Select all

			<!-- IF U_UPLOAD_IMAGE -->
				<td align="{S_CONTENT_FLOW_BEGIN}" valign="middle"><a href="{U_UPLOAD_IMAGE}"><img src="http://www.mysite.com/phpbb3/styles/milky_way/imageset/en/button_upload_image.gif" /></a></td>
			<!-- ENDIF -->
The button shows up. But If I kept the original html file, it doesn't.

Purge cache (styles and boardwide) did not solve the problem. Edit on imageset.cfg has been applied and uploaded.

Anyone knows what's the next move?

May I know where is {UPLOAD_IMG} and {U_UPLOAD_IMAGE} being defined?

Thanks
PHPBB on HOSTGATOR SERVER. MY PERSONAL CHOICE ;)
Need phpBB images and buttons? HIRE ME
my MOD: BB3 Media Player | a phpbb based media player

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: phpBB Gallery

Post by nickvergessen » Tue Apr 06, 2010 10:29 am

Than you either did not edit your imageset.cfg, edit the includes/acp/acp_styles.php or forgot to refresh the imageset afterwards.
No Support via PM

User avatar
ameisez
Registered User
Posts: 1166
Joined: Sun Nov 04, 2007 7:04 am

Re: phpBB Gallery

Post by ameisez » Tue Apr 06, 2010 10:41 am

ameisez wrote:Purge cache (styles and boardwide) did not solve the problem. Edit on imageset.cfg has been applied and uploaded.
I mention I did.

I refresh all styles elements, imageset, templates, themes (info said it said no need to refresh theme)
Went to ACP>Purge Cache>Run Now>OK

EDIT:
Here's my acp_styles.php after editing the line

Code: Select all

			'buttons'	=> array(
				'icon_back_top', 'icon_contact_aim', 'icon_contact_email', 'icon_contact_icq', 'icon_contact_jabber', 'icon_contact_msnm', 'icon_contact_pm', 'icon_contact_yahoo', 'icon_contact_www', 'icon_post_delete', 'icon_post_edit', 'icon_post_info', 'icon_post_quote', 'icon_post_report', 'icon_user_online', 'icon_user_offline', 'icon_user_profile', 'icon_user_search', 'icon_user_warn', 'button_pm_forward', 'button_pm_new', 'button_pm_reply', 'button_topic_locked', 'button_topic_new', 'button_topic_reply', 'button_upload_image',
			),
Here's the last few lines of my imageset.cfg after edit

Code: Select all

img_button_pm_forward =
img_button_pm_new = button_pm_new.gif
img_button_pm_reply = button_pm_s_reply.gif
img_button_topic_locked = button_topic_locked.gif
img_button_topic_new = button_topic_new.gif
img_button_topic_reply = button_topic_reply.gif

img_button_upload_image = button_upload_image.gif
PHPBB on HOSTGATOR SERVER. MY PERSONAL CHOICE ;)
Need phpBB images and buttons? HIRE ME
my MOD: BB3 Media Player | a phpbb based media player

rayminator
Registered User
Posts: 310
Joined: Wed Nov 15, 2006 1:37 pm
Name: raymond green
Contact:

Re: phpBB Gallery

Post by rayminator » Wed Apr 07, 2010 6:00 am

Boyobejamin wrote:
4ndr01d wrote:Hi everyone.

I have installed this mod before, but now i've got a little incovenience.

I have installed it corretly ( i think ), and my ACP is not showing the configurations like before anymore.
It's only in blank. Although its look well on the forum, by clicking create a new album ( Its not possible because you havent the "x" permission ), i think thats working correctly. Its just not showing the configuratios on ACP.

Screen:

http://img101.imageshack.us/img101/2711/screensk.png

http://boxdownload.gofreeserve.com/forum/index.php

I've sent the STYLE things twice.
I've purged the cache.

Thank's. ;)
When you click phpBB Gallery in the Module management, is everything enabled or disabled? If its all disabled all you have to do is enable it and maybe purge the cache
sleevedbiker wrote:using phpbb 3.0.7-PL1
sonsofanarchyforever.com/forum
twilightbb - subsilver2

How do i remove the multiple Phpbb gallery mods that are showing up in my acp... picture below.....


also getting multiple phpbb albums in the control panel along with some randome code looking link that doesnt link to anything(the first option in pic)

also have 3 different albums showing up in the users profile

any help to clean this up would be much appreciated
This is really simple ;)

Just go to the ACP (Administration Control Panel) > System > Module Management
from their you will see the links to the ACP, MCP, and UCP. Just click on the appropriete links until you get to the duplicate entries for phpBB gallery and delete the duplicates deleting everything inside of the phpBB duplicate modules.

all of mine is enabled but it doesn't show up at all

User avatar
zake black
Registered User
Posts: 694
Joined: Fri Jan 23, 2009 8:34 am
Location: Milton Keynes (UK)
Contact:

Re: phpBB Gallery

Post by zake black » Wed Apr 07, 2010 11:17 pm

Hi,

Any one tell me how to change the thumbnail size on the album bb code?

I know you can do it in settings but this changes the thumbs throughout so next and previous, recent images etc. etc.

I only want to resize the images used on the album bb code within a post not the others..

Any ideas?

User avatar
nickvergessen
Former Team Member
Posts: 4397
Joined: Mon Apr 30, 2007 5:33 pm
Location: Stuttgart, Germany
Name: Joas Schilling
Contact:

Re: phpBB Gallery

Post by nickvergessen » Thu Apr 08, 2010 7:19 pm

you can change the bbcode so it uses mode=medium instead of mode=thumbnail
No Support via PM

User avatar
Balsa
Registered User
Posts: 57
Joined: Mon Jul 06, 2009 1:12 pm

Re: phpBB Gallery

Post by Balsa » Sat Apr 10, 2010 11:54 am

I use...

- phpBB 3.0.7-PL1

- First_Topic_Pic_on_ Forum_Index_v_0_0_5_a
- Medals_System_MOD_0.11.1
- categorize_announcements_stickies 1.0.1
- genders_1.0.1

Everything works fine until i try to install phpbb_gallery_1_0_5.

I follow the install instructions, include the files and edit the mentioned files.

When I visit my board and try to log in... I immediately get logged out. If I can't log in, I can't browse to install and run the installer.

Where went I wrong? Please help! ^_^

Locked

Return to “[3.0.x] MOD Database Releases”