Page 12 of 19

Re: Karma MOD

Posted: Mon Mar 01, 2010 1:12 am
by channelasian
Hello,

My purpose to update from 3.0.6 to 3.0.7, but i got the problem here. when i click
Now start the update process by pointing your browser to the install folder.
i got this error message

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/session.php on line 1897: user::require(./../includes/functions_karma.php) [function.user-require]: failed to open stream: No such file or directory

Fatal error: user::require() [function.require]: Failed opening required './../includes/functions_karma.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/h/a/n/hangmeasmp3/html/forum/includes/session.php on line 1897
Is it because of the Karma MoD?

Please help.

Thanks alot

Re: Karma MOD

Posted: Mon Mar 01, 2010 3:12 am
by krawlingkaos
[edited] Thanks for the great mod!

Re: Karma MOD

Posted: Mon Mar 01, 2010 3:21 am
by channelasian
u got the same problem as mine. i am waiting for developer to reply. :(

Re: Karma MOD

Posted: Mon Mar 01, 2010 4:35 am
by Anyasha
I have the same problem.

Re: Karma MOD

Posted: Mon Mar 01, 2010 6:22 am
by m157y
2 channelasian & krawlingkaos & channelasian & Anyasha
Sorry me for this error. Please use this quick fix

2 SuperFedya
It's already done for 1.6.0

Re: Karma MOD

Posted: Mon Mar 01, 2010 7:21 am
by channelasian
m157y wrote:2 channelasian & krawlingkaos & channelasian & Anyasha
Sorry me for this error. Please use this quick fix

2 SuperFedya
It's already done for 1.6.0
Thanks alot man for respond. now i've done my update to 3.0.7.

Re: Karma MOD

Posted: Mon Mar 01, 2010 7:58 am
by m157y
3.0.7 release was earlier then i wait, so update for karma mod wasn't released :(

Re: Karma MOD

Posted: Mon Mar 01, 2010 8:13 am
by channelasian
m157y wrote:3.0.7 release was earlier then i wait, so update for karma mod wasn't released :(
so is it ok between 3.0.7 and karma 1.2.3? still works fine?

Re: Karma MOD

Posted: Mon Mar 01, 2010 8:41 am
by m157y
Yep, it works like on 3.0.6, but as you see little problem at phpbb updater.

Re: Karma MOD

Posted: Mon Mar 01, 2010 12:15 pm
by channelasian
m157y wrote:Yep, it works like on 3.0.6, but as you see little problem at phpbb updater.
well, i c. thanks alot for your hard work, bro.

Re: Karma MOD

Posted: Tue Mar 02, 2010 8:13 pm
by Praetorian Guard
For some reason I only show 3 users on the Karma Top List on the index page, though I have others who have Karma Power and have set the ACP to 20 users. What is wrong, and where should I be looking? Thanks!!!

Re: Karma MOD

Posted: Tue Mar 02, 2010 8:53 pm
by Praetorian Guard
OK, looking at that database and original install schema we have this:

ALTER TABLE [phpbb_users] (
ADD [user_karma] [int] DEFAULT (0) NOT NULL ,
ADD [user_karma_powered] [int] DEFAULT (0) NOT NULL ,
ADD [user_karma_enable] [int] DEFAULT (1) NOT NULL ,
ADD [user_karma_notify_email] [int] DEFAULT (0) NOT NULL ,
ADD [user_karma_notify_pm] [int] DEFAULT (1) NOT NULL ,
ADD [user_karma_notify_jabber] [int] DEFAULT (0) NOT NULL ,
ADD [user_karma_toplist] [int] DEFAULT (1) NOT NULL ,
ADD [user_karma_toplist_users] [int] DEFAULT (3) NOT NULL ,
ADD [user_karma_comments_per_page] [int] DEFAULT (15) NOT NULL ,
ADD [user_karma_comments_self] [int] DEFAULT (1) NOT NULL ,
ADD [user_karma_comments_show_days] [int] DEFAULT (0) NOT NULL ,
ADD [user_karma_comments_sortby_type] [varchar] (1) DEFAULT ('t') NOT NULL ,
ADD [user_karma_comments_sortby_dir] [varchar] (1) DEFAULT ('d') NOT NULL
) ON [PRIMARY]
GO

Is this why I am getting 3 and no more users? For some reason the new value of 20 is not being written to the DB. Thanks!


EDIT*** Changed it to 20 in the db and refreshed the template and cleared the board cookies, and the cache, and now it shows all my users with Karma. This mod is not writing to the Db for some reason through the settings in ACP.

Re: Karma MOD

Posted: Tue Mar 02, 2010 9:14 pm
by Praetorian Guard
OK, something is FUBAR'd!!!! Because even though I made the db change to 20 instead of three, I can see the additional toplist users ONLY if I sign out of the board and view it as a guest. The minute I sign in, I'm back down to three users only in my TopList. It would be nice if someone here could address this issue. Thanks!



**Edit!!! Ok, in the previous post I only changed the default row int value to 20. I had to change all of the col that currently existed for user_karma_toplist_users and user_karma_comments_per_page to 20 (each). If you looked at the columns for these properties they were 3 and 15 respectively because they had already been created using 3 and 15 as the default. Changed these two to both 20 and it works perfect now, no matter if I'm signed on or not. Somebody really needs to fix this!!!!

Re: Karma MOD

Posted: Tue Mar 02, 2010 9:30 pm
by m157y
Agrh. For 1.4.0 this question added to FAQ:
I was changed toplist users value at ACP, but board still shows 3 users at list.
That's not problem, because you're changed default value, which will be used for guests and while registration, but not for already exists users. They must change it via User Control Panel (UCP->Board Preferences->Edit karma settings->Users in toplist)
P.S.
Also for 1.5.0 it'll be changed to 10 users.

Re: Karma MOD

Posted: Tue Mar 02, 2010 9:43 pm
by Praetorian Guard
OK, so should I change the fields back to 3 and 15 in the db???? Or leave it as I have it becuase it works? Thanks!


OK, I got it. Sort of confusing setting the amount of visible posts in ACP and then having to set it in your UCP...