Contact Board Administration

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
unknown2
Registered User
Posts: 676
Joined: Sat Mar 07, 2009 1:34 pm

Re: Contact Board Administration

Post by unknown2 » Sat Mar 27, 2010 2:54 pm

Does this mode allows admin recieave e-mails from users, showing the real e-mail of senders (instead of seeing the e-mail from board in the FROM box)?

azdolfan
Registered User
Posts: 98
Joined: Thu Sep 03, 2009 5:24 am

Re: Contact Board Administration

Post by azdolfan » Sat Mar 27, 2010 8:06 pm

unknown2 wrote:Does this mode allows admin recieave e-mails from users, showing the real e-mail of senders (instead of seeing the e-mail from board in the FROM box)?
Yes, from users or they couldn't respond to guests (at least)! I have this mod installed and what it does for me is if the user is a guest, they have to manually enter their email address when submitting inquiry. If they are a registered user and already logged in, it doesn't ask but pulls from the database the email address. The email will show the return email address so that the admin can respond back. If you want to hide your email address on responding, use a noreply email address. Keep in mind that's only if set up to send emails instead of PMs or Posts. Did I answer your question? :roll:

azdolfan
Registered User
Posts: 98
Joined: Thu Sep 03, 2009 5:24 am

Re: Contact Board Administration

Post by azdolfan » Sun Mar 28, 2010 5:02 am

@ RMcGirr83...

I reposted my problem in the regular support section and told them that someone else reported the same error that wasn't installing this mod but mChat so I didn't think it was related. But two different moderators said I still have to keep it with the mod area and sent me back. :?

But, I decided to just restore a backup. I had to go 3 backups because I know I installed a lot of mods in between the time I suspect the problem occurred. So after restoring, I did this mod first and it worked just fine like I figured. But, now I have the great task to reinstall all the other mods and add all the other changes I made in the last few weeks. Fun, Fun, but at least the problem is gone! Thanks again for going beyond a quick answer. Much appreciated! :D

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Contact Board Administration

Post by RMcGirr83 » Sun Mar 28, 2010 9:52 am

Glad to hear you got it sorted. :)
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

Phil7789
Registered User
Posts: 32
Joined: Mon Mar 22, 2010 3:16 pm
Location: Germany

Re: Contact Board Administration

Post by Phil7789 » Sun Mar 28, 2010 10:45 am

RMcGirr83 wrote:
Phil7789 wrote:EDIT: Checked and everything is set to german (de_DE.utf8) so i really can't figure out why the date is printed in english
What does your PHP information state in the ACP for "Accept-Language"?
The php information states the following:

Code: Select all

_SERVER["HTTP_ACCEPT_LANGUAGE"]	de,de-DE;q=0.9,en;q=0.8
So i guess it should print the date in german, shouldn't it?

Thanks for any help
Phil

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Contact Board Administration

Post by RMcGirr83 » Sun Mar 28, 2010 12:22 pm

It looks like both german and english are set and the server is using the last in the list.

I really don't know anything about server configurations so it may be a question for your host.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

Phil7789
Registered User
Posts: 32
Joined: Mon Mar 22, 2010 3:16 pm
Location: Germany

Re: Contact Board Administration

Post by Phil7789 » Sun Mar 28, 2010 5:38 pm

Alrigth, thanks any way for your help

unknown2
Registered User
Posts: 676
Joined: Sat Mar 07, 2009 1:34 pm

Re: Contact Board Administration

Post by unknown2 » Sun Mar 28, 2010 7:11 pm

azdolfan wrote:Yes, from users or they couldn't respond to guests (at least)! I have this mod installed and what it does for me is if the user is a guest, they have to manually enter their email address when submitting inquiry. If they are a registered user and already logged in, it doesn't ask but pulls from the database the email address. The email will show the return email address so that the admin can respond back. If you want to hide your email address on responding, use a noreply email address. Keep in mind that's only if set up to send emails instead of PMs or Posts. Did I answer your question? :roll:
I you did! Thank you for your help ;)

User avatar
Jaifaime
Registered User
Posts: 170
Joined: Wed Jun 10, 2009 12:16 am

Re: Contact Board Administration

Post by Jaifaime » Sat Apr 03, 2010 8:58 pm

I've used this mod on 2 sites with now issues, works perfectly. However, a third site now I get nothing but a blank white page with "The service is unavailable" and I can't figure out why. I've checked edits three times, I've reuploaded files in case of bad file transfer, the mod is enabled in the .MODS tab, I have installed, uninstalled, and reinstalled it, I get nothing but that error. It said something about new permissions being added after the install, all I could find was the admin permission about "can manage...", and I don't recall having to set permissions for users to be able to view the contact page. I've run out of obvious things to check, any ideas?

Phpbb 3.0.7-PL1
Burnerz style (prosilver based)
This account is inactive. Have a nice day.

Phil7789
Registered User
Posts: 32
Joined: Mon Mar 22, 2010 3:16 pm
Location: Germany

Re: Contact Board Administration

Post by Phil7789 » Wed Apr 07, 2010 2:46 pm

Hey,
i have a little problem with this mod. My first installation seemed to work perfectly but after a new installation i receive the following error:

Code: Select all

Board Administration kontaktieren
PHP Version: 5.2.11
DBMS: MySQL(i) 4.1.22-standard-log
phpBB3 Version: 3.0.7-PL1

Eine neue Spalte contact_urls_allowed der Tabelle ge_phpbb_contact_config hinzufügen
SQL ERROR Table 'db271645.ge_ge_phpbb_contact_config' doesn't exist

Eine neue Spalte contact_username_chk der Tabelle ge_phpbb_contact_config hinzufügen
SQL ERROR Table 'db271645.ge_ge_phpbb_contact_config' doesn't exist

Eine neue Spalte contact_email_chk der Tabelle ge_phpbb_contact_config hinzufügen
SQL ERROR Table 'db271645.ge_ge_phpbb_contact_config' doesn't exist
The problem is that the table was created correct, but the installation script adds an additional prefix to the table.
Instead of

Code: Select all

ge_ge_phpbb_contact_config
The table is

Code: Select all

ge_phpbb_contact_config
Hope you can help me. Seems that this could be a problem within the contact_install.php?

What's additional irritating is the fact that those columns ARE created, at least i can see them via phpMyAdmin:

Code: Select all

contact_urls_allowed 	tinyint(1) 	Nein 	0 	 
contact_username_chk 	tinyint(1) 	Nein 	0 	 
contact_email_chk 	tinyint(1) 	Nein 	0 
Phil
Last edited by Phil7789 on Wed Apr 07, 2010 2:53 pm, edited 1 time in total.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Contact Board Administration

Post by RMcGirr83 » Wed Apr 07, 2010 2:51 pm

Please check your edits to includes/constants.php.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

Phil7789
Registered User
Posts: 32
Joined: Mon Mar 22, 2010 3:16 pm
Location: Germany

Re: Contact Board Administration

Post by Phil7789 » Wed Apr 07, 2010 2:54 pm

Woops didn't see you already answered ;) thx for the quick reply.

Which edits should i check? There are no edits made by this mod

Oh and btw did you notice my edit in the post above? The columns are somehow created although they should not have been according to the installation file

EDIT: There's a last thing just came to my mind... I installed the last version of UMIL, could that cause the problem, as i am not using the version of umil the mod uses?

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Contact Board Administration

Post by RMcGirr83 » Wed Apr 07, 2010 3:27 pm

Phil7789 wrote:Woops didn't see you already answered ;) thx for the quick reply.

Which edits should i check? There are no edits made by this mod
Nevermind, got it confused with another mod.
Oh and btw did you notice my edit in the post above? The columns are somehow created although they should not have been according to the installation file
Yes I saw that
EDIT: There's a last thing just came to my mind... I installed the last version of UMIL, could that cause the problem, as i am not using the version of umil the mod uses?
Don't know, this mod uses the installer and I can't come close to reproducing the problem. Have you ever run across this installing any other mod that uses UMIL? Can you post up your config.php file removing the user and password for the database entries?
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

Phil7789
Registered User
Posts: 32
Joined: Mon Mar 22, 2010 3:16 pm
Location: Germany

Re: Contact Board Administration

Post by Phil7789 » Wed Apr 07, 2010 4:15 pm

Well i have installed some mods that brought UMIL files with them (i downloaded the version i am using right know from the homepage so it is not related to any mod)

Here's my config.php

Code: Select all

<?php
// phpBB 3.0.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'mysqli';
$dbhost = 'mysql4.gameagle.net';
$dbport = '';
$dbname = 'db271645';
$dbuser = '*********';
$dbpasswd = '********';
$table_prefix = 'ge_phpbb_';
$acm_type = 'file';
$load_extensions = '';

@define('PHPBB_INSTALLED', true);
// @define('DEBUG', true);
// @define('DEBUG_EXTRA', true);
?>
This is just a demo webspace i am testing the mods until i can release our "real" board. The only difference between those two webspaces is the version of MySQL and PHP which is lower on the demo webspace, but i think this should not make any problems ;)

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Contact Board Administration

Post by RMcGirr83 » Wed Apr 07, 2010 4:21 pm

I have no idea where the ge_ge is coming from. Is it possible you installed it on one forum but think you installed it on the other?
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

Locked

Return to “[3.0.x] MOD Database Releases”