Country Flag User Edition

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
nicolass
Registered User
Posts: 6
Joined: Mon Mar 22, 2010 10:55 am
Name: Nick Hyde

Re: Country Flag User Edition

Post by nicolass » Tue Mar 30, 2010 8:17 am

Odd

I also use 3.0.7-PL1,

nicolass
Registered User
Posts: 6
Joined: Mon Mar 22, 2010 10:55 am
Name: Nick Hyde

Re: Country Flag User Edition

Post by nicolass » Tue Mar 30, 2010 8:39 am

Looking at the error

SQL ERROR [ mysql4 ]

Table 'web101-a-foru-66.FLAGS_TABLE' doesn't exist [1146]

I had a look at the database and the Table exists as:
phpbb_flags

and within this table the following fields:
flag_id
flag_country
flag_code
flag_image

so in the error message:
----------------------------------------------------------------
SQL

SELECT * FROM FLAGS_TABLE ORDER BY flag_country

BACKTRACE
---------------------------------------------------------------
Is as it should be so I am assuming it is the way, the MOD has been installed.

I am not an expert on MySql, but hoping for some info which would point me in the right direction.

Thanks

azdolfan
Registered User
Posts: 98
Joined: Thu Sep 03, 2009 5:24 am

Re: Country Flag User Edition

Post by azdolfan » Tue Mar 30, 2010 8:54 am

I installed this mod a few weeks ago and everything seemed fine, but I noticed that some how the whole "Country" selection field is no longer there on the registration page. And, what makes it worse is that you always get an error when submitting saying "you must select your country flag". So, users can not register at all because that field doesn't show on form. I have to disable so people can register, but I'm attaching a screen shot of the form showing it not there and the error showing. However, the image gets removed after so long so hopefully somebody sees it before it gets removed. Thanks!
country flag registering.png
country flag registering.png (55.49 KiB) Viewed 1007 times

User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Re: Country Flag User Edition

Post by Gremlinn » Tue Mar 30, 2010 12:50 pm

azdolfan: Double check your template edits. Make sure you have the CFUE edits where they need to be.

nicolass: Check your constants.php edits. It looks like you are missing something there or have a bad edit.

nicolass
Registered User
Posts: 6
Joined: Mon Mar 22, 2010 10:55 am
Name: Nick Hyde

Re: Country Flag User Edition

Post by nicolass » Tue Mar 30, 2010 1:57 pm

OK Thanks

Will do.

It does seem I have a common problem because I installed another MOD Welcome PM settings and a similar error has appeared, after the installation no errors were reported until I selected the function from the users group.


General Error
SQL ERROR [ mysql4 ]

Table 'web101-a-foru-66.WPM_TABLE' doesn't exist [1146]

SQL

SELECT * FROM WPM_TABLE WHERE wpm_config_id = WPM_CONFIG_ID

BACKTRACE


FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

So I must be doing something wrong!.

Thanks

nicolass
Registered User
Posts: 6
Joined: Mon Mar 22, 2010 10:55 am
Name: Nick Hyde

Re: Country Flag User Edition

Post by nicolass » Tue Mar 30, 2010 2:32 pm

Hi Gremlinn

The file found at this location: /public_html/forum/includes
Looks like there is a problem with the Constants.php file.


The section // Table names
there are is no definition for the Database Flags_TABLE
and this includes the other database WPM_TABLE

The includes directory has 711 permission and 755 for sub-directories of it.

Is is just the case of editing the Contants.php to include the definitions?

Thanks

azdolfan
Registered User
Posts: 98
Joined: Thu Sep 03, 2009 5:24 am

Re: Country Flag User Edition

Post by azdolfan » Tue Mar 30, 2010 11:20 pm

New postby Gremlinn » Tue Mar 30, 2010 4:50 am
azdolfan: Double check your template edits. Make sure you have the CFUE edits where they need to be.
That was it! But I just can't figure out how some files changed on 3/16. I keep versions and dates of my changes and nothing matches up except I installed the donation mod that day but they don't have related files. And, I've never had to change anything in the register files. Anyway, I've fixed the problem so I hope it stays that way. Thanks for your help! :D

User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Re: Country Flag User Edition

Post by Gremlinn » Wed Mar 31, 2010 12:32 pm

azdolfan: Great.

nicolass: A directory with the permissions 711 will not be able to be looked into by anyone other than the owner of that directory. Normal permissions for a directory is 755, where the 7 means that the owner can read and also write to that directory. Unless, your web server is also the owner of that directory, 711 will not work out well.
Now, with that said, you will need to add anything that is missing from the contacts.php file.

seven7pie
Registered User
Posts: 13
Joined: Tue Feb 23, 2010 7:50 am

Re: Country Flag User Edition

Post by seven7pie » Wed Mar 31, 2010 4:19 pm

I don't have "Country flag settings" on my .MODs-tab, it only shows "Manage country flags".

Can anyone tell me where is the "Country flag settings"?

Thank you.

azdolfan
Registered User
Posts: 98
Joined: Thu Sep 03, 2009 5:24 am

Re: Country Flag User Edition

Post by azdolfan » Wed Mar 31, 2010 10:41 pm

seven7pie wrote:I don't have "Country flag settings" on my .MODs-tab, it only shows "Manage country flags".

Can anyone tell me where is the "Country flag settings"?

Thank you.
Did you follow the complete DIY that goes with this mod? Where you add the settings to the .mods tab? Review those notes and and see what happens. The part your probably missing is the System > Module Management > ACP > .mods > Add Settings Module

AzAce
Registered User
Posts: 6
Joined: Wed Aug 12, 2009 8:02 pm

Re: Country Flag User Edition

Post by AzAce » Mon Apr 12, 2010 7:12 pm

I got these errors after I installed the mod and then uploaded the edited files.

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4284: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4286: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4287: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4288: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)

User avatar
onehundredandtwo
Registered User
Posts: 1228
Joined: Fri Nov 14, 2008 8:07 am

Re: Country Flag User Edition

Post by onehundredandtwo » Mon Apr 12, 2010 7:38 pm

Try saving both of those files with another editor, such as Notepad++. Ensure that it is saved with the encoding UTF-8 without BOM.
Need help preventing spam? Read Preventing spam in phpBB 3.0.6 and above

dok69
Registered User
Posts: 1
Joined: Wed Apr 14, 2010 8:04 pm

Re: Country Flag User Edition

Post by dok69 » Wed Apr 14, 2010 8:32 pm

Good evening!
Now updated with a 3.06 to 3.07 l, set modes CFUE_1.2.1 (flags)
and ACP / modules / ACP_FLAG_SETTINGS is such byaka pops:
ACP.jpg
ACP.jpg (14.84 KiB) Viewed 910 times
He went right to access / Admin Role and there
ACP1.jpg
ACP1.jpg (36.13 KiB) Viewed 910 times
Weácan in which file the problem was there?

azdolfan
Registered User
Posts: 98
Joined: Thu Sep 03, 2009 5:24 am

Re: Country Flag User Edition

Post by azdolfan » Wed Apr 14, 2010 10:39 pm

@doc 69 - It's your language files. You need to copy the translated mod language files and copy in to yourforum/language/yourlanguage/newmodfiles ;)

ADEOBI
Registered User
Posts: 11
Joined: Tue Mar 23, 2010 11:00 pm
Name: ADE OBI

Re: Country Flag User Edition

Post by ADEOBI » Thu Apr 15, 2010 1:11 pm

I use automod for uninstalling and i get this proble
Image
how to fix this problem
General Error
SQL ERROR [ mysql4 ]

Unknown column 'u.user_flag' in 'field list' [1054]

SQL

SELECT u.user_id, u.group_id as default_group, u.username, u.username_clean, u.user_colour, u.user_flag, u.user_rank, u.user_posts, u.user_allow_pm, g.group_id, g.group_name, g.group_colour, g.group_type, ug.user_id as ug_user_id FROM (phpbb_users u, phpbb_groups g) LEFT JOIN phpbb_user_group ug ON (ug.group_id = g.group_id AND ug.user_pending = 0 AND ug.user_id = 2) WHERE u.user_id IN (53, 2, 955, 1730, 128, 55, 1056, 1003, 1061, 110) AND u.group_id = g.group_id ORDER BY g.group_name ASC, u.username_clean ASC

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: memberlist.php
LINE: 175
CALL: dbal_mysql->sql_query()

Locked

Return to “[3.0.x] MOD Database Releases”