Instant Post Redirect

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
User avatar
Trinity
Registered User
Posts: 474
Joined: Wed Dec 11, 2002 10:06 pm
Location: Hollywood, CA

Re: Instant Post Redirect

Post by Trinity » Mon Feb 04, 2008 5:11 pm

Oh okay. I thought for some reason it was having issues with the .php code or something. :roll:
Shop smart, shop S-mart.

xkphmp
Registered User
Posts: 7
Joined: Tue Feb 05, 2008 8:31 pm
Contact:

Re: Instant Post Redirect

Post by xkphmp » Tue Feb 05, 2008 9:02 pm

thanks for this

dzedward
Registered User
Posts: 61
Joined: Thu Dec 06, 2007 8:02 pm
Contact:

Re: Instant Post Redirect

Post by dzedward » Fri Feb 08, 2008 3:59 pm

I used the global redirect edits, and its working great, however the "whos online" is receiving "The page isn't redirecting properly" in firefox, and won't even load in IE. I've done the edit to viewonline.php that said it corrected that. Any ideas?

Freedom Fighter
Registered User
Posts: 59
Joined: Fri Dec 14, 2007 12:41 am

Re: Instant Post Redirect

Post by Freedom Fighter » Tue Feb 12, 2008 7:00 am

dzedward wrote:I used the global redirect edits, and its working great, however the "whos online" is receiving "The page isn't redirecting properly" in firefox, and won't even load in IE. I've done the edit to viewonline.php that said it corrected that. Any ideas?
Yeah Iv'e just tried setting the meta_refresh functions 2nd parameter for calling the refresh function to false ,and it broke the "whose online" redirect in firefox.

iftitaj
Registered User
Posts: 638
Joined: Tue Jan 15, 2008 6:21 am
Location: Karachi, Pakistan

Re: Instant Post Redirect

Post by iftitaj » Wed Feb 13, 2008 6:55 am

I downloaded this MOD but am confused about few things, plz help me.

> I want to use alternative IPR which give user option to choose whether they want it or not under /contrib/ipr_ucp folder. Thats fine but does it includes IE fix & on which redirections it applies to. Does it has all redirection option or only applies to Posting New Post.

I want to give user the option to enable/disable it & at the same time, want to apply it on all redirections if they enable it - which MOD should I install which should have IE fix also? In short a complete package.

Thanx

User avatar
ThunderCrew
Registered User
Posts: 1438
Joined: Sat Jun 30, 2007 6:26 pm
Location: Ill, Usa
Contact:

Re: Instant Post Redirect

Post by ThunderCrew » Thu Feb 14, 2008 12:01 am

well Ive still had NO luck with this one. :shock: this is soooo odd. Could I just go change all instances of meta 10 etc to meta 1 ? to speed it up at least if not make it instant :lol: ???
Ugg im a t0tal newb again ...... 2 years off cant remember jack ... time to get to it

roBBx
Registered User
Posts: 287
Joined: Fri Feb 15, 2008 3:00 am
Contact:

Re: Instant Post Redirect

Post by roBBx » Fri Feb 15, 2008 3:16 am

Hi to all :)

First of all many thanks to eviL<3 for this mod! As far as I'm concerned, the IE-fix causes Firefox to redirect to the top of the page (before this fix it worked fine). I noted that after having posted the url becomes always in the form:

viewtopic.php?f=x&t=y&p=z&ipr_p=z (x,y,z are numbers)

Should the piece of string ipr_p appear as it is? :?

PhpBB 3.0.0 & Firefox 2.0.0.12 over Windows XP Pro. Thanks in advance for any help :)

Hugh1981
Registered User
Posts: 2
Joined: Fri Feb 15, 2008 1:32 pm

Re: Instant Post Redirect

Post by Hugh1981 » Fri Feb 15, 2008 1:39 pm

evil<3

1. Thank you very much for putting the time in to get this working for all of us. :)
2. For me, this works fine in Firefox, but not in IE7. IE7 redirects to the top of the topic page.
3. The MOD's addon (ie_fix.xml from 1.0.2) instructs me to copy/paste a section of code into posting.php which is different to the code you've posted in this thread.

Code in this thread:

Code: Select all

                // ipr_p
                if (strpos($redirect_url, '#') !== false)
                {
                   $redirect_url = substr_replace($redirect_url, "&ipr_p={$data['post_id']}#", strrpos($redirect_url, '#'));
                }
Code in ie_fix.xml:

Code: Select all

				// ipr_p
				if (($pos = strrpos($redirect_url, '#')) !== false)
				{
					$redirect_url = substr_replace($redirect_url, "&ipr_p={$data['post_id']}", $pos);
				}
(A) Which should I be using?
(B) Neither of them work for me in IE7 - I've tried both.

As there are so many different requests going on in this thread, bor PM and login redirects etc, could you please post a definitive step-by-step to get the instant post redirect working in IE7 (and Firefox)?

Thanks in advance. :)

User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Re: Instant Post Redirect

Post by igorw » Fri Feb 15, 2008 10:30 pm

roBBx wrote:viewtopic.php?f=x&t=y&p=z&ipr_p=z (x,y,z are numbers)

Should the piece of string ipr_p appear as it is? :?
Seems like you missed the fix edit in viewtopic.php.
Hugh1981 wrote:(A) Which should I be using?
(B) Neither of them work for me in IE7 - I've tried both.
A) both do the same, you should use the one from the download
B) I'll take a look at it...
Igor Wiedler | area51 | GitHub | trashbin | Formerly known as evil less than three

roBBx
Registered User
Posts: 287
Joined: Fri Feb 15, 2008 3:00 am
Contact:

Re: Instant Post Redirect

Post by roBBx » Sat Feb 16, 2008 2:26 am

eviL<3 wrote:
roBBx wrote:viewtopic.php?f=x&t=y&p=z&ipr_p=z (x,y,z are numbers)

Should the piece of string ipr_p appear as it is? :?
Seems like you missed the fix edit in viewtopic.php.
Yes, that was the problem! I didn't realize the code

Code: Select all

trigger_error('NO_TOPIC');
}
appears 8 times and probably pasted the fix in the wrong place. Shell we paste the fix 8 times? I made so and now it works fine with both Firefox and IE 6.0 :D Then I tried to delete some of them and it worked, too :)

Hugh1981
Registered User
Posts: 2
Joined: Fri Feb 15, 2008 1:32 pm

Re: Instant Post Redirect

Post by Hugh1981 » Sat Feb 16, 2008 8:02 am

eviL<3 wrote:
Hugh1981 wrote:(A) Which should I be using?
(B) Neither of them work for me in IE7 - I've tried both.
A) both do the same, you should use the one from the download
B) I'll take a look at it...
Thanks! Out of interest, what version/s of IE have you developed/tested on?

iftitaj
Registered User
Posts: 638
Joined: Tue Jan 15, 2008 6:21 am
Location: Karachi, Pakistan

Re: Instant Post Redirect

Post by iftitaj » Sat Feb 16, 2008 11:57 am

Evil<3! Plz answer my query - I'm very confused about it.
iftitaj wrote:I downloaded this MOD but am confused about few things, plz help me.

> I want to use alternative IPR which give user option to choose whether they want it or not under /contrib/ipr_ucp folder. Thats fine but does it includes IE fix & on which redirections it applies to. Does it has all redirection option or only applies to Posting New Post.

I want to give user the option to enable/disable it & at the same time, want to apply it on all redirections if they enable it - which MOD should I install that should have IE fix also? In short a complete package.

Thanx

User avatar
ThunderCrew
Registered User
Posts: 1438
Joined: Sat Jun 30, 2007 6:26 pm
Location: Ill, Usa
Contact:

Re: Instant Post Redirect

Post by ThunderCrew » Sat Feb 16, 2008 3:41 pm

roBBx wrote:
eviL<3 wrote:
roBBx wrote:viewtopic.php?f=x&t=y&p=z&ipr_p=z (x,y,z are numbers)

Should the piece of string ipr_p appear as it is? :?
Seems like you missed the fix edit in viewtopic.php.
Yes, that was the problem! I didn't realize the code

Code: Select all

trigger_error('NO_TOPIC');
}
appears 8 times and probably pasted the fix in the wrong place. Shell we paste the fix 8 times? I made so and now it works fine with both Firefox and IE 6.0 :D Then I tried to delete some of them and it worked, too :)

So should I try that ? I only did it for the first occurance of the code since the install does not say find all occourances. I guess I can try that today. But seems you are saying once you applied the install code to all instances of

Code: Select all

trigger_error('NO_TOPIC');
}
it worked
Ugg im a t0tal newb again ...... 2 years off cant remember jack ... time to get to it

User avatar
ThunderCrew
Registered User
Posts: 1438
Joined: Sat Jun 30, 2007 6:26 pm
Location: Ill, Usa
Contact:

Re: Instant Post Redirect

Post by ThunderCrew » Sat Feb 16, 2008 4:21 pm

Well this is odd. :? When I took out all of the coding in posting.php that I had added from this mod BAM I have instant post redirect now. New message / or reply to message both. I post then submit and it goes to click for last topic or click for last forum instantly without a meta refresh. Not sure why or how doesnt make sence to me, but it does now.

So in my posting.php where I had added your

Code: Select all

//-- mod : Instant Post Redirect ------------------------------------------------------------
//-- add
// ipr_p
if (isset($_GET['ipr_p']))
{
	$ipr_p = request_var('ipr_p', 0);
	redirect("{$phpbb_root_path}viewtopic.$phpEx?p=$ipr_p#p$ipr_p");
}
			redirect($redirect_url);
//-- fin mod : Instant Post Redirect --------------------------------------------------------
and gotten no results for redirecting without the meta refresh crap I just deleted the above code and was gonna start fresh again but tested posting to make sure I did not break the posting programing and umm it worked instantly without meta junk. ODD :shock:
Ugg im a t0tal newb again ...... 2 years off cant remember jack ... time to get to it

iftitaj
Registered User
Posts: 638
Joined: Tue Jan 15, 2008 6:21 am
Location: Karachi, Pakistan

Re: Instant Post Redirect

Post by iftitaj » Sat Feb 16, 2008 5:11 pm

^^ Even after purging cache ???? :?

Locked

Return to “[3.0.x] MOD Database Releases”