Evil Quick Reply

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
HoosierDaddy
Registered User
Posts: 15
Joined: Tue Jul 14, 2009 10:06 pm

Re: Evil Quick Reply

Post by HoosierDaddy » Wed Jul 15, 2009 3:00 am

I just tried to install this mod in 3.0.5 and I have an issue.

Image

As you can see from the screenshot, the quick reply box is below everything. What part of the code needs changed for it to be directly beneath the posts and above the footer. I put it exactly where it says throughout the tutorial. Any help is greatly appreciated, thanks!

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: Evil Quick Reply

Post by leviatan21 » Wed Jul 15, 2009 3:21 am

HoosierDaddy wrote:I just tried to install this mod in 3.0.5 and I have an issue.

As you can see from the screenshot, the quick reply box is below everything. What part of the code needs changed for it to be directly beneath the posts and above the footer. I put it exactly where it says throughout the tutorial. Any help is greatly appreciated, thanks!
Can you tell which style is it, and post your viewtopic_body.html file
Also a link to your forum will be better ;)
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

HoosierDaddy
Registered User
Posts: 15
Joined: Tue Jul 14, 2009 10:06 pm

Re: Evil Quick Reply

Post by HoosierDaddy » Wed Jul 15, 2009 4:04 am

The style is AeroBlack

The link to the forum is http://www.vincecarteronline.net/forum

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: Evil Quick Reply

Post by leviatan21 » Wed Jul 15, 2009 4:19 am

HoosierDaddy wrote:The style is AeroBlack

The link to the forum is http://www.vincecarteronline.net/forum
I don't see the changes to the viewtopic_body.html file on your server :?
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: Evil Quick Reply

Post by leviatan21 » Wed Jul 15, 2009 4:43 am

HoosierDaddy wrote:The style is AeroBlack

The link to the forum is http://www.vincecarteronline.net/forum
Also you can read some post about Aero styles and QR since this page
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

HoosierDaddy
Registered User
Posts: 15
Joined: Tue Jul 14, 2009 10:06 pm

Re: Evil Quick Reply

Post by HoosierDaddy » Wed Jul 15, 2009 5:35 pm

I actually overwrote the files and was going to start fresh again. I tried inserting the provided viewtopic_body.html file in the links you provided, and it put the quick reply box in the same spot I was referring to initially.

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: Evil Quick Reply

Post by leviatan21 » Wed Jul 15, 2009 8:14 pm

HoosierDaddy wrote:I actually overwrote the files
If I can't see, I can't find the problem ;)
HoosierDaddy wrote: I tried inserting the provided viewtopic_body.html file in the links you provided, and it put the quick reply box in the same spot I was referring to initially.
Did you purge the cache and refresh all related to this style ?
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

cherryaa
Registered User
Posts: 25
Joined: Sun May 10, 2009 1:54 am

Re: Evil Quick Reply - Button

Post by cherryaa » Thu Jul 16, 2009 12:47 pm

I've just installed this mod and am VERY happy with it - thanks, Evil! 8-)

A lot of people still seem to be suffering from "missing button" disease - and I did, too. I had the Quick Reply text link, but not the image. This turned out to be because of the insane number of css files used with the Prosilver SE edition; no matter how much I de-cached & refreshed, the entire stylesheet wasn't getting written.

One way to hurry it up is as follows:
* Look in the on-board imageset editor, to make sure the Quick Reply button is listed in the Prosilver SE en imageset. (If not, perhaps you didn't upload both of the corrected imageset.cfg files)
* Use the on-board editor to change buttons.css and colours.css, which are in the Prosilver theme set.
* Check that you can now see the button.
* Upload the corrected stylesheets.
* Refresh both themes.

If you want your Quick Reply button next to the Reply button instead of below it, add a second "buttons" div around it. Your viewtopic_body.html file will now look like this:

Code: Select all

<div class="topic-actions">
	<div class="buttons">
	<!-- IF not S_IS_BOT and S_DISPLAY_REPLY_INFO -->
		<div class="<!-- IF S_IS_LOCKED -->locked-icon<!-- ELSE -->reply-icon<!-- ENDIF -->"><a href="{U_POST_REPLY_TOPIC}" title="<!-- IF S_IS_LOCKED -->{L_TOPIC_LOCKED}<!-- ELSE -->{L_POST_REPLY}<!-- ENDIF -->"><span></span><!-- IF S_IS_LOCKED -->{L_TOPIC_LOCKED_SHORT}<!-- ELSE -->{L_POST_REPLY}<!-- ENDIF --></a></div>
	</div>
	<div class="buttons">
		<!-- IF S_QR_ENABLED --><div class="quick-reply-icon"><a href="javascript:toggle_quick_reply();" title="{L_QUICK_REPLY}"><span></span>{L_QUICK_REPLY}</a></div><!-- ENDIF -->
	<!-- ENDIF -->
	</div>
As the "buttons" div floats left, it will sit next to the preceding one.

Cheers :)
Cherry

User avatar
Elitzur
I've Been Banned!
Posts: 323
Joined: Sat Sep 15, 2007 7:49 am
Location: Europe, UK.
Contact:

Re: Evil Quick Reply

Post by Elitzur » Thu Jul 16, 2009 5:12 pm

Hey, I have installed this MOD using AutoMOD, There are a few problems, the link to the
quick reply is at the bottom of the post, I would like the button to be displayed at the top as
well as the bottom, and also the image is not showing up.

Any help please? Thanks.

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: Evil Quick Reply

Post by leviatan21 » Thu Jul 16, 2009 5:49 pm

Elitzur wrote:Hey, I have installed this MOD using AutoMOD, There are a few problems, the link to the
quick reply is at the bottom of the post, I would like the button to be displayed at the top as
well as the bottom, and also the image is not showing up.

Any help please? Thanks.
You forget to do some changes for your style :

Code: Select all

http://www.djforums.info/phpbb/styles/proglass/imageset/en/imageset.cfg
http://www.djforums.info/phpbb/styles/proglass/theme/buttons.css
http://www.djforums.info/phpbb/styles/proglass/theme/colours.css
After you do it, don't forget to purge your board cache, and refresh template, theme and imageset ;)
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

User avatar
Elitzur
I've Been Banned!
Posts: 323
Joined: Sat Sep 15, 2007 7:49 am
Location: Europe, UK.
Contact:

Re: Evil Quick Reply

Post by Elitzur » Thu Jul 16, 2009 5:51 pm

I installed it with AutoMOD, but when I found out that it was broke, I uninstalled it :P ;) :)

I will go and put it back on, and then see what I need to do, thanks for the response though :)


*EDIT: I need help, I have installed the MOD again, but I have added the BBCode and Smilies however
they both get duplicated, so when you open the QR box it shows two lists of smilies and bbcodes.

Any help please?

Thanks.

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: Evil Quick Reply

Post by leviatan21 » Thu Jul 16, 2009 6:25 pm

Elitzur wrote:I installed it with AutoMOD, but when I found out that it was broke, I uninstalled it :P ;) :)

I will go and put it back on, and then see what I need to do, thanks for the response though :)


*EDIT: I need help, I have installed the MOD again, but I have added the BBCode and Smilies however
they both get duplicated, so when you open the QR box it shows two lists of smilies and bbcodes.

Any help please?

Thanks.
You have duplicated code, please delete this first coincidence, in your

Code: Select all

http://www.djforums.info/phpbb/styles/proglass/template/posting_qr_body.html
:

Code: Select all

			<!-- INCLUDE posting_buttons.html -->
			
			<dl id="smiley-box">
				<!-- IF S_SMILIES_ALLOWED and .smiley -->
					<strong>{L_SMILIES}</strong><br />
					<!-- BEGIN smiley -->
						<a href="#" onclick="insert_text('{smiley.A_SMILEY_CODE}', true); return false;"><img src="{smiley.SMILEY_IMG}" width="{smiley.SMILEY_WIDTH}" height="{smiley.SMILEY_HEIGHT}" alt="{smiley.SMILEY_CODE}" title="{smiley.SMILEY_DESC}" /></a>
					<!-- END smiley -->
				<!-- ENDIF -->

				<!-- IF S_SHOW_SMILEY_LINK and S_SMILIES_ALLOWED-->
					<br /><a href="{U_MORE_SMILIES}" onclick="popup(this.href, 300, 350, '_phpbbsmilies'); return false;">{L_MORE_SMILIES}</a>
				<!-- ENDIF -->
			</dl>
Remember refresh your template after the change ;)
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

User avatar
Elitzur
I've Been Banned!
Posts: 323
Joined: Sat Sep 15, 2007 7:49 am
Location: Europe, UK.
Contact:

Re: Evil Quick Reply

Post by Elitzur » Thu Jul 16, 2009 6:31 pm

Hmm... I deleted the extra code, however there is now a big gap between the qr box and the smilies...

Any help? Thanks :)

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: Evil Quick Reply

Post by leviatan21 » Thu Jul 16, 2009 6:43 pm

Elitzur wrote:Hmm... I deleted the extra code, however there is now a big gap between the qr box and the smilies...

Any help? Thanks :)
Please use this posting_qr_body.html file :

Code: Select all

<script type="text/javascript">
<!--
/**
 * Toggle the visibility of the qr box
 */
function toggle_quick_reply()
{
	if (document.getElementById('quick_reply'))
	{
		if (document.getElementById('quick_reply').style.display == 'none')
		{
			document.getElementById('quick_reply').style.display = 'block';
		}
		else
		{
			document.getElementById('quick_reply').style.display = 'none';
		}
	}
}

if (<!-- IF S_QR_HIDE_BOX -->1<!-- ELSE -->0<!-- ENDIF -->)
{
	if (document.addEventListener)
	{
		document.addEventListener('DOMContentLoaded', toggle_quick_reply, false);
	}
	else
	{
		onload_functions.push('toggle_quick_reply()');
	}
}
//-->
</script>

<div id="quick_reply">

	<form action="{S_QR_POST_ACTION}" method="post" id="postform">

		<div class="panel" id="postingbox">
			<div class="inner"><span class="corners-top"><span></span></span>

			<h3>{L_POST_REPLY}</h3>

			<fieldset class="fields1">

			<!-- IF S_QR_SUBJECT -->
			<dl>
				<dt><label for="subject">{L_SUBJECT}:</label></dt>
				<dd>
					<input type="text" name="subject" id="subject" size="45" maxlength="64" class="inputbox" value="{SUBJECT}" tabindex="1" />
				</dd>
			</dl>
			<!-- ENDIF -->

			<!-- INCLUDE posting_buttons.html -->

			<div id="smiley-box">
				<!-- IF S_SMILIES_ALLOWED and .smiley -->
					<strong>{L_SMILIES}</strong><br />
					<!-- BEGIN smiley -->
						<a href="#" onclick="insert_text('{smiley.A_SMILEY_CODE}', true); return false;"><img src="{smiley.SMILEY_IMG}" width="{smiley.SMILEY_WIDTH}" height="{smiley.SMILEY_HEIGHT}" alt="{smiley.SMILEY_CODE}" title="{smiley.SMILEY_DESC}" /></a>
					<!-- END smiley -->
				<!-- ENDIF -->
				<!-- IF S_SHOW_SMILEY_LINK and S_SMILIES_ALLOWED-->
					<br /><a href="{U_MORE_SMILIES}" onclick="popup(this.href, 300, 350, '_phpbbsmilies'); return false;">{L_MORE_SMILIES}</a>
				<!-- ENDIF -->
			</div>

			<div id="message-box">
				<textarea name="message" id="message" rows="10" cols="76" class="inputbox" tabindex="2">{MESSAGE}</textarea>
			</div>
			</fieldset>

			<span class="corners-bottom"><span></span></span></div>
		</div>

		<!-- IF not S_USER_LOGGED_IN -->
		<div class="panel bg2">
			<div class="inner"><span class="corners-top"><span></span></span>

			<fieldset class="fields1">
				<div class="column1">
				<dl>
					<dl>
						<dt><label for="username">{L_USERNAME}:</label></dt>
						<dd><input type="text" tabindex="3" name="username" id="username" size="25" maxlength="30" class="inputbox" /></dd>
					</dl>
					<!-- IF S_CONFIRM_CODE -->
					<dl>
						<dt><label for="confirm_code">{L_CONFIRM_CODE}:</label></dt>
							<dd><input type="hidden" name="confirm_id" value="{CONFIRM_ID}" />{CONFIRM_IMAGE}</dd>
							<dd><input type="text" name="confirm_code" id="confirm_code" size="8" maxlength="8" tabindex="4" class="inputbox narrow" title="{L_CONFIRM_CODE}" /></dd>
					</dl>
					<!-- ENDIF -->
				</dl>
				</div>
			</fieldset>

			<span class="corners-bottom"><span></span></span></div>
		</div>
		<!-- ENDIF -->

		<div class="panel bg2">
			<div class="inner"><span class="corners-top"><span></span></span>

			<fieldset class="submit-buttons">
				{S_FORM_TOKEN}
				{S_QR_HIDDEN_FIELDS}
				<input type="submit" name="preview" tabindex="6" value="{L_PREVIEW}" class="button1" onclick="document.getElementById('postform').action += '#preview';" />&nbsp;
				<input type="submit" name="post" tabindex="5" value="{L_SUBMIT}" class="button1" accesskey="s" />
			</fieldset>

			<span class="corners-bottom"><span></span></span></div>
		</div>

	</form>

</div>
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

User avatar
Elitzur
I've Been Banned!
Posts: 323
Joined: Sat Sep 15, 2007 7:49 am
Location: Europe, UK.
Contact:

Re: Evil Quick Reply

Post by Elitzur » Thu Jul 16, 2009 7:01 pm

Oh well it is working fine and it's ok now, thanks for your help mate :)

Locked

Return to “[3.0.x] MOD Database Releases”