Page 1 of 150

Evil Quick Reply

Posted: Wed Nov 21, 2007 3:36 am
by Extensions Robot
Modification name: Evil Quick Reply
Author: igorw
Modification description: This modification will add a hidden quick reply form to the bottom of the viewtopic page. It adds a "Quick reply" image next to "Post reply", that will display the quick reply form when clicked. The goal of this MOD is not to offer as many features as possible, it's built to be as simple as possible.
Modification version: 1.0.0
Tested on phpBB version: 3.0.0

Download file: evil_quick_reply_1_0_1.zip
File size: 44692 Bytes

Modification overview page: View

The phpBB Team is not responsible nor required to provide support for this modification. By installing this MOD, you acknowledge that the phpBB Support Team or phpBB Modifications Team may not be able to provide support.

-->Modification support<--

Evil Quick Reply

Posted: Wed Nov 21, 2007 3:36 am
by Handyman`
Modification validated/released

Notes:
The description says it all.
"The goal of this MOD is not to offer as many features as possible, it's built to be as simple as possible."

Yet it still has some cool features :)

You must have javascript enabled to use this MOD.
After installation, make sure you purge the cache and refresh all the styles through the ACP to get everything to show up correctly.

Re: Evil Quick Reply

Posted: Wed Nov 21, 2007 3:56 am
by yaw_pakhtoon
I'll be the second person to say thank you.

Thank YOU..

Re: Evil Quick Reply

Posted: Wed Nov 21, 2007 7:56 am
by igorw
FAQ POST - READ THIS BEFORE ASKING ANY QUESTIONS


NOTHING HAPPENS...
  1. Make sure you made the style edits. They are in the templates/ folder. Follow the instructions of prosilver.xml / subsilver2.xml
  2. Make sure you refreshed templates, imagesets and themes in the acp. Go to the admin control panel -> styles. Select Templates on the left and hit "refresh" next to your style. Repeat for imagesets and templates.
  3. Make sure you uploaded all your files.
  4. Using the latest version?
Found a bug? Please report it here: http://phpbbmodders.net/tracker.php?p=1 But check if it's been reported and/or fixed yet.

Re: Evil Quick Reply

Posted: Wed Nov 21, 2007 1:34 pm
by T50
i waited for evil to reply first..
so he can have an early post! that he can edit for updates and info!
good mod, I might use it!

Re: Evil Quick Reply

Posted: Wed Nov 21, 2007 3:19 pm
by Highway of Life
T50 wrote:i waited for evil to reply first..
so he can have an early post! that he can edit for updates and info!
Doesn’t always happen, he was probably asleep when we validated the MOD. :D

Re: Evil Quick Reply

Posted: Wed Nov 21, 2007 3:27 pm
by igorw
T50 wrote:i waited for evil to reply first..
so he can have an early post! that he can edit for updates and info!
good mod, I might use it!
Thanks, very kind :)
Highway of Life wrote:Doesn’t always happen, he was probably asleep when we validated the MOD. :D
Image :twisted:

Re: Evil Quick Reply

Posted: Thu Nov 22, 2007 11:32 am
by BlackburnRavers
is this an update from the beta vesion? it prob is but just makin sure tho.

Re: Evil Quick Reply

Posted: Thu Nov 22, 2007 12:21 pm
by tomcat22
Thanx for what looks like an interesting mod.

I am having a bit of trouble. I am using the subsilver based theme called TECH-B.

I have installed your mod and nothing happens. I know the code is working because I placed a bug to cause the code to error. It broke exactly where it should have.

The main problem I have is that there is no button showing for the quick reply. I have the new topic and the post reply buttons, on the lower left of the post window, but there is no quick reply button.

At this point I have a quick reply, but no way to access it.

Thank You

Re: Evil Quick Reply

Posted: Thu Nov 22, 2007 12:23 pm
by igorw
BlackburnRavers wrote:is this an update from the beta vesion? it prob is but just makin sure tho.
Yes, replace the old files with the new ones.
tomcat22 wrote:The main problem I have is that there is no button showing for the quick reply. I have the new topic and the post reply buttons, on the lower left of the post window, but there is no quick reply button.
Did you refresh imagesets in the ACP?

Re: Evil Quick Reply

Posted: Thu Nov 22, 2007 12:41 pm
by yaw_pakhtoon
tomcat22 wrote:The main problem I have is that there is no button showing for the quick reply. I have the new topic and the post reply buttons, on the lower left of the post window, but there is no quick reply button.
Did you refresh imagesets in the ACP?[/quote]


I had that problem too, but i works now, after refreshing it. :D
Thanks

Re: Evil Quick Reply

Posted: Thu Nov 22, 2007 12:46 pm
by yaw_pakhtoon
i got one more question.. you know the button is on the top of the page.. how do you put it on the bottom of the page :?:

Re: Evil Quick Reply

Posted: Thu Nov 22, 2007 1:41 pm
by igorw
yaw_pakhtoon wrote:i got one more question.. you know the button is on the top of the page.. how do you put it on the bottom of the page :?:
If it's at the top, you didn't follow the instructions correctly :)

Re: Evil Quick Reply

Posted: Thu Nov 22, 2007 1:45 pm
by yaw_pakhtoon
If it's at the top, you didn't follow the instructions correctly :)[/quote]
i think i did.. i went over it twice.. :?

Re: Evil Quick Reply

Posted: Thu Nov 22, 2007 3:59 pm
by BlackburnRavers
yo evil, im trying to install the bbcode & smiles code in the addons file, when i try to view a message after i place in the code i get this error:-

Code: Select all

Fatal error: Call to undefined function: add_form_key() in /home/l13blac/public_html/blackburnraversforum/includes/functions_quick_reply.php on line 126
any idea what i could be?

Edited:- It shows this error when the addon code hasn't ben placed in the functions_quick_reply.php file.