Prime Quick Login

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
mdvaldosta
Registered User
Posts: 353
Joined: Sat Mar 26, 2005 12:26 am
Contact:

Re: Prime Quick Login

Post by mdvaldosta »

Snazzy. :ugeek:
User avatar
primehalo
Former Team Member
Posts: 2904
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: Prime Quick Login

Post by primehalo »

mara7 wrote:Is this mod redirecting me to last page or to index ?
Last page.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
holder10
Registered User
Posts: 31
Joined: Sat Feb 02, 2008 6:52 pm

Re: Prime Quick Login

Post by holder10 »

2 problems:
1. The quick login is redirecting me to the index, not the last page. I use phpbb3portal and proGrey, a style that looks exactly like this one (phpbb.com).
Edit: Okay, I think this is because I turned off the meta redirects. So, the functions.php looks like this now:

Code: Select all

       $url = redirect($url, false);
//-- mod: Prime Quick Login -------------------------------------------------//
	$template->assign_var('AUTO_REFRESH', $time);
//-- end: Prime Quick Login -------------------------------------------------//
Is this wrong?

2. In Firefox all is finde, but in IE and Opera, the fields are bigger and so the menu is in a new line. How can I change the weight of a field (username/password/login)? [fixed by myself]

Thank you very much, I hope somebody can help me.
Luk4ward
Registered User
Posts: 73
Joined: Sat Nov 25, 2006 10:12 pm

Re: Prime Quick Login

Post by Luk4ward »

There are problems with 3.0.1 version
User avatar
primehalo
Former Team Member
Posts: 2904
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: Prime Quick Login

Post by primehalo »

Luk4ward wrote:There are problems with 3.0.1 version
There are none that I know of.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
User avatar
mcdanielnc89
Registered User
Posts: 703
Joined: Tue Feb 06, 2007 10:49 pm
Location: Missouri
Contact:

Re: Prime Quick Login

Post by mcdanielnc89 »

primehalo wrote:
Luk4ward wrote:There are problems with 3.0.1 version
There are none that I know of.

None on my end either. Great mod primehalo. Am really looking forward to what else you plan on making for phpBB3. :D
User avatar
KenTech
Registered User
Posts: 17
Joined: Thu Jan 11, 2007 7:35 pm
Location: Glendale, CA
Contact:

Re: Prime Quick Login

Post by KenTech »

The mod doesn't work on 3.0.1 for me either. I installed it and then logged out. As soon as I try to view the index, I get an error that it cannot find prime_quick_login.php.

I am not a PHP programmer, but is the line in red pulling the language path correctly?

//-- mod: Prime Quick Login -------------------------------------------------//
$user->add_lang('mods/prime_quick_login');
$redirect = $user->page['page_dir'] ? '' : '&redirect=' . urlencode(str_replace('&', '&', build_url(array('_f_'))));
$template->assign_var('S_LOGIN_ANYWHERE', append_sid("{$phpbb_root_path}ucp.$phpEx", 'mode=login' . $redirect));
//-- end: Prime Quick Login -------------------------------------------------//
User avatar
primehalo
Former Team Member
Posts: 2904
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: Prime Quick Login

Post by primehalo »

KenTech wrote:The mod doesn't work on 3.0.1 for me either. I installed it and then logged out. As soon as I try to view the index, I get an error that it cannot find prime_quick_login.php.

I am not a PHP programmer, but is the line in red pulling the language path correctly?

//-- mod: Prime Quick Login -------------------------------------------------//
$user->add_lang('mods/prime_quick_login');
$redirect = $user->page['page_dir'] ? '' : '&redirect=' . urlencode(str_replace('&', '&', build_url(array('_f_'))));
$template->assign_var('S_LOGIN_ANYWHERE', append_sid("{$phpbb_root_path}ucp.$phpEx", 'mode=login' . $redirect));
//-- end: Prime Quick Login -------------------------------------------------//
Yes it is. Make sure you placed the "prime_quick_login.php" file where it was supposed to go.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
User avatar
mcdanielnc89
Registered User
Posts: 703
Joined: Tue Feb 06, 2007 10:49 pm
Location: Missouri
Contact:

Re: Prime Quick Login

Post by mcdanielnc89 »

Okay For some reason this mod just totally disappeared of my website.. It was working, but now it isn't.. i've tried redoing it and still isn't working.

EDIT: It just isn't working on the index page..
VJain
Registered User
Posts: 2
Joined: Wed Jun 25, 2008 4:37 am

Re: Prime Quick Login

Post by VJain »

I have a problem with the logins, here's what happens.

. :What Works:.
- Logging in from the index
- Logging in from the login page (both the Quick, and the default login)

. :What Doesn't Work:.
- Logging in from any other page.

. :What Occurs:.
- The button is clicked. It basically refreshes the page. No login happen, no error, no "incorrect password", etc. Just the same page.

Thanks in advance
~VJ
User avatar
primehalo
Former Team Member
Posts: 2904
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: Prime Quick Login

Post by primehalo »

Please go over the installation instructions again carefully and make sure everything was done correctly. Most of the time a mistake during installation is what causes people to experience bugs. Also check to see if you have any other MODs installed that may be interfering.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
VJain
Registered User
Posts: 2
Joined: Wed Jun 25, 2008 4:37 am

Re: Prime Quick Login

Post by VJain »

Got it fixed~.

It was a cookie problem, not a mod problem ^_^.
User avatar
vkams
Registered User
Posts: 7
Joined: Sat Sep 08, 2007 8:32 am
Location: Moscow

Re: Prime Quick Login

Post by vkams »

Primehalo, thank you for this mod - it's just what I dreamed about! The little addition I made is removing standard login-button in overall-header.html. Now instead of

Code: Select all

					<!-- IF not S_USER_LOGGED_IN and S_REGISTER_ENABLED --><li class="icon-register"><a href="{U_REGISTER}">{L_REGISTER}</a></li><!-- ENDIF -->
					<li class="icon-logout"><a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="l">{L_LOGIN_LOGOUT}</a></li>
it looks like

Code: Select all

					<!-- IF not S_USER_LOGGED_IN and S_REGISTER_ENABLED --><li class="icon-register"><a href="{U_REGISTER}">{L_REGISTER}</a></li><!-- ELSE -->
					<li class="icon-logout"><a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="l">{L_LOGIN_LOGOUT}</a></li><!-- ENDIF -->
User avatar
primehalo
Former Team Member
Posts: 2904
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: Prime Quick Login

Post by primehalo »

The standard login link allows people to visit the actual login page which contains the "I forgot my password" link and the "Hide my online status this session" option.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!
teman
Registered User
Posts: 145
Joined: Fri Mar 21, 2008 5:50 pm

Re: Prime Quick Login

Post by teman »

notsa wrote:small template edit, o p en index_body.html:
in acid tech find and delete:

Code: Select all

<!-- IF not S_USER_LOGGED_IN -->
	<br clear="all" />

	<form method="post" action="{S_LOGIN_ACTION}">
	
	<table class="tablebg" width="100%" cellspacing="{$CA_SPACING}">
	{$CA_CAP_START}<a href="{U_LOGIN_LOGOUT}">{L_LOGIN_LOGOUT}</a>{$CA_CAP_END}
	<tr>
		<td class="row1" align="center"><span class="genmed">{L_USERNAME}:</span> <input class="post" type="text" name="username" size="10" />&nbsp; <span class="genmed">{L_PASSWORD}:</span> <input class="post" type="password" name="password" size="10" />&nbsp; <!-- IF S_AUTOLOGIN_ENABLED --><span class="gensmall">{L_LOG_ME_IN}</span> <input type="checkbox" class="radio" name="autologin" />&nbsp;<!-- ENDIF --> <input type="submit" class="btnmain" name="login" value="{L_LOGIN}" /></td>
	</tr>
	</table>
	{S_FORM_TOKEN}
	</form>
<!-- ENDIF -->
In subsilver2 find and delete:

Code: Select all

<!-- IF not S_USER_LOGGED_IN -->
	<br clear="all" />

	<form method="post" action="{S_LOGIN_ACTION}">
	
	<table class="tablebg" width="100%" cellspacing="1">
	<tr>
		<td class="cat"><h4><a href="{U_LOGIN_LOGOUT}">{L_LOGIN_LOGOUT}</a></h4></td>
	</tr>
	<tr>
		<td class="row1" align="center"><span class="genmed">{L_USERNAME}:</span> <input class="post" type="text" name="username" size="10" />&nbsp; <span class="genmed">{L_PASSWORD}:</span> <input class="post" type="password" name="password" size="10" />&nbsp; <!-- IF S_AUTOLOGIN_ENABLED --> <span class="gensmall">{L_LOG_ME_IN}</span> <input type="checkbox" class="radio" name="autologin" /><!-- ENDIF -->&nbsp; <input type="submit" class="btnmain" name="login" value="{L_LOGIN}" /></td>
	</tr>
	</table>
	{S_FORM_TOKEN}
	</form>
<!-- ENDIF -->
In prosilver find and delete:

Code: Select all

<!-- IF not S_USER_LOGGED_IN and not S_IS_BOT -->
	<form method="post" action="{S_LOGIN_ACTION}" class="headerspace">
	<h3><a href="{U_LOGIN_LOGOUT}">{L_LOGIN_LOGOUT}</a>&nbsp; &bull; &nbsp;<a href="{U_REGISTER}">{L_REGISTER}</a></h3>
		<fieldset class="quick-login">
			<label for="username">{L_USERNAME}:</label>&nbsp;<input type="text" name="username" id="username" size="10" class="inputbox" title="{L_USERNAME}" />  
			<label for="password">{L_PASSWORD}:</label>&nbsp;<input type="password" name="password" id="password" size="10" class="inputbox" title="{L_PASSWORD}" />
			<!-- IF S_AUTOLOGIN_ENABLED -->
				| <label for="autologin">{L_LOG_ME_IN} <input type="checkbox" name="autologin" id="autologin" /></label>
			<!-- ENDIF -->
			<input type="submit" name="login" value="{L_LOGIN}" class="button2" />
		</fieldset>
	</form>
<!-- ENDIF -->
sorry for my ignorance,for what this code?and how to place this mod on top of body?

those who are running sub2 styles based if u can't find

Code: Select all

<td class="gensmall"><!-- IF S_USER_LOGGED_IN -->{LAST_VISIT_DATE}<!-- ENDIF --></td>
then try to find

Code: Select all

{LAST_VISIT_DATE}
and add in line after

Code: Select all

<!-- ELSEIF not AUTO_REFRESH --><form method="post" action="{S_LOGIN_ANYWHERE}"><span class="genmed">{L_USERNAME}:</span> <input tabindex="100" class="post" type="text" name="username" size="10" />&nbsp; <span class="genmed">{L_PASSWORD}:</span> <input tabindex="101" class="post" type="password" name="password" size="10" />&nbsp; <!-- IF S_AUTOLOGIN_ENABLED --> <input tabindex="102" type="checkbox" class="radio" name="autologin" />  <span class="gensmall">{L_PRIME_REMEMBER_ME}</span><!-- ENDIF -->&nbsp; <input tabindex="103" type="submit" class="btnmain" name="login" value="{L_LOGIN}" /></form>
it works perfect for me.
never pleased become the leader!!!
ask me for any symbian issues at
http://gsmvolt.com and see our rank here
Locked

Return to “[3.0.x] MOD Database Releases”