Add User Id in Viewtopic

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Extensions Robot
Extensions Robot
Extensions Robot
Posts: 28600
Joined: Sat Aug 16, 2003 7:36 am

Add User Id in Viewtopic

Post by Extensions Robot »

Modification name: Add User Id in Viewtopic
Author: idiotnesia
Modification description: This mod will add user id in viewtopic. It also can be enable/disable in ACP
Modification version: 1.0.0
Tested on phpBB version: 3.0.0

Download file: Add user_id in viewtopic 1.0.0.zip
File size: 30553 Bytes

Modification overview page: View

The phpBB Team is not responsible nor required to provide support for this modification. By installing this MOD, you acknowledge that the phpBB Support Team or phpBB Modifications Team may not be able to provide support.

-->Modification support<--
Last edited by Extensions Robot on Tue Feb 08, 2011 4:48 am, edited 5 times in total.
(this is a non-active account manager for the phpBB Extension Customisations Team)
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 26938
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Add User Id in Viewtopic

Post by Paul »

Modification validated/released

Notes:
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development
User avatar
Allegro
Registered User
Posts: 7
Joined: Fri Dec 14, 2007 6:22 pm

Re: Add User Id in Viewtopic

Post by Allegro »

Is it supposed to say my UserID is 2 instead of 1 as it should :|
Rosca
Registered User
Posts: 21
Joined: Sat Dec 15, 2007 8:27 pm

Re: Add User Id in Viewtopic

Post by Rosca »

where can we see a demo for this mod ?

LE: This mod is not working properly beacause my user ID must be 2 if I look on member list. I also take a look on my database and there my user ID is 53 which this mod diplays in viewtopic.
How can I chnage from ID to member number?
User avatar
nickb611
Registered User
Posts: 69
Joined: Sat Nov 24, 2007 4:58 am

Re: Add User Id in Viewtopic

Post by nickb611 »

Rosca wrote:where can we see a demo for this mod ?

LE: This mod is not working properly beacause my user ID must be 2 if I look on member list. I also take a look on my database and there my user ID is 53 which this mod diplays in viewtopic.
How can I chnage from ID to member number?
Your USED ID is not the same as your MEMBER NUMBER. You just distinctly said that this mod works. Actually, no mod in the db doesn't work when properly installed. So, it's not the mod that's not functioning correctly, you just have the wrong mod.
Rosca
Registered User
Posts: 21
Joined: Sat Dec 15, 2007 8:27 pm

Re: Add User Id in Viewtopic

Post by Rosca »

ok, thanks. After I checked the database I realised that the user ID is comming from there, so the mod is ok ;), it's working!
idiotnesia
Registered User
Posts: 509
Joined: Sun Jun 18, 2006 10:58 am
Location: www.phpbbindonesia.com
Name: Pungky Putra
Contact:

Re: Add User Id in Viewtopic

Post by idiotnesia »

This mods is for user id not member number.
in phpBB3 user id is started from 2 (admin), and user id 3 - 52 is used for bots
User avatar
bbrian017
Registered User
Posts: 720
Joined: Mon Mar 19, 2007 2:20 pm
Location: Canada
Contact:

Re: Add User Id in Viewtopic

Post by bbrian017 »

I tried to install this mod and got many errors. I have installed many mods and I know sometimes it's my fault but I got header errors like crazy. Sorry I didn't copy paste them! I will try again soon and if I get the errors again I will post them here. I just want to ensure it wasn't my mistake :)

I think it was my mistake and it's late here right now... really tired :)

ok so I re did the mod and I contine to get this error,

Code: Select all

UTC + 13] Tonga Time, Phoenix Islands Time', '14' => '[UTC + 14] Line Island Time', ), // The value is only an example and will get replaced by the current time on view 'dateformats' => array( 'd M Y, H:i' => '01 Jan 2007, 13:37', 'd M Y H:i' => '01 Jan 2007 13:37', 'M jS, \'y, H:i' => 'Jan 1st, \'07, 13:37', 'D M d, Y g:i a' => 'Mon Jan 01, 2007 1:37 pm', 'F jS, Y, g:i a' => 'January 1st, 2007, 1:37 pm', '|d M Y|, H:i' => 'Today, 13:37 / 01 Jan 2007, 13:37', '|F jS, Y|, g:i a' => 'Today, 1:37 pm / January 1st, 2007, 1:37 pm' ), // The default dateformat which will be used on new installs in this language // Translators should change this if a the usual date format is different 'default_dateformat' => 'D M d, Y g:i a', // Mon Jan 01, 2007 1:37 pm // add userid in viewtopic mod 'USER_ID' => 'User ID', // end )); ?>[phpBB Debug] PHP Notice: in file /includes/session.php on line 1591: Cannot modify header information - headers already sent by (output started at /language/en/common.php:833)

Warning: Cannot modify header information - headers already sent by (output started at /home/content/b/b/r/bbrian017/html/blogengage/forum/language/en/common.php:833) in /home/content/b/b/r/bbrian017/html/blogengage/forum/includes/functions.php on line 3391

Warning: Cannot modify header information - headers already sent by (output started at /home/content/b/b/r/bbrian017/html/blogengage/forum/language/en/common.php:833) in /home/content/b/b/r/bbrian017/html/blogengage/forum/includes/functions.php on line 3393

Warning: Cannot modify header information - headers already sent by (output started at /home/content/b/b/r/bbrian017/html/blogengage/forum/language/en/common.php:833) in /home/content/b/b/r/bbrian017/html/blogengage/forum/includes/functions.php on line 3394

Warning: Cannot modify header information - headers already sent by (output started at /home/content/b/b/r/bbrian017/html/blogengage/forum/language/en/common.php:833) in /home/content/b/b/r/bbrian017/html/blogengage/forum/includes/functions.php on line 3395
I ran the database query, I edited the style files. The files were pretty easy to edit! I can't login or access the admin cp after doing the install files instructions to even clear th cache.

What could be doing wrong?

EDIT:

I decided to re upload all the files I edited and the errors are gone. it seems I never overwrote the common file!

I refreshed the template and still see nothing? What should this look like?

Seriously does this only add a link under the users avatar on every post?

Image
Mandarola
Registered User
Posts: 245
Joined: Tue Sep 25, 2007 3:21 am

Re: Add User Id in Viewtopic

Post by Mandarola »

if is it possible in user id the numbers be same like in member list?
because is my second registered user is the number 2, why is he/she the number 52 in user id? the mdo is perfect, but it has this little detail
pumpkinkid
Registered User
Posts: 91
Joined: Wed Oct 31, 2007 3:36 am

Re: Add User Id in Viewtopic

Post by pumpkinkid »

that would be because of the 50 bots that are added as "users" when you create the forum...
monkeymaker
Registered User
Posts: 138
Joined: Tue Jul 24, 2007 1:00 am

Re: Add User Id in Viewtopic

Post by monkeymaker »

I haven't yet installed a mod that requires SQL changes, and this I don't know how to do. Where do I find the SQL file?
Thanks to everyone who has helped me thus far, and to all those who will in the future because I know I'll need it! :D

To see how my forum has progressed, check it out: http://www.BrentwoodConnect.com.
idiotnesia
Registered User
Posts: 509
Joined: Sun Jun 18, 2006 10:58 am
Location: www.phpbbindonesia.com
Name: Pungky Putra
Contact:

Re: Add User Id in Viewtopic

Post by idiotnesia »

monkeymaker wrote:I haven't yet installed a mod that requires SQL changes, and this I don't know how to do. Where do I find the SQL file?
click this link
http://www.phpbb.com/community/viewtopi ... 7#p3244163
User avatar
noth
Registered User
Posts: 2487
Joined: Fri Jan 07, 2005 7:10 pm
Location: North Surrey
Contact:

Re: Add User Id in Viewtopic

Post by noth »

I tried to enstall this mod and as soon as I did the common.php edits I got
phpBB Debug] PHP Notice: in file /includes/functions.php on line 3395: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3397: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3398: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3399: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
does anybody know what the cause is?

If I replace the original common.php (without the edits) then the errors vanish but the edits on common php are critical in this mod so I am unable to enstall it :(

in addition ... in my admin panel I now see
phpBB Debug] PHP Notice: in file /adm/index.php on line 149: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 151: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 152: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
I tried the SQL edit and saw this
SQL query:

INSERT INTO h2phpbb_config( config_name, config_value )
VALUES (

'load_userid_viewtopic', '1'
)

MySQL said:

#1062 - Duplicate entry 'load_userid_viewtopic' for key 1
madtay
Registered User
Posts: 328
Joined: Tue Jun 27, 2006 10:27 pm
Contact:

Re: Add User Id in Viewtopic

Post by madtay »

Excellent modification, Thanks! :)

It was very easy to install too ;)
idiotnesia
Registered User
Posts: 509
Joined: Sun Jun 18, 2006 10:58 am
Location: www.phpbbindonesia.com
Name: Pungky Putra
Contact:

Re: Add User Id in Viewtopic

Post by idiotnesia »

noth wrote:I tried to enstall this mod and as soon as I did the common.php edits I got
phpBB Debug] PHP Notice: in file /includes/functions.php on line 3395: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3397: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3398: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3399: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
does anybody know what the cause is?

If I replace the original common.php (without the edits) then the errors vanish but the edits on common php are critical in this mod so I am unable to enstall it :(

in addition ... in my admin panel I now see
phpBB Debug] PHP Notice: in file /adm/index.php on line 149: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 151: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 152: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
I tried the SQL edit and saw this
SQL query:

INSERT INTO h2phpbb_config( config_name, config_value )
VALUES (

'load_userid_viewtopic', '1'
)

MySQL said:

#1062 - Duplicate entry 'load_userid_viewtopic' for key 1
what is your phpBB version 3.0.0 or 3.0.1
I haven't tested this mod in 3.0.1
Locked

Return to “[3.0.x] MOD Database Releases”