SEO MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
Ann_L
Registered User
Posts: 38
Joined: Mon Jun 25, 2007 12:18 pm

Re: SEO MOD

Post by Ann_L »

Has some one tried on implementing a virtual folder rewrite ie something like http://localhost/forum/forum-title/topictitle.html

Any ideas or suggestions?
Silver Sonic
Registered User
Posts: 2
Joined: Sat Jul 01, 2006 3:04 pm

Re: Bugs and bug fix compilation.

Post by Silver Sonic »

flycker wrote:2. - Unread orange icon (When you are viewing a forum and there are unread threads you can click on the little orange)
2.1 Image
2.2 Go to "http://new1.myforum.com/sdfsdfs-t9.html ... ead#unread" a "404 - Not Found" page.
Is there a solution availible now for this problem?
Couldn't find one. This is urgent
parmen.cz
Registered User
Posts: 3
Joined: Sat Apr 12, 2008 5:02 pm

Re: SEO MOD

Post by parmen.cz »

Hi there

I have installed this mod.
Then i have installed this mod "[RC] Sort topics alphabetically 1.0.1" link
http://www.phpbb.com/community/viewtopi ... abetically
and the problem is that this mod currectly not working with this seo mod.
I need both :( Please help me someone.
AllGo
Registered User
Posts: 12
Joined: Sun May 04, 2008 12:48 pm
Contact:

Re: Bugs and bug fix compilation.

Post by AllGo »

Silver Sonic wrote:
flycker wrote:2. - Unread orange icon (When you are viewing a forum and there are unread threads you can click on the little orange)
2.1 Image
2.2 Go to "http://new1.myforum.com/sdfsdfs-t9.html ... ead#unread" a "404 - Not Found" page.
Is there a solution availible now for this problem?
Couldn't find one. This is urgent
Find in viewforum.php (line +/- 650)

Code: Select all

'U_NEWEST_POST'
Make sure that line read:

Code: Select all

			'U_NEWEST_POST'			=> $view_topic_url . '-view=unread#unread',
Do the same in search.php (line +/- 820).
AllGo
Registered User
Posts: 12
Joined: Sun May 04, 2008 12:48 pm
Contact:

Re: SEO MOD

Post by AllGo »

Okay,
I installed this mod (before reading all the posts in this topic). I spend most of my saturday fixing a lot of bugs. If you are not a programmer, or have at least some knowledge of PHP, I suggest you keep away from this mod a while. The base is really good (thanks Handyman!), but there's still some work to do.

One weird problem I can't seem to figure out though:
I have this topic that contains 5 pages During pagination, something strange happens.
Link to the topic:
http://board.hondamatics.nl/het-%CA%B9t ... e-t87.html

Link to page 1:
http://board.hondamatics.nl/het-%3Cspan ... t87s0.html

Link to page 4:
http://board.hondamatics.nl/het-%3Cspan ... 87s75.html

What code is responsible for putting in the <span class="posthilit"> statements?
AllGo
Registered User
Posts: 12
Joined: Sun May 04, 2008 12:48 pm
Contact:

Re: SEO MOD

Post by AllGo »

Fixed that one too.

Find

Code: Select all

$row['topic_title'] = preg_replace('#(?!<.*)(?<!\w)(' . $hilit . ')(?!\w|[^<>]*(?:</s(?:cript|tyle))?>)#is', '<span class="posthilit">$1</span>', $row['topic_title']);
Replace with

Code: Select all

if ($hilit)
				{
					$row['topic_title'] = preg_replace('#(?!<.*)(?<!\w)(' . $hilit . ')(?!\w|[^<>]*(?:</s(?:cript|tyle))?>)#is', '<span class="posthilit">$1</span>', $row['topic_title']);
				}
This looks like a phpBB bug though, not really SEO mod related.
User avatar
UncleVIBES
Registered User
Posts: 64
Joined: Sat Jun 09, 2007 5:08 am
Location: France
Contact:

Re: SEO MOD

Post by UncleVIBES »

I asked http://www.phpbb-seo about the same bug & they got a patch on the htaccess file only.
replace

Code: Select all

[a-z0-9_-]+
by

Code: Select all

[a-z0-9_-]*[a-z_]+
after

Code: Select all

# FORUM WITHOUT ID & DELIM
    # THESE FOUR LINES MUST BE LOCATED AT THE END OF YOUR HTACCESS TO WORK PROPERLY
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
User avatar
mcdanielnc89
Registered User
Posts: 703
Joined: Tue Feb 06, 2007 10:49 pm
Location: Missouri
Contact:

Re: SEO MOD

Post by mcdanielnc89 »

How far away is the next release? :D
CafeSaiGon
Registered User
Posts: 50
Joined: Thu Jan 24, 2008 12:37 am

Re: SEO MOD

Post by CafeSaiGon »

Last edited by Highway of Life on Fri May 09, 2008 7:35 pm, edited 1 time in total.
Reason: spam removed
Ann_L
Registered User
Posts: 38
Joined: Mon Jun 25, 2007 12:18 pm

Re: select forum from option box is not url rewritten

Post by Ann_L »

On selecting a forum from the option box(jumpbox which lists all the forums) in the viewforum.php & viewtopic.php, the url goes to viewforum.php.. It is not called by the new url. Anyone have worked on it?
User avatar
mcdanielnc89
Registered User
Posts: 703
Joined: Tue Feb 06, 2007 10:49 pm
Location: Missouri
Contact:

Re: SEO MOD

Post by mcdanielnc89 »

Handyman':

Have any major bugs been reported that really truly are bugs... I'd liek to knwo so i know whether or not to install this or wait until the next version
lonepare
Registered User
Posts: 66
Joined: Wed Jan 16, 2008 8:20 am
Location: Nottingham
Contact:

Re: SEO MOD

Post by lonepare »

Hi.... I'm using board 3 portal with the seo mod and am having just one problem with it, that just might be related to the seo mod....

Here is the part I am having problems with and is to do with pagination... and resides in the portal code not seo.. When I click on any number higher than 1st page it takes me to first page and not the intended page.

Code: Select all

'PAGINATION'		=> topic_generate_pagination($fetch_news[$i]['topic_replies'], $view_topic_url),
and here is what relates to

Code: Select all

$view_topic_url

Code: Select all

$view_topic_url = append_sid("{$phpbb_root_path}viewtopic.$phpEx", 'f=' . (($fetch_news[$i]['forum_id']) ? $fetch_news[$i]['forum_id'] : $forum_id) . '&t=' . $topic_id);
Do I need to change this for it to work with Seo Mod....

Also I have..... gone through pages 1-10 and patched but pages 10-30 is just so much stuff and confusing.... has anyone come up with a patch mod for this so that all fixes can be seen in one place and then easily updated.... Is a logical step :?
Regards Micheal....
Lone Parent community at http://www.lone-parents.net a phpBB Forum
downloadthenet
Registered User
Posts: 19
Joined: Fri Dec 15, 2006 9:39 pm

Re: SEO MOD

Post by downloadthenet »

Well, I think this is the last unsolved problem I have with this mod but it's a big one. The search engines are indexing two different version of each thread.

Here's an example:
free-file-and-evidence-eraser--p30.html
free-file-and-evidence-eraser--t17.html

They're actually indexing the "p" version much better and I cannot even figure out where they're finding it. Can someone please help with this?
Bawls
Registered User
Posts: 7
Joined: Wed Apr 09, 2008 3:28 am

Re: SEO MOD

Post by Bawls »

Hey all,
I finished up installing this mod. It's working great, however I have one issue. When a topic notification email is received, the link to the topic reply (i.e.: http://specv.net/forum/11may08-updates- ... 1823#p1823) runs into a 404.

Any ideas?
ever-fresh
Registered User
Posts: 177
Joined: Fri Nov 16, 2007 2:48 pm
Location: Dubai, United Arab Emirates.
Contact:

Re: SEO MOD

Post by ever-fresh »

Can someone Edit for me the viewforum.php and viewtopic.php Files for Phpbb 3.0.1 ?
i can Pay to the persone who is intrested !
i have no Mod installed except SEO Mod. and i dont have time to edit these 2 files, as i need to read this complete topic with all fixes.
Any one ? PM me.
Salman,
Locked

Return to “[3.0.x] MOD Database Releases”