SEO MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
XToF.be
Registered User
Posts: 61
Joined: Thu Jun 28, 2007 10:52 am
Contact:

Re: SEO MOD

Post by XToF.be » Sun Jun 15, 2008 2:01 pm

When I post a reply and I want to view my post, the MOD redirects me to the first page of the topic instead of my reply. I didn't find something about this issue in this topic so far.

Edit:
I'm having the exact same issue as described by flycker some posts above:

Here and
here and
here .
So from the moment that there are more than one page of reply posts, I'm redirected to the first page when replying.

It takes me to the URL:
http://myboard.com/topic-title-t464.html#p1822,
where it should take me to:
http://myboard.com/topic-title-t464s40.html#p1822

Does anyone have an idea? Or can anyone give me some hints?

NLCrEaTiVe
Registered User
Posts: 29
Joined: Wed Apr 04, 2007 2:39 pm

Re: SEO MOD

Post by NLCrEaTiVe » Mon Jun 16, 2008 2:03 pm

I installed the following mod: http://www.phpbb.com/community/viewtopi ... &sk=t&sd=a

This mod uses code to display the last post in a topic. But when I press the link it shows the following error:

Code: Select all

SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'phpbb3_topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 5418' at line 3 [1064]

SQL

SELECT t.topic_title FROM phpbb3_posts p phpbb3_topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 5418

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: includes/functions_seo.php
LINE: 170
CALL: dbal_mysqli->sql_query()

FILE: viewtopic.php
LINE: 57
CALL: moved_topic()
Is there a way to solve this?

adda4u
Registered User
Posts: 69
Joined: Mon Apr 21, 2008 1:46 am

Re: SEO MOD

Post by adda4u » Tue Jun 17, 2008 1:43 am

installed mod

Now how to check it ...???
Adda4u friendly directory -
http://www.adda4u.com

adda4u
Registered User
Posts: 69
Joined: Mon Apr 21, 2008 1:46 am

Re: SEO MOD

Post by adda4u » Tue Jun 17, 2008 1:56 am

Installed every thing perfectly and i didnt see any changes ...

Can any one help me ...

How to check weather it is really working or not
Adda4u friendly directory -
http://www.adda4u.com

AllGo
Registered User
Posts: 12
Joined: Sun May 04, 2008 12:48 pm
Contact:

Re: SEO MOD

Post by AllGo » Tue Jun 17, 2008 8:57 am

NLCrEaTiVe wrote:I installed the following mod: http://www.phpbb.com/community/viewtopi ... &sk=t&sd=a

This mod uses code to display the last post in a topic. But when I press the link it shows the following error:
http://www.phpbb.com/community/viewtopi ... 5#p5497265

Should probably go in the essentials post.. (rwap01?)

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: SEO MOD

Post by rwap01 » Tue Jun 17, 2008 2:08 pm

adda4u wrote:Installed every thing perfectly and i didnt see any changes ...

Can any one help me ...

How to check weather it is really working or not
The only changes you should see is that when you are browsing the forums, instead of for example:

www.yourforum.com/viewtopic.php?f=3&t=10&p=1020
You should see

http://www.yourforum.com/this-is-your-t ... p1020.html

for example.

The idea is to help with search engine results - nothing else.

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Link to First Unread Post when you are in a topic

Post by rwap01 » Tue Jun 17, 2008 3:54 pm

I have just spotted another error in the pageination when viewing a topic. The link to "First unread post" goes to :

http://www.rwapservices.co.uk/ZX80_ZX81 ... iew=unread

rather than:

http://www.rwapservices.co.uk/ZX80_ZX81 ... ead#unread

(for example).

The solution lies within viewtopic.php - you need to replace the two instances of:

Code: Select all

'U_VIEW_UNREAD_POST'	=> format_url($topic_title, "t$topic_id", 0, 'view=unread'),
with

Code: Select all

'U_VIEW_UNREAD_POST'	=> format_url($topic_title, "t$topic_id", 0, 'view=unread#unread'),

idontwantausername
Registered User
Posts: 219
Joined: Fri Nov 09, 2007 8:25 pm

Re: SEO MOD

Post by idontwantausername » Tue Jun 17, 2008 9:07 pm

Hi,

I've never used your mod before and I'm trying to install it, but when i open includes/functions, I cannot find the line "global $_SID, $_EXTRA_URL;", I have tried just finding "$_EXTRA_URL;" and ""$_SID", but i cannot find it, please tell me what i should do, this is what it says it says in the installation file:

Open: includes/functions.php
Find

Code: Select all

Tip: This may be a partial find and not the whole line.

global $_SID, $_EXTRA_URL;
Add after

Code: Select all

Tip: Add these lines on a new blank line after the preceding line(s) to find.

global $phpbb_root_path, $phpEx;

	if ($url === "{$phpbb_root_path}index.$phpEx")
	{
		return append_sid($phpbb_root_path);
	}
---------------------------------------------------------------------------------------------------------------------------------

ok found the error

for 3.0.1, instead of:

Code: Select all

global $_SID, $_EXTRA_URL;
it should now read:

Code: Select all

global $_SID, $_EXTRA_URL,

idontwantausername
Registered User
Posts: 219
Joined: Fri Nov 09, 2007 8:25 pm

Re: SEO MOD

Post by idontwantausername » Fri Jun 20, 2008 12:46 am

hihi, i'm now getting blank topics, and i don't know why lol.

Milkin
Registered User
Posts: 4
Joined: Wed Jun 18, 2008 12:49 pm

Re: SEO MOD

Post by Milkin » Fri Jun 20, 2008 5:33 am

Thanks for this MOD Handyman.
Thanks to everyone with all the fixes and help.
I worked my way through the last 39 pages and now have this SEO MOD installed & working with all bugs fixed except for one small issue:
When a user sends a topic to a friend using the "E-mail friend" link, that person recieves the email ok but the link back to the topic is like this example:

./test-page-etc.html

when the link in the email should be something like:

hxxp://www.myDomain.com/test-page-etc.html (this is not a working link)

Any help would be great.
Thanks.

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: SEO MOD

Post by rwap01 » Fri Jun 20, 2008 12:06 pm

Milkin wrote:Thanks for this MOD Handyman.
Thanks to everyone with all the fixes and help.
I worked my way through the last 39 pages and now have this SEO MOD installed & working with all bugs fixed except for one small issue:
When a user sends a topic to a friend using the "E-mail friend" link, that person recieves the email ok but the link back to the topic is like this example:

./test-page-etc.html

when the link in the email should be something like:

hxxp://www.myDomain.com/test-page-etc.html (this is not a working link)

Any help would be great.
Thanks.
Yes, I can confirm this problem as well - not sure why - memberlist.php does not appear to be able to pick up the PHPBB_ROOT_PATH and so, sets $phpbb_root_path to './'

Hmm - I am puzzled here - anyone got some bright ideas?

tupeu
Registered User
Posts: 320
Joined: Wed Jul 25, 2007 5:47 pm
Location: roFLmania
Contact:

Re: SEO MOD

Post by tupeu » Sat Jun 21, 2008 9:44 am

This is really a shame, such a wanted mod to be left unfinished-bugsfull
You have 3 options if you want Static Url:

1. You can install this mod, reserve one full day for this is very difficult to install and make a
full database+files backup because there is a high posibility to f$$k-up your board

2. I found on the internet a mod just like this one only it is NOT FREE
(i don`t want to speculate)
It costs 70 euros (100$) it does exacly the same thing as this one does but they say you have to do
ONLY 1 FILE EDIT TO INSTALL THE MOD !

(It is called Magic SEO URL for phpBB3 if you can`t find it and want the www adress PM me)

Magic SEO URL for phpBB3 is the successor of similar Search Engine Optimization Enhancement for phpBB.
It changes the dynamic URLs to static and well-structured SEO friendly URLs. It also includes verification and validation of each URL, supports for safe change of URLs and redirections from all native and rewritten phpBB3 URLs, properly Sessions IDs handling*, high speed without negative effects to server load or web server response, it also prevents possible duplicate content penalties and does much more in comparison with other SEO solutions!


* Does not break phpBB3 MODs!
* You add only one line of code for installation!
* In comparison with other phpBB3 SEO MODs is The Best ever made!
* Free Installation service!



3. There is a premodded phpBB3 3.0.1 version that includes a similar but better mode FOR FREE:
(tested and working)

http://www.phpbb-seo.com/boards/phpbb-s ... t1549.html

Advanced phpBB3 SEO mod Rewrite

Description : This mod will URL rewrite phpBB URLs, injecting forums and topic titles in their URLS, each URL being rewritten once, no matter the number of links using it on the page.


They already are preparing themselves for updating this MOD to the phpBB3 3.0.2

:roll:
Last edited by tupeu on Sat Jun 21, 2008 3:12 pm, edited 2 times in total.

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: SEO MOD

Post by rwap01 » Sat Jun 21, 2008 10:04 am

I disagree that this MOD is that difficult to install - true there are some bugs, but thanks to various users (including myself), these have now all been fixed (apart from the email the link to a friend - above). The details of all fixes are at least now contained within a single post - http://www.phpbb.com/community/viewtopi ... 5#p5716395

The great shame is that the original author (Handyman) does not appear to have continued to support this MOD and include all of the bug fixes in the actual MOD instructions.

He is still about writing MODs, so the question is why has he stopped updating this one?

p0Wer
Registered User
Posts: 162
Joined: Sat Aug 04, 2007 10:53 pm

Re: SEO MOD

Post by p0Wer » Sat Jun 21, 2008 10:49 am

I really don't know if I should install this mod. Theoretically, it sounds great. I tried installing it a while back but totally messed my board up, but I am willing to try again.

To the above poster, what are all those fixes for? What do they do?

Thanks

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: SEO MOD

Post by rwap01 » Sat Jun 21, 2008 11:22 am

p0Wer wrote:I really don't know if I should install this mod. Theoretically, it sounds great. I tried installing it a while back but totally messed my board up, but I am willing to try again.

To the above poster, what are all those fixes for? What do they do?

Thanks
If you are careful following the instructions for installation and double check the lines where you place additional / replacement code, you should be fine.

However, there are numerous bugs in the original code, which is why I have listed all of the essential fixes to overcome the bugs and ensure that your board operates as it did before implementing the MOD.

I have emailed Handyman to ask him to incorporate these within the release and re-upload the MOD, but alas he just tells people to read through this forum!!

Locked

Return to “[3.0.x] MOD Database Releases”