SEO MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
azzam
Registered User
Posts: 345
Joined: Sat May 03, 2008 11:33 am

Re: SEO MOD

Post by azzam » Fri Jun 27, 2008 2:17 pm

If there's any other template files or you know how to handle phpbb3 so you can edit by your own.Other wise you need help from others to work the code with your template.

:)
Azzam Malik
I love mods :)

r4dsking
Registered User
Posts: 89
Joined: Tue Jun 17, 2008 3:56 am
Contact:

Re: SEO MOD

Post by r4dsking » Sat Jun 28, 2008 3:07 am

This is a problem im getting, the pages 1|2|3|4|5 end in .php
Image

this is the url it goes to
Image

how do i fix it so it goes to html, from the # pages?

User avatar
goldenfaith
Registered User
Posts: 11
Joined: Thu Sep 27, 2007 8:39 pm

Re: SEO MOD

Post by goldenfaith » Sun Jun 29, 2008 11:26 am

i want to modify the url

Code: Select all

$name +"-f" + $id + ".html"
TO

Code: Select all

"f" + $id + ".html"
how can i do?

User avatar
GurlzLubme
Registered User
Posts: 880
Joined: Wed Sep 01, 2004 11:21 am
Location: New York

Re: SEO MOD

Post by GurlzLubme » Sun Jun 29, 2008 11:32 pm

so many pages of bugs and fixes, i'm still unsure if this is compatible with 3.0.1? Is anyone running this mod without a hitch or errors that others are reporting with the latest phpbb3 version?
1,000,000 Thank Yous to everyone who's been helping me on phpbb.com!

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: SEO MOD

Post by rwap01 » Mon Jun 30, 2008 11:00 am

GurlzLubme wrote:so many pages of bugs and fixes, i'm still unsure if this is compatible with 3.0.1? Is anyone running this mod without a hitch or errors that others are reporting with the latest phpbb3 version?
Yes, I run it under phpbb 3.0.1 - but you do need to ensure that you implemement the essential fixeswhich are signposted on p34 of this forum

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: SEO MOD

Post by rwap01 » Mon Jun 30, 2008 11:15 am

r4dsking wrote:This is a problem im getting, the pages 1|2|3|4|5 end in .php
Image

this is the url it goes to
Image

how do i fix it so it goes to html, from the # pages?
You have made an error in the implementation of the routine - it may be viewtopic.php or viewforum.php (you do not say whether the link to the page works from within the topic, or when looking at the list of topics).

Look for the links to generate_seo_pagination or topic_generate_seo_pagination
You may also need to implement the following essential modifications: http://www.phpbb.com/community/viewtopi ... 5#p5705125

User avatar
lanesharon
Registered User
Posts: 400
Joined: Fri Dec 05, 2003 9:33 pm
Location: º• Confused! •º
Contact:

Re: Essential Fixes to the SEO_MOD

Post by lanesharon » Mon Jun 30, 2008 3:53 pm

Is the a 'duh' moment for me. If everyone knows that these fixes MUST be done for this mod to work, then why aren't they blended into the original release and updated to the original download link package?
rwap01 wrote:It might help newbies if there was a sticky at the top to show essential updates to this MOD. Reading through the 34 pages, it is hard to find which ones were fixed in the proper release. However, from issues with my own forums, I have identified the following as the main problems which need to be corrected once you install the MOD.

Mark all forums read:
http://www.phpbb.com/community/viewtopi ... 5#p4099045

Clean URL to ensure characters such as "!" work in topic titles:
http://www.phpbb.com/community/viewtopi ... 0#p5305115

Sort out pagination errors on list of topics:
http://www.phpbb.com/community/viewtopi ... 5#p5705125

Sort out pagination when viewing a topic:
http://www.phpbb.com/community/viewtopi ... 5#p5274095

Correct the link in email notification of a new post (not fully tested!):
http://www.phpbb.com/community/viewtopi ... 0#p5733555

Correct the javascript pop up when you click on Page 1 of 4 to enable you to jump directly to a page number:
http://www.phpbb.com/community/viewtopi ... 5#p5784105

Correct the go to new posts in a topic using the orange icon before the start of the topic name:
http://www.phpbb.com/community/viewtopi ... 5#p5784105

Correct Link to First Unread Post when you are in a topic so that it works:
http://www.phpbb.com/community/viewtopi ... 5#p5851575

Correct error in SQL statement in functions_seo.php (shown particularly if you implement the RSS MOD):
http://www.phpbb.com/community/viewtopi ... 5#p5497265

Correct the link to a topic when you email a link to a friend:
http://www.phpbb.com/community/viewtopi ... 5#p5915295


Anyone got any others??

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: Essential Fixes to the SEO_MOD

Post by rwap01 » Mon Jun 30, 2008 4:13 pm

lanesharon wrote:Is the a 'duh' moment for me. If everyone knows that these fixes MUST be done for this mod to work, then why aren't they blended into the original release and updated to the original download link package?
Mainly because the package author does not respond to emails although he still posts on the forums, he appears to have lost complete interest in this.

Many people agree that this should all be incorporated in the original release - however, what else to do?

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: SEO MOD

Post by rwap01 » Mon Jun 30, 2008 4:15 pm

Damien Boyle wrote:Hello,

Thanks for this great mod 8-)

I just installed this mod and it seems to be working fine, but when i click a topic with the symbols @ ! * in the topics name i get 500 Internal Server Error error.

Here is a example..

Working: http://www.mixjunkies.com/lee-burridge- ... a-t17.html

Not working: http://www.mixjunkies.com/inertia-@-the ... 8-t45.html

SORTED THANKS TO FLYCKER :D

Some improvements to the clean_url() in functions_seo.php:

Code: Select all

function clean_url($url)
{
   $url = trim(str_replace(array('Re:', 're:'), '', $url));
   //$find = array('?', '#', '%', '?', '^', '.', '/', ' ', '_', ')', '(', '[', ']', ':', '.');
   $find = array(' ', '@', '=', '$', '&amp', '+', '~', '`', '?', '#', '%', '!', '^', '.', '/', '_', ')', '(', '[', ']', '{', '}', ':', ',', '<', '>', ';', '|', '*', '"', '\'', '\\');
   $url = str_replace($find, '-', censor_text($url));
   // remove all duplicates "-"
   $url = ereg_replace("-+", '-', $url);
   // remove the last "-", to avoid this "/test--t14.html"
   if ($url{strlen($url)-1} == '-')
   {
      $url = substr($url, 0, -1);
   }
   return utf8_clean_string($url);
}
I have found a problem with this where the Quote (") character is used in topic titles.

I have resolved this by amending this updated code to:

Code: Select all

function clean_url($url)
{
   $url = trim(str_replace(array('Re:', 're:'), '', $url));
   //$find = array('?', '#', '%', '?', '^', '.', '/', ' ', '_', ')', '(', '[', ']', ':', '.');
   $find = array(' ', '@', '=', '$', '&amp', '&quot', '+', '~', '`', '?', '#', '%', '!', '^', '.', '/', '_', ')', '(', '[', ']', '{', '}', ':', ',', '<', '>', ';', '|', '*', '"', '\'', '\\');
   $url = str_replace($find, '-', censor_text($url));
   // remove all duplicates "-"
   $url = ereg_replace("-+", '-', $url);
   // remove the last "-", to avoid this "/test--t14.html"
   if ($url{strlen($url)-1} == '-')
   {
      $url = substr($url, 0, -1);
   }
   return utf8_clean_string($url);
}
(Updated 18:43 on 30th June 2008 - needed to add '&quot' to the $find array.

User avatar
vellatechie
Registered User
Posts: 185
Joined: Fri Feb 01, 2008 7:33 pm

Re: SEO MOD

Post by vellatechie » Tue Jul 01, 2008 7:34 am

fcuk... so many bugs :|... i am now thinking of using this http://www.phpbb-seo.com/ instead :roll:... has anyone used phpbb-seo before??

AllGo
Registered User
Posts: 12
Joined: Sun May 04, 2008 12:48 pm
Contact:

Re: Essential Fixes to the SEO_MOD

Post by AllGo » Tue Jul 01, 2008 1:24 pm

rwap01 wrote: Many people agree that this should all be incorporated in the original release - however, what else to do?
A hostile takeover.. Just release a 1.0.1 :)

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: SEO MOD

Post by rwap01 » Tue Jul 01, 2008 6:17 pm

vellatechie wrote:fcuk... so many bugs :|... i am now thinking of using this http://www.phpbb-seo.com/ instead :roll:... has anyone used phpbb-seo before??
I think / hope that all of the bugs have been fixed now if you take account of the essential fixes

Not used phpbb-seo before - sorry

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: Essential Fixes to the SEO_MOD

Post by rwap01 » Tue Jul 01, 2008 6:46 pm

AllGo wrote:
rwap01 wrote: Many people agree that this should all be incorporated in the original release - however, what else to do?
A hostile takeover.. Just release a 1.0.1 :)
Anyone fancy doing this? I am hopeless at editing .xml files!!

User avatar
vellatechie
Registered User
Posts: 185
Joined: Fri Feb 01, 2008 7:33 pm

Re: SEO MOD

Post by vellatechie » Tue Jul 01, 2008 8:10 pm

rwap01 wrote:Anyone fancy doing this? I am hopeless at editing .xml files!!
are we allowed to edit xml files and post teh link without permission from the guy who build the mod :roll:

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: SEO MOD

Post by rwap01 » Tue Jul 01, 2008 9:01 pm

vellatechie wrote:
rwap01 wrote:Anyone fancy doing this? I am hopeless at editing .xml files!!
are we allowed to edit xml files and post teh link without permission from the guy who build the mod :roll:
My guess is that you keep the copyright statement and just upload it to the MOD database!!

Locked

Return to “[3.0.x] MOD Database Releases”