SEO MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
drankur
Registered User
Posts: 271
Joined: Sat Dec 22, 2007 4:16 am

Re: SEO MOD

Post by drankur » Sat Aug 09, 2008 6:10 am

rwap01 wrote:
c4gamerz wrote:i just got a problem with phpbb 3.0.2 when i click on bump topic it shows return message to topic or forum but link is broken and when i click on return to the post or return to forum it gives file not found error so anyway to fix it?

edit: it may be because of outdated style?
I have not yet implemented 3.0.2 due to time, therefore will wait and see and how others get on with it.
i have installed it on3.0.2 with style also updated to 3.0.2 ,but still getting the bump problem mentioned
plz help rwap01,u have been excellent and others too

drankur
Registered User
Posts: 271
Joined: Sat Dec 22, 2007 4:16 am

Re: SEO MOD

Post by drankur » Sat Aug 09, 2008 6:26 am

Andey wrote:working with 3.0.2 :)
http://www.ugk.cc/

just remember to edit

Code: Select all

function topic_generate_seo_pagination($replies, $url)

Code: Select all

$append = '.' . $phpEx;
to

Code: Select all

$append = '.' . $config['seo_ext'];
in which file??

pappfer
Registered User
Posts: 128
Joined: Fri Apr 16, 2004 5:05 pm

Re: SEO MOD

Post by pappfer » Sat Aug 09, 2008 10:39 am

I've got a couple of questions before installing it.
  • Is it safe to use in a live environment after correcting the known bugs?
  • I've checked phpBB SEO mod, which seems more powerful then this one but I also have a feeling that much more people uses this. Why? Because of support?
  • Will the new version (which Handyman stated) use the same rewrited addresses to make sure there won't be any duplicated content, or that might change? Also wondering how are you going to solve the upgrade? Cause many users use the mod just how it is (maybe with some fixes) and many users use all the fixes, so it won't be easy to make an upgrade tutorial I think.
  • In general (not just about this mod): how does the automatic updater work? I've read the documentation which says automatic updater is the preferred way to use when your forum has MODs. But how does it work, actually? Compares the original file with mine from line by line and what does it do when there's a difference?
    How does it know when to my line or just add the new lines?
Last but not least: Thank you very much for this MOD! ;) Even if it's buggy it's still one of the most important MODs I think.

danswano
Registered User
Posts: 273
Joined: Sun Apr 06, 2008 10:43 pm

Re: SEO MOD

Post by danswano » Sat Aug 09, 2008 11:21 am

Removed it totally because:
made conflict with some mods like portal and thankyou mod
alot of bugs in search function like view new posts and pagination.

tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: SEO MOD

Post by tommekemc » Sat Aug 09, 2008 4:16 pm

drankur wrote:
Andey wrote:working with 3.0.2 :)
http://www.ugk.cc/

just remember to edit

Code: Select all

function topic_generate_seo_pagination($replies, $url)

Code: Select all

$append = '.' . $phpEx;
to

Code: Select all

$append = '.' . $config['seo_ext'];
in which file??
in includes/functions_seo.php
find:

Code: Select all

$append = '.' . $phpEx;
replace with

Code: Select all

$append = '.html';
Last edited by tommekemc on Mon Aug 11, 2008 5:09 am, edited 1 time in total.
my sig
my projects

images deleted because of the 6kb (wtf?) rule...

kebabas
Registered User
Posts: 10
Joined: Tue Feb 27, 2007 9:28 pm

Re: SEO MOD

Post by kebabas » Sun Aug 10, 2008 10:59 am

polls doesn't work. people can't vote, when they choose the answer ar press VOTE the site reloads, but there are again vote menu, like nothing happend. How can i fix that?

drankur
Registered User
Posts: 271
Joined: Sat Dec 22, 2007 4:16 am

Re: SEO MOD

Post by drankur » Mon Aug 11, 2008 4:24 am

one more bug:

u are not able to prewiew style other than the default one.

so two bugs remains to be sorted:
bump topic bug and the prewiew style bug

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: SEO MOD

Post by rwap01 » Tue Aug 12, 2008 6:34 am

Handyman` wrote:
rwap01 wrote:Unfortunately, the original author seems to have lost interest, therefore the original files will never be updated so far as I can see.
Do not start up rumors.
Only reason I'm not providing support in here is because
  1. Every issue has already been addressed in this topic and I don't have time to keep answering the same questions over and over.
  2. I'm extremely busy currently and what time I do have available is spent on updating MODs and performing my duties as a MOD Team Member.
  3. If you've taken the 2 seconds to look at my signature, you will notice that stuff is slowly being updated.
  4. I still need this for myself and I have already laid out plans for the next version (a rewrite so you only have add 2 lines of code)
It is great to see that you are still updating this MOD then - it was not intended to be a rumour, I had emailed you a couple of times, and tried contacting you, but you didn't respond, so how were people to know you were still interested? - any chance you could simply amend the first post on this topic to actually link to the post where all of the fixes are listed, rather than having to trawl through goodness how many pages to find all of the bug fixes?

Good luck with the new version.

rwap01
Registered User
Posts: 91
Joined: Wed Jun 04, 2008 11:09 am
Contact:

Re: SEO MOD

Post by rwap01 » Tue Aug 12, 2008 6:39 am

kebabas wrote:polls doesn't work. people can't vote, when they choose the answer ar press VOTE the site reloads, but there are again vote menu, like nothing happend. How can i fix that?
Oh - do you mean the last of the bug fixes listed at:
http://www.phpbb.com/community/viewtopi ... 5#p5716395

absolutex
Registered User
Posts: 57
Joined: Tue Jul 01, 2008 4:33 pm
Contact:

Re: SEO MOD

Post by absolutex » Tue Aug 12, 2008 5:14 pm

this mod is very hard to fix bc New user should read all page to fix it :D

finally worked! :lol:

Thank for good mod

User avatar
Handyman`
Former Team Member
Posts: 1751
Joined: Thu Feb 03, 2005 8:44 pm
Contact:

Re: SEO MOD

Post by Handyman` » Tue Aug 12, 2008 7:35 pm

rwap01 wrote:any chance you could simply amend the first post on this topic to actually link to the post where all of the fixes are listed, rather than having to trawl through goodness how many pages to find all of the bug fixes?
Done… well, 4th post anyways.
Seems I was the last to know my MOD was validated :P
http://startrekguide.com My Mod Queue || 1/16/10 Display Posts Anywhere 1.2.0 RC5, Cash MOD 1.0.0 b1, MOD Version Check, AJAX Chat, SEO MOD, AJAX QR, Photo Gallery
MOD Development Manager (version 0.2.0-dev with MODX Generator)

ANgelArvil
Registered User
Posts: 99
Joined: Tue May 27, 2008 7:04 am

Re: SEO MOD

Post by ANgelArvil » Wed Aug 13, 2008 12:00 am

Open: includes/functions.php
Find

Tip: This may be a partial find and not the whole line.
Code: Select All

Code: Select all

Code: Select all

global $_SID, $_EXTRA_URL;

The code there never exist in my Phpbb... I am using 3.0.2, but it has, something similar like that, I'm afraid to edit that, coz syntax ; is : there

Can I use any other alternation?

Thx in advance!

bluecafez
Registered User
Posts: 43
Joined: Thu Apr 24, 2008 9:25 pm

Re: SEO MOD

Post by bluecafez » Thu Aug 14, 2008 12:41 pm

Please update the mod and release the fully stable.

XToF.be
Registered User
Posts: 61
Joined: Thu Jun 28, 2007 10:52 am
Contact:

Re: SEO MOD

Post by XToF.be » Sat Aug 16, 2008 2:12 pm

I think it's time to remove the one week layer of dust from my previous post :) .
XToF.be wrote:Bump:
XToF.be wrote:When I post a reply and I want to view my post, the MOD redirects me to the first page of the topic instead of my reply. I didn't find something about this issue in this topic so far.

Edit:
I'm having the exact same issue as described by flycker some posts above:

Here and
here and
here .
So from the moment that there are more than one page of reply posts, I'm redirected to the first page when replying.

It takes me to the URL:
http://myboard.com/topic-title-t464.html#p1822,
where it should take me to:
http://myboard.com/topic-title-t464s40.html#p1822

Does anyone have an idea? Or can anyone give me some hints?

fix johnson
Registered User
Posts: 12
Joined: Sat Feb 25, 2006 2:39 pm
Contact:

Re: SEO MOD

Post by fix johnson » Mon Aug 18, 2008 11:51 am

I have been trying to install seo into my database but get the following error, anyone help with this?

Error

SQL query:

INSERT INTO phpbb_config( config_name, config_value, is_dynamic )
VALUES (
'seo_ext', 'html', 0
)

MySQL said: Documentation
#1054 - Unknown column 'is_dynamic' in 'field list'

thanks

Fix

Locked

Return to “[3.0.x] MOD Database Releases”