SEO MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
User avatar
dontcoz
Registered User
Posts: 478
Joined: Mon Sep 29, 2008 9:49 pm
Location: Vancouver, BC
Contact:

Re: SEO MOD

Post by dontcoz »

I know.. it's sort of OK i guess, it works but it's buggy for sure. none of the other MODs presented such a challenge to install either. it would be nice if it became an integral part of the next phpBB version. i keep seeing people post about how this forum has no problems without the SEO mod etc. but what they seem to not get is that there is a not-so-slight difference between a small, 100-1000 threads forum and this monster :P
Anyways, i don't want to sound ungrateful, it is an open source after all, and my comment is really just to underline the importance of this MOD.

I've added your disallow compilation to my robots.txt thanks again for posting it. will see what it does, I wish i understood better the inconsistency in disallowed links titles. but oh well! can't win them all;))
Last edited by dontcoz on Tue Jan 13, 2009 7:49 am, edited 1 time in total.
LondonGeezer
Registered User
Posts: 30
Joined: Wed Nov 26, 2008 1:15 am

Re: SEO MOD

Post by LondonGeezer »

dontcoz wrote:I know.. it's sort of OK i guess, it works but it's buggy for sure. none of the other MODs presented such a challenge to install either. it would be nice if it became an integral part of the next phpBB version. i keep seeing people post about how this forum has not problems without the SEO mod etc. but what they seem to not get is that there is a not-so-slight difference between a small, 100-1000 threads forum and this monster :P
Anyways, i don't want to sound ungrateful, it is an open source after all, and my comment is really just to underline the importance of this MOD.

I've added your disallow compilation to my robots.txt thanks again for posting it. will see what it does, I wish i understood better the inconsistency in disallowed links titles. but oh well! can't win them all;))

Is that why this board doesn't use such a static url mod? - Because of the sheer size of it?.. I hope the mod doesn't ruin boards as they grow, it's almost impossible to reverse the mod because of the amount of fixes applied to it.. well not impossible but way hard lol.

That robots file will work perfectly as I used a similar one on my article site and done the trick for me there :) but as mentioned in my previous post, with some slight modification to the way the SEO_MOD works (keeping forum categories in the static url names) will add great seo benefits and help us to add "ALLOW" commands to the robots file very easily!

I don't think anyone here who has used this mod is ungreatful, it's a great mod and much respect to the author ;)

However, if the following could be completed and added to the download file.. it would be much appreciated because we will all benefit (including those who are downloading it and installing on a daily basis):

1. Update all the bug fixes to the download file
2. Add forum categories existence in the static url (/forum/category-name/topic-title.php)
3. Maybe include a simple robots file to disallow bots crawling dynamic topic links & allow static urls.

I would do it if I knew how.
User avatar
dontcoz
Registered User
Posts: 478
Joined: Mon Sep 29, 2008 9:49 pm
Location: Vancouver, BC
Contact:

Re: SEO MOD

Post by dontcoz »

^^^what he said:))

And as far as why they don't use the mod here - they simply don't need it, they have a very valuable content here that's googled by thousands on a daily basis.
jsingh
Registered User
Posts: 6
Joined: Mon Dec 29, 2008 3:12 pm

Re: SEO MOD

Post by jsingh »

Print topic fix:

Open viewtopic.php

replace

Code: Select all

'U_PRINT_TOPIC'			=> ($auth->acl_get('f_print', $forum_id)) ? $viewtopic_url . '&view=print' : '',
with

Code: Select all

'U_PRINT_TOPIC'			=> ($auth->acl_get('f_print', $forum_id)) ? $viewtopic_url . '-view=print' : '',
Bookmark Topic fix:

replace

Code: Select all

'U_BOOKMARK_TOPIC'		=> ($user->data['is_registered'] && $config['allow_bookmarks']) ? $viewtopic_url . '&bookmark=1&hash=' . generate_link_hash("topic_$topic_id") : '',
with

Code: Select all

'U_BOOKMARK_TOPIC'		=> ($user->data['is_registered'] && $config['allow_bookmarks']) ? $viewtopic_url . '-bookmark=1&hash=' . generate_link_hash("topic_$topic_id") : '',
takadante
Registered User
Posts: 62
Joined: Tue Nov 11, 2008 5:52 am
Contact:

Re: SEO MOD

Post by takadante »

Any input on my redirection issue? I have portal installed and when I click to go to forum, it redirects me back to the portal.

****Solved. I changed the name of index.php to board.php, and changed the link in my navbar to correspond with the name.

I am still have trouble with the thank you mod. My error is posted a few posts above.
http://theappshare.com ~ iPhone and OSX Applications!
User avatar
Ratmaster
Registered User
Posts: 163
Joined: Sun Feb 12, 2006 3:14 pm
Location: New Jersey, USA

Re: SEO MOD

Post by Ratmaster »

I am not sure if anyone else is having trouble with this, but I seem to be the only one.

My "Who is online" in my viewtopic page is supposed to show users viewing topics in that specific forum too, right? When I am viewing a topic, the Who is online doesn't show my name in it.

From what it looks like, this mod doesn't show the forum number in the URL. I don't know if this is the problem, but I found something:

Code: Select all

if (empty($_REQUEST['f']))
{
    $_REQUEST['f'] = $forum_id;
} 
Is this mod the problem or did I miss an edit or something?

Thanks.
Aexo
Registered User
Posts: 20
Joined: Sun Dec 09, 2007 12:27 pm
Contact:

Re: SEO MOD

Post by Aexo »

When voting in a poll at the end of the URL I put a '-' I do a 404, but does not believe that the function of voting. I button to vote and I get the same URL that the post but with the '-'
Example:
http://www.clubifone.com/foro/que-le-pe ... 24349.html

If I vote, then
http://www.clubifone.com/foro/que-le-pe ... 4349.html-

This post don't work me.
Any idea?
User avatar
rexkyo
Registered User
Posts: 14
Joined: Mon May 23, 2005 8:44 am
Contact:

Re: SEO MOD

Post by rexkyo »

品質就是當價格被遺忘之後,消費者還依然記得的事~
Aexo
Registered User
Posts: 20
Joined: Sun Dec 09, 2007 12:27 pm
Contact:

Re: SEO MOD

Post by Aexo »

Thank you! gave me the solution. It also says the other problem I have but I do not work. The problem is that I do not mark all forums read.
I will put forward a solution here for those who have the same problem as me.

Don't fully understand why it decides to add an extra '-' at the end of the link, but hey, heres how to get rid of it.
Open includes/functions_seo.php
Find:

Code: Select all

return $url . (($append_url) ? $url_delim . $append_url . $amp_delim : $url_delim) . $params . ((!$session_id) ? '' : $amp_delim . 'sid=' . $session_id);
Replace With:

Code: Select all

return trim($url . (($append_url) ? $url_delim . $append_url . $amp_delim : $url_delim) . $params . ((!$session_id) ? '' : $amp_delim . 'sid=' . $session_id), '-');
Thanks to cyba
User avatar
fazaljatoi
I've Been Banned!
Posts: 503
Joined: Wed Aug 31, 2005 8:02 pm

Re: SEO MOD

Post by fazaljatoi »

i istall this mod phpBb 3.0.4
but i face two issue

when i go in my forum section show section name

Code: Select all

/forum/satellite-forum-english--f3.html
but when u want to see any topic section name remove and topic name show

Code: Select all

/forum/where-i-watch-cnn-fta-t74367.html
i want show forum name & topic name both same here

Code: Select all

/forum/satellite-forum-english--f3.html/where-i-watch-cnn-fta-t74367.html
2nd

i end of my forum show this i want delete this where i found this link any files
[
SEO MOD © 2007 StarTrekGuide ]
Last edited by fazaljatoi on Thu Jan 08, 2009 5:41 am, edited 2 times in total.
pacix
Registered User
Posts: 28
Joined: Sun Sep 28, 2008 10:03 pm

Re: SEO MOD

Post by pacix »

I am trying to install this MOD and I getting problems in the very first step (to verify my server allow rewritting).
When I do the modifications on htacess and upload to a test-t1, I get the following:
ERROR 403: ¡PROHIBIDO!
El servidor ha entendido la solicitud, pero no la puede llevar a cabo. La solicitud de autorización no será necesaria, ya que esta acción está prohibida y NO ESTÁ PERMITIDO volver a solicitarla.

Which means
ERROR 403: FORBIDDEN!
The server has understood the request, but can not perform it. The request for authorization is not required as this action is prohibited and is not allowed to be replayed.

Does this mean that I can not install this MOD? If the answer is yes, is there any way that I can get rid of the "sid" thing in phpbb3?
Aexo
Registered User
Posts: 20
Joined: Sun Dec 09, 2007 12:27 pm
Contact:

Re: SEO MOD

Post by Aexo »

ask your server. It may have turned off the url rewrite or anything
Friendly
Registered User
Posts: 66
Joined: Tue May 06, 2008 12:21 pm

Re: SEO MOD

Post by Friendly »

I have been using this mod mostly problem free for a while, but I have discovered a problem. When setting up a poll (or a survey, using the survey mod) the action of the form is incorrect, causing the polls to not work. A hyphen is added to the end of the URL in the action of the form tag. There is no hyphen at the end of the URL though, so the user is forwarded to the home page of the site. Does anybody have an idea of how to fix this?
tarok
Registered User
Posts: 5
Joined: Fri Jan 09, 2009 9:23 am

Re: SEO MOD

Post by tarok »

hi

thanks for this mod

i have a problem however

i cannot find this code:

Code: Select all

global $_SID, $_EXTRA_URL;
in includes/functions.php
tarok
Registered User
Posts: 5
Joined: Fri Jan 09, 2009 9:23 am

Re: SEO MOD

Post by tarok »

would someone be willing to help me out installing this mod :oops:

i do know few things about php so it should not take long :oops:

my msn is tarokboy@gmail.com, please, i need help
Locked

Return to “[3.0.x] MOD Database Releases”