SEO MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
grawat
Registered User
Posts: 33
Joined: Wed Jan 30, 2008 5:10 am

Re: SEO MOD

Post by grawat »

Ok. I tried clicking on link that shows "View first unread post" and I get a 404 error. Is that an error with this mod or something else ? and is there a fix for it ?
User avatar
Jaymie1989
Registered User
Posts: 1991
Joined: Thu Aug 02, 2007 5:21 pm
Name: Jaymie

Re: SEO MOD

Post by Jaymie1989 »

Jaymie1989 wrote:Dont suppose this is like the Raw URL Converter from phpBB2 is it. :)
Dear creators of Sesame Street,
Kids are still fat. Can I come back now?
Sincerely, Cookie Monster.

View my MODs - Need phpBB help with MODs and Styles? Take a look at my phpBB3 services
yasinahmetsevim
Registered User
Posts: 26
Joined: Mon Mar 17, 2008 6:28 pm
Location: Istanbul
Contact:

Re: SEO MOD

Post by yasinahmetsevim »

'<br /><br />' . sprintf($user->lang['RETURN_PAGE'], '<a href="' . append_sid("{$phpbb_root_path}viewtopic.$phpEx", 'p=' . $post_id) . '#p' . $post_id . '">', '</a>'));
I need help for the bolded part of the quote. I use rep.mod and need to redirect to previous topic. I think I the link is in the bolded part and I need one part that works with the seo mod.
User avatar
JinYoshi
Registered User
Posts: 46
Joined: Wed Sep 20, 2006 12:41 pm
Location: Jakarta
Contact:

Re: SEO MOD

Post by JinYoshi »

@yasinahmetsevim:
For back link reputation.
Replace the file reputiation.php in the root of your forum folder.
http://phpbb.pastebin.com/f4b55121b
Last edited by JinYoshi on Thu Mar 20, 2008 7:52 pm, edited 2 times in total.
sorry, no signature for this month...
User avatar
Jaymie1989
Registered User
Posts: 1991
Joined: Thu Aug 02, 2007 5:21 pm
Name: Jaymie

Re: SEO MOD

Post by Jaymie1989 »

Jaymie1989 wrote:
Jaymie1989 wrote:Dont suppose this is like the Raw URL Converter from phpBB2 is it. :)
Dear creators of Sesame Street,
Kids are still fat. Can I come back now?
Sincerely, Cookie Monster.

View my MODs - Need phpBB help with MODs and Styles? Take a look at my phpBB3 services
flycker
Registered User
Posts: 25
Joined: Fri Jun 01, 2007 2:27 pm

Re: SEO MOD

Post by flycker »

A little error to correct:
Image
* it's not add after, it's replace with (will working anyway..)

And another strange thing:
Image
* after this, we have this line:

Code: Select all

trigger_error($message);
It's correct?
User avatar
Jaymie1989
Registered User
Posts: 1991
Joined: Thu Aug 02, 2007 5:21 pm
Name: Jaymie

Re: SEO MOD

Post by Jaymie1989 »

Jaymie1989 wrote:
Jaymie1989 wrote:
Jaymie1989 wrote:Dont suppose this is like the Raw URL Converter from phpBB2 is it. :)
Anyone?
Dear creators of Sesame Street,
Kids are still fat. Can I come back now?
Sincerely, Cookie Monster.

View my MODs - Need phpBB help with MODs and Styles? Take a look at my phpBB3 services
flycker
Registered User
Posts: 25
Joined: Fri Jun 01, 2007 2:27 pm

Bugs and bug fix compilation.

Post by flycker »

I do my homework, read through all the post in this topic.
Sorry if I forgot something.

I tested all in my fresh install, last phpbb3 + SEO mod.
The domain name is "new1.myforum.com", and you cannot access them.

Bugs and bug fix compilation.

First, bug fix's:

- "Mark forums read" doens't work.
http://www.phpbb.com/community/viewtopi ... 0#p3251600
or
http://www.phpbb.com/community/viewtopi ... 5#p4099045

- The pagination bug (direct link to subsites of threads, where the extension ist .php but have to be .html).
http://www.phpbb.com/community/viewtopi ... 0#p3903285

- This will fix all the "Return to" and the "Poll".
http://www.phpbb.com/community/viewtopi ... 5#p4222945

Thanks to all people that post a bug fix! Especial to Handyman and JinYoshi.

Second, bugs without a bug fix:

1. - "Page 2 of 4" (javascript) doens't work:
1.1 Image
1.2 Image
1.3 Go to "http://new1.myforum.com/&start=10" a "404 - Not Found" page.

2. - Unread orange icon (When you are viewing a forum and there are unread threads you can click on the little orange)
2.1 Image
2.2 Go to "http://new1.myforum.com/sdfsdfs-t9.html ... ead#unread" a "404 - Not Found" page.

3. After report a topic, has a problem in "Return to the topic last visited".
3.1 Image
3.2 Go to this link "http://new1.myforum.com/viewtopic.php?f=2&p=29#p29", and show this error:

Code: Select all

"General Error
SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right 

syntax to use near 'topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 29' at line 3 [1064]

SQL

SELECT t.topic_title FROM posts p topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 29

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: includes/functions_seo.php
LINE: 171
CALL: dbal_mysqli->sql_query()

FILE: viewtopic.php
LINE: 58
CALL: moved_topic()"
* I have a fresh copy of phpBB3, and only add this MOD.. i don't know who to fix this..

4. When you have more than one page, and you reply a post, the return goes to the first page.
4.1 For example: The page goes to "http://new1.myforum.com/teste-t2.html#p34", but the correct is "http://new1.myforum.com/teste-t2s20.html#p34".

Anyone have fixes for these problems?
Anyone have new bugs to add in this list? If you prefer, send me a PM instead of posting here.. to this post stay more clean.

Others:
Maybe this is usefull:
http://www.phpbb.com/community/viewtopi ... 0#p4282965
http://www.phpbb.com/community/viewtopi ... 5#p4447405

Cya!
FlycKER
flycker
Registered User
Posts: 25
Joined: Fri Jun 01, 2007 2:27 pm

clean_url()

Post by flycker »

Some improvements to the clean_url() in functions_seo.php:

Code: Select all

function clean_url($url)
{
	$url = trim(str_replace(array('Re:', 're:'), '', $url));
	//$find = array('?', '#', '%', '?', '^', '.', '/', ' ', '_', ')', '(', '[', ']', ':', '.');
	$find = array(' ', '@', '=', '$', '&amp', '+', '~', '`', '?', '#', '%', '!', '^', '.', '/', '_', ')', '(', '[', ']', '{', '}', ':', ',', '<', '>', ';', '|', '*', '"', '\'', '\\');
	$url = str_replace($find, '-', censor_text($url));
	// remove all duplicates "-"
	$url = ereg_replace("-+", '-', $url);
	// remove the last "-", to avoid this "/test--t14.html"
	if ($url{strlen($url)-1} == '-')
	{
		$url = substr($url, 0, -1);
	}
	return utf8_clean_string($url);
}
User avatar
JinYoshi
Registered User
Posts: 46
Joined: Wed Sep 20, 2006 12:41 pm
Location: Jakarta
Contact:

Re: SEO MOD

Post by JinYoshi »

@flycker: thanks for listing :D

number 1:
Open file viewtopic.php
Find (Line +/- 612):

Code: Select all

    'U_VIEW_TOPIC'             => $viewtopic_url,          
Add After:

Code: Select all

    'A_BASE_URL'             => $viewtopic_url,          
number 2:
Open file viewforum.php
Find (Line +/- 638):

Code: Select all

            'U_NEWEST_POST'            => $view_topic_url . '&view=unread#unread',     
Replace:

Code: Select all

            'U_NEWEST_POST'            => $view_topic_url . '?view=unread#unread',    
number 3:
In my forum after click the report, doing well, the redirect and the Link URL looks fine and OK.

number 4:
In my forum it doenst go back to teste-t2.html#p34 or teste-t2s20.html#p34, it return to the post, teste-p34.html#p34
Please compare/view diff /your_root_forum/posting.php with this one: http://phpbb.pastebin.com/f3e57f350
I think it will fix for the number 3 too.
Last edited by JinYoshi on Fri Mar 21, 2008 4:33 pm, edited 4 times in total.
sorry, no signature for this month...
User avatar
JinYoshi
Registered User
Posts: 46
Joined: Wed Sep 20, 2006 12:41 pm
Location: Jakarta
Contact:

Re: SIDs in URLs

Post by JinYoshi »

divinemanwah wrote:hello,
i know it's very odd to ask about this (especially i have been using this mod for some time now),
but is it really normal that i have the SID part in my URLs?

ex.:
http://www.itspot.co.cc/forums/news-upd ... ts-f1.html-sid=5654645645636

it only shows up when it is the first time that you visit the forum.

is it normal?

thanks!
Please read this: http://startrekguide.com/community/view ... =62&t=5272
and this: http://www.phpbb.com/community/viewtopi ... 3#p3006767
Last edited by JinYoshi on Thu Mar 20, 2008 8:20 pm, edited 1 time in total.
sorry, no signature for this month...
User avatar
Jaymie1989
Registered User
Posts: 1991
Joined: Thu Aug 02, 2007 5:21 pm
Name: Jaymie

Re: SEO MOD

Post by Jaymie1989 »

Jaymie1989 wrote:
Jaymie1989 wrote:
Jaymie1989 wrote:
Jaymie1989 wrote:Dont suppose this is like the Raw URL Converter from phpBB2 is it. :)
Anyone?
Dear creators of Sesame Street,
Kids are still fat. Can I come back now?
Sincerely, Cookie Monster.

View my MODs - Need phpBB help with MODs and Styles? Take a look at my phpBB3 services
User avatar
JinYoshi
Registered User
Posts: 46
Joined: Wed Sep 20, 2006 12:41 pm
Location: Jakarta
Contact:

Re: SEO MOD

Post by JinYoshi »

Jaymie1989 wrote:
Jaymie1989 wrote:
Jaymie1989 wrote:
Jaymie1989 wrote:
Jaymie1989 wrote:Dont suppose this is like the Raw URL Converter from phpBB2 is it. :)
Anyone?
I do not know, i have never install SEO for phpbb2.
And why you asking this?
sorry, no signature for this month...
User avatar
Jaymie1989
Registered User
Posts: 1991
Joined: Thu Aug 02, 2007 5:21 pm
Name: Jaymie

Re: SEO MOD

Post by Jaymie1989 »

because if it is like the Raw URL Converter then its what i am looking for.
Dear creators of Sesame Street,
Kids are still fat. Can I come back now?
Sincerely, Cookie Monster.

View my MODs - Need phpBB help with MODs and Styles? Take a look at my phpBB3 services
User avatar
Eclipse2564
Registered User
Posts: 85
Joined: Thu Mar 20, 2008 2:28 am
Contact:

Re: SEO MOD

Post by Eclipse2564 »

Hi,

I notice some mods that I want to install including the SEO MOD but I can't find any instructions on installing them on different styles. All I see is how to install them on prosilver. Also, where do I upload the SEO_MOD.xml file to? Can someone help me?
Locked

Return to “[3.0.x] MOD Database Releases”