Page 39 of 77

Re: SEO MOD

Posted: Sun Jun 15, 2008 2:01 pm
by XToF.be
When I post a reply and I want to view my post, the MOD redirects me to the first page of the topic instead of my reply. I didn't find something about this issue in this topic so far.

Edit:
I'm having the exact same issue as described by flycker some posts above:

Here and
here and
here .
So from the moment that there are more than one page of reply posts, I'm redirected to the first page when replying.

It takes me to the URL:
http://myboard.com/topic-title-t464.html#p1822,
where it should take me to:
http://myboard.com/topic-title-t464s40.html#p1822

Does anyone have an idea? Or can anyone give me some hints?

Re: SEO MOD

Posted: Mon Jun 16, 2008 2:03 pm
by NLCrEaTiVe
I installed the following mod: http://www.phpbb.com/community/viewtopi ... &sk=t&sd=a

This mod uses code to display the last post in a topic. But when I press the link it shows the following error:

Code: Select all

SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'phpbb3_topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 5418' at line 3 [1064]

SQL

SELECT t.topic_title FROM phpbb3_posts p phpbb3_topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 5418

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: includes/functions_seo.php
LINE: 170
CALL: dbal_mysqli->sql_query()

FILE: viewtopic.php
LINE: 57
CALL: moved_topic()
Is there a way to solve this?

Re: SEO MOD

Posted: Tue Jun 17, 2008 1:43 am
by adda4u
installed mod

Now how to check it ...???

Re: SEO MOD

Posted: Tue Jun 17, 2008 1:56 am
by adda4u
Installed every thing perfectly and i didnt see any changes ...

Can any one help me ...

How to check weather it is really working or not

Re: SEO MOD

Posted: Tue Jun 17, 2008 8:57 am
by AllGo
NLCrEaTiVe wrote:I installed the following mod: http://www.phpbb.com/community/viewtopi ... &sk=t&sd=a

This mod uses code to display the last post in a topic. But when I press the link it shows the following error:
http://www.phpbb.com/community/viewtopi ... 5#p5497265

Should probably go in the essentials post.. (rwap01?)

Re: SEO MOD

Posted: Tue Jun 17, 2008 2:08 pm
by rwap01
adda4u wrote:Installed every thing perfectly and i didnt see any changes ...

Can any one help me ...

How to check weather it is really working or not
The only changes you should see is that when you are browsing the forums, instead of for example:

www.yourforum.com/viewtopic.php?f=3&t=10&p=1020
You should see

http://www.yourforum.com/this-is-your-t ... p1020.html

for example.

The idea is to help with search engine results - nothing else.

Link to First Unread Post when you are in a topic

Posted: Tue Jun 17, 2008 3:54 pm
by rwap01
I have just spotted another error in the pageination when viewing a topic. The link to "First unread post" goes to :

http://www.rwapservices.co.uk/ZX80_ZX81 ... iew=unread

rather than:

http://www.rwapservices.co.uk/ZX80_ZX81 ... ead#unread

(for example).

The solution lies within viewtopic.php - you need to replace the two instances of:

Code: Select all

'U_VIEW_UNREAD_POST'	=> format_url($topic_title, "t$topic_id", 0, 'view=unread'),
with

Code: Select all

'U_VIEW_UNREAD_POST'	=> format_url($topic_title, "t$topic_id", 0, 'view=unread#unread'),

Re: SEO MOD

Posted: Tue Jun 17, 2008 9:07 pm
by idontwantausername
Hi,

I've never used your mod before and I'm trying to install it, but when i open includes/functions, I cannot find the line "global $_SID, $_EXTRA_URL;", I have tried just finding "$_EXTRA_URL;" and ""$_SID", but i cannot find it, please tell me what i should do, this is what it says it says in the installation file:

Open: includes/functions.php
Find

Code: Select all

Tip: This may be a partial find and not the whole line.

global $_SID, $_EXTRA_URL;
Add after

Code: Select all

Tip: Add these lines on a new blank line after the preceding line(s) to find.

global $phpbb_root_path, $phpEx;

	if ($url === "{$phpbb_root_path}index.$phpEx")
	{
		return append_sid($phpbb_root_path);
	}
---------------------------------------------------------------------------------------------------------------------------------

ok found the error

for 3.0.1, instead of:

Code: Select all

global $_SID, $_EXTRA_URL;
it should now read:

Code: Select all

global $_SID, $_EXTRA_URL,

Re: SEO MOD

Posted: Fri Jun 20, 2008 12:46 am
by idontwantausername
hihi, i'm now getting blank topics, and i don't know why lol.

Re: SEO MOD

Posted: Fri Jun 20, 2008 5:33 am
by Milkin
Thanks for this MOD Handyman.
Thanks to everyone with all the fixes and help.
I worked my way through the last 39 pages and now have this SEO MOD installed & working with all bugs fixed except for one small issue:
When a user sends a topic to a friend using the "E-mail friend" link, that person recieves the email ok but the link back to the topic is like this example:

./test-page-etc.html

when the link in the email should be something like:

hxxp://www.myDomain.com/test-page-etc.html (this is not a working link)

Any help would be great.
Thanks.

Re: SEO MOD

Posted: Fri Jun 20, 2008 12:06 pm
by rwap01
Milkin wrote:Thanks for this MOD Handyman.
Thanks to everyone with all the fixes and help.
I worked my way through the last 39 pages and now have this SEO MOD installed & working with all bugs fixed except for one small issue:
When a user sends a topic to a friend using the "E-mail friend" link, that person recieves the email ok but the link back to the topic is like this example:

./test-page-etc.html

when the link in the email should be something like:

hxxp://www.myDomain.com/test-page-etc.html (this is not a working link)

Any help would be great.
Thanks.
Yes, I can confirm this problem as well - not sure why - memberlist.php does not appear to be able to pick up the PHPBB_ROOT_PATH and so, sets $phpbb_root_path to './'

Hmm - I am puzzled here - anyone got some bright ideas?

Re: SEO MOD

Posted: Sat Jun 21, 2008 9:44 am
by tupeu
This is really a shame, such a wanted mod to be left unfinished-bugsfull
You have 3 options if you want Static Url:

1. You can install this mod, reserve one full day for this is very difficult to install and make a
full database+files backup because there is a high posibility to f$$k-up your board

2. I found on the internet a mod just like this one only it is NOT FREE
(i don`t want to speculate)
It costs 70 euros (100$) it does exacly the same thing as this one does but they say you have to do
ONLY 1 FILE EDIT TO INSTALL THE MOD !

(It is called Magic SEO URL for phpBB3 if you can`t find it and want the www adress PM me)

Magic SEO URL for phpBB3 is the successor of similar Search Engine Optimization Enhancement for phpBB.
It changes the dynamic URLs to static and well-structured SEO friendly URLs. It also includes verification and validation of each URL, supports for safe change of URLs and redirections from all native and rewritten phpBB3 URLs, properly Sessions IDs handling*, high speed without negative effects to server load or web server response, it also prevents possible duplicate content penalties and does much more in comparison with other SEO solutions!


* Does not break phpBB3 MODs!
* You add only one line of code for installation!
* In comparison with other phpBB3 SEO MODs is The Best ever made!
* Free Installation service!



3. There is a premodded phpBB3 3.0.1 version that includes a similar but better mode FOR FREE:
(tested and working)

http://www.phpbb-seo.com/boards/phpbb-s ... t1549.html

Advanced phpBB3 SEO mod Rewrite

Description : This mod will URL rewrite phpBB URLs, injecting forums and topic titles in their URLS, each URL being rewritten once, no matter the number of links using it on the page.


They already are preparing themselves for updating this MOD to the phpBB3 3.0.2

:roll:

Re: SEO MOD

Posted: Sat Jun 21, 2008 10:04 am
by rwap01
I disagree that this MOD is that difficult to install - true there are some bugs, but thanks to various users (including myself), these have now all been fixed (apart from the email the link to a friend - above). The details of all fixes are at least now contained within a single post - http://www.phpbb.com/community/viewtopi ... 5#p5716395

The great shame is that the original author (Handyman) does not appear to have continued to support this MOD and include all of the bug fixes in the actual MOD instructions.

He is still about writing MODs, so the question is why has he stopped updating this one?

Re: SEO MOD

Posted: Sat Jun 21, 2008 10:49 am
by p0Wer
I really don't know if I should install this mod. Theoretically, it sounds great. I tried installing it a while back but totally messed my board up, but I am willing to try again.

To the above poster, what are all those fixes for? What do they do?

Thanks

Re: SEO MOD

Posted: Sat Jun 21, 2008 11:22 am
by rwap01
p0Wer wrote:I really don't know if I should install this mod. Theoretically, it sounds great. I tried installing it a while back but totally messed my board up, but I am willing to try again.

To the above poster, what are all those fixes for? What do they do?

Thanks
If you are careful following the instructions for installation and double check the lines where you place additional / replacement code, you should be fine.

However, there are numerous bugs in the original code, which is why I have listed all of the essential fixes to overcome the bugs and ensure that your board operates as it did before implementing the MOD.

I have emailed Handyman to ask him to incorporate these within the release and re-upload the MOD, but alas he just tells people to read through this forum!!