SEO MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
danman1202
Registered User
Posts: 8
Joined: Sat Dec 01, 2007 5:17 am

Re: SEO MOD

Post by danman1202 »

danman1202 wrote:My, "next" and, "previous" buttons do not work. As in the buttons you click within a thread to go from one page of the thread to the next.I added the pagination fix and was able to successfully click page numbers to get to content but the "next page" and "previous page" buttons are non functioning. Any help...? I've looked through a bunch of pages but this thread is so long I can't sift through it all.

Other errors for me:

"Next Topic" and "Previous Topic" buttons do not work.

Bumping threads with the "bump" button creates a 404 on the thread.

When I say, "do not work" I mean a 404 error was registered.

I'll give this a two or three days or else I'm done with this mod. Too buggy.

My forum:

http://www.madein1903.com/forum/
Anything regarding this?
danman1202
Registered User
Posts: 8
Joined: Sat Dec 01, 2007 5:17 am

Re: SEO MOD

Post by danman1202 »

It has been seven months since the initial release and there is still no second re-release to address issues. I don't think this modification should have been validated with all the issues with 404 errors. I understand that this is a fairly complex modification and will be prone to more errors than most, but this mod should still be listed as in development until the errors are remedied in my humble opinion. I removed this modification off of my forum until these issues have been addressed that I have brought up. Perhaps they are of my own error, perhaps not. Either way, I will await until it is fixed. Thanks for taking the time to create such an interesting mod, and I say that with no sarcasm. This will be an awesome mod once presented sans errors.
Peter77sx
Registered User
Posts: 3260
Joined: Wed Nov 09, 2005 2:51 pm

Re: SEO MOD

Post by Peter77sx »

There are other great alternatives... like the SEO MOD's by dcz. full support for phpbb3 with sitemaps and all the 9 yards.
danman1202
Registered User
Posts: 8
Joined: Sat Dec 01, 2007 5:17 am

Re: SEO MOD

Post by danman1202 »

Peter77sx wrote:There are other great alternatives... like the SEO MOD's by dcz. full support for phpbb3 with sitemaps and all the 9 yards.
I'll try it out. Thanks!
dearbabu
Registered User
Posts: 9
Joined: Thu Mar 13, 2008 6:36 am

Re: SEO MOD

Post by dearbabu »

hello

Now my site is working. I have described my query here. Please have a look and say a suggestion.
http://www.phpbb.com/community/viewtopi ... 5#p6829805
vibgyor
Registered User
Posts: 18
Joined: Thu Aug 28, 2008 5:35 pm

Re: SEO MOD

Post by vibgyor »

dearbabu wrote:hello

Now my site is working. I have described my query here. Please have a look and say a suggestion.
http://www.phpbb.com/community/viewtopi ... 5#p6829805
open ur viewtopic_body.html from ur (root/styles/style/template).
root- public_html
styles-ur themes folder
style-ur current theme folder

then remove

Code: Select all

<h2><a href="{U_VIEW_TOPIC}">{TOPIC_TITLE}</a></h2>
in that file save it,
then log into ur admin cp and run purge the cache
snadowitz
Registered User
Posts: 12
Joined: Tue Jul 25, 2006 2:45 pm

Re: SEO MOD

Post by snadowitz »

handyman - how do I get the latest version of this MOD? how do I install/activate it? (for a newbie to phpbb)
Snadowitz
Current projects:-
http://www.starcrossedtattoo.com
snadowitz
Registered User
Posts: 12
Joined: Tue Jul 25, 2006 2:45 pm

Re: SEO MOD

Post by snadowitz »

Peter77sx wrote:There are other great alternatives... like the SEO MOD's by dcz. full support for phpbb3 with sitemaps and all the 9 yards.
Can you post a link to the mod itself? The mods database search function sucks.........
Snadowitz
Current projects:-
http://www.starcrossedtattoo.com
jhansle1
Registered User
Posts: 25
Joined: Sun Jul 30, 2006 4:53 pm

Re: SEO MOD

Post by jhansle1 »

HI all,

I have tried quite a few locations and I just can't seem to get the ad to display:

http://www.planetsteelers.com/phpBB3/viewforum.php?f=2

I am not getting any errors, or weird display issues when I post the adsense JS.

I'm not using the standard theme so that may be a problem, but I think the tags are in the correct place.
Vysse
Registered User
Posts: 9
Joined: Wed Sep 03, 2008 11:46 pm

Re: SEO MOD

Post by Vysse »

ok so iv been using phpbb for a few months now and finally got a server. for the past few weeks iv been doing mod after mod after mod. i just finished installing the SEO mod and the Advanced Meta Tags mod. now anytime i go to certain areas in my acp i get blank pages. i tried putting an htaccess file under forums/adm to show the php errors with no results. any ideas on how i can fix this?
harikumar001
Registered User
Posts: 7
Joined: Fri Aug 15, 2008 11:39 am

Re: SEO MOD

Post by harikumar001 »

Can anything be done about the Bump problem :(
User avatar
justclik
Registered User
Posts: 6
Joined: Fri Jul 20, 2007 11:26 am

Re: SEO MOD

Post by justclik »

plz can i know why whene i past the sql line :

Code: Select all

INSERT INTO phpbb_config (config_name, config_value, is_dynamic) VALUES ('seo_ext', 'html', 0);
it gives me that error i wondring why plz can u help me with that :)

Image

thanks in advince
lizard78
Registered User
Posts: 59
Joined: Tue Sep 09, 2008 5:57 pm

Re: SEO MOD

Post by lizard78 »

Hi, I user a recent topic mod. After installing this SEO mod, there is no change in the recent file. what I have to change, can anybody help me please?

Here is my recent.php:

Code: Select all

<?php
// ############         Edit below         ########################################
$topic_length = '45';	// length of topic title
$topic_limit = '10';	// limit of displayed topics
$special_forums = '1';	// specify forums ('0' = no; '1' = yes)
$forum_ids = '25,22,23,27';		// IDs of forums; separate them with a comma

$config_path = '/forum/';	// path to config.php
$root_path = '/forum/';		// link path
// ############         Edit above         ########################################

$path = dirname(__FILE__);
include_once($path.$config_path .'config.php');
mysql_connect($dbhost, $dbuser, $dbpasswd) OR die('Unable to select server.');
mysql_select_db($dbname) OR die('Unable to select database.'); 

// ############## output ##############
echo '<table width="340" cellpadding="3" cellspacing="0" border="0">
';
// ############## output ##############

$where_forums = ( $special_forums == '0' ) ? '' : 't.forum_id NOT IN ('. $forum_ids .') AND ';
$sql = "SELECT t.*, f.forum_id, f.forum_name, u.username AS first_poster, u.user_id AS first_poster_id, u2.username AS last_poster, u2.user_id AS last_poster_id, p.post_username AS first_poster_name, p2.post_username AS last_poster_name, p2.post_time
	FROM ". $table_prefix ."topics t, ". $table_prefix ."forums f, ". $table_prefix ."users u, ". $table_prefix ."posts p, ". $table_prefix ."posts p2, ". $table_prefix ."users u2
	WHERE $where_forums t.topic_poster = u.user_id AND f.forum_id = t.forum_id AND p.post_id = t.topic_first_post_id AND p2.post_id = t.topic_last_post_id AND u2.user_id = p2.poster_id
	ORDER BY t.topic_last_post_id DESC LIMIT $topic_limit";
$result = mysql_query($sql);
if( !$result )
{
	die('SQL Statement Error: '. mysql_error());
	exit();
}

$line = array();
while( $row = mysql_fetch_array($result) )
{
	$line[] = $row;
}

for( $i = 0; $i < count($line); $i++ )
{
	$forum_id = $line[$i]['forum_id'];
	$forum_url = $root_path.'forum'.$forum_id.'.html';
	$topic_id = $line[$i]['topic_id'];
	$topic_url = $root_path .'ftopic'. $topic_id.'.html';

	$topic_title = ( strlen($line[$i]['topic_title']) < $topic_length ) ? $line[$i]['topic_title'] : substr(stripslashes($line[$i]['topic_title']), 0, $topic_length) .'...';

	$topic_type =  ( $line[$i]['topic_type'] == '2' ) ? '': '';
	$topic_type .= ( $line[$i]['topic_type'] == '3' ) ? '': '';
	$topic_type .= ( $line[$i]['topic_type'] == '1' ) ? '': '';
	$topic_type .= ( $line[$i]['topic_vote'] ) ? '': '';

	$views = $line[$i]['topic_views'];
	$replies = $line[$i]['topic_replies'];

	$first_time = date('d.m.', $line[$i]['topic_time']);
	$first_author = ( $line[$i]['first_poster_id'] != '-1' ) ? '<a href="'. $root_path .'profile.php?mode=viewprofile&u='. $line[$i]['first_poster_id'] .'">'. $line[$i]['first_poster'] .'</a>' : ( ($line[$i]['first_poster_name'] != '' ) ? $line[$i]['first_poster_name'] : 'guest' );
	$last_time = date('d.m.Y', $line[$i]['post_time']);
	$last_author = ( $line[$i]['last_poster_id'] != '-1' ) ? $line[$i]['last_poster'] : ( ($line[$i]['last_poster_name'] != '' ) ? $line[$i]['last_poster_name'] : 'guest' );
	$last_url = '<a href="'. $root_path .'viewtopic.php?p='. $line[$i]['topic_last_post_id'] .'#'. $line[$i]['topic_last_post_id'] .'">'. $last_author .'</a>';
	// ############## output ##############
	echo '<tr><td valign="top" nowrap="nowrap">'. $topic_type .'<a href="'. $topic_url .'" class="textnorms">'. $topic_title .'</a>   
                        &nbsp;&nbsp; (<span class="textnorms">'. $last_author .' in <a href="'. $forum_url .'" class="textnorms">'. $line[$i]['forum_name'] .'</a></span>)
                      </td>
                    </tr>';
	// ############## output ##############
}

echo '</table>';
mysql_close();
?>
lizard78
Registered User
Posts: 59
Joined: Tue Sep 09, 2008 5:57 pm

Re: SEO MOD

Post by lizard78 »

A big problem on the index page. I get an error 404 if I click on the latest post.

Can anybody say where the problem is?
Attachments
screen.gif
screen.gif (10.66 KiB) Viewed 721 times
Muzet
Registered User
Posts: 189
Joined: Tue Mar 18, 2008 9:42 pm
Location: POSTER_FROM
Contact:

Re: SEO MOD

Post by Muzet »

lizard78 wrote:A big problem on the index page. I get an error 404 if I click on the latest post.

Can anybody say where the problem is?
Find in functions_seo.php:

Code: Select all

$append = '.' . $phpEx;
replace with:

Code: Select all

$append = '.html';
Locked

Return to “[3.0.x] MOD Database Releases”