SEO MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
alienbabeltech
Registered User
Posts: 415
Joined: Mon Sep 17, 2007 12:54 pm

Re: SEO MOD

Post by alienbabeltech »

can somebody apply all the fixes and post the download ?
This is the best and most helpful community I have been on. You are some of the best people I have met. GOD Bless You ALL !
My Forum - http://alienbabeltech.com/abt/index.php

User avatar
dontcoz
Registered User
Posts: 473
Joined: Mon Sep 29, 2008 9:49 pm
Location: Vancouver, BC
Contact:

Re: SEO MOD

Post by dontcoz »

I wish i knew the script a bit better, i'd love to do it^^. this mod works really great on my forum, after i installed the fixes, except for a few lil things, like topic titles that are out of the ordinary go 404 as i posted on the prev page, it's all good.

Posting this just to try again to get some of the developers attention if poss - come out, come out where ever you are:))

LondonGeezer
Registered User
Posts: 30
Joined: Wed Nov 26, 2008 1:15 am

Re: SEO MOD

Post by LondonGeezer »

Mine seems to be working perfectly now :D

I'm useless at it, the phpBB site is wayyyy to complex for me, so I got some help from jrsweets (hope he don't mind me saying so in here) but I've only just had a brief look over it all and everything seems to be working like a dreeeeeeam :mrgreen:

But definitely, would be an idea to fix all the bugs and redo the download, will save people a LOT of time and repetitive posting in here :)

Great Mod!

jsingh
Registered User
Posts: 6
Joined: Mon Dec 29, 2008 3:12 pm

Re: SEO MOD

Post by jsingh »

One thing has been completely overlooked in this MOD, that is the forwarding to dynamic URL's to the new static URL's

Surely having both working, will cause the opposite effect of what we are trying to acheive, and result in duplicate content, which is frowned upon by Google.

Is there a way to redirect the previous links? via the htaccess or robots file into the root?

LondonGeezer
Registered User
Posts: 30
Joined: Wed Nov 26, 2008 1:15 am

Re: SEO MOD

Post by LondonGeezer »

Yeah or maybe dissallow the bots to crawl the old dynamic links..?

S@m0v@ru1_Pr@fu1t
Registered User
Posts: 9
Joined: Sat Jan 12, 2008 1:05 pm

Re: SEO MOD

Post by S@m0v@ru1_Pr@fu1t »

I have the same problem with 3.0.4 and Romanian language forum: on my topic pagination the links are not created correctly (i think), i have the following links:

On the FORUM list of topics (http://forum.clubcalibra.ro/clubcalibra-ro-f3.html)i have these pagination links:
PAGE 1: http://forum.clubcalibra.ro/regulamentu ... 105s0.html
PAGE 2: http://forum.clubcalibra.ro/regulamentu ... 05s15.html
PAGE 3: http://forum.clubcalibra.ro/regulamentu ... 05s30.html

On the TOPIC PAGE (http://forum.clubcalibra.ro/regulamentu ... 5s0.html)i have these pagination links:
PAGE 2: http://forum.clubcalibra.ro/-t1105s15.html
PAGE 3: http://forum.clubcalibra.ro/-t1105s30.html

In conclusion the TOPIC PAGE pagination doesn't work, i think because the links are not correctly created. I suspect that the problem is in functions_seo.php, but i don't know how to fix it. Anybody with a clue?

thanks alot!

LATER EDIT: SOLVED!!!
Folowing some explanation on the forum i've seen that my edit of VIEWTOPIC.PHP had an error at line 286:

I've had:

Code: Select all

	trigger_error('NO_TOPIC');
	$topic_title = $topic_data['topic_title'];
        $forum_name = $topic_data['forum_name'];
}

instead of:

Code: Select all

	trigger_error('NO_TOPIC');
}
	$topic_title = $topic_data['topic_title'];
$forum_name = $topic_data['forum_name'];

jsingh
Registered User
Posts: 6
Joined: Mon Dec 29, 2008 3:12 pm

Re: SEO MOD

Post by jsingh »

Code: Select all

User-agent: *
Disallow: /forum/viewtopic.php
Disallow: /forum/viewforum.php
Disallow: /forum/index.php?
Disallow: /forum/posting.php
Disallow: /forum/search.php?
Disallow: /forum/ucp.php
Disallow: /forum/mcp.php
Disallow: /forum/post
Disallow: /forum/member
Disallow: /forum/memberlist.php
Disallow: /forum/faq.php
Ive added this into my robots.txt file, does anyone know if this would work?
Are any other methods being used by users of this MOD?

LondonGeezer
Registered User
Posts: 30
Joined: Wed Nov 26, 2008 1:15 am

Re: SEO MOD

Post by LondonGeezer »

jsingh wrote:

Code: Select all

User-agent: *
Disallow: /forum/viewtopic.php
Disallow: /forum/viewforum.php
Disallow: /forum/index.php?
Disallow: /forum/posting.php
Disallow: /forum/search.php?
Disallow: /forum/ucp.php
Disallow: /forum/mcp.php
Disallow: /forum/post
Disallow: /forum/member
Disallow: /forum/memberlist.php
Disallow: /forum/faq.php
Ive added this into my robots.txt file, does anyone know if this would work?
Are any other methods being used by users of this MOD?


That looks spot on to me.. there's no way to do an allow for all the links the bots CAN follow.. because for example, if i post a topic in the /forum/general-category/ section.. the "general-category" is not kept in the static url, it's simply replaced with the topic title.. which is a shame.. otherwise we could have used the "ALLOW" command on every forum category.. for example:

Allow: /forum/general-category/
Allow: /forum/technical/
Allow: /forum/third-category/


Can anyone edit the mod so that the Static URLS keep the category?

alienbabeltech
Registered User
Posts: 415
Joined: Mon Sep 17, 2007 12:54 pm

Re: SEO MOD

Post by alienbabeltech »

wolf2009 wrote:can somebody apply all the fixes and post the download ?
can somebody please help ?
This is the best and most helpful community I have been on. You are some of the best people I have met. GOD Bless You ALL !
My Forum - http://alienbabeltech.com/abt/index.php

takadante
Registered User
Posts: 62
Joined: Tue Nov 11, 2008 5:52 am
Contact:

Re: SEO MOD

Post by takadante »

I am also having trouble with my "Thanks Mod (hide compatible)" The error is below; occurs when attempting to give thanks

Code: Select all

SQL ERROR [ mysql4 ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'phpbb_123topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 114' at line 3 [1064]

SQL

SELECT t.topic_title FROM phpbb_123posts p phpbb_123topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 114

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: includes/functions_seo.php
LINE: 164
CALL: dbal_mysql->sql_query()

FILE: viewtopic.php
LINE: 58
CALL: moved_topic()
Last edited by takadante on Wed Dec 31, 2008 5:03 am, edited 1 time in total.
http://theappshare.com ~ iPhone and OSX Applications!

User avatar
dontcoz
Registered User
Posts: 473
Joined: Mon Sep 29, 2008 9:49 pm
Location: Vancouver, BC
Contact:

Re: SEO MOD

Post by dontcoz »

jsingh wrote:

Code: Select all

User-agent: *
Disallow: /forum/viewtopic.php
Disallow: /forum/viewforum.php
Disallow: /forum/index.php?
Disallow: /forum/posting.php
Disallow: /forum/search.php?
Disallow: /forum/ucp.php
Disallow: /forum/mcp.php
Disallow: /forum/post
Disallow: /forum/member
Disallow: /forum/memberlist.php
Disallow: /forum/faq.php
Ive added this into my robots.txt file, does anyone know if this would work?
Are any other methods being used by users of this MOD?
Thank you so much for compiling those. I was just wondering why put a question mark at the end of some and not all of them?

Also, i still hope somebody knows how to tweak functions_seo.php, how make it not 404 for threads titled "." or "^-^" or "^=^" etc.. and thanks to that nice person in advance:))

jsingh
Registered User
Posts: 6
Joined: Mon Dec 29, 2008 3:12 pm

Re: SEO MOD

Post by jsingh »

reason for the index.php? is that sometimes we get index.php?sid= and index.php?(variable)=

This tells the crawler not to index these.

I've also noticed that the bookmark topic also gives a 404 error, anyone have a fix for this?

LondonGeezer: good point, maybe someone could look into your suggestion

takadante
Registered User
Posts: 62
Joined: Tue Nov 11, 2008 5:52 am
Contact:

Re: SEO MOD

Post by takadante »

I am also having trouble with my "Thanks Mod (hide compatible)" The error is below; occurs when attempting to give thanks

Code: Select all

SQL ERROR [ mysql4 ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'phpbb_123topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 114' at line 3 [1064]

SQL

SELECT t.topic_title FROM phpbb_123posts p phpbb_123topics t WHERE t.topic_id = p.topic_id AND t.topic_id = 114

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: includes/functions_seo.php
LINE: 164
CALL: dbal_mysql->sql_query()

FILE: viewtopic.php
LINE: 58
CALL: moved_topic()
[
Last edited by takadante on Wed Dec 31, 2008 5:04 am, edited 1 time in total.
http://theappshare.com ~ iPhone and OSX Applications!

User avatar
dontcoz
Registered User
Posts: 473
Joined: Mon Sep 29, 2008 9:49 pm
Location: Vancouver, BC
Contact:

Re: SEO MOD

Post by dontcoz »

jsingh wrote:reason for the index.php? is that sometimes we get index.php?sid= and index.php?(variable)=

This tells the crawler not to index these.

I've also noticed that the bookmark topic also gives a 404 error, anyone have a fix for this?

LondonGeezer: good point, maybe someone could look into your suggestion
Thanks jsingh. but don't they all get a "?" at some point, i can see most all of those ending with a "?mode=..etc."

I'd love to know the solution for your bookmark topic issue but I've stripped that together with the print view etc. prior to installing the mod.. which could be the reason why this mod works so well on my phpBB, i'm running only half of it lol

jsingh
Registered User
Posts: 6
Joined: Mon Dec 29, 2008 3:12 pm

Re: SEO MOD

Post by jsingh »

Im not sure, I asked someone to give me a quick robots file and thats what they gave me.

As for bookmarks, I've just disabled it from the Admin panel. There is a fix around it, which is in the viewtopic.php file, I'll try figuring it out when im free.

I have the print fix, I'll double check and post it.

Real shame with regards to the number of bugs in this MOD, its almost too late to go back now too, as all my new links have been posted out using the static url format.

Locked

Return to “[3.0.x] MOD Database Releases”