Posting template

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
Glenn I
Registered User
Posts: 172
Joined: Wed Apr 20, 2005 6:11 am

Re: Posting template

Post by Glenn I »

I'm having the same problem as netjet5030

mk666
Registered User
Posts: 3
Joined: Tue Mar 04, 2008 11:02 am

Re: Posting template

Post by mk666 »

Hello there!

Is there a way to automatically show the acual date and time in the template when someone create a new topic?

Greetings

netjet5030
Registered User
Posts: 28
Joined: Wed Jan 23, 2008 5:03 pm

Re: Posting template

Post by netjet5030 »

Glenn I wrote:I'm having the same problem as netjet5030
Any help please?

User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Re: Posting template

Post by igorw »

mk666 wrote:Hello there!

Is there a way to automatically show the acual date and time in the template when someone create a new topic?

Greetings
Please explain this in more detail.
Igor Wiedler | area51 | GitHub | trashbin | Formerly known as evil less than three

mk666
Registered User
Posts: 3
Joined: Tue Mar 04, 2008 11:02 am

Re: Posting template

Post by mk666 »

eviL<3 wrote:
mk666 wrote:Hello there!

Is there a way to automatically show the acual date and time in the template when someone create a new topic?

Greetings
Please explain this in more detail.
Sure. I will try to explain it.

I would have a posting template like the following:

Code: Select all

Name:
Homepage:
E-Mail:
Date:
Until this there is no problem. But after "Date" I would like automatically inserted the actual date and time when an user start a new topic. E.g. with variables like {date} and {time} or something else.

Hope this is more understandable. My english is not the best.

Greetings

mag00_br
Registered User
Posts: 43
Joined: Thu Jan 03, 2008 3:09 pm
Location: Brasil -SP
Contact:

Re: Posting template

Post by mag00_br »

Just to know, why you want this information if it is already at top of post?

[]'s
*[NMT]*Mag00* / [Granja] Falco Peregrinus / | CDA | Mr.Orange |
http://www.granjaklan.com/forum
Image

User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Re: Posting template

Post by igorw »

It would be possible but in my opinion not worth the effort, as you can see when the post was made. mag00_br beat me to it :)
Igor Wiedler | area51 | GitHub | trashbin | Formerly known as evil less than three

netjet5030
Registered User
Posts: 28
Joined: Wed Jan 23, 2008 5:03 pm

Re: Posting template

Post by netjet5030 »

Guys it's working, I've found my stupid error... :oops:
Actually you have to fill the "posting template" section, editing the forum.

Glenn I
Registered User
Posts: 172
Joined: Wed Apr 20, 2005 6:11 am

Re: Posting template

Post by Glenn I »

I did that and it submit, then the page changed with this error

Code: Select all

SQL ERROR [ mysql4 ]

Unknown column 'forum_post_tpl' in 'field list' [1054]

SQL

UPDATE phpbb3_forums SET parent_id = 52, forum_type = 1, forum_status = 0, forum_parents = '', forum_name = 'Australian Aviation News', forum_link = '', forum_desc = 'News sourced from the media relating to aviation in Australia. Please feel free to leave your comments on each article', forum_desc_uid = '', forum_desc_options = 7, forum_desc_bitfield = '', forum_post_tpl = 'testing', forum_rules = '', forum_rules_uid = '', forum_rules_options = 7, forum_rules_bitfield = '', forum_rules_link = 'http://www.theaussieaviator.net/forum/forumrules.php', forum_image = '', forum_style = 0, display_on_index = 1, forum_topics_per_page = 0, enable_indexing = 1, enable_icons = 1, enable_prune = 0, prune_days = 7, prune_viewed = 0, prune_freq = 1, forum_flags = 50 WHERE forum_id = 14

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal_mysql->sql_error()

FILE: includes/acp/acp_forums.php
LINE: 1236
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_forums.php
LINE: 181
CALL: acp_forums->update_forum_data()

FILE: includes/functions_module.php
LINE: 471
CALL: acp_forums->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()

mk666
Registered User
Posts: 3
Joined: Tue Mar 04, 2008 11:02 am

Re: Posting template

Post by mk666 »

eviL<3 wrote:It would be possible but in my opinion not worth the effort, as you can see when the post was made. mag00_br beat me to it :)
Ok, then I think I will give it up. ;)

jayhova
Registered User
Posts: 1
Joined: Thu Mar 06, 2008 7:58 pm

Re: Posting template

Post by jayhova »

Any chance to add functionality to allow posting new topics (in any forum) to be designated as a FORM reply only post. Similar to creating a poll type post only allow the user to create new posts in any forum and specify their own form for replies. In phpBB 3.0 it looks like there are tabs at the bottom when creating new posts for Options, Upload Attachments, Poll creation etc.

Thanks.

Glenn I
Registered User
Posts: 172
Joined: Wed Apr 20, 2005 6:11 am

Re: Posting template

Post by Glenn I »

Still waiting for some assistance with a previous post about an error. See below. I can't add or edit forums until this is fixed. Please help
Glenn I wrote:I did that and it submit, then the page changed with this error

Code: Select all

SQL ERROR [ mysql4 ]

Unknown column 'forum_post_tpl' in 'field list' [1054]

SQL

UPDATE phpbb3_forums SET parent_id = 52, forum_type = 1, forum_status = 0, forum_parents = '', forum_name = 'Australian Aviation News', forum_link = '', forum_desc = 'News sourced from the media relating to aviation in Australia. Please feel free to leave your comments on each article', forum_desc_uid = '', forum_desc_options = 7, forum_desc_bitfield = '', forum_post_tpl = 'testing', forum_rules = '', forum_rules_uid = '', forum_rules_options = 7, forum_rules_bitfield = '', forum_rules_link = 'http://www.theaussieaviator.net/forum/forumrules.php', forum_image = '', forum_style = 0, display_on_index = 1, forum_topics_per_page = 0, enable_indexing = 1, enable_icons = 1, enable_prune = 0, prune_days = 7, prune_viewed = 0, prune_freq = 1, forum_flags = 50 WHERE forum_id = 14

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal_mysql->sql_error()

FILE: includes/acp/acp_forums.php
LINE: 1236
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_forums.php
LINE: 181
CALL: acp_forums->update_forum_data()

FILE: includes/functions_module.php
LINE: 471
CALL: acp_forums->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()

User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Re: Posting template

Post by igorw »

As already mentioned, you didn't run the SQL actions...
Igor Wiedler | area51 | GitHub | trashbin | Formerly known as evil less than three

Glenn I
Registered User
Posts: 172
Joined: Wed Apr 20, 2005 6:11 am

Re: Posting template

Post by Glenn I »

I did run it

User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Re: Posting template

Post by igorw »

Did you adjust the table prefix? It needs to be ALTER TABLE phpbb3_forums in your case, not phpbb_forums.
Igor Wiedler | area51 | GitHub | trashbin | Formerly known as evil less than three

Locked

Return to “[3.0.x] MOD Database Releases”